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Preface

DMU Fitting Simulator is a software dedicated to simulating part motions for assembly
and maintainability issues. It addresses the design review environment of Digital
Mock-Ups (DMU) and can handle a wide range of products from consumer goods to
very large automotive or aerospace projects as well as plants, ships and heavy
machinery.

DMU Fitting Simulator is a dedicated DMU Navigator Version 5 workbench and is
available on both UNIX and Windows NT environments.

This guide is organized as follows:
@ Getting Started

Provides a scenario allowing you to get acquainted with the product.
@ Basic Tasks

Provides a step-by-step guide for using DMU Fitting Simulator. Useful tips are given for
getting the most out of the product.

@ Advanced Tasks

Provides a step-by-step guide for using DMU Fitting Simulator along with
complementary DMU products.

@ Workbench Description

Describes menu commands and workbench toolbars that are useful for DMU Fitting
Simulator.

@ Glossary

Provides definitions of terms that are specific to DMU Fitting Simulator.
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Using This Guide

This guide is intended for the user who needs to quickly become familiar with DMU
Fitting Simulator. The user should be familiar with DMU Navigator Version 5 concepts
such as document windows, standard and view toolbars.

To get the most out of DMU Fitting Simulator, use the following user guide wizard. It
will help you better locate information relevant to you as well as to the way you work.

User Guide Wizard
Go to:

The getting started tutorial. Once you have finished,
| am a first time user you should move on to the user task section of this
guide. This steps you through basic procedures.
Your DMU Fitting Simulator Version 5 session and
start reviewing your own documents. If you need
some help in understanding tools and commands,
use the on-line help. You can also take a look at the
basic task section and advanced task section of this
guide to locate information with which you are not
already familiar.

have used DMU Fitting Simulator
before
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Where to Find More Information

Prior to reading this book, we recommend that you read the DMU Infrastructure User's
Guide.

You may also like to read the following complementary product guides, for which the
appropriate license is required.

DMU Navigator User's Guide

DMU Kinematics Simulator User's Guide

DMU Space Analysis User's Guide

DMU Optimizer User's Guide

e eO
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What's New?

Enhanced: automatic insert of the starting shot in Recording a Simulation and
Compiling a Simulation

Enhanced: Shuttle Graphic Representation in Defining the Shuttle

New task: Animating a Viewpoint

New task: Generating an Animation

New Task: Adding a Shuttle in a Simulation




Getting Started

"@" Before getting into the detailed instructions for using DMU Fitting Simulator, the
== following tutorial aims at giving you a feel of what you can do with the product. It
provides a step-by-step scenario showing you how to use key functions.

The main tasks described in this section are:

Staring & Seszion
Defining the Shuttle

Fecording & Simulation

5585

Feplaving & Simulation

Ii'l.
tfj, These tasks should take about 15 minutes to complete.



Starting a DMU Fitting Session

- Before starting this scenario, you should be familiar with the basic commands common to all
.==._workbenches. These are described in the DMU Navigator User's Guide.

"@‘ This first task will show you how to enter the DMU Fitting workbench and select your products.

=1
1. Select Digital Mockup -> DMU Fitting from the Start menu.

e The DMU Fitting workbench is displayed.

2. Select File->Open.
The File Selection dialog box displays:

File Selection |

Look in: Ia Samples j | Eﬁl b éél
) all CAT Product; o8] DEMI_
@ DEMO_CGE_CHAIMESAW_BODY _BUMPER. car @ DEMO_
@ DEMO_CGE_CHAINSAW BODY _CHAIM. cor @ DERO_
@ DEMO_CGE_CHAIMSAW _BODY _CLUTCHCOWER. cor EI DEMO_
@ DEMO_CGE_CHAINSAW BODY _CRAMECASE_LSIDE car @ DERO_
@ DEMO_CGE_CHAINSAW BODY CRAMKCASE _RSIDE. cor @ DERO_
KN i
File narie: IaII.E.-'-‘-.TF"rn:u:Iuct Open
Filez of tppe: Iﬁi'«ll [#] ﬂ Cancel

[T Open as read-only

[T Load partially

3. Select the all. CATProduct from the online\samples\dmufitting directory.

4. Click Open to open the selected files.

The specification tree is displayed showing all the selected products. in our example, the
CATProduct has been divided in four main groups of objects.

@Note that you can also select model files using insert-> existing component.

In this case, select the desired model files by clicking the first one then shift-clicking the last one you

want.

[CZ" Use the Fit All In icon EEI to position the model geometry on the screen.



[%]|CATIA ¥5.3 - [all. CATProduct] =] E3

n Start  File  Edit  “iew Inzert  Tools  Analyze  Window  Help

€f”¢ 3 Body (Body.1)
-—? Engine (Engine.1)

'5?) Sword (Sword.1)
I:‘@?’ Handle {Handle 1)
— Applications

J@@@ -%%@#@fmﬁg%?Jﬁg@ 4(:,4?;,4?2

Select an object or a command |

Clicking off View -> Specifications Visible in the menu bar removes the specification tree and lets
you use the entire screen for the product.You can also use the F3 key to toggle more quickly.

E g E Starting a Session E Defining the Shuttle
iﬁecnrding a Simulation iﬁeplaying a Simulation
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Defining the Shuttle

Before starting this scenario, you should have loaded your products as described in the previous steps.

A shuttle is a set of products defined explicitly by selecting products individually.
Shuttles are persistent and can be stored in the document.

This task explains you how to define the list of products you want to move together.

1. Select a product in the geometry area or in the specification tree.
2. Ctrl-click other products to add them to the initial selection

=3 Body (Body.1)

—&8 CLUTCHCOVER [CLUTCHCOVER.1)

—%8 CRAMKCASE_LSIDE [CLUTCHCOVER.1)

—%8 CRAMKCASE_RSIDE [CRANKCASE_RSIDE.1]

— %% CYLINDERCOVER [CYLINDERCOVER.1)

%% FILTER [FILTER.1)

—%8 FILTERCOVER (FILTERCOVER.1)

%8 GASTRIGGER [GASTRIGGER.1)

—&8 HOOK_FR4 (HOOK_FR4.1)

—%8 0ILCAP (OILCAR1) -

—%8 PETROLCAP [PETHDLD&%T- .

%8 SAFETYTRIGGER (SAFETYTRIGGER.1]

&k SILEMCER [SILENCER.1]

—%8 SILEMCERSUPPORT [SILENCERSUPPORT.1)
e m————

— 8 STARTHANDLE [STARTHANDLE 1]

3 STARTINGHOUSE (STARTINGHOUSE.1)

— %8 TAMK_LSIDE (TAME_LSIDE. 1]

58 TAMK_RSIDE [TANK_RSIDE.1)

G%g} Engine [Engine.1]

%3 Sword [Sword 1)

%3 Handle Handle.1)

Applications

2. Select Insert->Shuttle... from the menu bar or click the Shuttle @P icon in the DMU Fitting Tools

Toolbar to create a shuttle:

The Edit Shuttle dialog box and the Preview window appear.

The 3D compass automatically positions according to the to-be-created shuttle axis. See below:

Edit Shuttle EHE
— Definition
Mame: m—
S election: 4
Move: @ Shutle
() Az

T -

@ 0K I ﬂEancell




| . —
The Preview window shows selected products

4. (Optional)
Enter a meaningful name for the shuttle you want to create.
Preview |

A
5. Click OK to create the shulttle.
The shuttle is identified in the specification tree.

|
=—Applications
=—Shuttle

il
L% shuttie ]

(= Shuttles created in this manner are persistent and can be stored in the document. They are listed as
separate entity in the specification tree and can be selected at any time and modified.

g Starting a Sezszion . Defining the Shuttle
(& I | . €
|§emrding a Simulation |§eplaying a Simulation
+ +
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Recording a Simulation

Before starting this scenario, you should have created a "Shuttle" as described in

the previous steps.
You opened the sample document: online\samples\dmufitting\all. CATProduct

This task explains how to quickly define the motion of a "Shuttle" and to record it
in a simulation object.
1. Select your "Shuttle" in the specification tree (Shuttlel)

‘roduct]
5 Body (Body.1)
{? Engine (Engine.1)
9 Sword (Sword.1)
5 Handle (Handle. 1)

-'—Afjplicatiuns
=—Shuttle

l—ﬁﬂ Shuttle.1

2. Select Insert->Simulation...or click the Simulation *=  icon.

3. The 3D compass automatically positions according to the axis shuttle.

The Edit Simulation dialog box and the Preview window appear.
You are ready to record a simulation.



Edit Simulation K E3 |
Name:MMl |

I
A
Eln.nn = 1|1 -]

[ ] Animate viewpoint

[rizert l b odify l Delete l Skip l

[ ] Automatic inzert

Interference Digtance ————
’[fo [ ’[fo [

Edit analyzis l Edit zimulation objects l

w 0K I ﬂEar‘u:eIl

e,
rm You can now record a simulation with an animated viewpoint. For this activate the
: Animate viewpoint option. For more details, please refer to Animating a Viewpoint

rm 4. The first shot: shuttle in the origin position is already recorded in the
. simulation.

5. Select the manipulator to move the shuttle as desired.
6. Drag the cursor to the desired shuttle location.



7. Click Insert to save and insert in the "Simulation" the shuttle in the new
position.

8. Insert another location in the same manner:

point) to move in different ways.
¥ You can do several manipulations before inserting a new position in the

@ You can select and drag all the components of the manipulator (axis, plane, arc,

"Simulation".

8. Click OK to end the Simulation creation.
The simulation is identified in the specification tree.



Ef; _:3 Body [Body.1)
u_:} Engire [Engine. 1)
--.1_:_‘:-3 Sward [Sword. 1)
%% Handle (Handie 1)

== Applications

Shuttle
L;“%n Shuttle.

== S imulation

==E8 Simulation. ]

B Shuttle. 3

#7/
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Replaying the Simulation

Before starting this scenario, you should have created a "Simulation” with a
shuttle at different locations as shown in the previous step. Open the
all.CATProduct from the online\samples\dmufitting directory.

& This task explains how to run a shuttle motion recorded in a "Simulation"
using the Simulation command.

-"; ~
%

@

1. Double-click your "Simulation" in the specification tree (Simulation.1)

S I

Sf; :} Body [Badp.1]
-.ﬁ. Engine [Engine. 1]
-Lf:-} Swword [Sward. 1]
% Handle [Handle.1]

I--.":".IJIZI"C-EIHDFIE

Shuttle
B Shuttle. 1

=="5imulation

&= Simulation. 1

Edit Simulation Kl E3
Name:MMl |
Jl A MNP »
A In.nn 21|1 Rd

The Edit Simulation _ . .

dialog box and the [ ] Anirnate YIewpoint

Preview window

Inzert I b odify I Delete I Skip I

[ ] Autamatic inzert

appear.

— Interference Digtance ————
0ff | |[fo ]

Edit analy=iz l Edit zimulation objects I

@ 0K | @ Cancell

o




nﬁw If you checked the Animate viewpoint option in the simulation recording, you
2 can now animate viewpoints while recording a simulation. They are taken
into account. For more details please refer to Animating a Viewpoint.

@ You also can select a "Simulation” graphically by clicking on the tracks.

2. Modify the interpolation value as desired. For example: 0.04

I

Gf° = omm—

[~

3. Click the Play Forward button.
The recorded motion is replayed.

I

Elln.nn ﬁ 1

Flay Fommard|«

At any time, you can go back to the starting shot. Use the VCR buttons as

[E? desired:

COEO OO

€

Play Forward (step by step)
Go to Maximum Time position
Pause

Go to Zero Time position
Backward (step by step)

Play Back.

g Staring & Seszion Defining the Shuttle

E@ﬁecu:urding a Simulation { Feplaving a Simulation



Basic Tasks

The table below lists the information you will find in the Basic User Tasks section.

Theme Purpose

Setting Up ¥our DM Fitting Simulator Session m Entering the workbench and define a shuttle

Shuttle m Define and move a shuttle.
Mono-Shuttle Fitting Simulstion ﬁ Simulate and replay a mono-shuttle recording.

Excploding fa Understand the product structure



Setting Up Your DMU Fitting Session

Task Purpose

Ertering The Workbench ﬁ Start a DMU Fitting Session

Defining a Shuttle ‘3 Define groups of objects

g ip_ﬂing g % our Dk Fitting Shuttle

2 - &
o-Shuttle Fitting Simulatic Exploding
I &




Entering the DMU Fitting Workbench

@ This task shows you how to enter the DMU Fitting workbench and open a new document.

@
A
E 1. Select Digital Mockup -> DMU Fitting from the Start menu
The DMU Fitting workbench is loaded and an empty document opens:

[#]|CATIA V5.3 - [Productl] H =] E3
-8 x|

n Statt File  Edit  Miew  lnzet Toolz Analpze  Window  Help

% Product o
Applications [

i

[ %
‘_',.-"{—}
&4 B2 @ ) ™ fo B L2 J%@ 4::,41';.4'?3

Select an object or a command |

The DMU Fitting workbench comprises:

@ A Specification tree and a geometry area

@ Specific Toolbars
@ A number of contextual commands available both in the specification tree and the

geometry area.
2. You are now ready to open models and products either using the Insert -> Existing
Component... command or the Open->File... command.
Clicking off View -> Specifications Visible in the menu bar removes the specification tree and lets
you use the entire screen for the geometry.You can also use the F3 key.
Note that more toolbars may appear next to the Standard toolbar when you create a document.

#3
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Defining a Shuttle

A shuttle is a set of products defined explicitly by selecting products individually.
Shuttles are persistent and can be stored in the document

The sample document used in this task can be accessed in the folder:
S online\samples\dmufitting\all. CATProduct.

i {=

'T@" This task explains how to define a shuttle. You will move this group of objects
= afterwards according to a manipulator. For more details, please refer to Moving the
Shuttle and Moving the Manipulator Independently from the Shuttle
L L Select a group of
oty objects in the [ - .

specification tree.

2. Click the Shuttle icon

b

The Edit Shuttle
dialog box and the
Preview window
appear.

The DMU

Manipulation
toolbar displays



&

=45} Body (Body.1)

—%& CLUTCHCOVER (CLUTCHCOVER.1)]

— %8 CRANKCASE_LSIDE ([CLUTCHCOVER.T)

— %8 CRANKCASE_RSIDE [CRAMKCASE_RSIDE 1)

— %8 CYLINDERCOVER (CYLINDERCOVER.1]

—5%& FILTER [FILTER.1)

— %% FILTERCOVER [FILTERCOVER.1]

—% GASTRIGGER (GASTRIGGER.1)

—%&8 HOOK_FR4 HOOK_FR4.1]

— %8 DILCAP [DILCAP.1) -l

—% PETROLCAP PETROLCAPA). 4

— %8 SAFETYTRIGGER (SAFETYTRIGGER.1]

—&& SILENCER [(SILENCER.1]

— %% SILENCERSUPPORT [SILENCERSUPPORT.1)
L e,

— %8 STARTHANDLE [STARTHAMDLE 1)

— %% STARTINGHOUSE [STARTINGHOUSE. 1]

%8 TANK_LSIDE [TAME_LSIDE.1)

—%& TANK_RSIDE [TAMK_RSIDE.1)

5’%_«} Enagine [Engine.1]

%3 Sword [Sward 1]

%3 Handle (Handle. 1)

Applications

w The shuttle graphic representation displays. It corresponds to the
to-be-created shuttle axis.

Edit Shuttle EHE
— Definition
M armne; EMEI

TS ie & products
Move: @ Shuttle
) fwis

w O I ﬂEanceII




%

by

The Preview window shows selected products.

To change the default display setting for this window, see "Customizing DMU Navigator
Settings" in the DMU Navigator User's Guide

Poview ——H|

o
4. (optional)
Select products in the specification tree or in the geometry area to remove
them from the shuttle.

|
rﬁlpplications
=—Shutfle
e
L% shutte



@

T

5. (Optional)
Enter a meaningful name for the shuttle you want to create

6. Click OK to end the shuttle creation
The shuttle is identified in the specification tree

Shuttles created in this manner are persistent and can be stored in the document. They
are listed as a separate entity in the specification tree and can be selected at any time
and modified. See_Editing a Shuttle

If you need to deactivate the automatic display setting of the Preview window, uncheck
the Manipulating objects option in the DMU Navigator tab via the Tools->Options
command... For more details please refer to Customizing DMU Navigator setting in the

DMU Navigator user's Guide.

E g E‘iering The Wiarkbench { Defining a Shuttle




Shuttle

DMU Fitting Simulator provides easy methods to edit and then move products.

Edit Shuttle

— Definition
M ame: IS hittle. 2
Selection: f3 products
Move: @ shutle

02 Az
@ 0K I ﬂl:ann:ell

Moving the Manipulator
Independently from the Shuttle

Editing a Shuttle Moving the Shuttle

L ing Up v our DL Fitting . Shuttle
2 - [ -
o-=huttle Fitting Zimulatic Exploding
(. . I



Editing a Shuttle
A shuttle is a set of products defined explicitly by selecting products individually.
Shuttles are persistent and can be stored in the document.

@ This task shows how to edit a shuttle. This procedure can be performed either before
==, the shuttle creation or after.
The sample document used in this task can be accessed in the folder:

&1 online\samples\dmufitting\all. CATProduct.
“*%=-You defined at least one shuttle. For more details please refer to Defining a Shuttle.

1. In the specification

tree, double-click the Bl T
shuttle you defined
to modify it or, Detine Selection Set
m right-click the shuttle _
s and select Shuttle.1 | Hide/Show
object->Definition
from the contextual Shuttle. object Definitiar..

menu.
The Edit Shuttle dialog box appears and displays the contents of the shuttle
you selected. Objects included in the shuttle are highlighted in the specification
tree and in the geometry area.

@ Froduct
ﬁ—'f’f‘” Body (Body.1) Edit Shuttle K E

i—'g? Engine (Engine.1) | [ Definiion

Q_{"’ M amne: Emm
= Sword (SWDFd.” S election: sl ¥se

[

ﬁ-g'f": Hande(Handedy M @ Shte
I () Awis

r,ﬁlpplicatiana
=—Shuttle
B Shuttle |

@ 0K | @ Cancel |

2. Modify shuttle contents as desired. For this:

3. (optional)

Select objects in the specification tree or in the geometry area to remove
them or select new ones to be added.

4. (optional)

Rename the shuttle. For instance, enter Shuttle.1a in the Name field.



Edit Shuttle EE3
— Drefinition
M ame: IS huttle. 14

Selection: &
b ove:

@ 0Kk | @ Cancel |

DMU takes automatically your operation into account. The selection field from the
[ Edit dialog box is automatically updated as well as the Preview window.The new
selection is highlighted in the specification tree and the geometry area.

5. Click OK to confirm your operation.
By default, the Shuttle option is activated, which means that when you move a shuttle
the axis and geometry move together. If you choose to activate the Axis option
instead, only the shuttle axis moves. Please refer to Moving the Shuttle and Moving

the Manipulator.

You can at any time use the DMU manipulation toolbar. For more details, please
U ® refer to DMU Manipulation Toolbar.

E g { Editing a Shuttle % Moving the Shuttle
ﬁnving the Manipulator




Moving the Shuttle

This task shows how to move the shuttle you just defined to the desired location. For
this, you will use the graphic manipulator referred to as the 3D compass to
manipulate the shuttle.

®Note that the graphic manipulator is attached to the shuttle by default. See the

&,
Manipulation toolbar the Attach icon k. IS activated.

- You defined a shuttle. The sample document used in this task can be accessed in the
-=*.. folder: online\samples\dmufitting\all. CATProduct.

m 1. Double-click the shuttle in the specification tree (shuttle.1)

i,

-
=

=
-

The Edit Shuttle dialog box, the Preview window and the
Manipulation Toolbar appear.

|

-

e
=—Shuttle | -

i Shutte ==







[-_The Move shuttle option is activated by default which means that both the shuttle axis
and geometry move.

1. Click the z axis from the manipulator.
2. Drag the cursor to the shuttle desired location.

3. Click the x plane from the 3D compass.

4. Drag the cursor to the left.
5. Use the Reset command when needed.




5. Select the z axis and drag the 3D compass.

6. Drag the cursor to the shuttle
desired location.

7. Now rotate the shuttle. For this:
drag an arc of the compass, for example dragging the arc xz to the left rotates
the shuttle in the plane subtended by the arc xz like this:



You may also enter more precise coordinates using the Compass manipulation dialog
box. For this you can either:

@ right-click the 3D compass and select edit from the displayed contextual menu

@ or click the Editor icon =) from the DMU Manipulation toolbar



Compass Manipulation E E3 |

Paszitian

ol 2 6465 3m 2] +v: [4.60035mm ] z [76.0071mm B spply new pasition |
Increment

Tranzlation Raotation

A ID'T"T' E_I;I 4 avis: _I;I
' [ = ]+ ] Ange |0deg B2 v awis e s
Z. ID'T"T' E__I‘;I Z aviz: __|‘;|
Distance: IDmm E;l"'

Meazure diztance. . I Meazure angle... I

Cloze
. oase |

8. Click OK in the Edit Shuttle dialog box.
E g E Editing a Shuttle { Moving the Shuttle
| ﬁ oving the Manipulatar




Moving the Manipulator Independently from the
Shuttle

This task shows how to reposition the graphic manipulator (3D compass) without moving the shuttle. This
P == A
task aims at illustrating the use of the ,@f @‘ > - commands.
You defined a shuttle. Please refer to Defining a Shuttle
_&1" The sample document used in this task can be accessed in the folder:
online\samples\dmufitting\all. CATProduct.
E 1. Double-click the shuttle in the

O

specification tree (shuttle.2 |

Bt P ( ) =—Applications
The Edit Shuttle dialog box, the |D
Preview window and the Manipulation =—Shuttle
Toolbar appear. =

g ohuttle

i —%

By default, the Attach mode is
activated:

ply e @




Make sure the Selection field in the Edit Shuttle dialog box is de-activated to keep the selection you need.

Edit Shuttle | 7]

— Definition
Mame:  [Shuttle.2
Selection: |2 products
Move: @ Shuttle

1 iz

@ 0K I ‘Eancell

3. Swap to Detach mode clicking the Attach/Detach icon %

The 3D compass changes color:

You are now in the Detach mode.
The icon changes in the Manipulation toolbar

The 3D compass and the shuttle are free from each other.
6. Drag the 3D compass as shown opposite.

N
7. Click the Reset icon ,@ to go back to the initial 3D compass location.

S
8. Click the Target icon 4@3’ from the DMU manipulation toolbar or drag and drop the icon onto an
edge.

9. Set the manipulator to the desired position as shown below:



10. Swap to the Attach mode clicking the Attach/Detach icon
The 3D compass recovers its initial color.
11.Now drag an arc of the compass to rotate the shuttle:

Care that as long as you set the manipulator to the Detach option, you cannot move the shuttle. The shuttle
axis remains linked to the shuttle.

[ Note that at any time you can via the contextual menu, edit the 3D compass position.

If you use the Invert icon, the 3D compass and the attached shuttle are flipped.

12. Click OK to confirm you operation.

A%/



Lp Editing & Shuttle Moving the Shuttle

_g.-juving the Manipulator
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Mono-Shuttle Fitting Simulation

DMU Fitting Simulator provides easy methods for running a simulation in which a shuttle is
dismounted from an assembly.

A simulation corresponds to a user-defined scenario on a track assigned to a shuttle.

This scenario will be used either for being shot or for checking whether a part in an assembly can
actually be dismounted.

Fecording & Simulation
Aninating & Yiewpoirt
Compiling & Simulation

Generating an Animation

Replaying the Simulstion

55555
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Recording a Simulation

Y This task shows how to record a Simulation, in other words a scenario on mono-shulttle fitting simulation.
=
o You created a shuttle or you create a shuttle via current selection.The sample document used in this task can be accessed in the folder:

e

=9 online\samples\dmufitting\all. CATProduct.

1. Select the shuttle either in the specification tree.

0 |

Click the Simulation icon *# or select Insert->Simulation... from the menu bar.
In this case the Select dialog box displays and lets you select the shuttle you want to use in your Simulation.
The Edit Simulation dialog box and Preview window appeatr.

Select Hi=] E3
ou cannot create an empty Simulation, =]
I
Shuttle. 1

@ ok | @ Cancel|

2. Click the Insert switch and record the starting shot.

& Note that you can change the automatic display setting of the Preview window via the Tools->Options command...

@ Insert means that you record and insert shots inside the scenario.
nEW The initial location of the shuttle is automatically recorded as a starting shot.
If you need to reposition the shuttle, please delete the first position ormodify it



Edit Simulation |

|N SN Simulation, 1 |

I
[
GJ* = ]

[ Animate viewpoint

Inzert I b iy I Delete _I Skip I

[ Autamatic inzert

— |nterference — Diztance

forf | o I~

Edit analyziz ] Edit zimulation objects l

@ 0K ] ﬂEancel]

4. Move the shuttle to the desired location via the manipulator.
5. Click the Insert switch and record the desired shot.

6. Move the shuttle as often as necessary, clicking Insert to record shots.




7. Select the appropriate interpolation, for instance 0.04. You can modify or choose the automatic insert at any time.
8. Click OK to confirm your operation.
The Simulation is identified in the specification tree

[
i—AFpIicatiDns
shuttle
B Shuttle.]

= Shuttle.?
==5Simulation

|
#—{ﬁ =imulation.

At any time, you can press the Edit Analysis button from the Edit Simulation dialog box:
It is empty because you have not defined interferences.

Edit Analysis in Simulation BHE
Nu:-| Namel
Browse,.. I Add.. I Hemnvel
@ 0k | & Cancel
.

@ The Edit Simulation objects button lets you add simulation objects such as cameras...
& You recorded a Simulation based on shuttles. Here, you selected the shuttle.2. Keep in mind that editing shuttles impact the simulation.

#7
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n®w Animating a Viewpoint in a Simulation
"@” This task shows how to animate viewpoints in a simulation.
=%
&P

You created a shuttle or you create a shuttle via current selection.

‘H

The sample document used in this task can be accessed in the folder: online\samples\dmufitting\all. CATProduct.
1. Select the shuttle either in the geometry area or in the specification tree.

Click the Simulation icon ==

or select Insert->Simulation... from the menu bar.
In this case the Select dialog box displays and lets you select the shuttle you want to use in your simulation

The Edit simulation dialog box and Preview window appear.
2. Click the Insert switch and record the shots.

Select [ |O) =]
ou cannot create an empty Simulation, =]
=
Shuttle. 1

@ ok | @ cancel]
-

f@w Remember the initial position is automatically recorded. If you need to reposition the shuttle, please delete the first position or modify it

Note that you can change the automatic display setting of the Preview window via the Tools->Options command...
& .

Insert means that you record and insert positions with the current viewpoints inside the scenario.



E dit Simulation EHE

|NamEZ|SimulatiDn.2 |

I

EAE S
Dln.uu = =
mf :

[nzert _I b oodify I Delete _I Skip _I

[ &wtomatic insert

— Interference — Diztance
[t = [o6 El

Edit analysis ] Edit zimulation objects ]

@ Ok _I ﬂEanceI_l

4. Move the shuttle to the desired location via the manipulator a
5. Click the Insert switch and record the desired position.

6. Move the shuttle as often as necessary, clicking Insert to record shots.

7. Select the appropriate interpolation. You can modify or choose the automatic insert at any time.

The Simulation is identified in the specification tree
9. Replay your simulation now with the animate viewpoint option set.



[
n—A{:plicatiDns
Shuttle
B Shutle.]

B Shutile 2
==Simulation

#—{gﬁ Simulation.1

10. Replay your simulation now with the animate viewpoint activated.
The simulation is replayed with the viewpoint changes.

= Note that you can activate the Animate viewpoint option at anytime either before recording or after.

11. Click OK to save your simulation.
You are now ready to create a replay or an animation. This is done by compiling your simulation.

& You recorded a Simulation based on shuttles. Here, you selected the shuttle.2. Keep in mind that editing shuttles impact the Simulation.

E g ﬁemrding a Simulation { Animating a Wiewpoint 5Cu:ump:uiling] & Zimulation Eeneraﬁng an Animation
Eeplaying the Simulation



Compiling a Simulation

==

@

=
s

&

néw
=

This task shows how to compile a recorded Simulation to generate a replay
or an animation
You recorded a Simulation. Please refer to Recording a Simulation

The sample document used in this task can be accessed in the folder:
online\samples\dmufitting\all. CATProduct.

a
1. Click the Compile Simulation icon %
The Compile Simulation dialog box displays
2. Make sure the Generate a replay option is activated.
3.(Optional)
Enter a meaningful name for the replay you want to create.

Compile Simulation K Ed

4 [Fenerate a replay
Hame:'H eplay. 1

[] Generate an arirmation file Microzoft A j
| File pame ... i|
— Definibion

Sirnulation name:l Simulation. 1 j

[ ] Animate viewpoint

@ or | & cancel|

Compiling a simulation lets you either generate a replay or an animation. For
more details, please refer to Generating an Animation.

If you activated the animate viewpoint option in the simulation recording, the
option is still on in the Compile Simulation dialog box.
By default, the Animate viewpoint option is de-activated.

5. Activate the step time drop-down list box and select the
number of steps you want to break down each shot into, 0.2 for
example.

4. Click Ok to compile the simulation and create a replay object.
The Replay object is created and identified in the specification
tree.




=—Applications
T—xhuttle

25 Shuttle.
B Shuttle 2

==—Simulation

L— simulation.

*—Feplay

g g iﬁecnrding a Simulation ﬁnimaﬂng a Wiewpoint
{_Cnmpiling a Simulation Einerating an Animation Eiplaying the Simulstion




DEW Generating an Animation

@ This task shows how to compile a recorded Simulation to generate a replay or an
==, animation
You recorded a Simulation Please refer to Recording a Simulation

-=*_. The sample document used in this task can be accessed in the folder:
online\samples\dmufitting\all. CATProduct.

a
.% 1. Click the Compile Simulation icon %
The Compile Simulation dialog box displays
2. Make sure the Generate an animation file option is activated.
3. (Optional)
Enter a meaningful name for the animation file you want to create.

4.Activate the Time step drop-down list box and select the time step.
5.Click File name to store your animation.

The Save As dialog box displays
6. Click Save.

The animation file is created and saved In AVI Microsoft format.
Compile Simulation 7]

[ ] Generate a replay
Name:|H eplay.1

4 Generate an animation file: kicrozoft A

H
| File narne ... I|

— Diefinition

Sirmulation name:f i akon 1 j

Time step: 1 j

[ ] &nimate viewpoint

w Ok w Cancel

-
@Compiling a simulation lets you either generate a replay or an animation. Please

refer to Animating a Viewpoint
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Replaying the Simulation
I'@' This task shows how to rerun the Replay object resulting from the Compile Simulation

(=
The sample document used in this task can be accessed in the folder:
gf online\samples\dmufitting\all. CATProduct.

E 1. Click the Replay icon g % or double-click the Replay in the specification tree

P
- The Replay dialog box is displayed:
2.Specify the desired speed: x 5 for instance.

Replay [ 7] |

Marne: Feplay.1 j

NS
EIE'DD 3@

4 Animate viewpoint

— Interference — Digtance

Off =\ =
Cloze I
-

I@W' Check the Animate viewpoint option if you want to take into account the viewpoints recorded
- during the simulation.
@ Of course assigning a high number of interpolations amounts to replaying the scenario at a very

low speed.

3. Go back to the starting shot.
For instance, use the VCR buttons.

GJT Eneeem:
4 Animate viewpoint

4. Step forward.



RIDVIT OGNS
DIU:IEI = 1)1

I Animate viewpaint

5. Modify the speed at anytime.
6.Step forward again

G IS.IIIIII =1, 1 '

d Animate viewpoint

7. Replay the scenario back to the starting shot and at a 1 interpolation number between
recorded shots.

You can choose one of the loop modes to re-run the animation in a continuous way (either in
one direction only or in one direction then the other).

#

g |ﬁecnrding & Simulation |ﬁnimaﬂng a Yiewpoint
@_ & &
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Exploding

DMU Fitting Simulator provides the Explode capability. You can use this powerful functionnality either to understand
better the structure of your part and analyze the dismount capability or to obtain a printed document of your exploded
product for futher analysis.

Task Purpose

Exploding & Product g Understand the product structure to dismount purposes

Exploding a Shuttle g Obtain a printed document for further analysis

i

e

A

g ing Up S our Dk Fitting Shuttle
wn-Shuﬁle Fitting Sirmulstic €: Exploding
it 4




Exploding a Entire Product

[ This task illustrates the use of the Explode capability. Exploding the view of an assembly means separating the components of
== this assembly to see their relationships.
At any time though, you can check the product structure via the specification tree. The explode capability allows you to fully
understand the product structure in a 3D context.

=81 Open the all. CATProduct from the online\samples\dmufitting directory.

E 1.Select Productl in the specification tree
fac"

Product]
#—5 Body (Body 1)
I‘—'g? Engine (Engine. 1)
i—‘g? Sword (Sword.1]
#-%5 Handle (Handle 1)
— Applications

P
2. Click the Explode icon =7 |
The Explode dialog box is displayed.

Explode K E3
— Definition

Depth:l.-‘i'«ll lewvels j 53Iec:tin:un:|1 product

Type: I a0 j

— Scroll Explode

i ]|

o Cancel l




Product 1 is the assembly to be exploded. The Depth parameter lets you choose between a total (All levels) or partial (First

level) exploded view.

3. Set All levels if not already set.

4. Set 3D to define the explode type.

5. Click Apply to perform the operation.

The Scroll Explode field gradually displays the progression of the operation. The application assigns directions and distance.Once

complete, the assembly looks like this:
[%|DMU Navigator ¥5.2 - [all. CATProduct] O]
- 2] x|

n Statt  FEile  Edit Miew Inzett  Tool:  Analze Window  Help

Froductl

#5 Body (Body 1)
-—5”’ Engine (Engine. 1)
-—é? Sword (Sword.1]
#-%5 Handle (Handle 1)
— Applications

=]
ul

Sl B



- 7 mx' g2

E
P
F—¥;

NEE@gsurane R nBeénsQQ5 866 |y
I

Select products ar a group

The interest of this operation lies in the ability of viewing all components separately.

1
6. If you click : you go back to the product structure level which correspond in this case to the sub-entities: engine,
handle, sword as shown below:




[%]DMU Mavigator ¥5.2 - [all. CATProduct] M=l E3

E Stait  File Edit “iew Inzett  Toolr Analbze  Window  Help _|E|E|

#%5 Body (Body.1)
-f—%!’ Engine (Engine. 1)
-—ﬁ? Sword (Sword.1)
#-5 Handle (Handle 1)
— Applications




JQ@@Q%@%@#@@'J%@ﬁl@%%@g‘r%%i _ﬁmwmvmmn

Convertz a Test and Ty into a replay C:Enmpilel

7. Click OK to validate the operation or click Cancel to restore the initial view, it is up to you.

p Exploding a Product Exploding a Shuttle

(- €L €



Exploding a Shuttle

@ This task shows how to explode a shuttle. This time, you need to print the
==, exploded view to define a bill of material for instance

You created a shuttle.
ﬁ Open the all. CATProduct from the online\samples\dmufitting directory.
m 1.Set to no show mode the sword, handle
Sty and body for this:
a. Select the handle, body and sword in
the specification tree.
b. Swap to no show mode, click the
2. Click the Explode icon 1)
The Explode dialog box displays:
3.Select the shuttle you need to explode either
in the specification or dragging and dropping it
onto the selection field.

@ Froduct]

-|-—€?’i 3 Body (Body.1)

r—f‘ Engine (Engine. 1)
-|-€f’i %3 Sword (Sword.1)
ﬁf* Handle (Handle.1)

-—,&\Ipplica’ri@ns

=—Shuttle

I—fﬁﬂ Shuttle 1

Shuttle.1l is the assembly to be exploded. The Depth parameter lets
you choose between a total (All levels) or partial (First level)
exploded view.




Explode EHE3

— Definition

Selection: JERE== Sy

— Scroll Explode

| Bl

@ Apply J w Cancel
.

3. Set first level if not already set.

4. Set projection to define the explode type. The exploded view
Is set to the screen plane

5. Click Apply to perform the operation.
Explode EHE3

— Definitian

¥ | Selection: BIgRH =N,
Type: IF'ru:niec:tin:un j
— Scroll Explode

1.Dm

= ﬁ.ﬁl}l | w Cancel I

The Scroll Explode field gradually displays the progression of the

operation. The application assigns directions and distance.Once complete,
the resulting exploded view looks like this:




L

u_. The interest of this operation lies in the ability of viewing all components
separately within the same plane.

6. Now you can print the exploded view. Select File->Print command
to display the Print dialog box
7. Once you select the desired settings, press the preview button:



Print Preview K

{_i %l A4 21002297 0mm] [ 40%]

p Exploding & Product . Exploding & Shuttle

| - €




Advanced Tasks

DMU Fitting Simulator provides easy methods to define a multi-shuttle that will then be
recorded and replayed. Simultaneously to, or after, the replay, users can analyze the
interferences and distance assigned to the assembly.

<h

Defininq/Editind éeveral Shuttles Moving and Recording a Multi-Shuttle Simulation

—>
AL |
e

Measurihq Distances Detecting Interferences




Defining Several Shuttles

= This task shows how to define/edit two shuttles. The final purpose being to dismount the
==, engine.

p First, perform an explode of product 1 to understand better how to dismount the engine.

»

iy

Let's create a first shuttle.

5. Open the all. CATProduct from the online\samples\dmufitting directory.

1. Click two objects in the specification tree as shown opposite:

P
2. Click the Shuttle icon &=

The Edit Shuttle dialog box and the Preview window appear.

3. Press OK to confirm your operation.

== Body [Body.1)

—% CLUTCHCOWER [CLUTCHCOWER.T)

—% CRAMECASE_LSIDE [CLUTCHCOVER.T)
—% CRAMECASE_RSIDE [CRANECASE_RSIDEN]
—% CYLINDERCOVER [CYLINDERCOWER.T)
—% FILTER [FILTER.1]

—% FILTERCOWER [FILTERCOWVER.)

—% GASTRIGGER [GASTRIGGER.]

—% HOOK_FR4 [HOOK_FR4.7)

—% OILCAR [OILCAR.T)

—% FPETROLCAR [FETROLCAR.T)

—% SAFETYTRIGGER [SAFETYTRIGGER.)
—% SILEMCER [SILEMCER.T]

—% SILEMCERSUPPORT (SILENCERSUPPORT.T)
—% STARTHAMDLE [STARTHAMDLE. )

—% STARTINGHOUSE [STARTINGHOUSE 1]
—% TAME_LSIDE [TAME_LSIDE.]

—% TaMk_RSIDE [TAME_RSIDE.T)

" The Shuttle is created and identified in the specification tree.

Edit Shuttle EE3

M ame:

M ove:

— Definition

Selection: |2 products

|5 hittle. 1

@ Shuttle
() fis

w 0K J IIﬂl:anl::EIJ




=—Applications

B Shuttle 1

Let's create a second shuttle based on an existing group

4. You Drag the Shuttle icon @P .and drop it on the existing group in the
specification tree (Groupl)or click the shuttle icon first and select Groupl
afterwards.

The Edit Shuttle dialog window appears (Shuttle 1).
5. Press OK.

Edit Shuttle EE3
— Definition
M amne: |5 huittle. 2
Selectinn:mmupl

G |
T' E”% Move: @ Shumle
: ) Az

1
I‘—.-'l‘-.I:pIil:atiDns

o 0K l il:anc:ell

6. The second shuttle is created and identified in the specification tree.

7. You can edit the shuttles independently. For more information, please
refer to Editing a Shuttle.




;'—.&Fplic:atinns
==liroup

I—bﬁ?? Group. 1

== Shuttle

|—§§n Shuttle, 1

-;i‘ﬁi Shuttle. 2
l& Group. 1

One manipulator appears on each shuttle. These manipulators will allow you locating and
moving the shuttles to the desired location.

#7/

g ﬁgefining Several Shuttles uti-=huttle Simulation
|Fieasuring Diztances |§etecting Irterferences |Efining a Sweept Wolume
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Moving and Recording a Multi-Shuttle
Simulation

"@" This task shows how to simulate a more than one shuttle fitting simulation.

=,
i;,'fi" Open the all. CATProduct from the online\samples\dmufitting directory.

E 1. Click the Simulation icon ==
2. Select shuttle.1 and shuttle.2 in the Select dialog box.

Select I [=]

ou cannot create an emphy Simulation.

=
I

Shuttle.

(Shuttle 2

w Ok j ﬂEan:te

Two manipulators appear (one on each shuttle) as well as the Edit Simulation
dialog box.

3. Click the Insert switch and record the starting shot.



Edit Simulation = |

Name:m

I
<>
EIMD = 1| iy =

[ ] Arimate viewpoint

| Inzert l kA odify I Delete I Skip I

[ Automatic inzert

|nterference Digtance ———
’[fo = ’[fo F

Edit analyzis l Edit zimulation objects I

W 0K I ﬂEar‘u:eIl

Y
‘

4. Move the shuttle.1 to the desired location via the manipulator.

5. Click the Insert switch and record the desired shot.

6. Move the shuttle.1 again.



7. Now select the shuttle.2 Three possibilities are available:

@ Select the shuttle in the specification tree
@ Select the shuttle.2 axis in the geometry area

@ Select the product in the geometry area

8. Press OK to confirm your operation.



) .l!;l:llr,!:!:ll 1 - .1\"1"

b

8. Now, move the shuttle.2.

9. Click Insert. You recorded the motion of the two shuttles.

To analyze an object and its related objects under the form of a specification tree or in the
E?BD, select the current selection icon from the DMU Simulation toolbar or select Analyze
->Current Selection from the menu bar. The Current dialog box appears as follows:

Current Selection !E[ E

8 DEMO_CGE_CHAINSAW _BODY_STARTINGHOUSE 1

B Test Try 1= 5 Shuten < -
5’% DEMO_CGE_CHAIMSAW BODY _STARTHAMDLE 1

[ | Reframe on selection [ ] Freeze 4 View related objects
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Measuring Distances

This task shows how to measure distances as or after you record a route.

Open the all. CATProduct from the online\samples\dmufitting directory.

1. In the
specification
tree, click
shuttle.1.

2. Click the

Distance icon

>
LA

The Edit
Distance
dialog box
IS
displayed.
Make sure
the
distance
type is set
to
Minimum
and
Between
two
selections.

3.You
need to
define the
second
selection,
for
this:select
the handle
either in
the
specification
tree or in

Edit Diztance

— Defirution

Name:lDistanceJ

Type: IMinimum

j Selection 1:] Shuttle. 1

Between bwo selectiofill BSEEEE (a0 1 product

w OK l - ﬁ'-.ppl_l,ll w Cancel




the
geometry
area.

3. Click OK.

The specification tree is updated.
:.-—Alpplic:aticuna

shuttle
Simulation
| & .
#—H% Simulation.l
=—Distance
—»
L& oisteresn
4. Double-click on Simulation.1 in the specification tree.

The Edit Simulation dialog box is displayed.
6. Click Edit Analysis.
The Edit Analysis in Simulation dialog box displays.

Edit Analyziz in Simulation

Mo Mame

Browsze, .. l .-'-‘-.Q,E I Hemu:u'-.-'el

w Cancel

7. Click Add then select Distancel from the displayed dialog box..



Select !EI

@ o0k | @ Cancell

The Edit Analysis Simulation dialog box is updated.

8. Click Ok.

Edit Analyziz in Simulation

Mo | Mame
1 Dhstance. 1

Browse... I Add... I Flemwel
@ 0k | & Cancel
.
9. Set the Distance combo to On in the Edit Simulation dialog box,
then click OK.

The Preview window is updated too.



Edit Simulation K E3 |

M ame:W

I
R T
EID.EIEI :|1 |

[ ] Animate viewpoint

Insert | Modify | Delete | Skip_|

[ ] Autornatic inzert

Interference Diztance ————
T 7] [Fr—]

Edit analyziz I E dit zimulation objects I

w Ok I lﬁEanceIl

‘.




Preview |

: VIZ\F

10. Click the required switches for replaying shots.

The minimum distance (represented by a line , two crosses and a
value) appears in the geometry area as shown below:




11. You can display detailed information about the minimum
distance at a given step by clicking on the Distance Results

object in the specification tree.
You can also use the Browse switch from the Analysis tab.



Edit Distance

— Definition
RENER [iztance. 1
Type: |Minimum j Selection 1 :| Shuttle. 1

Between bwo zelechons j Selecton 2:
— Results
Distance |5.EIEEIEmm
Delta 2 |EI.I:II:I'I 2 iy |5.EIEEIEmm Z |EI.EIEIEI4mm
FPaoint1 |-T-"5.I:I5?3mm i |--'-1E.EI1 34 i |55mm
Pairt 2 = |-75.0562mm Y |-5dmm 2 |55.0004rmm
Poirt 1 on |ST.-'-‘-.HTIN|3HEIL|5E.1
Point 2 an IH.E'-.N DLEA

w 0K I Iﬂ.-i'-.|:||:|l_l,ll w Cancel

.

12.The specification tree is updated.

Distance
==t Distance. 1

—
T

Please refer to the DMU Space Analysis User's Guide for more information about
detecting and analyzing distances between products or between groups.

#3
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Detecting Interferences

@ This task shows how to detect clashes while recording a route (Simulation)..

3 Jo

The sample document used in this task can be accessed in the folder: online\samples\dmufitting\all. CATProduct.
-=._The fitting document must be already opened.

1. In the specification tree, click Group 1.
The two products are highlighted in the specification tree.

‘H

2. Click the Clash icon % .

The Check Clash dialog box is displayed.

3. Activate the first Type drop-down list box and select Clash

4. Click the second Type drop-down list box and select Selection Against All.

Check Clazh EE

D efinition

Name:llnterference.'l

Type: P
ISEIectinn against all j Selection 2
@ I:Krj @ Apply J s Eann::el]
. L

5. Click OK. The specification tree is updated.



=t plicationz

== Shuttle
2 Shuttle. 1
== Simulation
#—@ Simulation.
== Diztance

E Diztance.

=—|nterference

b

6. Double-click on Simulation in the specification tree.

The Edit Simulation dialog box is displayed.
7. Click Edit Analysis.

The Edit Analysis in Simulation dialog box is displayed.
8. Click Add then select Interferencel from the displayed dialog box.

Select _ (O]

Distance.

b

@ 0k | @ Cancel |

The Edit Analysis Simulation dialog box is updated as shown opposite.
9. Click Ok



Edit Analyzis in Simulation

Mo | M arme |

1 [nterference. 1

b

Browse.. | Add. | Eemove I

@ 0K | & Cancel |

10. Set the nterference combo to On in the Edit Simulation dialog box, then click OK.
Edit Simulation K|

Name:lW|

It
A
Eln.nn =1[1 =]

[ ] Animate viewpaint

Inzert I b cify I Delete I Skip I

[ ] Avstomatic insert

Interference Digtahce ———————
HM - ﬁﬂff =

Edit analysiz I E dit zimulation objectz I

@ 0K I & Cancel |

-

11. Replay the fitting simulation. The product in collision is highlighted







The specification tree is updated.
12. Now set the interference combo to Stop and

click OK. I_ Interference —————
imulati " ilw -
The simulation stops at the position where a . B

collision is detected between Group 1 (Shuttle 1)
and the other products.

The product in collision is highlighted.

The value of the Current time option provides
precise time of the clash.
U._'The interference combo is still set to Stop. If you manipulate the shuttle 1 directly, the simulation stops just before the collision is
detected. Thus, you can record the exact position
13. To locate the clash position more precisely, first select Interferencel in the Analysis tab from the Edit Simulation
dialog box. Then, act on the Browse switch described in the previous distance step.



Check Clazh

List by Canfict | List by Product |

7]
— Definition
Mame: Interference. 1
Type: IEIash j Ornirn Selection 1: 1 product
ISeIectinn againzt all j Selection 2
— Results
ﬁ Mumber of interferences; & [ClazhiB, Contach ], Clearance: 0]
Filker lizt: I.ﬂ.ll lpes lenfiIter ar walle jl.-‘l'«ll statugzes j .ﬂ.EEIE filkers I

Mo, | Froduct 1 | Froduct 2 | Tupe | W alLie | Statuz |
1 CLUTCHCOWE..  CYLINDERCOY.. Clazh -1.0833 Relewvant

2 CLUTCHCOYE..  HOOK_FR4.1 Clagh Mat inzpect. ..
3 CLUTCHCOWE...  OILCAP.1 Clagh Mat inzpect. ..
4 CLUTCHCOWE..  SILEMCERSUP... Clazh Mat inzpect. ..
5 CLUTCHCOVE..  FLYW“WHEEL1 Clazh Helewvant

<] |

M are > I

@ 0K | @ spoly | @ Cancel |

14. The preview window is updated.



Preview T H

@Please refer to the DMU Space Analysis User's Guide for more information about detecting and analyzing distances between

products or between groups.




g |ﬁfining Several Shuttles |ﬂuﬁi-5huﬁle Simulation |Eieasuring Diztances Detecting Irterferences
) .5‘
@— # # # F
|Efining a =vwept Yolume ﬁing a =huttle in a Simulat
¥ +




Defining a Swept Volume

This task shows how to define a swept volume.

Jlo

The sample document used in this task can be accessed in the folder:

& ._online\samples\dmufitting\all. CATProduct.
You recorded a Simulation and compiled it . You obtained a Replay object. Please
refer to Compiling a Simulation

% 1. Click the Swept Volume icon
The Swept Volume dialog box dlsplays

Sweptvolme K|

— D efinition
Replay Replay.1 il
Product[z) to sweep | 3 products I

[ ] Usze level of details

2. Click Apply to generate the swept volume
3. If you check the Use level of details option

This is what you obtain :

@ Apply I - Eann:ell




EDHU Mavigator ¥5.2 - [ WARNIMNG: Save thiz product as a _cgr or _wil hile]

n Start  File  Edt  “iew Inset  Tools  Analyze  Window  Help

=8| x|

s HedB3RAQUL G

Select an object or a command |

4. Select File->Save As... from the menu bar.
5.Select cgr from the Save as Type field

T T
S ave i I‘E S amples j EI BhT IE

DEMO_CGE_CHAIMSAW EMGINE_CYLINDER.cor
DEMO_CGE_CHAIMSAW EMGINE_FLYWHEEL cor
] DEMO_CGE_CHAIMSAW_ENGINE_PISTOM. car

|#] DEMO_CGE_CHAINS AW _ENGINE_PISTONBOLT car
] DEMO_CGE_CHAINS AW _ENGINE_PUMPHOUSE. car

sweptkin . cor
A N
File name: Isweptfit'l .cgr Save

Save as lype: |W:|' Cancel

6. Click Save.
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n@wAdding A Shuttle in a Simulation

This task shows how to add a shuttle in a simulation. In our example you need to move first the
starthandle to dismount the startinghouse.

The sample document used in this task can be accessed in the folder:
online\samples\dmufitting\all. CATProduct.
You created a shuttle with the startinghouse.

1. In the specification tree, click Shuttle.1.

=53 Bady (Body 1)
#=T% Ergine [Engine.1)
=T Sword (Sword 1)
#=T5 Handie [Handie1]
==~ nplications

==5huttle
L;“ﬁ,, Shuttle. 1

b

2. Iick the Simulation icon C elect O[]

ou cannot create an empty Simulation,

=]
=

The Select dialog box
displays.

3.Select Shuttle.1 and click
OK.

@ glﬁi I ﬂEanceli

The Edit Simulation dialog box and Preview window appear.

The starting shot (shuttle initial position) is automatically recorded.

4. Move the shuttle to the desired location with the manipulator
5. Click the insert switch and record the desired shots



You need to move the starthandle, for this: create a shuttle without exiting the simulation
command

6. Click the Shuttle Icon %

Select Starhandle either in the geometry area or in the specification tree.
7. Click OK to confirm the shuttle creation.
8. Click Edit simulation objects in the Edit Simulation dialog box as shown opposite

Edit Simulation K E |

|N-3ITIEZ|SimuIatil:nn.1 |

i
EIRTMCIES
Eln.nn [ "l

[ Animate viewpairnt

Inzert ] Fdmdlify I [elete _I Skip I

L] Avtomatic inzert

— |nterferenice — Digtance
[ =\ o =

E dit analyziz _I Edit zinulakion ohjects _I

........

The Edit Analysis in Simulation dialog box displays.
9. Click Add and select shuttle.2 in the Select dialog box.




E dit Analysziz in Simulation EHE3

! [ | MHarme |
1 Shuttle.

Browae,,. i .ﬁ.g'wlll Flemmfel
1)

-
10. Click OK in the Edit Analysis in Simulation to confirm your operation.
E dit Analysis in Simulation BHE
N-:ul M ame |

1 Shuttle

Browsze. . ] .fi'-.clcl...’ Flemn:n.fel
@ 0K I annceII

=4 plications
. Shattl
The shuttle.2 is u._E
identified in the ;ﬁn Shuttle. 1
specification tree S Shuttle.?

Simulation I}S

11. Move the shuttle.2 to the desired location with the manipulator
12. Click the insert switch and record the desired shots.




You can dismount the startinghouse.

g |Efining Several Shuttles |ﬁuﬁi-5huﬁle Simulstion
L + &
|§Eeasuring Distances |§etecting Irterferences |Efining a Swept Yolume
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iﬂding a Shuttle in a Simulst

|
]




Workbench Description

This section contains the description of the icons and menus which are specific to the DMU Fitting
Simulator workbench.

The DMU Fitting Simulator window looks like this:

Click the sensitive areas to see the related documentation.

e e [ ow jeed  Jock  jeelor  mindm  Heb

DMU Fitting Simulator Menu Bar
DMU Fitting Simulation Toolbar
DMU Manipulation Toolbar
DMU Space Analysis Toolbar

o RR

T

1E 6

¥

§

I %



DMU Fitting Simulator Menu Bar

Here we will present the various menus and menu commands that are specific to DMU
Fitting Simulator version 5.

Start File Edit View Insert Tools Analyze Windows Help

Insert

Tool:  Analyze FOI... See...
HEject
;‘!%m Shuttle Distance Measuring Distances
-ﬁ}ﬁ Simulation
Clash Detecting Interferences
(g Clash
E Distance Shuttle Defining/Editing Several Shuttles
(&35 Group o _ .
Simulation Moving and Recording a
%g e ERrs s Multi-Shuttle Simulation

% e Froduct

Hew COM Component - EXisting Component Entering in the DMU Navigator and
'%ﬂ}- Mew Part. Selecting Models

% Ewisting Companent...

Tasks corresponding to the general menu commands are described in the
Infrastructure User's Guide.

g Menu Bar Simulation Toolbar

E ManipulationToolbar giace Analyzsiz Toolbar



DMU Simulation Toolbar

The DMU Simulation toolbar contains a number of tools that are useful for DMU Fitting
Simulator.

DMU Simulation x|
| S

b % See Replaying the Recorded Motion

See Defining a Swept Volume

n;- See_Exploding an Entire Product
< See Exploding a Shuttle

g g E Menu Bar { Simulation Toolbar
E ManipulationToalbar giace Analyziz Toolbar



DMU Manipulation Toolbar

The DMU Manipulation toolbar contains a humber of tools that are useful for DMU
Fitting Simulator. It displays when using the Shuttle, Explode and Simulation
commands (if based on one or various shuttle(s).

DMU M anipulation x|

'?@See Moving the Manipulator independently from the Shuttle

See Moving the Shuttle

= See Moving the Manipulator independently from the Shuttle

":@ See Moving the Shuttle

See Moving the Manipulator independently from the Shuttle

See Editing a Shuttle

See Moving the Shuttle

See Moving the Manipulator independently from the Shuttle

=

ﬁmSee Moving the Shuttle

g Menu Bar Simulation Toolbar

{ ManipulationToolbar giace Analysiz Toolbar



DMU Space Analysis Toolbar

Whenever DMU Space Analysis is installed, the DMU Space Analysis toolbar can be
activated. It contains a number of tools that are useful for DMU Fitting Simulator.

DMUC... B3

J%E

—> i i
4 Measuring Distances

R

% Detecting Interferences

(]4] Menu Bar ZSimulation Toolkar

ManipulationToolbar =pace Analysis Toolbar

2 - &



Glossary
C

clash A logical process checking whether the shuttle and the environment are
In intersection or in contact.

clearance A logical process checking whether the minimum distance existing
between the shuttle and its environment is greater than a specified
threshold distance or not.

collision A logical process checking whether the shuttle and the environment are
In intersection or in contact.

D

distance A logical process measuring the minimal distance between the shuttle
and its environment (considered as geometrical entities).

G

group A entity to group models together. This entity is recognized during
shuttle, distance and clash definition.

interference A logical process checking whether the intersection of the shuttle and its
environment (considered as geometrical entities) is null or not.

L

location A position in the space used to define the trajectory of the shuttle during

its motion.

manipulator An graphic editor for positioning the shuttle. It is composed with symbols
and a dialog box. The symbols are used to drive the positions of the
shuttle in a specific direction.

P

position The temporary location of a shuttle during manipulation.

S



shuttle

shuttle axis

simulation

track

A shuttle is an element representing the object to be fitted or unfitted from
an assembly. It is composed of an axis and list of models. The shuttle
can be moved about to simulate the fitting or unfitting of the object within
the assembly.

The position of a particular axis attached to the shuttle, by convention.
This axis is called shuttle axis. This axis is choose by the system at the
center of the shuttle bounding sphere.
A record and replay of a scenario in which a shuttle is dismounted from
an assembly according to some constraints like interferences..During the
definition and replay interference detection and distance measurement
can be performed.

T

A seqguence of locations forming a single path for a shuttle to follow. A
track can be defined by creating locations. A track can then be simulated.

During this simulation, interference detection can be performed.




Index
C

Clash icon ¥
commands
clash »
distance »
shuttle» ,» , »
simulation ¥ , »
contextual menu
align »
attach »
axis »
editor »
follow ¥
free »
target »

Distance icon ¥
DMU Manipulation toolbar »

DMU Simulation toolbar ¥
DMU Space Analysis toolbar ¥

manipulator »
moving ¥
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moving »



