Preface

DMU Kinematics Simulator is an independent CAD product dedicated to simulating assembly motions. It addresses the design review environment of digital mock-ups (DMU) and can handle a wide range of products from consumer goods to very large automotive or aerospace projects as well as plants, ships and heavy machinery.

DMU Kinematics Simulator is a dedicated DMU Navigator workbench and is available on both UNIX and Windows NT environments.

This guide is organized as follows:

- **Getting Started**

  Provides a scenario allowing you to get acquainted with the product.

- **Basic Tasks**

  Provides a step-by-step guide for using DMU Kinematics Simulator. Useful tips are given for getting the most out of the product.

- **Advanced Tasks**

  Provides a step-by-step guide for using DMU Kinematics Simulator along with complementary DMU Navigator products.

- **Workbench Description**

  Describes menu commands and workbench toolbars that are useful for DMU Kinematics Simulator.

- **Glossary**

  Provides definitions of terms that are specific to DMU Kinematics Simulator.

DMU Kinematics Simulator Version 5 makes use of CATIA Version 4 multi-model sessions that have been prepared with one or more kinematic mechanisms. This preparation task is described in the Basic User Tasks section of this guide.
Using This Guide

This guide is intended for the user who needs to quickly become familiar with ENOVIA-DMU Kinematics Simulator. The user should be familiar with basic ENOVIA-DMU Navigator Version 5 concepts such as document windows, standard and view toolbars.

To get the most out of this guide, we suggest you start reading and performing the step-by-step tutorials "Getting Started".

The next sections present main capabilities in the form of user's tasks. It may be a good idea to take a look at the section describing the menus and toolbars.
Where to Find More Information

Prior to reading this book, we recommend that you read the *ENOVIA-DMU Navigator User's Guide*.

You may also like to read the following complementary ENOVIA-DMU Navigator product guides, for which the appropriate license is required:

- [DMU Fitting Simulator User's Guide](#)
- [DMU Space Analysis User's Guide](#)
What's New?

Enhanced: Automatic design mode in: Managing Dressup Mechanism

New Getting Started: Designing a V5 Mechanism

New Task: Converting V4 Kinematic Data into DMU Kinematic Version 5

New Task: Creating a V5 Mechanism and Revolute Joints

New task: Defining a Fixed Part

New Task: Defining a Command

New Task: Creating Joints

New Task: Editing Joints
Getting Started

Before getting into the detailed instructions for using DMU Kinematics Simulator Version 5, the following tutorials aim at giving you a feel of what you can do with the product. It provides a step-by-step scenario showing you how to use key functionalities.
The main tasks described in this section are:

Theme
- Designing a V5 Mechanism
- Using V4 Kinematic Data

Each Getting started should take about 10 minutes to complete.
Designing a V5 Mechanism

Before getting into the detailed instructions for using DMU Kinematics Simulator Version 5, the following tutorial aims at giving you a feel of what you can do with the product. It provides a step-by-step scenario showing you how to use key functionalities.

The main tasks described in this section are:

- Entering The Workbench
- Creating Mechanism & Joints
- Creating Cylindrical Joints
- Defining a Command
- Defining a Fixed Part
- Simulating a V5 Mechanism

These tasks should take about 15 minutes to complete.
Entering the Workbench

Before starting this scenario, you should be familiar with the basic commands common to all workbenches. These are described in the DMU Navigator User's Guide. Open the rods.CATProduct from the online\samples\dmukinematics directory.

This first task will show you how to enter the DMU Kinematics Simulator workbench and select your models.

1. Select Digital Mockup -> DMU Kinematics from the Start menu

The DMU Kinematics workbench is loaded and an empty document opens:

2. Select File -> Open from the menu bar.
3. Select the rods.CATProduct document.

Click Open to open the selected file.

The specification tree is displayed showing all the selected products.
4. Select the products in the tree, then select Edit -> Design Mode. You can now expand the tree to show all the design components of the products.
Use the Fit All In icon to position the model geometry on the screen.
Creating a Mechanism and Revolute Joints

This task will show you how to create a mechanism and revolute joints.

Open the rods.CATProduct from the online\samples\dmukinematics directory.

1. Select the product in the specification tree, then select Edit -> Design Mode.
   You can now expand the tree to show all the design components of the products.

2. Click the Revolute icon \ from the DMU Simulation Toolbar.

   The New Joint: Revolute dialog box displays:

3. Click New Mechanism.

   The Mechanism is identified in the specification tree.
Now you need to select two lines and two planes.

4. Select Line 1 in the geometry area. In our example select a cylinder as shown below. The dialog box is automatically updated with your selection.

5. Select Line 2 in the geometry area. Select a second cylinder. The dialog box current selection field is automatically updated.
6. Select the planes as shown below. The Current selection field automatically updates.
7. Click Ok to end the Revolute Joint creation.

The Revolute Joint is created as well as the coincidence constraints. The specification tree is updated.

Proceed in the same manner to create joint 2, joint 3 and joint 4. This is what you obtain:
You can also create a new mechanism selecting Insert -> New Mechanism... from the Menu bar. The new mechanism is created and identified in the specification tree.
Creating Cylindrical Joints

This task will show you how to create cylindrical joints.

Open the rods.CATProduct from the online\samples\dmukinematics directory. You created a mechanism and 3 revolute joints as shown in the previous task.

1. Click the Cylindrical icon.

The New Joint Cylindrical dialog box appears:

2. Select Line 1 in the geometry area. In our example select a cylinder as shown opposite:

The dialog box is automatically updated with your selection.
3. Select Line 2 in the geometry area. In our example select a cylinder as shown opposite:

The dialog box is automatically updated with your selection.

4. Click OK to end the cylindrical joint creation.

The Revolute Joint is created as well as the constraints. The specification tree is updated.
You can define commands while creating cylindrical joints:

- Driven angle
- Driven length

All you need to do is to check the required option.

Remember that you can at any time modify the command. For this, double-click the joint in the specification tree and edit the settings in the displayed dialog box. For more details, please refer to Editing joints.
You can either define a command after joint creation or during joint creation. This task will show you how to define a Command after joint creation.

Open the rods.CATProduct from the online\samples\dmukinematics directory.

1. Double-click the joint 3 in the specification tree.

The Joint Edition dialog box is displayed.

2. Activate the Driven angle option. The command will be an angle type command.
3. Click Ok to confirm your operation.

The command is identified in the specification tree.
Defining a Fixed Part

This task will show you how to define a Fixed part.

Open the rods.CATProduct from the online\samples\dmukinematics directory.

1. Click the Fixed Part icon from the DMU Kinematics toolbar or select Insert->New Fixed Part... from the menu bar.

The New Fixed Part dialog box is displayed.

2. Select the Fixed Part either in the geometry area or in the specification tree.

3. The fixed Part is automatically defined.
The fixed part is identified in the specification tree.

👉 At any time you can use the undo command 🔄 to modify your selection.
Simulating a V5 Mechanism

This task will show you how to simulate the V5 mechanism you created.

Open the rods.CATProduct from the online\samples\dmukinematics directory.

You designed a V5 mechanism as described in the previous steps.

1. Click the Simulation With Commands icon.

The Kinematic Simulation dialog box displays:

The command of the kinematics mechanism are available as shown opposite.

2. a. Manipulate the slider of the command.

The kinematics mechanism moves accordingly.

2. b. Use the manipulator in the geometry area. For this:

Move the mouse over a joint. The driven joint highlights and the manipulator appears.
Drag the model with the left mouse button.
For more information please refer to Running Simulations and About Joints.

You can also enter a value for the command to achieve the same result.

Note that if you click the button, the Kinematics Simulation dialog box expands. The immediate option is set by default. For more information about the On request option, please refer to Simulating on Request.
Using V4 Kinematic Data

Task

Entering the Workbench
Browsing the Mechanism
Simulating With Commands
Simulating With Laws

Up
Designing a V5 Mechanism
Using V4 Kinematic Data
Entering The Workbench

Before starting this scenario, you should be familiar with the basic commands common to all workbenches. These are described in the *DMU Navigator User's Guide*. This first task will show you how to enter the DMU Kinematics Simulator workbench and select your models.

1. Select Digital Mockup -> DMU Kinematics from the Start menu.

The DMU Kinematics workbench is loaded and an empty document opens:

2. Select Insert -> Existing Component... from the menu bar.

3. Select the desired Kinematics model files by clicking the first one then shift-clicking the last one you want.

Click Open to open the selected files.

The specification tree is displayed showing all the selected products.
4. Select the products in the tree containing kinematics objects, then select Edit -> Design Mode. You can now expand the tree to show all the design components of the products.
Remember that DMU Kinematics Simulator exploits CATIA Version 4 multi-model sessions that have been prepared with one or more kinematic mechanisms.

Use the Fit All In icon to position the model geometry on the screen.
Browsing the Properties of the Kinematics Mechanism

This task will show you how to browse the properties of the selected kinematics mechanism.

Open the .model files from the online\samples\dmukinematics directory.

1. Select KIN_EX17_00_ACTIVE in the specification tree.

2. Right-click the kinematics mechanism in the specification tree or select the Edit->Properties... from the menu bar.

3. In the first case, select Properties from the contextual menu displayed.

The Properties dialog box is displayed:
4. Click the Mechanism Analysis icon 🔄.
   The General Properties of the kinematics mechanism are displayed as shown.

5. You can select another mechanism using the Mechanism name combo.
6. If you check the Show joints, this is what you obtain:

7. If you click the Laws... button, you access to a graphic representation of the laws associated to each command. It is represented by a colored curve. When you pass the cursor along the curve, information about the law is displayed in the status bar.

8. The More >> button is described in detail in Analyzing A Mechanism.

For more information about laws, please refer to Simulating With Laws.
Running a Kinematics Simulation With Commands

This task will show you how to run a kinematics simulation with commands.

Open the .model files from the online\samples\dmukinematics directory. A kinematic product is highlighted in the specification tree.

1. Click the Simulation With Commands icon.

The Kinematic Simulation dialog box is displayed:

The commands of the kinematics mechanism are available as shown opposite.

2. Manipulate the slider of a command. For instance select the LEFT. The corresponding part of the kinematics mechanism moves accordingly.

Note that if you click the button, the Kinematic Simulation dialog box expands. The immediate option is set by default. For more information about the On request option, please refer to Simulating on Request.
You can use the slider, enter a value or manipulate the geometry directly to achieve the same result.

3. Manipulate the other commands in the same way.
Running a Simulation With Laws

This task will show you how to run a kinematics simulation with laws that are already defined on the mechanism.

The sample document used in this task can be accessed in the folder: online\samples\dmukinematics.

The Kinematics Simulation dialog box is displayed as described in the previous task.

1. Click the Simulation With Laws icon.

   The Kinematic Simulation dialog box appears.

   ![Kinematic Simulation Dialog Box]

2. Set the Number of steps to 10, then click the Play VCR button.

   The kinematic mechanism moves according to the pre-defined laws.

Notice that you cannot record simulations within the Simulation With Laws functionality. If you need to record such a simulation or several simulations, please refer to Recording Positions.

You can use the other VCR buttons to run the simulation again in different modes (backward, step by step, and so on).
Basic Tasks

The table below lists the tasks you will find in this section.

<table>
<thead>
<tr>
<th>Theme</th>
</tr>
</thead>
<tbody>
<tr>
<td>Setting Up Your Session</td>
</tr>
<tr>
<td>Designing a V5 mechanism</td>
</tr>
<tr>
<td>Running Simulations</td>
</tr>
<tr>
<td>Reviewing Simulations</td>
</tr>
<tr>
<td>Managing Dressup Mechanism</td>
</tr>
</tbody>
</table>
Setting Up Your DMU Kinematics Simulator Session

DMU Kinematics Simulator provides easy methods to simulate mechanisms previously defined using the CATIA Version 4 KINEMAT and KINEMUSE functions.

You may find it useful to refer to your CATIA Version 4 Kinematics User’s Reference Manual.

<table>
<thead>
<tr>
<th>Tasks</th>
</tr>
</thead>
<tbody>
<tr>
<td>Preparing CATIA Version 4</td>
</tr>
<tr>
<td>Converting V4 Kinematic Data into DMU Kinematics</td>
</tr>
<tr>
<td>Opening Version 5</td>
</tr>
</tbody>
</table>

Up, Setting Up Your Session, Designing a V5 mechanism
Running Simulations, Reviewing Simulations, Managing Dressup Mechanism
Designing a V5 Mechanism

DMU Kinematics Simulator provides easy methods to record and replay kinematic simulations.

Tasks

- About Joints
- Creating Mechanism & Joints
- Creating Joints
- Defining a Fixed Part
- Defining Commands
- Editing Joints

Up

Running Simulations

Setting Up Your Session

Reviewing Simulations

Designing a V5 mechanism

Managing Dressup Mechanism
DMU Kinematics Simulator lets you define and edit 6 different joint types.

The table below describes the joint types and their characteristics:

<table>
<thead>
<tr>
<th>GRAPHIC REPRESENTATION</th>
<th>JOINT TYPE</th>
<th>DEGREES OF FREEDOM</th>
<th>COMMAND TYPE</th>
<th>DIRECT MANIPULATION</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Revolute</td>
<td>1 Rotation</td>
<td>Angle</td>
<td>YES / Left-mouse button</td>
</tr>
<tr>
<td></td>
<td>Prismatic</td>
<td>1 Translation</td>
<td>Length</td>
<td>YES / Left-mouse button</td>
</tr>
<tr>
<td></td>
<td>Cylindrical</td>
<td>1 Rotation 1 Translation</td>
<td>Angle or Length</td>
<td>YES / Left-mouse button</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Length +Angle</td>
<td></td>
<td>Length: Left-mouse button Angle: Left-Mouse button + Middle-Mouse button</td>
</tr>
<tr>
<td></td>
<td>Spherical</td>
<td>3 Rotations</td>
<td>_</td>
<td>NO</td>
</tr>
<tr>
<td></td>
<td>Planar</td>
<td>2 Translations 1 Rotation</td>
<td>_</td>
<td>NO</td>
</tr>
<tr>
<td></td>
<td>Rigid</td>
<td>_</td>
<td>_</td>
<td>NO</td>
</tr>
</tbody>
</table>

Only the joints which are assigned a command can be manipulated.
Creating a Mechanism and Revolute Joints

This task shows how to create a kinematics mechanism for use in DMU Kinematics Simulator Version 5.

Open the rods.CATProduct from the online\samples\dmukinematics directory.

1. Make sure you are in Design mode. If not select the products in the tree, then select Edit -> Design Mode.
   If the menu item cannot be selected, right-click product1 in the specification tree.

2. Click the Revolute icon from the DMU Simulation Toolbar.

   The New Joint: Revolute dialog box is displayed:

   3. Click New Mechanism.

   The Mechanism is identified in the specification tree.

   Now you need to select two lines and two planes.

   4. Select Line 1 in the geometry area. In our example select a cylinder as shown opposite.

   The dialog box is automatically updated with your selection.
5. Select Line 2 in the geometry area. Select a second cylinder. The dialog box current selection field is automatically updated.

6. Select the planes as shown below. The Current selection field is automatically updated.

The Revolute Joint is created as well as the constraints. The specification tree is updated.
7. Click Ok to end the Revolute Joint creation.

8. Proceed in the same manner to create other joints.

Do not forget to define a command and a fixed part.

You can also create a new mechanism selecting Insert-> New Mechanism... from the Menu bar.
Creating Joints

This task shows how to create joints in a V5 mechanism.

You opened the rods.CATProduct from the online\samples\dmukinematics directory.

When you create joints, you can define the mechanism within the same dialog box. Remember though, that you create a mechanism independently from the joints by selecting Insert->New Mechanism... from the menu bar.

1. Click the Revolute Joint from the DMU Simulation Toolbar which is the default joint type.

2. Click the arrow within the icon and undock the DMU Kinematics toolbar.

The DMU Kinematics toolbar displays:
3. Select the joint type of your choice.
4. For instance click the rigid joint icon.

The New Joint: Fully Restricted dialog box is displayed.

5. Select the parts either in the geometry area or in the specification tree.

6. Click Ok to confirm your operation.
The Rigid Joint is identified in the specification tree.

For more information, please refer to About Joints and Creating Mechanisms and Joints.
Defining a Fixed Part

This task will show you how to define a Fixed part.

Open the rods.CATProduct from the online\samples\dmukinematics directory.

1. Click the Fixed Part icon from the Simulation toolbar or select Insert->New Fixed Part... from the menu bar. The New Fixed Part dialog box is displayed.

2. Select the Fixed Part either in the geometry area or in the specification tree.

3. The fixed Part is automatically defined.
The Fixed part is identified in the specification tree.

At any time you can use the undo command to modify your selection.
Defining Commands

You can define a command either during joint creation or after joint creation. This task shows how to define a command on a cylindrical joint during its creation.

Open the rods.CATProduct from the online\samples\dmukinematics directory. You created a mechanism.

1. Click the Cylindrical icon. The New Joint Cylindrical dialog box appears.

2. Select the line 1 and line 2 in the geometry area

3. Activate the Driven angle for instance.

4. Click Ok to confirm your operation. The command is identified in the specification tree.
DMU Kinematics Simulator lets you easily edit joints. Editing joints means you can modify:

- its name
- deactivate the command

This task shows you how to do so.

1. Double-click the joint to be edited in the specification tree. For instance Joint 1. The Joint Edition dialog box displays:

3. In the name field enter a meaningful name: Revolute 1-3 for instance.
4. Activate the Driven angle command.

3. Click OK to confirm your operation. The Joint is updated and identified in the specification under its new name.

Note that you can edit the mechanism name. For this all you need to do is double-click the mechanism in the specification tree and enter a new name in the dialog box displayed and click OK.
Running Simulations

DMU Kinematics Simulator provides easy methods to run kinematics simulations and detect collisions during simulations.

Tasks

<table>
<thead>
<tr>
<th>Simulating With Laws</th>
</tr>
</thead>
<tbody>
<tr>
<td>Simulating With Commands</td>
</tr>
<tr>
<td>Simulating On Request</td>
</tr>
</tbody>
</table>

Manipulator symbols are displayed for either translating or rotating the mechanism whenever its joints have associated commands.

- For a joint with a linear command, a linear manipulator symbol is displayed. To translate the mechanism just drag it using the left mouse button.
- For a joint with an angular command, a circular manipulator symbol is displayed. To rotate the mechanism just drag it using the left mouse button.
- For a joint with linear and angular commands, a linear manipulator symbol is displayed. To translate the mechanism just drag it using the left mouse button.
- To access the circular manipulator for rotating the mechanism you must use the left and middle mouse buttons together and drag as before.
Simulating With Laws

This task will show you how to run a kinematics simulation with laws that are already defined on the mechanism.

The sample document used in this task can be accessed in the folder: online\samples\dmukinematics.

1. Click the Simulation With Laws icon in the DMU Simulation Toolbar or The Kinematic Simulation.

![Kinematic Simulation dialog box]

2. Set the desired Number of steps, then run the simulation using one of the VCR buttons:
   - Play
   - Forward (step by step)
   - Go to Maximum Time position
   - Pause
   - Go to Zero Time position
   - Backward (step by step)
   - Play Back.

   The kinematics mechanism moves according to the pre-defined laws.

   You can switch between any of the simulation modes at any time.
   You can also enter a time value to visualize the position of the mechanism at that time.

3. Click Analysis if you need to detect interferences or distances while simulating
   The Analysis Studies dialog displays.

4. Click add to display the Select dialog box.
5. Select the interference .1 and set to the interference combo to on.
6. Run the simulation.

For more details, please refer to Detecting Interferences and Detecting Distances.

Notice that you cannot record simulations within the Simulation With Laws functionality. If you need to record such a simulation or several simulations, please refer to Recording Positions.
Simulating With Commands

This task will show you how to run a kinematics simulation with commands.

The sample document used in this task can be accessed in the folder: online\samples\dmukinematics

The Kinematics Simulation dialog box is displayed as described in the previous task.

1. Click the Simulation With Commands icon.

The Kinematic Simulation dialog box appears:

The commands of the kinematics mechanism are available as shown opposite.

2. Manipulate the slider of a command. For instance select the LEFT command.

The corresponding part of the kinematics mechanism moves accordingly.

Note that if you click the More >> button, the Kinematic Simulation dialog box expands. The immediate option is set by default. For more information about the On request option, please refer to Simulating on Request.
You can use the slider, enter a value or manipulate the geometry directly to achieve the same result.

3. Manipulate the other commands in the same way.

You can set a command value directly in the spin box.

You can also set lowest and highest values for the range of a command by clicking on the button opposite the command and entering values in the displayed pop-up.

You cannot record your simulation within the Simulation With Commands command. You can record simulations within the Simulation command (please refer to Recording Positions).
Simulating On Request

This task shows how to perform a simulation on request.

The sample document used in this task can be accessed in the folder: online\samples\dmukinematics.

A kinematics mechanism must be active in the specification tree.

1. Click the Simulation With Commands icon.

The Kinematics Simulation dialog box displays.

2. Click

The commands of the kinematics mechanism are available as shown below.

By default, the Immediate option is set.
3. Activate the On Request option.

If you run the simulation without changing at least one command value the following message displays:

4. Enter values for the various commands. For instance:

- 20 for the OPENING command
- 50 for the LEFT command
- 30 for the INCLINAT command
- 40 for the LANDING command

5. Enter the number of steps you need, 20 for example.
6. Click Play Forward.

The corresponding parts of the kinematics model move accordingly at each step.
You can modify values of one or more commands for each motion.
# Reviewing Simulations

DMU Kinematics Simulator provides easy methods to record and replay kinematic simulations.

**Tasks**

<table>
<thead>
<tr>
<th>Tasks</th>
</tr>
</thead>
<tbody>
<tr>
<td>Recording Positions</td>
</tr>
<tr>
<td>Replaying Simulations</td>
</tr>
</tbody>
</table>

- **Up**
  - Running Simulations
  - Setting Up Your Session
  - Reviewing Simulations
  - Designing a V5 mechanism
  - Managing Dressup Mechanisms
Recording Positions

This task shows how to record positions of a kinematics mechanism.

The sample document used in this task can be accessed in the folder: online\samples\dmukinematics. At least one kinematics mechanism must be active in the specification tree.

1. Click the Simulation icon.

The Select dialog box displays.

2. Select LANDING GEAR and click OK.

Kinematics Simulation and Edit Simulation dialog boxes appear. A Simulation object is created in the specification tree.

2. Click the Insert switch and record the starting position.

Insert means that you record and insert positions inside the scenario.

3. Move the mechanism (using the manipulators or sliders, for example), then Click the Insert switch again.

4. Record as many positions as necessary.

5. Use the VCR buttons to replay the recorded positions.

This type of record can be used to simulate several mechanisms simultaneously.
Replaying Simulations

This task shows you how to create a traction on a geometry of a part.

The sample document used in this task can be accessed in the folder: online\samples\dmukinematics. You recorded a simulation in a Simulation object. See Recording Positions.
You then compiled the Simulation created as described in the previous task. Please refer to Compiling a Simulation in the DMU Fitting Simulator User's Guide

1. Activate the Simulation object in the specification tree.

2. Click the Replay icon.

The Replay dialog box is displayed.

3. Click:
   - the Play VCR button to run a continuous replay of the recorded motion
   - or the Forward VCR button to run a step-by-step of the recorded motion.

Each motion is replayed one after another in the order they were recorded.

You can increase the interpolation sampling step of the replay for a finer replay.

You can choose one of the loop modes to re-run the simulation in a continuous way (either in the one direction only or in one direction then the other).
Managing the Mechanism Dressup

This task shows how to dress-up mechanisms.

The sample document used in this task can be accessed in the folder: online\samples\dmukinematics.

At least one kinematics mechanism must be active in the specification tree.

You no longer need to select Edit -> Design Mode as it is automatically activated. DMU Kinematics Simulator finds the product containing kinematics objects automatically. This new capacity is available for all Kinematic commands (simulation...)

1. Click the Mechanism Analysis icon.
   The Mechanism Analysis dialog box displays:

2. Click on the Simulation With Commands icon.
   The Kinematic Simulation dialog box is displayed.
3. Manipulate the slider of the LEFT command.

The corresponding part of the kinematics mechanism namely the Opening moves accordingly.

4. Click Reset and then Close.
Let's attach the left door to the LANDING GEAR mechanism:

4. Click the Mechanism Dressup icon from the DMU Simulation Toolbar. The Mechanism Dressup dialog box displays.
5. Select The KIN_EX17_09_DOOR from the available products list to attach it to the link:

The selected product is highlighted in the specification tree and in the geometry area as shown below:

6. Click OK to confirm your operation.
Let's simulate the mechanism with the new dressup

7. Click on the Simulation With Commands icon again.

8. In the Kinematic Simulation dialog box, manipulate the slider of the LEFT command.

   This time, the corresponding part of the kinematics mechanism moves accordingly.

The Simulation With Commands capability is only used to simulate. If you need to record the simulation use the Simulation functionality.
DMU Kinematics Simulator provides easy methods to detect and analyze collisions and distances between products. It also provides the capacity of generating a swept volume.

The DMU Space Analysis Version 5 product must be installed before using these functionalities.
Detecting Collisions and Distances

Detecting Distances
Detecting Interferences

Up
Detecting Collisions and Distances
Analyzing a Mechanism
Defining a Swept Volume
Detecting Distances

This task shows how to detect distances between two products.

The sample document used in this task can be accessed in the folder: online\samples\dmukinematics.

The kinematics document must be already opened.

1. In the specification tree, click CENTRAL_DOOR then control-click LEFT_DOOR.

   The two products are highlighted in the specification tree.

2. Click the Distance icon in the DMU Space Analysis toolbar, or select Insert -> Distance from the menu bar to calculate distances:

   The Edit Distance dialog box is displayed. Make sure the distance type is set to Minimum and Inside one selection.
The default distance analysis is measuring the minimum distance inside one selection.

3. Click OK.
The specification tree is updated.

5. Double-click the Simulation.1 in the specification tree.
The Edit Simulation dialog box is displayed.

6. Click the Edit Analysis button.

The Edit Analysis In Simulation dialog box displays:

7. Click Add then select Distance1 from the displayed pop-up.

The Edit Simulation dialog box is updated.

8. Set the Distance combo to On in the Edit Simulation dialog box.
The specification tree is updated.

8. In the Kinematics Simulation dialog box, run a step by step simulation using the Use Laws tab.

The minimum distance between the two products is displayed at each step.

Please refer to the DMU Space Analysis User’s Guide for more information about detecting and analyzing distances between products or between groups.
Detecting Interferences

This task shows how to detect clashes between two kinematic products.

The sample document used in this task can be accessed in the folder: online/samples/dmukinematics

The kinematics document must be already opened. You recorded a Simulation.

1. In the specification tree, click ENS1 then control-click OPENING.

The two products are highlighted in the specification tree and in the geometry area.
2. Click the Clash icon.

The Check Clash dialog box is displayed. Make sure the interference type is set to Clash and Inside one selection.

3. Click OK.

The specification tree is updated.

4. Select Simulation.1 in the specification tree

The Edit Simulation and Kinematic Simulation dialog boxes are displayed.

6. Click Edit Analysis in the Edit Simulation dialog box.

The Edit Analysis in Simulation dialog box displays
7. Click Add then select interference 1 from the displayed Select dialog box

The Edit Analysis in Simulation dialog box is updated as shown opposite:

8. Click OK to confirm your operation.

You defined an interference.

7. Set the Interference combo to On.

The specification tree is updated.

10. To locate the clash position more precisely, set the Interference combo to Stop in the Edit Simulation dialog box.
The simulation stops at the position where a collision is detected between the ENS1 and the LEFT DOOR products. The products in collision is highlighted.

11. Click Edit Analysis in the Edit Simulation dialog box. The Edit Analysis in Simulation displays.
12. Click Browse.
13. The Check Clash dialog box displays. The specification tree is updated.
Please refer to the [DMU Space Analysis User’s Guide](#) for more information about detecting and analyzing interferences between products or between groups.
DMU Kinematic Simulator lets you easily review the mechanism structure.

This task shows how to analyze a mechanism using the Mechanism Analysis dialog box.

The kinematics document must be already opened.
The sample document used in this task can be accessed in the folder: online\samples\dmukinematics.

1. Click the Mechanism Analysis icon.

The Mechanism Analysis dialog box is displayed.

It lets you access information about each joint in the kinematics mechanism, you can see which joint is a command for instance.

The following mechanism components are detailed under the following characteristics:
- Command
- Type: revolute, prismatic, spherical...
- Part1: first part upon which the joint is based
- Geometry: geometry associated to the part

If you defined a new mechanism, when you delete a part including in the mechanism the corresponding joint is no longer valid. The message invalid joint! appears in the Mechanism Analysis dialog box.

2. Click the LEFT command. The Mechanism dressup information displays

The products are highlighted both in the 3D and in the specification tree.
<table>
<thead>
<tr>
<th>Joint</th>
<th>Command</th>
<th>Type</th>
<th>Part1</th>
<th>Geometry1</th>
<th>Part2</th>
<th>Geon</th>
</tr>
</thead>
<tbody>
<tr>
<td>19</td>
<td>CENTRAL</td>
<td>Revolute</td>
<td>REF</td>
<td>*LN1320</td>
<td>CENTRAL DOOR</td>
<td></td>
</tr>
<tr>
<td>20</td>
<td>LEFT</td>
<td>Revolute</td>
<td>REF</td>
<td>*LN1322</td>
<td>LEFT DOOR</td>
<td></td>
</tr>
<tr>
<td>21</td>
<td>OPENING</td>
<td>Revolute</td>
<td>LEFT DOOR</td>
<td>*LN1329</td>
<td>OPENING</td>
<td></td>
</tr>
</tbody>
</table>

**Mechanism dressup information:**

<table>
<thead>
<tr>
<th>REF</th>
<th>LEFT DOOR</th>
</tr>
</thead>
<tbody>
<tr>
<td>KIN_EX17_09_LEFT_DOOR</td>
<td></td>
</tr>
</tbody>
</table>
Defining A Swept Volume

This task shows how to generate a Swept volume.

You recorded a simulation in a Simulation object and compiled the Simulation. You obtained a Replay object. You need this Replay object to define a swept volume. The sample document used in this task can be accessed in the folder: online\samples\dmukinematics

1. Click the Swept Volume icon
   The Swept Volume dialog box displays.
   ![Swept Volume Dialog Box]

2. If you click in the spin box, the Sweepable Bodies dialog box lets you select or deselect the bodies you want to sweep.
   ![Sweepable Bodies Dialog Box]

3. Click OK.
4. Click Apply to generate the swept volume
5. If you check the Use level of details option,
   This what you obtain:
4. Select File->Save As... from the menu bar.
5. Select cgr from the Save as Type field
Workbench Description

This section contains the description of the icons and menus which are specific to the DMU Kinematics Simulator Version 5 workbench.

The DMU Kinematic Simulator window looks like this (click the sensitive areas to see the related documentation):

DMU Kinematic Simulator Menu Bar
DMU kinematics Toolbar
DMU Joint Toolbar
DMU Generic Animations
DMU Space Analysis Toolbar
Here we will present the various menus and menu commands that are specific to DMU Kinematics Simulator Version 5.

Tasks corresponding to General menu commands are described in the *DMU Version 5 Infrastructure User's Guide*.

## Edit

<table>
<thead>
<tr>
<th>For...</th>
<th>Description...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Undo</td>
<td>Cancels the last action.</td>
</tr>
<tr>
<td>Redo</td>
<td>Recovers the last action that was undone.</td>
</tr>
<tr>
<td>Cut</td>
<td>Performs cut copy paste and special paste operations.</td>
</tr>
<tr>
<td>Copy</td>
<td></td>
</tr>
<tr>
<td>Paste</td>
<td></td>
</tr>
<tr>
<td>Paste Special</td>
<td></td>
</tr>
<tr>
<td>Delete</td>
<td>Deletes selected geometry.</td>
</tr>
<tr>
<td>Search</td>
<td>Allows searching and selecting objects.</td>
</tr>
</tbody>
</table>
Insert

For...

New Mechanism
New Joint
New Fixed Part
Simulation
Clash
Distance
Existing Component

See...

Creating a Mechanism and Revolute Joints
Creating a Mechanism and Revolute Joints
About Joints
Creating Cylindrical Joints
Defining a Fixed Part
Recording Positions
Detecting Interferences
Detecting Distances
Entering the DMU Navigator Workbench and Selecting Models
DMU Kinematics Toolbar

The DMU Kinematics toolbar contains a number of tools that are useful for DMU Kinematics Simulator.

See Simulating with Commands

See Managing the Mechanism Dressup

See Creating a Fixed Part

See Creating a Mechanism and Revolute Joints

See Analyzing a Mechanism
The DMU Kinematics toolbar contains the various types of joints you can create in DMU Kinematic Simulation version 5.

See Creating a Mechanism and Revolute Joints
See About Joints and Creating Joints
See Creating Cylindrical Joints
See About Joints and Creating Joints
See About Joints and Creating Joints
See About Joints and Creating Joints
DMU Generic Animation Toolbar

The DMU Generic Animation toolbar contains a number of tools that are useful for DMU Kinematics Simulator.

See Recording Simulations

See Replaying Simulations

The remaining icon (Shuttle) is available whenever the DMU Fitting Simulator product is installed.
DMU Space Analysis Toolbar

Whenever the DMU Space Analysis product is installed, the DMU Space Analysis toolbar can be activated. It contains a number of tools that are useful for DMU Kinematics Simulator.

See Detecting Distances.

See Detecting Interferences.
Glossary

C

cable joint A cable type joint between three products (two products are mobile, the other is a reference). Number of degrees of freedom is 1 (translation).

cylindrical joint A translation type joint between two products along an axis with a rotation about that axis. Number of degrees of freedom is 2 (1 translation and 1 rotation). This joint was called Actuator in Version 4.

command An angular or linear command that drives the kinematics mechanism.

CV joint A constant velocity joint between two products. Number of degrees of freedom is 4 (comprises two U joints).

D

degrees of freedom The number of possible independent rotation or translation movements of a joint.

dress up A list of models attached to a set of the kinematics model. These models have the same motion as the set.

F

fixed product The product that remains stationary when the kinematics mechanism is in motion.

G

gear joint A gear type joint between three products (two products are pinions, the other is a reference). Number of degrees of freedom is 1 (rotation).

J

joint A constraint between geometric entities of two or three products. There are several types of joint.

joint stop An imposed limit applied to a joint.
**kinematics mechanism** A mechanism comprising several products that are connected by **joints**.

It can be simulated when the number of commands is equal to degrees of freedom (in this case the mechanism is said to be **complete**).

**kinematics product** A rigid product defined in a single geometric set that contains all the elements required to describe the kinematics mechanism and its motion.

**kinematics simulation** A simulation of the mechanism's motion using commands. Simulation can be immediate (commands are used one by one) or on request (one or more commands are used with a given number of steps).

**law** A numeric or graphic representation of the commands applied to a kinematics mechanism as a function of time.

**planar joint** A planar joint between two products. Number of **degrees of freedom** is 3 (1 rotation and 2 translations).

**prismatic joint** A translation joint between two products along an axis with no rotation about that axis. Number of **degrees of freedom** is 1 (translation).

**PT/CRV joint** A point/curve joint between two products. Number of **degrees of freedom** is 4 (3 rotation and 1 translation) for a 3D mechanism and 2 (1 rotation and 1 translation) for a 2D mechanism.

**PT/SUR joint** A point/surface joint between two products. Number of **degrees of freedom** is 5 (3 rotations and 2 translations).

**rack joint** A gear/rack type joint between three products (one product is the rack, another is the rack, the other is a reference). Number of **degrees of freedom** is 1 (combined translation and rotation).

**revolute joint** A revolute joint about an axis between two products with no translation along that axis. Number of **degrees of freedom** is 1 (rotation).
rigid joint
A rigid joint between two products. There are no degrees of freedom associated to this joint.

roll/CRV joint
A rolling type joint between two products that include curves. There is no sliding motion with this type of joint. Number of degrees of freedom is 2 (1 rotation and 1 translation) for a 3D mechanism and 1 (translation) for a 2D mechanism.

screw joint
A screw/nut type joint between two products relative to an axis. Number of degrees of freedom is 1 (combined translation and rotation).

slid/CRV joint
A rolling type joint with a sliding motion between two products that include curves. Number of degrees of freedom is 3 (2 rotations and 1 translation) for a 3D mechanism and 2 (1 rotation and 1 translation) for a 2D mechanism.

spherical joint
A spherical joint between two products. Number of degrees of freedom is 3 (3 rotations) for a 3D mechanism and 1 (rotation) for a 2D mechanism. This joint was called PT/PT in Version 4.

storyboard
A recorded kinematic motion.

U joint
A universal joint between two products. Number of degrees of freedom is 2 (2 rotations).
Index

C

cable joint
Clash icon
command
CV joint
cylindrical joint

D

degrees of freedom
detecting
  clash between products
distance between products
displaying
  joints
  progress indicator
Distance icon
DMU Generic Animations toolbar
DMU Simulation toolbar
DMU Space Analysis toolbar
dress up

E

Edit Simulation dialog box

F

fixed product
G

gear joint ➤

J

joint ➤
joint stop ➤

K

kinematic mechanism ➤
kinematic product ➤
kinematic simulation ➤
Kinematics Simulation dialog box ➤, ➤, ➤

L

law ➤

M

manipulator
  for rotating ➤
  for translating ➤

P

planar joint ➤
prismatic joint ➤
PT/CRV joint ➤
PT/SUR joint ➤
rack joint
recording
  simulation
Replay dialog box
Replay icon ✓, ✓
replaying
  simulation
revolute joint
rigid joint
roll/CRV joint

screw joint
simulating
  using commands
  using laws
slid/CRV joint
spherical joint
storyboard

Simulation icon ✓, ✓, ✓, ✓

U joint
Version 4 model
Version 5 document