Preface

DMU Navigator Version 5 addresses Digital Mock-Up (DMU) process centric design and review requirements of the extended enterprise. It offers a scalable solution capable of handling digital mock-ups of all sizes, ranging from consumer goods to very large automotive, aerospace, plant, ship and heavy machinery mock-ups.

Available on both UNIX and Windows environments, DMU Navigator is built to be totally compliant with Windows presentation standards.

DMU Navigator Version 5 comprises the following main applications:

- Kinematics Simulator
- Fitting Simulator
- Space Analysis

The above applications are delivered as totally interoperable workbenches. From a user interface standpoint, switching from one to another is completely transparent and done in a context-sensitive fashion. In addition, to these workbenches, DMU Navigator is an open solution which offers:

- Support of native CATIA Version 4 and Version 5 data
- Interface with the VRML industry standard for data exchange
- Native OLE (Object Linking and Embedding) compliance. This facilitates the system integration within the office environment and across the digital enterprise.

DMU Kinematics Simulator

- Offers motion simulation capabilities. Kinematics Simulator can be cooperatively used with other current or future companion products of the DMU Navigator next generation such as DMU Fitting Simulator and DMU Space Analysis.

DMU Fitting Simulator

- Allows the user to define and simulate assembly and disassembly procedures thereby validating product assembly and maintenance at the design stage. Fitting Simulator can be cooperatively used with other current or future companion products of the DMU Navigator next generation such as Kinematics Simulator and Space Analysis.

DMU Space Analysis
Offers advanced interference analysis, sectioning and measurement capabilities. Space Analysis can be cooperatively used with other current or future companion products of the DMU Navigator next generation such as DMU Kinematics Simulator and Fitting Simulator.

**DMU Optimizer**

Improves user's productivity by computing an optimized representation of data for mockup verification in the context of the immersive and collaborative design review environment of the full digital mockup.

DMU Optimizer is a dedicated DMU Navigator workbench and is available on both UNIX and Windows NT environments.
This guide is the DMU Navigator Version 5 User's Guide.

To get the most out of DMU Navigator, use the following user guide wizard. It will help you better locate information relevant to you as well as to the way you work.

**User Guide Wizard**

**Go to:**

**I am a first time user**

The [getting started](#) tutorial. Once you have finished, you should move on to the user task section of this guide. This steps you through basic procedures.

**I have used DMU Navigator before**

Your DMU Navigator Version 5 session and start reviewing your own documents. If you need some help in understanding tools and commands, use the on-line help. You can also take a look at the [basic user task section](#) of this guide to locate information with which you are not already familiar.
Where to Find More Information

Prior to reading this book, we recommend that you read the *Infrastructure User's Guide*.

**Note**: You can start a DMU Navigator session by entering the command dmu (Windows) or DMU (UNIX). This starts the default DMU Navigator Version 5 environment.

You may also like to read the following complementary product guides, for which the appropriate license is required.

- *DMU Fitting Simulator User's Guide*
- *DMU Kinematics Simulator User's Guide*
- *DMU Optimizer User's Guide*
What's New?

Enhanced **Fly mode**:
- the compass is no longer used
- support for banking
- when colliding with solid objects when flying, you now slide along the object surface instead of flying through the object

New: [Separate overview window for viewing geometry](#)

Enhanced: Transforming 2D markers into 3D markers in and moving markers in:

Using the 2D Marker

Enhanced: Animate viewpoint - automatic insert and Edit simulation objects in:

Recording Animations
Replaying Animations

New: [Generating an Animation](#)

New: Scenes in:
About Scenes,
Adding a Component,
Replacing a Component,
Removing a Component
Managing an Exploded View

New: Proximity Query in:
Running Proximity Query (DMU Navigator license only)
Running Proximity Query (DMU Navigator & Optimizer)
Getting Started

This tutorial will guide you step-by-step through your first DMU Navigator session, allowing you to get acquainted with the product.

You will need a DMU Navigator V5 session and should be familiar with basic concepts such as document windows, standard and view toolbars.

You should be able to complete this tutorial in about 15 minutes.

Task

- Entering the Workbench
- Inserting Components
- Examine Mode
- Managing Views
- Beginner's Fly Mode
- Looking At Objects
- Managing URLs
- Creating Scenes
Entering the DMU Navigator Workbench

This task shows you how to enter the DMU Navigator workbench and create a new document.

1. Select Digital Mockup -> DMU Navigator from the Start menu

The DMU Navigator workbench is displayed and a document like this will appear:

![Image of the DMU Navigator workbench]

Note that more toolbars may appear next to the Standard toolbar when you create a document.
Inserting Components

This task shows you how to insert components into a DMU Navigator document.

1. Select the Insert -> Existing Component... command

If the menu item cannot be selected, right-click product1 in the specification tree and select Existing Component... from the contextual menu.

2. In the Insert an Existing Component dialog box, specify the file location for the model of interest: the platform.model document from the \online\samples\dmunavigator directory.

3. Click the Files of type drop-down list and select the model type

4. Double-click the platform.model to insert it into your DMU Navigator document

The DMU Navigator document now looks like this:
Navigating in Examine Mode

Navigating in Examine Mode is the default mode. You can examine your document as you would from the outside by moving around the document's perimeter, or as you would from within, turning your head to view or moving closer (zoom in, zoom out) to different objects.

This task shows you how to rotate, zoom and move your document.

Open the platform.model document from the \online\samples\dmunavigator directory.

1. Press and hold down the middle mouse button, then the left mouse button, and drag (still holding both buttons down) to rotate

2. Press and hold down the middle mouse button, then click the left mouse button and drag (still holding the middle mouse button down) to zoom:

Dragging towards 12 o'clock zooms in on your document; dragging towards 6 o'clock zooms out of your document.
3. Drag using the middle mouse button to a new location
Managing Views

This task shows you how to create and annotate a user-defined view.

Open the platform.model document from the \online\samples\dmunavigator directory.

1. Select the View->Named Views... command:

   The Named Views dialog box appears listing standard views you can use to display the document.

2. Double-click the iso view to obtain an isometric view of your document:

   You can now customize this view.

3. Adjust the different view parameters (zoom, rotation, etc.) until you are happy with the result.
4. Click the Add button to add the view to the list.
5. Rename the view as required and press Enter.

The 2D Marker toolbar is active and you can now annotate your view.

6. To add text, click the required object and click the Text icon.

The Annotation Text dialog box appears.

7. Enter the desired text in the text box.
8. In the view, click where you want to place the text.

The text is added at the desired position.

9. Click the Rectangle icon to create a text box around the text.
10. Drag across the text you added to create a text box.
11. Annotate your document further as desired.
Navigating in Beginner's Fly Mode

This task shows you how to navigate through a document in beginner's fly mode. In beginner's fly mode you can move upward or downward on any horizontal view plane as you move forward.

Open the platform.model document from the \online\samples\dmunavigator directory.

1. Click the Fly icon in the View toolbar:

The toolbar expands to include four icons that you will use to navigate through your document.

2. Click the Turn Head icon then drag (left mouse button) to define your starting position

3. Release at desired location

4. Click the Fly icon, then click the left mouse button to begin to flying:

You begin to fly forward in the chosen direction

A small orange rectangle appears as you fly. This rectangle represents a neutral zone and an imaginary horizontal line running through the center of it defines the up and the down.

5. Still holding the left button down, drag left or right to change direction:

6. Bring the cursor back into the orange rectangle to continue flying forward in the new direction
7. To modify your speed, click the Accelerate or Decelerate icon one or more times, then click the Fly icon again followed by the left mouse button to pursue your fly.

**Note:** The size of the arrow in the navigation compass reflects the speed of your fly.

8. Click the Examine mode icon in the View toolbar to return to the default navigation mode.
Looking At Objects

During the course of your inspection, you may want to concentrate on a particular object and view it closer up. Changing the target lets you dynamically redefine your target and viewing distance.

This task explains how to look at the document in a specific direction by targeting through a user-defined viewport.

Open the platform.model document from the \online\samples\dmunavigator directory.

1. Click the Look At icon in the DMU Viewing toolbar.
2. Click (left mouse button) on an object in the document to select it.
3. Drag (still holding left mouse button down) slowly to display the viewport.

As you begin to drag, a rectangle with two diagonals appears and continues to grow as long as you continue to drag. This rectangle represents the viewing window of the future view.

4. Continue dragging to move around, resize and reposition the viewport.

The viewport is then shaped like a pyramid: your eyepoint is located at the vertex of the pyramid. You can resize the viewport by dragging the middle mouse button.

5. Release the button.

You now see what is targeted inside the viewport.
Managing URLs

You can add hyperlinks to your document and then use them to jump to a variety of locations, for example to a marketing presentation, a Microsoft Excel spreadsheet or a HTML page on the intranet. This task explains how to add hyperlinks.

You should prepare a document that you want to see displayed via a hyperlink.

1. Select the object you want to represent the hyperlink.
2. Select the Insert-> Add Hyperlinks command
   The Manage Hyperlink dialog box appears.

3. Enter a name identifying your hyperlink
4. Click Browse... and select the file in the Link to File dialog box
5. Click OK in the Insert Hyperlink dialog box
   You can now test the link you added.
6. Select the object to which you just added the hyperlink
   6. Click the Go to Hyperlinks icon in the DMU Data Navigation toolbar
      The file linked is displayed.

This concludes the step-by-step getting started scenario.

You should now go to the user task section of this guide. This steps you through basic procedures, letting you get the most out of this product.
Creating Scenes

This task shows you how to create scenes.

Insert sample files `\online\samples\dmunavigator\ *.cgr`.

1. Click the Create Scene icon.

The Edit Scene dialog box and a scene representation in the window display.

2. Click Ok to end the scene creation.

You are now in a scene window:
- the background window turns to green.
- Scene 1 is identified in the specification tree.
3. Perform the required modifications. For instance modify the viewpoint.

4. Click the Exit From Scene icon to swap to the initial window.

The scene is updated.
5. Double-click Scene 1 either in the specification tree or in the geometry area to swap to the scene window.
6. Create as many scenes as needed.
## Basic Tasks

<table>
<thead>
<tr>
<th>Theme</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Setting Up Your Session</td>
<td>Enter the DMU Navigator workbench and insert components, define groups of products as well as view the current selection and content of the data cache</td>
</tr>
<tr>
<td>Navigating</td>
<td>Navigate using the fly mode, view objects, define document viewpoints and set light and depth effects</td>
</tr>
<tr>
<td>Annotating</td>
<td>Annotate documents, create hyperlinks, use standard and user-defined views, use 2D and temporary markers</td>
</tr>
<tr>
<td>Using Camera Capabilities</td>
<td>Use cameras to create animations, record and replay animations</td>
</tr>
<tr>
<td>Using Generic Animation</td>
<td>Record and replay animations. Generate an AVI file.</td>
</tr>
<tr>
<td>Creating Scenes</td>
<td>Use scene functionality to add and remove a component, use scene with the explode command</td>
</tr>
<tr>
<td>Proximity Query</td>
<td>Simplify an assembly</td>
</tr>
</tbody>
</table>
Setting Up Your DMU Navigator Session

<table>
<thead>
<tr>
<th>Task</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Entering the Workbench</td>
<td>Start a DMU Navigator session</td>
</tr>
<tr>
<td>Inserting Components</td>
<td>Insert components</td>
</tr>
<tr>
<td>Importing A CAD Part</td>
<td>Import CAD Parts</td>
</tr>
<tr>
<td>Defining Groups</td>
<td>Define groups of products</td>
</tr>
<tr>
<td>Viewing the Selection</td>
<td>View the objects in the current selection</td>
</tr>
<tr>
<td>Viewing the Cache</td>
<td>View the contents of the data cache</td>
</tr>
</tbody>
</table>

Up
ANNOTATING
Setting Up Your Session
Using Camera Capabilities
Navigating
Using Generic Animation
Creating Scenes
Proximity Query
Entering the DMU Navigator Workbench

This task shows you how to enter the DMU Navigator workbench and open a new document.

1. Select Digital Mockup->DMU Navigator from the Start menu

The DMU Navigator workbench is loaded and a DMU Navigator document opens:

The DMU Navigator workbench comprises:
- A specification tree and a geometry area
- Specific toolbars
- A number of contextual commands available in both the specification tree and the geometry area.

Clicking off View -> Specifications visible in the menu bar removes the specification tree and lets you use the entire screen for the geometry.

---

- Importing A CAD Part
- Entering the Workbench
- Inserting Components
- Defining Groups
- Viewing the Selection
- Viewing the Cache
Inserting Components

This task shows you how to insert components into a DMU Navigator document.

Open the .cgr files from the \online\samples\dmunavigator directory.

1. Select the Insert -> Existing Component... command

If the menu item cannot be selected, right-click product1 in the specification tree and select Existing Component... from the contextual menu.

2. In the Insert an Existing Component dialog box, select the file location

3. Click the Files of type: list

4. Select the desired type from the following:
   - cgr (*.cgr)
   - V4 model (*.model)
   - CATpart (*.CATpart)
   - CATproduct (*.CATproduct)
   - V4 session (*.session)
   - VRML 1.0.
   - obj (*.obj)
   - byu (*.byu)
   - iges
   - pdb (*.pdb)
   - stl (ASCII and binary) (*.stl)

Models, parts and products are loaded in visualization mode, i.e. without associated technological data (only visualization data is loaded). To access technological data, you must switch to design mode. This is done by selecting components inserted in the specification tree and then Edit -> Design Mode from the menu bar.

5. Click Open in the dialog box

The DMU Navigator document now looks like this:
You can load the product structure only and then specify which 3D representations to insert. For more information, see Loading the Product Structure Only.

**Adding CDM Products:** For more information, see Adding a CDM Product to a Product on UNIX as well as Customizing CDMA Data in Catia Version 5 on UNIX in the *V4 Integration User's Guide*.

**Reading Parts and Assemblies from VPM-1:** For information on reading parts and assemblies in VPM-1, please refer to Building a V5 product from a VPM1-PSN Window in the *V4 Integration User's Guide*.

**Open to MultiCAD:**

If you want to import a CAD part which is not directly supported by DMU Navigator, you can run a background converter that will output one of the following formats: cgr; pdb (Deneb part), vrml or stl. The CAD part files you want to import must have the .prt extension.

The DMUNAV_CONVCOMMAND environment variable must be given the name of the conversion command as value. This command can be a .bat script on Windows or a shell script on UNIX. It has the following arguments:

- input file
- full path of the cgr, pdb, vrml or stl file to be created in the data cache, depending on the format chosen

The command must return 0 if it completes successfully and 1 if an error occurs.

Once the DMUNAV_CONVCOMMAND environment variable is defined, the .prt extension is proposed in the Insert Existing Component command. If you select a file with this extension, the command defined by the DMUNAV_CONVCOMMAND environment variable is run.

Each time a CATProduct containing a reference to such a part is re-read, the data cache is searched for the up-to-date file. If no up-to-date file is found, the command defined by the
DMUNAV_CONVCOMMAND environment variable is re-run.
Importing CAD Parts into a .CATProduct Document

DMU Navigator Solution is an open system capable of importing data from the most used data standards and CAD systems. You can easily preserve your CAD investment while still benefiting from the DMU Navigator Solution.

How Does it Work?
Two translation modes are supported:
- batch mode
- associativity mode

What About the Elements you Import?
As the data contained in the parts you import are loaded in DMU Navigator, they are inserted as additional representations within the DMU Product Structure, along with any other representation previously inserted from any supported source.

Once imported, the data can be handled just as if it were created in the session.

This task shows you how to import data contained in CAD Parts or Assemblies into a .CATProduct. The main purpose of such an import is to be able to read data which remain synchronized with the most current level available.

DMU Navigator software P2.

1. Select the Insert -> Existing Component... command
If the menu item cannot be selected, right-click product 1 in the specification tree and select Existing Component... from the contextual menu.

2. In the Insert an Existing Component dialog box, select the file location

3. Click the Files of type: list

4. Select the desired type from the following:
   - .prt
   - .asm

Models, parts and products are loaded in visualization mode, i.e. without associated technological data (only visualization data is loaded). To access technological data, you must switch to design mode. This is done by selecting components inserted in the specification tree and then Edit -> Design Mode from the menu bar.

To set external formats import settings, see Customizing External Formats Import

5. Click Open in the dialog box.
Defining Groups of Products

This task explains how to define groups of products.

A group is a set of products defined explicitly by selecting products individually. Groups are persistent and can be stored in the document.

Open the *.cgr files from the \online\samples\dmunavigator directory.

1. Select a product in the geometry area or in the specification tree
2. Ctrl-click other products to add them to the initial selection

3. Select Insert -> Group... from the menu bar or click the Group icon in the DMU Navigator Tools toolbar to create a group:
The Edit Group dialog box and the Preview window appear.

The Preview window shows selected products.

To change the default display setting for this window, see Customizing DMU Navigator Settings.

4. (Optional) Select products in the specification tree or the geometry area.
to remove them from the group

5. (Optional) Enter a meaningful name for the group you want to create

6. Click OK to create the group

The group is identified in the specification tree.

Groups created in this manner are persistent and can be stored in the document. They are listed as a separate entity in the specification tree and can be selected at any time and modified.

7. In the specification tree, double-click the group you just defined to modify it

Or,
Right-click the group you just defined and select Group 1 object -> Definition from the contextual menu.

The Edit Group dialog box appears and displays the contents of the group you just created. Parts in the group are highlighted in the specification tree and in the geometry area.

8. Modify group contents as desired
9. Click OK to confirm
Up

Importing A CAD Part

Entering the Workbench

Defining Groups

Inserting Components

Viewing the Selection

Viewing the Cache
Viewing the Current Selection

The object or objects selected make up the current selection. The list of objects selected can be viewed using the Current Selection icon in the DMU Data Navigation toolbar. Making a new selection changes the current selection. For a description of the various selection techniques, please refer to the *Infrastructure User's Guide*.

Open the .cgr files from the \online\samples\dmunavigator directory.

This task illustrates current selection capabilities

In the geometry area or in the specification tree:

1. Select one or more objects

2. Click the Current Selection icon in the DMU Data Navigation toolbar

The Current Selection dialog box identifies all objects selected.
The Current Selection dialog box contains two tabs, letting you visualize the specification tree or 3D view of your current selection.
3. Click the Freeze checkbox to freeze the contents of the dialog box on the current selection. The dialog box will no longer be updated.

4. Select an object in the Current Selection dialog box
   The object is highlighted in the geometry area and in the specification tree

5. Click the Reframe on selection checkbox to fit the selection into the available space in the geometry area

6. Select other objects in the Current Selection dialog box in turn and notice the geometry area reframe on the selections

7. De-select the Freeze checkbox
   The dialog box is updated and now shows the last object selected only

8. Click the View related objects checkbox to navigate through objects linked to the current selection

**Note:** View related objects is only available if there is one object selected.
Relationships identified are parents, any children or connected objects and relationships between objects. Products, groups, simulation, shuttles and aec objects are all taken into account. Contextual menu commands are available in the Current Selection dialog box.
Viewing the Cache Content

The data cache directory (CATCache) defines the disk space used for the saving of conversions of models to cgr files. One or more data cache directories can be defined.

If you work with the cache system on, when you re-access the saved model in a subsequent session, the application will use the entry in the data cache, thereby reducing access time.

This task shows you how to view the contents of the data cache.

A DMU Navigator document open

1. Select the Tools -> Cache Content command

The Cache Content dialog box appears listing the contents of the local data cache.

<table>
<thead>
<tr>
<th>Cache status:</th>
<th>On</th>
</tr>
</thead>
<tbody>
<tr>
<td>Current cache used:</td>
<td>MB</td>
</tr>
<tr>
<td>Maximum cache allowed:</td>
<td>10 MB</td>
</tr>
<tr>
<td>Cache directory:</td>
<td>C:\WINNT\Profiles\mtn\CATCache\</td>
</tr>
<tr>
<td>File in Cache Directory</td>
<td></td>
</tr>
<tr>
<td>Model name</td>
<td>Time stamp</td>
</tr>
<tr>
<td>K:\BSF\N4DDocumentation\CNext\doc\samples\dmunavigator\platform.model</td>
<td>C:\WINNT\Profiles\mtn\CATCache\cgr\platform.model.cgr</td>
</tr>
</tbody>
</table>

Other information including whether or not the cache system is turned on, the current cache used and the maximum cache size is also given in the dialog box.

2. In the Cache directory drop-down list box, select the cache directory whose contents you want to review

By default, the contents of the local data cache are shown.

3. Click Close when done

To set default data cache settings, see Customizing Data Cache Settings
## Navigating

<table>
<thead>
<tr>
<th>Task</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Navigating in Examine Mode</td>
<td>Default mode for examining objects</td>
</tr>
<tr>
<td>Navigating in Walk Mode</td>
<td>Navigate in Beginner’s and Advanced Walk modes</td>
</tr>
<tr>
<td>Navigating in Fly Mode</td>
<td>Navigate in Beginner’s and Advanced Fly modes</td>
</tr>
<tr>
<td>Using the Viewpoint Palette</td>
<td>Define viewpoints</td>
</tr>
<tr>
<td>Changing Views</td>
<td>Review stored viewpoints</td>
</tr>
<tr>
<td>Viewing against Ground</td>
<td>View an object against the ground</td>
</tr>
<tr>
<td>Magnifying</td>
<td>View and magnify document contents in a separate window</td>
</tr>
<tr>
<td>Looking At Objects</td>
<td>Look at objects in a specific direction through a user-defined viewport</td>
</tr>
<tr>
<td>Using Geometry Overview</td>
<td>Analyze your position in space</td>
</tr>
<tr>
<td>Setting Lighting Effects</td>
<td>Sets different types of light sources to produce realistic lighting effects</td>
</tr>
<tr>
<td>Setting Depth Effects</td>
<td>Produces depth effects by clipping geometry between clipping planes, and creates a foggy effect</td>
</tr>
</tbody>
</table>

Up

Setting Up Your Session

Navigating

Annotating

Using Camera Capabilities

Using Generic Animation

Creating Scenes

Proximity Query
Navigating in Examine Mode

Navigating in Examine Mode is the default mode. You can examine your document as you would from the outside by moving around the document's perimeter, or as you would from within, turning your head to view or moving closer (zoom in, zoom out) to different objects.

**Note:** When in beginner's fly mode, click the Examine mode icon in the View toolbar to return to the default navigation mode.

For more information, see Activating Viewing Tools Using the Mouse in the *Infrastructure User's Guide*. 
Navigating in Walk Mode

In Walk mode, you can walk forward and backward as well as turn right or left as you walk along the horizontal view plane you define.

Two walk modes are available:
- **Beginner's mode**
- **Advanced mode** for experienced users.

Before using the Walk navigation mode, you must be in a perspective view (View->Render Style->Perspective).

**Beginners Walk Mode**

This task shows you how to navigate through a document in beginner's walk mode.

Beginner's walk mode commands are single-action commands. Releasing the mouse button means you exit the command. You can only move forward in beginner's walk mode.

Open Platform.model in the Samples/Infrastructure directory.

You need a V4 Integration license to open this sample document.


The icons used in the beginner's walk mode appear in the View toolbar:

![View toolbar with icons](image)

These commands are also available via View->Modify in the menu bar.

The horizontal indicator to the right helps you keep track of your horizontal view plane.

2. Click the Turn Head 🧠 icon in the View toolbar then drag (left mouse button) to define your starting position.
3. Release at desired location.

4. Click the Walk icon, then click the left mouse button to begin to walking:
You begin to walk forward in the chosen direction

5. Still holding the left button down, drag to the right or left to change direction.
Dragging to the left lets you view the object as if you had turned your head to
the left; dragging to the right produces the same effect in the opposite direction

6. Bring the cursor back into the orange rectangle to continue walking forward
in the new direction.

7. To modify your speed, click the Accelerate or Decelerate icon one
or more times, then click the Walk icon again followed by the left mouse button
to pursue your walk.

   **Note**: The size of the arrow in the navigation compass reflects the speed of
your walk.

8. To return to the default navigation mode, click the Examine mode icon in the View toolbar

---

**Advanced Walk Mode**

This task shows you how to navigate through a document in Walk mode.

Before using the Walk navigation mode, you must be in a perspective view (View
-> Render Style -> Perspective).

It is easier to walk through documents in contexts where you would find a virtual
ground, i.e. in buildings, planes or ships for example.

Open Platform.model in the Samples/Infrastructure directory.

You need a V4 Integration license to open this sample document.

Fine lines that represent the field of vision. When the green point is within these lines, you can see the document in the geometry area.

For the walk mode, a horizontal view plane indicator to the right of the compass
2. Press and hold down the middle mouse button to define the horizontal view plane.
3. Still holding the button down, drag to the left or to the right to determine the direction in which you wish to walk.

In the Walk mode, press and hold down the middle mouse button until you've finished navigating.
4. When in the direction in which you wish to walk, click the left mouse button to begin walking.

You begin to walk forward in the chosen direction.

An arrow indicating the direction in which you are walking appears in the navigation compass.
5. Still holding the middle button down, drag left or right to change direction:

Dragging to the left lets you view the object as if you had turned your head to the left; dragging to the right produces the same effect in the opposite direction.

6. Bring the cursor back into the orange rectangle to continue your walk forward in the new direction.
Pressing the PageUp and PageDown keys modifies your speed. Speed is indicated in the status bar. The size of the arrow in the navigation compass reflects the speed of your walk.

7. Click the left mouse button again to reverse direction:

You begin to walk backward, away from the target.

Note: The left and right are now defined as if you were walking away from the target with your back towards it.
Navigating in Fly Mode

In Fly mode you can move upward or downward on any horizontal view plane as you move forward or backward (advanced mode only). The horizontal indicator to the right helps you keep track of your horizontal view plane.

Two fly modes are available:
- Beginner's mode
- Advanced mode for experienced users.

Before using the Fly navigation mode, you must be in a perspective view (View->Render Style->Perspective).

Beginner's Fly Mode

This task shows you how to navigate through a document in beginner's fly mode.

**Note:** Beginner's fly mode commands are single-action commands. Releasing the mouse button means you exit the command. You can only move forward in beginner's fly mode.

1. Click the Fly Mode icon in the View toolbar or select View->Navigation Mode->Fly

The four icons used in the beginner's fly mode appear in the View toolbar

These four commands are also available via View -> Modify in the menu bar.
2. Click the Turn Head icon in the View toolbar then drag (left mouse button) to define your starting position

3. Release at desired location

4. Click the Fly icon, then click the left mouse button to begin to flying:
   You begin to fly forward in the chosen direction

5. Still holding the left button down, drag to the right or left to change direction
   Dragging to the left lets you view the object as if you had turned your head to the left; dragging to the right produces the same effect in the opposite direction

6. Bring the cursor back into the orange rectangle to continue flying forward in the new direction

7. To modify your speed, click the Accelerate or Decelerate icon one or more times, then click the Fly icon again followed by the left mouse button to pursue your fly
   Note: The size of the arrow reflects the speed of your fly.

When you collide with a solid object when flying, you will slide along the object's surface, and you will no longer fly through the object, providing a more realistic effect. This feature is also available in Advance Fly mode.

Pressing the Shift key and dragging lets you bank left or right.

Note that the compass and orange rectangle are no longer used.

You can use the option "Gravitational effects when navigating" in the Visualization tab, accessed via the Tools->Options command, to fix the X, Y or Z axis during navigation. While turning in Fly mode, this creates the impression that the user viewpoint tilts or banks with respect to the fixed axis, as in a real plane.

8. To return to the default navigation mode, click the Examine mode icon in the View toolbar
Advanced Fly Mode

This task shows you how to navigate through a document in advanced fly mode.

In advanced fly mode, you can move upward or downward on any horizontal view plane as you move forward or backward.

1. Click the Fly Mode icon in the View toolbar or select View -> Navigation Mode -> Fly

2. Press and hold down the middle mouse button to define the initial horizontal view plane

3. Still holding the button down, drag to the left or to the right to determine the direction in which you wish to fly

In the Fly mode, press and hold down the middle mouse button until you've finished navigating.

4. When in the direction in which you wish to fly, click the left mouse button to begin flying:

You begin to fly forward in the chosen direction.
5. Still holding the middle button down, drag left or right to change direction:

Dragging to the left lets you view the object as if you had turned your head to the left; dragging to the right produces the same effect in the opposite direction.

6. Bring the cursor back into the orange rectangle to continue flying forward in the new direction.

7. Click the left mouse button again to reverse direction:

You begin to fly backwards, away from the target.

**Note:** When flying backwards, the up and down are reversed.
You can use the option "Gravitational effects when navigating" in the Visualization tab, accessed via the Tools->Options command, to fix the X, Y or Z axis during navigation. While turning in Fly mode, this creates the impression that the user viewpoint tilts or banks with respect to the fixed axis, as in a real plane.

8. To return to the default navigation mode, click the Examine mode icon in the View toolbar.
Using the Viewpoint Palette

The Viewpoint Palette provides an easy and precise way to define your document views. It gives you access to a certain number of viewing tools that will let you fine-tune viewpoints. You can pan and rotate as well as turn your head to view or move closer (zoom in, zoom out) to different objects in your document by predetermined increments. You can start from scratch or fine-tune a standard view. Views can then be stored and called up from a list of viewpoints, as well as combined to produce an animation.

To access the Viewpoint Palette, select View -> Viewpoint Palette...
The Viewpoint Palette dialog box appears.

<table>
<thead>
<tr>
<th>Task</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Selecting Standard Views</td>
<td>Obtain standard document views</td>
</tr>
<tr>
<td>Panning, Zooming, Rotating &amp; Turning Your Head</td>
<td>Pan, zoom, rotate &amp; turn your head by predetermined increments</td>
</tr>
</tbody>
</table>
Selecting Standard Views

The Viewpoint Palette offers a certain number of viewing tools that let you define individual document views. You can start from scratch or fine-tune a standard view. Views can then be stored and called up from a list of viewpoints, as well as combined to produce an animation.

Open the platform.model document from the \online\samples\dmunavigator directory.

This task shows you how to obtain standard views of your document using the Viewpoint Palette.

1. Select View -> Viewpoint Palette...
   The Viewpoint Palette dialog box appears.
   
2. In the Translate box, click to activate the change view commands
   The Translate box now offers a number of standard views (top, back, left, right, front and bottom) you can use to display the document:
3. Click the desired view.
For example, clicking the Top view icon obtains the top view:

The other views are:

- Bottom view
- Left view
- Right view
Fine-tune your standard view using other viewing tools (pan, zoom, rotate and turn head) in the Viewpoint Palette.

You can also obtain standard views of your document using the View-> Named Views... command.
Panning, Zooming, Rotating & Turning Your Head

The Viewpoint Palette offers a certain number of viewing tools that let you define individual document views. You can start from scratch or fine-tune a standard view. Views can then be stored and called up from a list of viewpoints, as well as combined to produce an animation.

This task shows you how to pan, zoom, rotate and look at objects as if you are turning your head using the Viewpoint Palette.

1. Select View -> Viewpoint Palette...

The Viewpoint Palette dialog box appears.

The Translate box contains panning and zooming commands (default position).

Using these commands, you can move the current document contents by panning the viewpoint as well.
as zoom in/out by predetermined increments.

2. Enter a new step in the spin box and press Enter, or scroll to a new value with the up and down arrows.

3. Try experimenting with the pan and zoom commands until you are satisfied with the viewpoint.
   The Rotate box contains commands letting you rotate an object (default position) and turn your head to view the document.

4. Enter a new rotation step in the spin box and press Enter, or scroll to a new value with the up and down arrows.

5. Try experimenting with rotation commands until you are satisfied with the viewpoint.
6. Click the Turn Head icon to simulate what happens when you turn your head to look at the document.

7. Enter a new step in the spin box and press Enter, or scroll to a new value with the up and down arrows.

8. Try experimenting with turn head commands until you are satisfied with the viewpoint.

You can also progressively pan, zoom and rotate in the Examine navigation mode.

Set the viewing distance and angle as well as the eye and target locations directly using spin boxes.
Changing Views

Individual views are created as you navigate through your design in examine and fly modes. Views are stored and can be reviewed using previous and next icons in the DMU Viewing toolbar.

In fly mode, views are created each time you pause during your fly around.

Open the platform.model document from the \online\samples\dnunavigator directory.

This task shows you how to change views.

1. Navigate in Examine mode (zoom, pan, etc.) to create and save several different views.

2. Click the Previous icon in the DMU Viewing toolbar or select View -> Modify -> Previous View:

   The previous view is displayed in the geometry area.

3. Click the Previous icon again.

4. Click the Next icon, or select View -> Modify -> Next View:

   The next saved view is displayed in the geometry area.
Ground lets you visually insert a plane at the ground level of your document, thus enabling you to recognize when your document is viewed the right way up. By default, when you first access a document, the plane parallel or tangent to the bottom point of your document is considered to be the ground. You can, however, change the plane used to identify the ground. For more information, see Customizing the Ground.

This task shows you how to show and hide the ground.

1. Select View->Ground, or click the Horizontal Ground icon in the DMU Viewing toolbar.

   The ground plane is displayed in the geometry area.

   To hide the ground, simply repeat the same step.

2. Drag (left mouse button) the ground up or down to a new location, then release the mouse button.

   The ground is repositioned as defined.
Up
Navigating in Fly Mode
Viewing against Ground
Using Geometry Overview
Navigating in Examine Mode
Using the Viewpoint Palette
Magnifying
Setting Lighting Effects
Navigating in Walk Mode
Changing Views
Looking At Objects
Setting Depth Effects
Magnifying

This task explains how to obtain a magnified view of your document in a separate window.

1. Open the .cgr files from the \online\samples\dmunavigator directory.

2. Select the View->Magnifier... command or click the Magnifier icon in the DMU Viewing toolbar.

The Magnifier window opens containing a magnified section of your document:

The section magnified is defined by the magnifier viewport which appears over the object in your document:

Note that the magnifier viewport has handles:
- the "+" symbol lets you move the viewport
- the arrows in the corners let you resize the viewport.

2. Point to the + symbol and drag it to move the viewport and magnify another area of the document:
3. Point to one of the arrows and drag it to size the magnified area up and down:

While you drag, the symbol appears.

All the viewing and manipulations performed in the document window are also reflected in the Magnifier window. For example, rotate the object to see how the object is also rotated in the Magnifier window:
Looking At Objects

This task explains how to look at the document in a specific direction by targeting through a user-defined viewport.

1. Select the View->Modify->Look At command, or click the Look At icon.
2. Click (left mouse button) on an object in the document to select it.
3. Drag (still holding left mouse button down) slowly to display the viewport.

As you begin to drag, a rectangle with two diagonals appears and continues to grow as long as you continue to drag. This rectangle represents the viewing window of the future view.
4. Continue dragging to move around, resize and reposition the viewport.

The viewport is then shaped like a pyramid: your eyepoint is located at the vertex of the pyramid. You can resize the viewport by dragging the middle mouse button.

5. Release the button.

You now see what is targeted inside the viewport.
You can also press and hold down both Shift then the middle mouse button for a quicker result.
This task explains how to use the overview to view the geometry.

1. With geometry visible in the geometry area, select the View->Geometry Overview command. The geometry is displayed in the overview window, but not the specification tree:

2. Point to the Overview window to display the cursor, and drag.

This drags the overview viewport through which you view the geometry. Only that part of the geometry you see inside the overview viewport will be visible in the document window:
3. Zoom the size of the overview viewport by dragging the handles located at the top right and bottom left corners of the viewport.

While you drag, the cursor changes to: \( \text{放大镜图标} \). This lets you zoom the geometry in and out in the document window:

Note that you can resize the overview window itself to see the whole of the viewport.
Setting Lighting Effects

This tasks explains how to vary ambient lighting effects.

1. Select the View->Lighting... command or the Lighting icon in the DMU Viewing toolbar to display the Light Source Editor dialog box. The default light source settings look like this...

... and produce a lighting effect, for example, like this:
Note that the One Light Source icon is activated by default. The sphere indicates the current lighting direction. The handle on the sphere indicates the direction from which the light is being projected: by default, the light is coming from the top left.

You can drag the handle around (using the left mouse button) to change the lighting direction. The new lighting effect is created instantaneously as you drag the handle.

A slider at the bottom of the dialog box lets you adjust light source brightness.

2. Drag the handle down and towards the bottom right: the light is now coming from the bottom right:

3. Click the Two Light Source icon to add another light source.
In our example, using two light sources means that the lighting is now too bright.

4. Drag the brightness slider to the left to reduce the brightness.
5. Now drag the lower handle up towards the top left to change the direction of the corresponding light source.
6. Click the Neon Light icon to produce a neon light effect.

7. Click the No Light Source icon to switch off all light sources.
Setting Depth Effects

This task explains how to achieve 3D depth effects, namely, clipping geometry between clipping planes and creating fog effects.

1. Select the View->Depth Effect... command or the Depth Effects icon in the DMU Viewing toolbar to display the Depth Effect dialog box.

The orange sphere completely encompasses the objects in your document. The white cross represents the center of the objects in the geometry area.

The color of the area behind the orange sphere is the background color of your document. The vertical lines represent the front (near) and back (far) clipping planes.

By default, depth effects are deactivated: if you zoom in and out, you will see that for the moment the geometry is not clipped.

You can keep the Depth Effect dialog box open and continue working with other commands. You will be able to understand the results obtained by setting depth effects by zooming in and out.

2. Set the Near Limit and Far Limit by checking the Fixed checkbox for each option, entering values and pressing Enter in each case.

Note that location of the vertical lines representing the clipping planes has changed.
3. Zoom in progressively to see how the geometry is clipped by the near clipping plane:

The back (far) section of the geometry is clipped. You now only see what is located between the near and far clipping planes.
4. Zoom out to see all the geometry.
5. Click the Foggy option.

The foggy option introduces a foggy effect.

6. Zoom out again.

As you zoom out, the fog effect is increased. The fog gets thicker as you continue to zoom out beyond the back clipping plane.
<table>
<thead>
<tr>
<th>Up</th>
<th>Navigating in Examine Mode</th>
<th>Navigating in Walk Mode</th>
</tr>
</thead>
<tbody>
<tr>
<td>Navigating in Fly Mode</td>
<td>Using the Viewpoint Palette</td>
<td>Changing Views</td>
</tr>
<tr>
<td>Viewing against Ground</td>
<td>Magnifying</td>
<td>Looking At Objects</td>
</tr>
<tr>
<td>Using Geometry Overview</td>
<td>Setting Lighting Effects</td>
<td>Setting Depth Effects</td>
</tr>
</tbody>
</table>
## Annotating

<table>
<thead>
<tr>
<th>Task</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Using the 3D Marker</td>
<td>Annotate your document</td>
</tr>
<tr>
<td>Creating Hyperlinks</td>
<td>Create hyperlinks</td>
</tr>
<tr>
<td>Jumping to Hyperlinks</td>
<td>Jump to hyperlinks</td>
</tr>
<tr>
<td>Using Standard Views</td>
<td>View documents using standard views</td>
</tr>
<tr>
<td>User-Defined Views</td>
<td>Create, modify and delete user-defined views</td>
</tr>
<tr>
<td>Using the 2D Marker</td>
<td>Annotate views</td>
</tr>
<tr>
<td>Using Temporary Markers</td>
<td>Visualize object names and point coordinates</td>
</tr>
</tbody>
</table>

### Additional Sections
- Up
- Setting Up Your Session
- Navigating
- Annotating
- Using Camera Capabilities
- Using Generic Animation
- Creating Scenes
- Proximity Query
Using the 3D Marker

You can annotate your 3D document. Annotations are attached to the point selected to place the text.

This task explains how to add 3D text.

1. Select Insert -> 3D Annotation from the menu bar or,
   click the 3D Annotation icon in the DMU Navigator Tools toolbar.

2. Click an object at the point you want to place the text

   Note: You can select the object first.
   The Annotation Text dialog box appears

2. Enter the desired text in the 3D Text field
3. Click OK

The text is added at the desired position. Annotations are attached to the point selected. You can move your document; annotations remain attached to the point at which you place them.

   Note: Text annotations are identified in the specification tree.

A text's drawing properties include its color. You can change the color of text that you've already added.
4. Right-click a text you’ve already added and select Properties from the contextual menu, or click the text and select Edit -> Properties from the menu bar.

**Note:** Dynamic highlighting as you move your cursor over objects helps you locate them.

The Properties dialog box appears.
5. Click the Graphic tab to display the graphic properties of the current object.
6. Make desired changes.
7. Click OK when done.

Checking the Set as default checkbox in the Properties dialog box sets the selected properties as default properties and changes how new annotations will look when you create them.

To delete annotation text, right-click the object and then select Delete from the contextual menu.
Creating Hyperlinks

You can add hyperlinks to your document and then use them to jump to a variety of locations, for example to a marketing presentation, a Microsoft Excel spreadsheet or a HTML page on the intranet.

You can add hyperlinks to models, products and parts as well as to any constituent elements.

Visualization Mode does not permit selection of individual model elements. To select these elements, switch to Design Mode (Edit -> Design Mode)

This task explains how to add hyperlinks.

1. Select the Insert->Add Hyperlinks command, or click the Add Hyperlinks icon in the DMU Navigator Tools toolbar

2. Select the object you want to represent the hyperlink

Or,

1. Select the object you want to represent the hyperlink

2. Select the Insert-> Add Hyperlinks command, or click the Add Hyperlinks icon in the DMU Navigator Tools toolbar

The Manage Hyperlink dialog box appears.

3. Enter a name for your hyperlink

**Note**: This is the name that will appear as a textual cue if the Name checkbox is set in the Options dialog box. For more information, see Customizing DMU Navigator Settings.

4. Enter the path to the destination file in the URL field then press Enter

Or,

Click Browse... and select the destination file in the Link to File dialog box
**Note:** You can add more than one link. Simply enter another path or click Browse... and select another file. All links created are listed in the Link to file or URL box.

Select a link then click Go to to follow the link to the destination file. Select a link then click Remove to remove existing links.

5. Click OK in the Manage Hyperlink dialog box when satisfied. The hyperlink is created and is identified in the specification tree.

The hyperlink cue is displayed on the object in the geometry area. By default, hyperlink cues are graphical.

**Note:** You can change the color of the hyperlink cue. To do so, right-click the cue then select Properties from the contextual menu, or select the cue then Edit -> Properties from the menu bar.

Simply right-click the hyperlink cue and select URL object -> Add Hyperlinks from the contextual menu to edit the link.
Jumping to Hyperlinks

This task explains how to jump to hyperlinks.

There are several ways to jump to hyperlinks:

1. Double click the hyperlink cue, or the desired hyperlink in the specification tree
Or,

1. Click the Go to Hyperlinks icon in the DMU Data Navigation toolbar
2. Select the object with the desired hyperlink, the hyperlink cue or the desired hyperlink in the specification tree
Or,

1. Select the object with the desired hyperlink, the hyperlink cue or the desired hyperlink in the specification tree
2. Click the Go to Hyperlinks icon in the DMU Data Navigation toolbar
Or,

1. Right-click the hyperlink cue and select URL object-&gt;Definition... from the contextual menu

If more than one link has been created, the Open Hyperlink dialog box appears

3. Select the link of interest, then click OK
The file linked is displayed.

Objects with hyperlinks are identified by textual and/or graphical cues.
Using Standard Views

This task explains how to use standard views.

1. Select the View->Named Views... command:

The Named Views dialog box appears.

The list provides a number of standard views you can use to display the document:

- front
- back
- left
- right
- top
- bottom
- iso.

2. Double-click the desired view.

For example, double-clicking *front obtains the front view:

The other views are:
Creating, Modifying and Deleting User-Defined Views

This task explains how to create, modify and delete user-defined views. Note that user-defined views are stored with the document.

1. Select the View->Named Views... command and double-click the desired view.

You are now ready to customize the view.

2. Adjust the different view parameters (zoom, rotation, etc.) until you are happy with the result.

3. Click the Add button to add the view to the list.

The default name of the view is Camera 1.
4. Rename the view as required and press Enter.

5. Check the Show Representations checkbox:
You now see a 3D viewpoint representation in the geometry area. The 3D representation is a viewport that helps you to define what you want to see in the view. What you see inside the viewport can then be stored in your view. You can manipulate the 3D representation to define exactly what you want to see:

- zooming, rotating and panning the geometry using the standard tools also affects the 3D representation
- dragging the corners rotates it
- dragging any of its sides or any of the corner markers inside the representation moves it (the triangular marker always represents the bottom left corner)
- dragging the point in the center (the eye position) defines the direction in which you look at the document.
6. Manipulate the 3D representation to define your view parameters.
7. Click the Properties button to access the Camera Properties dialog box.

8. Double-click anywhere on the 3D representation to apply the view parameters, and click Apply to apply the changes to your view.
9. If you want to modify any customized view you already saved, select it, modify the view parameters again, then click the Modify button. You can also delete views by selecting the view from the list and clicking the Delete button.
The Reverse button lets you view the object from the reverse angle.
Using the 2D Marker

You can draw straight lines, freehand lines, circles, arrows and rectangles. You can create complex annotations by combining several objects as well as include text in document views. This task explains how to annotate your documents.

To annotate documents, you must be in an active view. Objects drawn are associated with the active view and will no longer be visible if the view is changed.

1. Select the View->Named Views... command

The Named Views dialog box appears.

2. Double-click the desired view.

The DMU 2D Marker toolbar becomes active. You can now annotate your view.
3. Click the appropriate icon in the DMU 2D Marker toolbar to draw straight lines, freehand lines, circles, arrows or rectangles.

4. Put the cursor where you want to start the object, then click and drag to draw the object:

   To draw a straight line, click at the start of the line and drag from the beginning to the end of the line.

   To draw a freehand line, click at the start of the line and drag the cursor along the path of the line.

   To draw a circle or a rectangle, click at the start of the object and drag diagonally across the area in which you want the object to appear.

   To draw an arrow, click at the start of the arrow and drag from the beginning to the end of the arrow.

5. Click the Text icon to annotate your view with text:

   You can now easily move and resize the 2D markers. All you need to do is drag the green manipulators attached to the marker selected.

   The Annotation Text dialog box appears

   6. Enter the desired text in the text box

   7. In the view, click where you want to place the text

   The text is added at the desired position

   Click Clear to remove the characters you typed in the text box.

   An object's drawing properties include color, line type and weight. You can change drawing properties of objects that you've already drawn.
8. Select the Select icon to enter the selection mode:
9. Right-click an object you've already drawn and select Properties from the contextual menu, or click the object then select Edit -> Properties from the menu bar

**Note:** Dynamic highlighting as you move your cursor over objects helps you locate them.

The Properties dialog box appears

10. Click the Graphic tab to display the graphic properties of the current object

11. Make desired changes:

You can change the color, line type and line weight of the selected object

12. Click OK when done

You can automatically transform 2D markers in 3D markers selecting Analyze->Graphic messages from the menu bar.
Checking the Set as default checkbox in the Properties dialog box sets the selected properties as default properties and changes how new annotations will look when you create them. To delete all annotations in the current view, select the Delete All Annotations icon.

You can also delete individual markers by right-clicking the object and then selecting Delete from the contextual menu.
Using Temporary Markers

You can visualize the names of objects as well as coordinates of points defined on objects in your document as you move your cursor over objects. This task explains how to visualize object names and point coordinates.

1. Select Analyze -> Graphic Messages -> Name from the menu bar to view object names.
2. Move your cursor over objects in your document:
   The name of the object is displayed.
3. Re-select Analyze -> Graphic Messages -> Name to de-activate the command.
4. Select Analyze -> Graphic Messages -> Coordinate from the menu bar to view point coordinates.
5. Move your cursor over objects in your document:
   The coordinates of the point under the cursor are displayed. Dynamic highlighting helps you identify points of interest.
6. Re-select Analyze -> Graphic Messages -> Coordinate to de-activate the command
Using Camera Capabilities

DMU Navigator provides easy methods to create and move cameras as well as to record and replay animations.

<table>
<thead>
<tr>
<th>Task</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>About Cameras</td>
<td>Background information on cameras</td>
</tr>
<tr>
<td></td>
<td>Create and display cameras</td>
</tr>
<tr>
<td>Creating Cameras</td>
<td>Move cameras to the desired position</td>
</tr>
<tr>
<td>Moving Cameras</td>
<td>Record an animation</td>
</tr>
<tr>
<td></td>
<td>Replay an animation</td>
</tr>
</tbody>
</table>
About Cameras

Cameras let you take stills of views or viewpoints in your document. A series of views showing different viewpoints in succession can be combined to create an animation.

Cameras are identified by name in the specification tree and by a symbol in the geometry area.

A 3D representation helps you locate the viewpoint of interest by showing what the camera sees through a viewport:

Cameras are moved using the 3D compass.
Creating and Displaying Cameras

This task shows how to create and display cameras.

1. Adjust the view parameters (zoom, rotation, etc.) of the document to define the desired camera location

2. Click the Create Camera icon or select Insert->Create Camera from the menu bar

   The Edit Camera dialog box is displayed.

   The Preview window, showing what the camera sees when created, also appears. To change the default display setting for this window, see Customizing DMU Navigator Settings.

3. Identify the camera in the Name field

4. Click Show Graphic Representation to visualize the camera symbol and 3D graphic representation in the geometry area

5. Click OK to create the camera

   A camera is created at the current viewpoint. The Preview window is closed.

6. Zoom out and rotate the model to see the 3D representation.
7. Click anywhere in the geometry area to de-select the camera and see the camera symbol.

You can create several cameras at different locations. The DMU Navigator offers you the possibility of visualizing the viewpoint of each camera in different windows.

8. Select Window -> Camera Window

All cameras created are listed

9. Select the cameras of interest from the list

A new window showing the camera viewpoint is opened for each camera selected

If you want to organize the opened windows horizontally:

10. Select Window -> Tile Horizontally
If you want to organize the opened windows vertically:

11. Select Window -> Tile Vertically
If you want to organize the opened windows in a cascading arrangement in which they overlap each other:
12. Select Window -> Cascade
Moving Cameras

This task shows how to move a camera you have just created to the desired position. For this, you will use the 3D compass.

For information on the 3D compass, see the *Infrastructure User's Guide*.

You defined a Camera.

To move a camera, you will attach the 3D compass to the 3D camera representation. If you cannot see the 3D representation, click the camera in the specification tree and select Camera object -> Definition from the contextual menu, then click the Show Graphic Representation checkbox in the Edit Camera dialog box.

1. Select the camera to be moved in the specification tree:
   The 3D representation is shown in the geometry area.

2. Attach the 3D compass to the 3D camera representation:
   - Press and hold down the left mouse button on the red square of the 3D compass
   - Drag the 3D compass to attach it to the camera representation:
     Notice that the compass changes appearance as you drag it.

   Pointing to a line coming from the eye automatically snaps the compass to the eye and pointing to one of the sides of the viewport snaps the compass to the target.

You can attach the 3D compass to two different positions of the camera representation as shown below: the eye and the target.

3. Select Window -> Camera Window and select the camera from the list to open a separate window showing the camera viewpoint

4. Select Window -> Tile Vertically to organize opened windows vertically
5. Click one of the translation axes of the 3D compass and drag to translate to the desired position.
6. Click one of the rotation axes of the 3D compass and drag to rotate to the desired position
7. Continue experimenting until satisfied with the camera position

The camera viewpoint is automatically stored.
Using Generic Animation

DMU Navigator provides to record and replay animations.

<table>
<thead>
<tr>
<th>Task</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Recording Animations</td>
<td>Background information on cameras</td>
</tr>
<tr>
<td></td>
<td>Create and display cameras</td>
</tr>
<tr>
<td>Replaying Animations</td>
<td>Move cameras to the desired position</td>
</tr>
<tr>
<td>Generating an Animation File</td>
<td>Record an animation</td>
</tr>
<tr>
<td></td>
<td>Replay an animation</td>
</tr>
</tbody>
</table>

Up

Setting Up Your Session

Navigating

Annotating

Using Camera Capabilities

Using Generic Animation

Creating Scenes

Proximity Query
Recording Animations

This task shows how to create an animation using one camera. This is done in two steps:

- Defining a simulation.
  For this, you will use the 3D compass. For more information on the 3D compass, see the *Infrastructure User's Guide*.

- Creating a film from your simulation.

You defined a Camera.

1. Click the camera in the specification tree
2. Click the Simulation icon or select Insert->Simulation from the menu bar

The Edit Simulation dialog box and the Preview window showing the object manipulated (in our case, the camera) appear.

To change the default display setting for the Preview window, see Customizing DMU Navigator Settings.

3. Close the Preview window

4. Click the Insert switch and record the
Remember the initial position is automatically recorded.

The camera viewpoint is stored in the Simulation object each time you click Insert. You can, in this way, record a series of viewpoints which when combined and compiled create your animation.

5. Using the 3D compass, move the camera to a new location

By default, the 3D compass snaps to the eye when you clicked the Simulation icon if it wasn’t attached before.

6. Click Insert and record the desired shot
7. Move the camera as often as necessary, clicking Insert to record shots

You may find it useful to open the camera window (Window->Camera Window) and tile the two windows. This will allow you to see the camera viewpoint better as you move the camera.

8. Use the VCR buttons to position the camera in its original location and replay the recorded camera positions
9. Click OK to save the simulation.

Note: No track is displayed when defining a simulation for cameras.

You are now ready to create a film. This is done by compiling your simulation.

10. Select the Simulation object in the specification tree

11. Click the Compile Simulation icon

The Compile Simulation dialog box appears

12. Enter a meaningful name for your film if desired
13. Activate the Number of steps drop-down list box and select the number of steps you want to break down each shot into
14. Click OK to compile the simulation and create a film:

   You can see the results in the geometry area as the simulation is being compiled.

   For more information on Simulation and Compile Simulation capabilities, see the *Fitting Simulator User's Guide.*

   Use Simulation in this way to produce an animated inspection of your design.
Replaying Animations

This task shows you how to replay a recorded animation.

You must have already recorded an animation. See Recording Animations

1. Select the Replay object in the specification tree.

2. Click the Replay icon.

   The Replay dialog box is displayed.

3. Open the camera window (Window->Camera Window) and tile the two windows to see the animation better

4. Click:
   - the Play VCR button to run a continuous replay of the recorded viewpoints
   - or the Forward VCR button to run a step-by-step of the recorded viewpoints

5. Check the Animate viewpoint option if you want to take into account the viewpoints recorded during the simulation

   Each viewpoint is replayed one after the other in the order in which they were recorded and compiled.
5. Adjust the sampling step:

Leaving the value at x1 replays the film in the number of steps defined when compiling the simulation. Increasing the value speeds up the animation, for example, setting the sampling step to x2 will replay the film at every second step.

You can choose one of the loop modes to re-run the animation in a continuous way (either in one direction only or in one direction then the other).

For more information on Replay capabilities, see the *Fitting Simulator User's Guide*.
Generating an Animation File

This task shows you how to generate an animation file.

You must have already recorded an animation. See Recording Animations

1. Click the Compile Simulation icon.

The Compile Simulation dialog box displays

2. Make sure the Generate an animation file option is activated.

3. (Optional) Enter a meaningful name for the animation file you want to create.

4. Activate the Time step drop-down
list box and select the time step.

5. Click File name to store your animation. The Save As dialog box displays.

6. Click Save. The animation file is created and saved in AVI Microsoft format.
Defining Scenes

DMU Navigator provides easy methods to create and move cameras as well as to record and replay animations.

<table>
<thead>
<tr>
<th>Task</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>About Scenes</td>
<td>Background information on scenes</td>
</tr>
<tr>
<td>Create and display scenes</td>
<td></td>
</tr>
<tr>
<td>Creating Scenes</td>
<td>Add a component in a product: Impact on the scene</td>
</tr>
<tr>
<td>Adding a Component</td>
<td>Replace component in a product: impact on the scene</td>
</tr>
<tr>
<td>Using Reset &amp; Checking Positioning</td>
<td>Remove component in a CATProduct: impact on the scene</td>
</tr>
<tr>
<td>Removing a Component</td>
<td></td>
</tr>
<tr>
<td>Exploding an Assembly</td>
<td>Use the explode functionality in scene context</td>
</tr>
</tbody>
</table>

- Up
- Setting Up Your Session
- Navigating
- Annotating
- Using Camera Capabilities
- Using Generic Animation
- Creating Scenes
- Proximity Query
About Scenes

The Scene capability lets you control the position and orientation of each component of an assembly. You can easily rotate a component and set different positions orientations in an instance.

Scenes are identified by name in the specification tree and by a graphical representation in the geometry area. The following operations are not allowed in a Scene context:

- add
- remove
- replace
- cut
- delete
- paste
Creating Scenes

This task shows you how to create scenes.

Insert sample files \online\samples\dmunavigator\ GARDENA*.cgr.

1. Click the Create Scene icon 📚.

The Edit Scene dialog box and a scene representation in the window display.

2. Click Ok to end the scene creation.

You are now in a scene window:
- The background window turns to green.
- Scene 1 is identified in the specification tree.
3. Perform the required modifications. For instance modify the viewpoint.
   - graphical attributes
   - show-no show

Within a scene, click the Reset selected products icon to reposition the components as they were in the initial product. Note that the color attributes, show-no show specification are not taken into account when using the Reset selected products icon.

4. Click the Exit From Scene icon to swap to the initial window.

The scene is updated.
5. Double-click Scene 1 either in the specification tree or in the geometry area to swap to the scene window.

6. Create as many scenes as needed.

Clicking off View -> Scene Specification Visible in the menu bar removes the scene representation and lets you use the entire screen for the product. You can also use the F3 key to toggle more quickly.
Adding a Component

This task shows you how to add a component in a Product.

Insert sample files `\online\samples\dmunavigator\*.cgr` except NOZZLE_1_2.cgr and NOZZLE_2_2.cgr.

1. Click the Create Scene icon.

   The Edit Scene dialog box and a scene representation in the window appear.
2. Click OK to end the scene creation.

You are now in a scene window:
- the background window turns to green.
- Scene 1 is identified in the specification tree.
4. Click the Exit From Scene icon to swap to the initial window. The scene is created and its representation appears in the left corner of the main window.

5. Now add the NOZZLE, for this:
   - Select Product.1 in the specification tree and select Insert->existing component...
   - Shift-select NOZZLE_1_2.cgr and NOZZLE_2_2.cgr

6. The added component (NOZZLE) is identified in the specification tree and added in the geometry area.
Back in the scene window:

- The corresponding component is automatically added and appears in the specification tree.
- The shape representation is deactivated therefore the scene visualization is unchanged.

Clicking the Exit From Scene icon updates the scene.
Using the Reset Selected Products

This task shows you how to use the Reset Selected Products
Please refer to Creating Scenes

Insert sample files \online\samples\dmunavigator\*.cgr.
You created Scene.1.

1. Double-click the scene representation to enter the scene.

In this scene you moved the certain components.
2. Select Tools->Checking Positioning... from the menu bar to find out the items you moved.

The moved items are highlighted in the specification tree.
3. Click the Reset selected products icon and exit the scene. The items are repositioned in the scene as they were in the initial product.
Removing a Component

This task shows you how to view the contents of the data cache.

Insert sample files \online\samples\dmunavigator\GARDENA*.model.
You created a first Scene.

1. Remove the REGULATION_COMMAND for instance.

2. Scene 1 is updated.
This scenario is also valid when replacing a component. The scene is automatically synchronized.
Using Explode in a Scene

The Explode function is available in the assembly workbench and can be used in scene context. You can easily create a scene and explode the assembly without changing anything in the original assembly.

Insert sample files 'online\samples\dmunavigator\GARDENA*.cgr'.

1. Click the Create Scene icon.
   The Edit Scene dialog box and a scene representation in the window display:

2. Click Ok to end the scene creation.

3. Select Product.1 and click the Explode icon.
4. Click Apply. This is what you obtain:

5. Click the Exit From Scene icon to swap to the initial window.
For more details about the explode capacity, please refer to the *DMU Fitting Simulator User's Guide*.
Proximity Query

Tasks

Running a Proximity Query (DMU Navigator license only)
Running a Proximity Query (DMU Navigator & Optimizer)

Up
Annotating
Creating Scenes
Proximity Query

Setting Up Your Session
Using Camera Capabilities
Using Generic Animation
Navigating
DMU Optimizer License:
If you have a DMU Optimizer License, you can run a query on the components with the representation deactivated.

This task shows how to perform a proximity Query.
You have the DMU Navigator license only, which means the query will take into account the objects of the activated representation only.
Insert sample files `\online\samples\dmunavigator\GARDENA*.model`.

1. Click the Proximity Query icon .

The Proximity Query dialog box displays:

2. Select one of the products you want to be the reference for the query, Lock.1 for instance.
3. Set the accuracy by entering a value, 3mm for example.  
4. Check the Far away products only option.  
5. Click Apply. 
The result displays in the Result field.

6. Click OK when done. 
The products found are highlighted both in the specification tree and geometry area:
7. Hide the products found.
Now you can work with a simplified assembly.
You can combine the Proximity Query command with other DMU commands for example Comparing Products (DMU Space Analysis toolbar). Note that if you have only the DMU Navigator license, the query only takes into account the products with an activated representation.
This task shows how to run a proximity Query based on components inserted without representation. You load the product structure only. Insert sample files `\online\samples\dmunavigator\ PLATFORM*.model`.

Make sure the representation is deactivated before inserting your model files.

1. Deactivate the representation
   For this:
   a. Select Tools->Options from the menu bar.
      The Options dialog box displays.
   b. Click Product in the left-hand box.
   c. Click the Product Structure tab.
   d. In the Representation field, check the Do not activate default shape on open option
   e. Click Ok to confirm your operation.

   For more details please refer in Customizing Settings to Product Structure Only

2. Click the Proximity Query icon.
   The Proximity Query dialog box appears:

2. Select one of the products you want to be the reference for the query, PLATFORM_10 (PLATFORM_10.1) for instance.
3. Set the Clearance by entering a value. In our example, we will keep the default value of 0mm.
4. Set the Accuracy by entering 1000mm for example.
5. Check the Nearby products including selection option.
6. Click Apply.
   The result displays in the Result field.
7. Click OK when done.

The products found are highlighted in the specification tree.

8. Specify the shape representation of the items for this:
   - Right-click the highlighted items in the specification tree
   - Select Representation
   - Select Activate nodes

This is what you obtain:
Now you can work with a simplified assembly.
You can combine the Proximity Query command with other DMU commands for example Comparing Products (DMU Space Analysis toolbar). Note that if you have only the DMU Navigator license, the query only takes into account the products with an activated representation.
Workbench Description

The DMU Navigator Version 5 application window looks like this:

Click the hotspots to see related documentation.
DMU Navigator Menu Bar

This section presents the menu bar tools and commands dedicated to the DMU Navigator workbench.

View

For...          See...

Modify -> Previous View          Changing Views
Modify -> Next View          Changing Views
Modify -> Look At          Looking At Objects
Viewpoint Palette...          Using the Viewpoint Palette
Named Views...          Using Standard Views and Creating, Modifying and Deleting User-Defined Views
Navigation Mode -> Examine          Navigating in Examine Mode
Navigation Mode -> Fly          Navigating in Fly Mode
Lighting...          Setting Lighting Effects
Depth Effect...          Setting Depth Effects
Ground          Viewing Objects against the Ground
Magnifier...          Magnifying

Insert

For...          See...

Create Camera          Using Camera Capabilities
See Creating a Camera
See Creating Hyperlinks
See Using the 3D Marker
See Defining Groups of Products
See Creating Scenes
DMU Viewing Toolbar

See Looking At Objects
See Changing Views
See Changing Views
See Magnifying
See Setting Depth Effects
See Viewing Objects against the Ground
See Setting Lighting Effects
View Toolbar

See Navigating in Fly Mode
See Navigating in Examine Mode
DMU 2D Marker Toolbar

The DMU 2D Marker toolbar contains the following tools:

For all 2D Marker tools, see Using the 2D Marker
DMU Data Navigation Toolbar

See Selecting Using the Search... Command in the Infrastructure User's Guide
See Viewing the Current Selection
See Jumping to Hyperlinks
DMU Generic Animation Toolbar

See Recording Animations
See Recording Animations
See Replaying Animations
Customizing Settings

Before you start your first working session, you can customize the way you work to suit your habits. You can, for example, customize how the data cache is managed. This is done using Tools -> Options from the menu bar.

This type of customization is stored in permanent setting files. Settings will not be lost if you exit your session.

<table>
<thead>
<tr>
<th>Task</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Customizing Settings</td>
<td>Change the appearance of the hyperlink cue</td>
</tr>
<tr>
<td>Customizing Data Cache Settings</td>
<td>Customize cache management settings</td>
</tr>
<tr>
<td>Loading the Product Structure Only</td>
<td>Load the product structure without associated 3D representations</td>
</tr>
<tr>
<td>Customizing the Ground</td>
<td>Specify the reference plane used for ground and navigating</td>
</tr>
<tr>
<td>Customizing External Format Import</td>
<td>Change the Import parameters</td>
</tr>
</tbody>
</table>
Customizing DMU Navigator Settings

This task explains how to customize DMU Navigator settings.

A DMU Navigator document

1. Select the Tools->Options... command.

The Options dialog box appears

2. Click Product in the left-hand box

3. Click the DMU Navigator tab
The DMU Navigator tab lets you customize:

- The appearance of the hyperlink cue
- Measurement display: number of decimal places after the decimal point for length, angle, area and volume measurements
- Automatic display of preview windows

4. Set Hyperlink Representation to Symbol, Name or both:

By default, all hyperlink cues are graphical ([image]). If you click the Name checkbox, all hyperlink cues will be textual. The name you give the link in the Manage Hyperlink dialog box when you create it will appear.

You can add hyperlinks to your document and then use them to jump to a variety of locations, for example, to a marketing presentation, a Microsoft Excel spreadsheet or a HTML page on the intranet.

5. To set the default measurement display, enter the number of decimal places you want to see displayed after the decimal point; for example for length measurements, enter 4 to display 20.4235

6. Repeat the above for angle, area and volume measurements

7. Click preview checkboxes as appropriate to change the automatic display setting of preview windows when creating cameras, manipulating objects, etc.

By default, preview windows are automatically displayed.

8. Click OK in the dialog box when done.
Customizing Data Cache Settings

The data cache directory (CATCache) defines the disk space used for the saving of conversions of models to cgr files. One or more data cache directories can be defined.

If you work with the cache system on, when you re-access the saved model in a subsequent session, the application will use the entry in the data cache, thereby reducing access time.

This task explains how to customize data cache settings.

A DMU Navigator document

1. Select the Tools->Options... command.

   The Options dialog box appears

   2. Click Product in the left-hand box

   3. Click the Cache Management tab
4. Turn the cache activation mode on or off:

- Work with the cache system box checked: the data cache is active and any cgr files in the directories currently listed in the cache location will be accessed. The local data cache is browsed first before the released data cache locations.
  The first time models are inserted, they will be converted to cgr files and saved in the data cache.

- By default, the activation mode is set to on.

- Work with the cache system box unchecked: the data cache is inactive. Cgr files in the data cache will not be accessed and models will be converted each time they are inserted.

5. (Optional) Enter the paths identifying the cache locations:

Browse buttons let you locate the file you want. The user can enter the path to his own local cache location as well as one or more paths to released cache locations.

The default directory is the user's home directory under UNIX and the USERPROFILE directory under Windows.

6. (Optional) Set the maximum size for the cache

The default size is 10 MB.

7. (Optional) Set the Check timestamp option:

The Check timestamp option, if clicked, checks the model's timestamp and if different from the timestamp of cgr files in the data cache, converts the model to cgr files. If timestamps are the same, no conversion is done and cgr files in the data cache are loaded.

Turning this option off means that no check is run and cgr files in the data cache are systematically loaded.

8. Note that you need to exit and restart to see the effects of customization, so click OK to confirm.
Loading the Product Structure Only

You can load the product structure only without associated 3D representations and then specify which 3D representations to insert.

This task explains how to load the product structure without the associated 3D representations.

An empty DMU Navigator document

1. Select the Tools->Options... command.
   The Options dialog box appears

2. Click Product in the left-hand box
3. Click the ProductStructure tab

4. Click No representation activated to load the product structure only
5. Click OK to confirm.

When inserting components, only the product structure will be loaded. You can then specify which 3D representations you want to be activated by right-clicking the desired item in the specification tree and selecting Representation -> Activate from the contextual menu.
Up

Customizing Settings

Customizing Data Cache Set

Loading the Product Structure

Customizing the Ground

Customizing External Format
Customizing the Ground

A reference plane serves to locate the ground when navigating.

You can fix the X, Y or Z axis (axis perpendicular to the ground) during navigation. While turning in Fly mode, this creates the impression that the user viewpoint tilts or banks with respect to the fixed axis, as in a real plane.

This task explains how to customize the ground.

A DMU Navigator document

1. Select the Tools->Options... command.
   
The Options dialog box appears

2. Click the Visualization tab

3. Click the Gravitational effects during navigation checkbox to activate this option

4. Click X, Y or Z to fix the axis perpendicular to the reference plane.

While turning in Fly mode, this creates the impression that the user viewpoint tilts or banks with respect to the fixed axis, as in a real plane.

Note: The z-axis is the default axis. The ground corresponds to the xy reference plane.

5. Click OK to confirm.
Customizing External Format Import

You can now easily import a CAD part which is not directly supported by DMU Navigator. DMU Navigator runs a background converter that will output one of the following formats:

- cgr
- pdb (Deneb part)
- vrml
- stl

The CAD part files you want to import must have the .prt extension (.asm for Assemblies).

You can import various types of CAD Parts into a CATProduct. For more details please refer to the DMU Navigator User's Guide.

This task explains how to customize the import settings.

You imported a CAD Part through the Insert ->Existing Component command.

1. Select the Tools->Options... command.
2. Click Product in the left-hand box.
3. Click the External Formats tab.

The corresponding Part Import box, (depending on the configuration) displays below the Standard Formats Import box.
4. Modify the settings as desired.

5. Click OK to confirm your operation.
Glossary

3D

3D representation

- **eye**: Defines the observer's position. See **3D representation**.
- **view angle**: Represents the angle at which the viewer is facing.
- **viewing distance**: The distance between the viewer and the target.
- **target**: The object to be viewed.
- **viewport**: The area within which the viewer can see.

**3D**

- **view**: Used to define your document viewpoints when using named views and camera capabilities.

**D**

- **data cache**: The area of storage used for the saving of conversions of models to cgr files.

**E**

- **examine**: The default navigation mode. Let's you view your document from the outside by moving around the document's perimeter, or from within, turning your head to view or moving closer (zoom in, zoom out) to different objects.

**F**

- **fly**: A navigation mode that lets you move upward or downward on any horizontal view plane as you move forward or backward through your document.

**Note**: In beginner's mode, you cannot move backward.

**P**
In DMU workbenches, subset or constituent part of a CATProduct document that can be of the following type:

- cgr (*.cgr)
- V4 model (*.model)
- CATpart (*.CATpart)
- CATproduct (*.CATproduct)
- V4 session (*.session)
- VRML 1.0.
- obj (*.obj)
- byu (*.byu)
- iges
- pdb (*.pdb)
- stl (ASCII and binary) (*.stl)

**fly**
A navigation mode that lets you move upward or downward on any horizontal view plane as you move forward or backward through your document.

**Note**: In beginner's mode, you cannot move backward.

**target**
Defines the point of the document at which the eye is looking. See 3D representation.

**URL**
Uniform Resource Locator. A text used for identifying and addressing an item in a computer network.

**viewing distance**
The distance between the eye and the target.

**viewport**
Defines what you see in a document view. You can manipulate the 3D representation to define exactly what you want to see. See 3D representation.
Index

Numerics

2D objects
  changing properties
3D Annotation command
3D marker
3D representation
3D text
  changing color of

A

Add Hyperlinks command
adding
  2D text
  3D text
  arrows
  circles
  coordinates
  hyperlinks
  lines
  object names
  rectangles
  temporary markers
analyzing your position in space
animation
  recording
  replaying
annotating
  using the 2D marker
  using the 3D marker
back view ➤➤
beginner's fly mode ➤➤
bottom view ➤ ➤
cameras ➤
creating ➤
moving ➤
using in animations ➤
clipping plane ➤, ➤
commands
3D Annotation ➤
Add Hyperlinks ➤
Compile Simulation ➤
Create Camera ➤
Current Selection ➤
Depth Effect... ➤
Existing Component... ➤
Fly ➤
Go to Hyperlinks ➤
Graphic Messages ➤
Group... ➤
Horizontal Ground ➤
Lighting... ➤
Look At ➤
Magnifier ➤
Named Views... ➤, ➤, ➤
New... ➤
Next View ➤
Previous View ➤
Replay ➤
Shuttle ➤ , ➤
Simulation

Space Map

Viewpoint Palette...

components
  inserting
contextual menu
  align
  attach
  axis
  editor
  follow
  free
  target
Create Camera command
creating
  cameras
  groups of products
  hypertext links
  new documents
  user-defined views

current selection
  viewing
Current Selection command

D

data cache

viewing content

defining
  groups of products

deleting
  user-defined views
Depth Effect... command
depth effects
  Far Limit
  foggy
  Near Limit
DMU 2D marker toolbar
DMU Management toolbar
DMU Visualization toolbar
documents
  creating new

E
examine mode
Existing Component... command

F
Far Limit
Fly command
fly mode
  beginner's fly mode
  advanced fly mode
front view

G
Go to Hyperlinks command
Graphic Messages command
Group... command
ground
  customizing
groups
defining
H

Horizontal Ground command ➤

hyperlinks
   creating ➤

jumping to ➤

I

inserting
   components ➤

isometric view ➤

L

left view ➤ ➤

lighting effects ➤
   neon light ➤
   one light source ➤
   switching off light sources ➤
   two light sources ➤

Lighting... command ➤

Look At command ➤

Look At icon ➤

looking at through viewport ➤

M

Magnifier command ➤

manipulator ➤
   moving ➤

markers
   using temporary markers ➤
   using the 2D marker ➤
   using the 3D marker ➤
modifying
  user-defined views
moving
  cameras

N

Named Views... command
navigating
  changing views
  examine mode
  fly mode
  magnified views
  viewing objects against the ground
Near Limit
New... command
Next View command

P

Previous View command
products
  defining groups of
  product structure
properties
  2D object
  3D text

R

recording animations
replaying animations
right view
setting
depth effects ➤
lighting effects ➤
shuttle ➤
  moving ➤
Space Map command ➤
standard views ➤ ➤
  back ➤ ➤
  bottom ➤ ➤
  front ➤ ➤
  isometric ➤
  left ➤ ➤
  right ➤ ➤
  top ➤ ➤

temporary markers ➤
top view ➤ ➤

user-defined views
  show representations ➤

viewing
  changing views ➤
  current selection ➤
  data cache content ➤
  looking at ➤
  magnifying ➤
objects against the ground
panning
rotating
standard views
turn head
user-defined views
using camera capabilities
using viewpoint palette
zooming

viewpoint palette
Viewpoint Palette... command