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Preface
DMU OPTIMIZER 2 (DOP) is a product dedicated to improve user's productivity by
computing an optimized representation of data for mockup verification in the context of
the immersive and collaborative design review environment of the full digital mockup.
DMU OPTIMIZER 2 (DOP) facilitates the full integration of Digital Mockup centric
processes within the global engineering environment of the customer.

DMU OPTIMIZER 2 is a dedicated DMU Navigator workbench and is available on both
UNIX and Windows NT environments.

This guide is organized as follows:
Getting Started

Provides a scenario allowing you to get acquainted with the product.
Basic Tasks

Provides a step-by-step guide for using DMU Optimizer. Useful tips are given for
getting the most out of the product.

Workbench Description

Describes menu commands and workbench toolbars that are useful for DMU
Optimizer.

 

 



Using This Guide
This guide is intended for the user who needs to quickly become familiar with DMU
Optimizer. The user should be familiar with basic DMU Navigator Version 5 concepts
such as document windows, standard and view toolbars.

To get the most out of this guide, we suggest you start reading and performing the
step-by-step tutorial "Getting Started".

>The next sections present main capabilities in the form of user's tasks. It may be a
good idea to take a look at the section describing the menus and toolbars.

  



Where to Find More Information
Prior to reading this book, we recommend that you read the DMU Navigator User's
Guide.

You may also like to read the following complementary DMU Navigator product guides,
for which the appropriate license is required:

DMU Fitting Simulator User's Guide
DMU Space Analysis User's Guide.

 

  



Getting Started
Before getting into the detailed instructions for using DMU Optimizer, the
following tutorial aims at giving you a feel of what you can do with the product. It
provides a step-by-step scenario showing you how to use key functions.
The main tasks described in this section are:

 
Tasks

 



Starting a DMU Optimizer Session
Before starting this scenario, you should be familiar with the basic commands common to
all workbenches. These are described in the DMU Navigator User's Guide.
This first task will show you how to enter the DMU Optimizer workbench and select your
models

1. Select Digital Mockup -> DMU Optimizer from the Start menu

The DMU Optimizer workbench is loaded and an empty document opens:

2. Select Insert -> Existing Component... from the menu bar.
3. Select the desired  model files by clicking the first one then shift-clicking the last
one you want.

Click Open to open the selected files.

The specification tree is displayed showing all the selected products.



Use the Fit All In icon  to position the model geometry on the screen.

 

  

  



Generating a Silhouette
This task will show you how to calculate new geometry and in this case generate
a silhouette
The sample document used in this task can be accessed in the folder:
online\samples\dmuoptimizer\ GARDENA*.cgr.

(Optional)
You can manage the Silhouette result as  alternate shape automatically.

For more details, please refer to
Managing an Alternate Shape.

1. Click the Silhouette icon  from the DMU Optimizer toolbar.
The Silhouette dialog box appears:

2. Select Product1 in the specification tree.
3. Enter the desired value in the grain field for instance 2mm



4. Click the more button  to display the Multiselection list.
5. Select the desired views. The 6 views for instance
6. Click OK to confirm your operation.



7. Click the Apply button
to obtain a silhouette
preview
The progress bar
displays:

The Preview window
display too.

DMN License:
If you have a DMU Navigator license, you can define cameras and they are
proposed in the multiselection dialog box.

8. Click OK to save the silhouette representation.



  

  



Generating a Wrapping
This first task will show you how to generate a Wrapping representation.

The sample document used in this task can be accessed in the folder: online\samples\dmuoptimizer\ *.cgr.
You activated

(Optional)
You can  manage your Wrapping result as alternate shape automatically. Please refer to Managing
an Alternate Shape.
1. Select Product 1 in the specification tree.

2.Click the Wrapping icon    from the DMU Optimizer
toolbar.
The Silhouette dialog box appears:

3.  Set the grain accuracy by entering a value, 4mm for
example.

Setting the Ratio
The Ratio determines the wrapping representation. A lower setting results in a thinner wrapping
coverage
4. Move the slider to the right to set the ratio to 0.50 for
example
5. Click Apply to obtain a preview
The progress bar shows the computation

The preview window lets you see the resulting wrapping



6.Click OK.
The Save As dialog box displays:
7. Click Save.

  

  



Generating a Thickness
This task will show you how to generate a thickness that is a solid from a surface.

Open SCENARIO01.model from  online\samples\dmuoptimizer directory.

Use the Fit All In icon  to position the model geometry on the screen.
(Optional)
You can manage automatically the Thickness result as alternate shape.

1. Click the Thickness icon  from the DMU Optimizer toolbar.
The Thickness dialog box displays.

2. Select  SCENARIO01.model in the specification tree

3.Enter the Offset values:
Offset 1: 2mm
Offset 2: 0mm

4. Click Apply to generate the thickness
representation

The preview window displays

The Orientation constraints option is deactivated by default. The propagation of constraints is done
automatically



5. Zoom to visualize better the thickness result :
You are not satisfied with the result.

You are still in the Thickness command.



6. Click the undo icon  to go back to the initial
representation.
7. Activate the Orientation constraints option in the
dialog box still displayed:
8. Click Apply
The Propagation of constraints is not complete.
The surfaces concerned are highlighted.

9. Define constraints on the corresponding
surfaces:

Drag the cursor onto the surface
When you are satisfied, click the left-hand
mouse button.
The constraint is created

At anytime, you can delete a constraint, what you need to do is to click on the white square
Note that if you click th arrow, you invert the constraint orientation.

10. Click Apply when done. The surfaces are correctly positioned.



11. Click OK.
The Save As dialog box displays:

12. Enter a meaningful name and click Save.

  

  



Generating an Offset
This task will show you how to generate a thickness that is a solid from a surface.

Open SCENARIO01.model from  online\samples\dmuoptimizer directory.

Use the Fit All In icon  to position the model geometry on the screen.
1. Make sure the Thickness is managed as
alternate shape and activated.
For this:
a. Select Tools->Options from the menu bar.
The Options dialog box displays.

b. Click Product in the left-hand box.
c. Click the DMU Optimizer tab.
d. In the Offset field, check the Manage as
alternate shape button and activate the
Activate shape option.

 
When activated the Offset representation is the one
visualized in the session.

2. Click the Offset icon    from the
DMU Optimizer toolbar.
The Offset dialog box displays:

3. Select SCENARIO01 in the
specification tree.
4. Enter the Offset value,2mm for
instance
5. Click Apply to obtain a preview.



6. Click the undo icon  to go back to
the initial representation.
7. Activate the Orientation constraints
option in the dialog box still displayed:
8. Click Apply

Orientation Constraints
The Orientation constraints option is deactivated by default. (The propagation of   default
orientation constraints is done automatically).
The constraints define the orientation of the offset (positive).

9. Click OK.
The Save As dialog box displays:
10. Enter a meaningful name and click Save.



  

  



Basic Tasks
The table below lists the tasks you will find in this section.

 
Theme



Simplifying an Assembly
The table below lists the tasks you will find in this section.

 
Tasks  

  



Generating a Silhouette
This task will show you how to calculate a new geometry and in this case
generate a silhouette
The sample document used in this task can be accessed in the folder:
online\samples\dmuoptimizer\ GARDENA*.cgr.

(Optional)
1. You can  manage automatically your Silhouette result as alternate
shape.

For this:
a. Select Tools->Options from the menu bar.
The Options dialog box displays.

b. Click Product in the left-hand box.
c. Click the DMU Optimizer tab.
d. In the Silhouette field, check the Manage as alternate shape button and
activate the Activate shape option.

 
When activated the Silhouette representation is the one visualized in the session.

Remember you can customize sihouette settings at any time.
For more details, please refer to Customizing DMU Optimizer Settings and
Managing as an Alternate Shape

2. Click the Silhouette icon

 from the DMU Optimizer
toolbar.
The Silhouette dialog box
displays:

3. Select Product1 in the specification tree.
4. Enter the desired value in the grain field for instance 2mm.



5. Click the more button  to display the Multiselection list.
6. Select the desired views. The 6 views for instance
7. Click OK to confirm your operation.



8. Click the Apply button to
obtain a silhouette preview
The progress bar displays:

The Preview window display
too.

DMN License:
If you have a DMU Navigator license, you can define cameras and they are
proposed in the multiselection dialog box .

9. Click OK to save the silhouette representation.



  



Generating a Wrapping
This task will show you how to generate a Wrapping representation.

The sample document used in this task can be accessed in the folder:
online\samples\dmuoptimizer\ *.cgr.

(Optional)
1. You can automatically manage your Thickness result as alternate shape.

For this:
a. Select Tools->Options from the menu bar.
The Options dialog box displays.

b. Click Product in the left-hand box.
c. Click the DMU Optimizer tab.
d. In the Thickness field, check the Manage as alternate shape button and activate the
Activate shape option.

 
When activated the Thickness representation is the one visualized in the session.

2. Select Product 1 in the specification tree

3. Click the Wrapping icon    from the DMU Optimizer toolbar.
The Silhouette dialog box displays:

4.  Set the grain accuray by entering a value, 4mm for example.



Setting the Ratio
The Ratio determines the wrapping representation. A lower value results in a thinner  
but less envelopping representation.
5. Move the slider to the right to set the ratio to
0.50 for example
6. Click Apply to obtain a preview
The progress bar shows the computation

The preview window lets you see the resulting
wrapping



7.Click OK.
The Save As dialog box displays:
8. Click Save.

  



Thickness and Offset
Tasks

  



Generating a Thickness
This task will show you how to generate a thickness that is a solid from a surface.

Open SCENARIO01.model from  online\samples\dmuoptimizer directory.

Use the Fit All In icon  to position the model geometry on the screen.
(Optional)
1. You can manage your Thickness result as alternate shape
automatically.

For this:
a. Select Tools->Options from the menu bar.
The Options dialog box displays.

b. Click Product in the left-hand box.
c. Click the DMU Optimizer tab.
d. In the Thickness field, check the Manage as alternate shape
button and activate the Activate shape option.

 
When activated the Thickness representation is the one visualized in
the session.

2. Click the Thickness icon  from the DMU Optimizer
toolbar.
The Thickness dialog box displays.
3. Select  SCENARIO01.model in the specification tree

4. Enter the Offset values:
Offset 1: 2mm
Offset 2: 0mm

5. Click Apply to generate the thickness representation

The preview window displays

Orientation Constraints
The Orientation constraints option is deactivated by default. (The propagation of constraints is done
automatically).
The constraints define the orientation of the offset (positive).



6. Zoom to visualize better the thickness result :
You are not satisfied with the result.

You are still in the Thickness command.

7. Click the Undo icon  to go back to the initial
representation.
8. Activate the Orientation constraints option in the
dialog box still displayed:
9. Click Apply



The Propagation of constraints is not complete. The
surfaces concerned are highlighted.
10. Define constraints on the corresponding surfaces:

Drag the cursor onto the surface
When you are satisfied, click the left-hand mouse
button.
The constraint is created

At anytime, you can delete a constraint, what you need to do is to click on the white square
Note that if you click the arrow, you invert the constraint orientation.

11. Click Apply when done. The result is correct : the calculation is based on the new orientation
constraints

12. Click OK.
The Save As dialog box displays:
13. Enter a meaningful name and click Save.



  



Generating an Offset
This task will show you how to generate an offset.

Open SCENARIO01.model from  online\samples\dmuoptimizer directory.

Use the Fit All In icon   to position the model geometry on the screen.
(Optional)
1. You can manage automatically your Offset result as alternate shape.
For this:
a. Select Tools->Options from the menu bar.
The Options dialog box displays.

b. Click Product in the left-hand box.
c. Click the DMU Optimizer tab.
d. In the Offset field, check the Manage as alternate shape button and activate the Activate shape option.

When activated the Offset representation is the one visualized in the session.

2. Click the Offset icon  from the DMU
Optimizer toolbar
The Offset dialog box is displayed

3. Select SCENARIO01 in the specification tree.

4. Enter the Offset value, 2mm for instance
5. Click Apply to obtain a preview.



Orientation Constraints
The Orientation constraints option is deactivated by default. (The propagation of constraints is done
automatically).
The constraints define the orientation of the offset (positive).

6. Click the Undo icon  to go back to the
initial representation.
7. Activate the Orientation constraints option in
the dialog box still displayed:
8. Click Apply
The Propagation of constraints is not complete. The surfaces concerned are highlighted.

9. Define constraints on the corresponding surfaces:
Drag the cursor onto the surface
When you are satisfied, click the left-hand mouse button.
The constraint is automatically created.

At anytime, you can delete a constraint, what you need to do is click on the white square.
Note that if you click the arrow, you invert the constraint orientation.

10. Click Apply when done. The result is correct : the calculation is based on the new orientation
constraints



11. Click OK.
The Save As dialog box is displayed:

12. Enter a meaningful name and click Save.

  



Advanced Tasks
The table below lists the tasks you will find in this section.

 
Theme



Managing an Alternate Shape
This task will show you how to manage representations as alternate shapes
automatically.

1. Select the Tools->Options... command.

The Options dialog box appears

2. Click Product in the left-hand box
3. Click the DMU Optimizer tab



3. Select the required representation, for example Offset.
4. Customize the  representation settings as required:

Manage as alternate shape : if activated, you manage
automatically your result as a new representation
Activate Shape :  if activated the Offset representation is the
one visualized in the session.
Default Shape : if activated the Default shape is the one
loaded when opening the product

5. Click Ok to confirm your operation
After a new offset calculation, if you right-click the product and select Manage
representations, the Manage representation dialog box is automatically updated
with the offset representation.

  



Editing Macros
If you perform a task repeatedly, you can take advantage of a macro to automate it. A macro is a series of functions,
written in a scripting laguage, that you group in a single command to perform the requested task automatically
This task will show you how to edit a macro created in the DMU Optimizer

You stored your recorded  macros in a text format file. For more details about recording, running macros please refer to
the Infrastucture User's Guide
  1. You can easily modify the macro instructions specific to DMU Optimizer (strings of characters put in bold).
Here is an example:

Thickness Macro
THICKNESS MACRO EXPLANATIONS

Language="VBSCRIPT"

Sub CATMain()
CATIA.ActiveWindow.ActiveViewer.Viewpoint3D.ProjectionMode = 0
CATIA.ActiveWindow.ActiveViewer.Reframe

Dim Product0 As AnyObject
Set Product0 = CATIA.ActiveDocument.GetItem ( "Product1" )
Dim Product1 As AnyObject
Set Product1 = Product0.Products.Item ( "SCENARIO01.1" )

var2 = Product1.HasAMasterShapeRepresentation

var3 = Product1.HasAMasterShapeRepresentation

Name of the product selected for the thickness.

Enter a meaningful name if you wish to edit the
name.

Dim OptimizerWorkBench4 As Workbench
Set OptimizerWorkBench4 = CATIA.ActiveDocument.GetWorkbench
( "OptimizerWorkBench" )

Dim var5 ( 5 )
var5 ( 0 ) = 1686.914185
var5 ( 1 ) = -687.232605
var5 ( 2 ) = -30.685900
var5 ( 3 ) = -0.006788
var5 ( 4 ) = -0.173665
var5 ( 5 ) = 0.984781
Dim DMOThickness6 As DMOThickness
Set DMOThickness6 = OptimizerWorkBench4.Thicknesses.Add (
Product1, 2.000000, -2.000000, 1, var5, "THICKNESS", 0, 0 )

Dim Document7 As AnyObject
Set Document7 = CATIA.Documents.Item (
"SCENARIO±013±-±ZWISCHENSTUECK.1_THICKNESS.cgr" )

Document7.Activate

Product1 : corresponds to the selected product

2.000000, -2.000000, Gives the values of the offset
1 and offset 2, you defined.

 

1 correspond to the number orientation constraints

var 5:  defines the constraint coordinates:
Constraint location point

var5 ( 0 ) = 1686.914185
var5 ( 1 ) = -687.232605
var5 ( 2 ) = -30.685900

Corresponding normal vector

var5 ( 3 ) = -0.006788
var5 ( 4 ) = -0.173665
var5 ( 5 ) = 0.984781

"THICKNESS": Name of the Alternate Shape

file:///E|/users/fbp/Adele/FBPDocr3dmo/BasEnglish/basug.doc/src/basugfrs.htm


 "" means the alternate shape option is
deactivated.
 

0,0 : refer to the shape representation settings

0 -> "Activate shape" option is deactivated

0 -> "Default Shape" option is deactivated

Please refer to Managing as an alternate
shape for more details

Document7.SaveAs
"E:\users\sbc\ADELE\sbcDPS3\SCENARIO01.1_THICKNESS.cgr"

CATIA.ActiveDocument.Activate

End Sub

Gives the location of the cgr file you saved.

Silhouette macro :

 

Dim var5 ( 17 )
var5 ( 0 ) = 1.000000
var5 ( 1 ) = 0.000000
var5 ( 2 ) = 0.000000
var5 ( 3 ) = -1.000000
var5 ( 4 ) = 0.000000
var5 ( 5 ) = 0.000000
var5 ( 6 ) = 0.000000
var5 ( 7 ) = 1.000000
var5 ( 8 ) = 0.000000
var5 ( 9 ) = 0.000000
var5 ( 10 ) = -1.000000
var5 ( 11 ) = 0.000000
var5 ( 12 ) = 0.000000
var5 ( 13 ) = 0.000000
var5 ( 14 ) = 1.000000
var5 ( 15 ) = 0.000000
var5 ( 16 ) = 0.000000
var5 ( 17 ) = -1.000000

Dim Silhouette6 As Silhouette

Set Silhouette6 = OptimizerWorkBench4.Silhouettes.Add (
Product1, 20.000000, var5, "", 0, 0 )

 

Var 5:  defines the viewpoints vector coordinates

Coordinates of the  first viewpoint vector :

var5 ( 0 ) = 1.000000
var5 ( 1 ) = 0.000000
var5 ( 2 ) = 0.000000

and so on...

 

  



Workbench Description
This section contains the description of the icons and menus which are specific to the DMU Optimizer
workbench.

The DMU Optimizer window looks like this: (click the sensitive areas to see the related documentation).

 

DMU Optimizer Menu Bar

DMU Otptimizer Toolbar

Sectioning Tools Toolbar

 



DMU Optimizer Menu Bar
Here we will present the various menus and menu commands that are specific to
DMU Kinematics Simulator Version 5.

 

Start File Edit View Insert Tools Analyze Windows Help

 

Tasks corresponding to General menu commands are described in the DMU Version
5 Infrastructure User's Guide.

Edit
For... Description...

Undo Cancels the last action.

Redo Recovers the last action that
was undone.

Cut
Copy
Paste
Paste Special

Performs cut
copy
paste and
special paste operations.

Delete Deletes selected geometry.



Search Allows searching and selecting
objects.

Links Manages links to other
documents.

Properties Allows displaying and editing
object properties.

 



Insert

For... See...

Existing Component Starting a Session

Tools
For... Description...

Formula... Allows using 
Knowledgeware
capabilities

Image Allows capturing and
managing images for
the album

Macro Editing a DMU
Optimizer Macro

Customize... Allows customizing
toolbars

Options...

Allows customizing
settings
See Managing an
Alternate Shape

Search
Order...

Allows creating a
document search
order



  



DMU Optimizer Toolbar
The DMU Optimizer toolbar contains a number of tools that are useful for DMU
Optimizer.

 

 
See Generating a Silhouette

See Generating a Wrapping

See Generating a Thickness
See Generating an Offset

See the Fitting Simulator User's Guide

  



Sectioning ToolsToolbar
DMU Optimizer provides the sectioning tool.Please refer to DMU Space Analysis
User's Guide for more information

Using cutting planes, you can create sections, section slices, section boxes as well as
3D section cuts of your products automatically.
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