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Preface

A major issue that affects every industry in which products are developed is the retention and
reuse of knowledge. While every organization produces data and information about its
products, transforming that data into an accessible knowledge base is difficult. The tools used
throughout the product development process typically do not help retain the knowledge of how
and why decisions are made, nor do they provide convenient access to that knowledge.
Knowledge is the embodiment of experience and data in a directly useable form. How you get
home from your office is knowledge. A map showing the way is data that has to be interpreted.
Through experience, you know to use different routes shown on the map depending on various
conditions such as the weather or the time of day. You have used the map and other
information to create knowledge. Likewise, in product development, understanding how a
product is intended to function and how to apply that understanding to create an appropriate
product is knowledge. The models and drawings of the product are part of the data that defines
the product, but they don’t convey how or why someone created the product in a specific way.
It is difficult to embed knowledge in a design. It takes extra effort to write out or codify the
decision process so that it can be passed as knowledge from one person to another.

The tools that are most often used in product development also need to be capable of capturing
knowledge, and they must allow product developers to apply that knowledge to their product
designs.

CATIA Version 5, in addition to embodying a significant new architecture that has been
evolving over a number of years, also provides some very interesting capabilities that allow
designers to drive their design processes from associative specifications and to integrate
specifications into their product development processes. It gives product developers ways to
create specifications and rules, save them, and reuse them.
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Highlights

The CATIA knowledgeware capabilities are based on special features that you add to a
document to enrich its data with knowledge-based information. The features you are going to
create and manipulate in a CATIA knowledgeware application are divided into three categories:

@ the parameters
@ the relations
@ the behavior.

Parameters and relations help you design a document with respect to a particular know-how.
Once these features have been created, the Knowledge Inspector can be run on a document to
determine impacts and dependencies.

The behavior is a particular feature. It is written in Visual Basic language and executed only
when a feature replies to a given event.

Here are some highlights about the features you are going to manage with the Knowledge
Advisor product.

Parameters Parameters define the properties of a document. When used within relations,
they act like arguments. Parameters are given a name, a type and a value. In
place of a value, a parameter can be defined by a relation. The parameter is
then constrained, you won't be able to modify directly its value.

Parameters are divided into two categories:

@ The intrinsic parameters: they are part of the document and depend on
the application. The purpose of a knowledgeware application is not to
create or delete these parameters but to specify how these parameters
can be constrained by relations.

@ The user parameters: they are irrespective of the document basic
definition. They should be considered as extra pieces of information.
Knowledgeware applications quite often use these parameters to add
knowledge to a document and to define relations.

User parameter capabilities are provided to all CATIA users. You can create
and manage user parameters with the CATIA Infrastructure product.



Relations

Knowledge
Inspector

Behavior

Knowledgeware applications manage four types of relations:

@ the formulas
a formula defines how a parameter is to be calculated with respect to
other parameters. Formula capabilities are provided to all CATIA users.
@ the design tables
data contained in tables referred to as design tables can be used to
manage document parameters. Design table capabilities are provided to
all CATIA users.
@ therules
a rule is a set of instructions which conditionally executes a group of
statements depending on a context or depending on the values of some
parameters.

@ the checks
a check is a set of instructions whereby you are warned that some
statements are fulfilled or not. Checks have no impact on parameter
values.

Rule and check capabilities are only provided to those of you who have the
Knowledge Advisor product installed.

The Knowledge Inspector is a tool to analyze impacts and dependencies when
a number of parameters and relations have been added to a document. It
offers two options:
@ Whatf
What is going to be modified if a given parameter is changed
@ HowTo
What parameters should be modified in order to modify a given
parameter.

The Knowledge Inspector requires the Knowledge Advisor product.

A behavior is a set of operations associated with a feature. It is executed as a
reply to an event. A behavior is defined by:

@ the feature it is applied to
@ a set of operations
@ the event which triggers the list of operations.

A behavior is written in Visual Basic language.
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The CATIA Knowledge Advisor
Documentation

This documentation covers the knowledgeware capabilities provided both in the Infrastructure
and the Knowledge Advisor products. It is divided into the following parts:

9

Getting Started

Introduces the CATIA knowledgeware capabilities by working through a simple example.
Little detail is given in this part. Its purpose is to give beginners a global idea of the
concepts.

Basic Tasks

Provides the bulk of information needed by users building knowledgeware applications.
Is mainly based on interactive tasks such as creating relations. Syntax rules to be used
when programming relations are also detailed.

Advanced Tasks

Focuses on design table aspects and behavior. Describes programming functions which
allow you to access parameter values in design tables. Explains how to write a behavior.
Workbench Description

Describes the Knowledge Advisor icons.
Case Study

Applies the CATIA Knowledge Advisor capabilities to a deep groove ball bearing.
Quick Reference

Summarizes the interactions to perform when manipulating knowledgeware features.

Glossary
Gives some useful definitions.
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About Samples

The material provided in this documentation is mainly based on step-by-step instructions. Generally, the exercises are easy to
complete because of the basic instructions provided. The exercise in Case Study is a little more complicated and requires a good
knowledge of the Part Design and knowledgeware capabilities, especially if you want to redo it from scratch.

To do the exercises which illustrate the knowledgeware principles, you should have installed a certain number of samples. These
samples are listed below. Refer to the "Infrastructure” documentation for information on how to access these samples.

Starting or Resulting Documents

KwrStartDocument.CATPart
KwrForRuCh.CATPart
KwrParamO.CATPart
KwrMaterial0.CATPart
Kwrlmport. CATPart
KwrFormula0.CATPart
KwrFormulal.CATPart
KwrFormula2.CATPart
KwrProgramDT.CATPart
KwrDesignTable0.CATPart
KwrDesignTable1l.CATPart
KwrDesignTable2. CATPart
KwrBallBearing0.CATPart

KwrBallBearingResult. CATPart

Tabulated Text Files
TxCompanyFile0.txt

KwrBallBearinglmport.txt

CATIA Macro
KwrMacrol.CATScript

Microsoft® Excel Tables
KwrCreatedDesignTable.xls
KwrBallBearing.xls

ExCompanyFile0.xIs
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Infrastructure
KnowledgeAdvisor
Infrastructure
Infrastructure
Infrastructure
Infrastructure
Infrastructure
Infrastructure
Infrastructure
Infrastructure
Infrastructure
Infrastructure
KnowledgeAdvisor

KnowledgeAdvisor

Infrastructure

KnowledgeAdvisor

KnowledgeAdvisor

Infrastructure
KnowledgeAdvisor

Infrastructure

"Getting Started" & Basic tasks.
Resulting document of "Getting Started".
Basic tasks.

Basic tasks.

Basic tasks.

Basic tasks.

Basic tasks.

Basic tasks.

Illustrates how to program the design table access.
Advanced tasks.

Advanced tasks.

Advanced tasks.

Case study.

Case study.

Basic tasks.

Case study.

Case study.

Advanced tasks.
Case study.

Basic tasks.
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What's New?

Knowledgeware - Infrastructure

Functions to Access a Design Table

Two new functions: CloserInfConfig, CloserSupConfig

Tools->Options->Knowledge

Copy/Pasting parameters - Parameters written in non-latin characters.

Knowledge Advisor

Programming Rules

Temporary variables

Using the Knowledge Inspector

Enhanced: What If Mode, How To

Creating a Behavior

New task: Creating a Behavior
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Getting Started: CATIA Knowledgeware at a Glance

We introduce the CATIA Knowledgeware capabilities by working through a simple example. Since many of the knowledgeware
concepts are unfamiliar to you at this point, little detail is given. You just have to follow step-by-step the instructions described
below to get a first appreciation of the CATIA knowledgeware principles.

Before starting, check the following options:

@ Tools->Options->Part->Display->Parameters
@ Tools->Options->Part->Display->Relations
@ Tools->Options->General->Knowledge->Parameter Tree View->With Formula.

Parameters

This task can be performed by all CATIA users. Its purpose is to give a brief outline of what parameters are and how you can
manipulate them. For a fuller outline of the parameter-related tasks, see Parameters.

E 1. Open the KwrStartDocument.CATPart document. This document is a hollow cylinder. The document parameter list
ety can be displayed. New parameters can also be added to the existing ones.

EwrStartDocument. CATPart [_ O] =]

ﬂ Pad 1
"I —E‘i iz

2. Click the :ﬁ*ﬂ icon. The "Formulas" dialog box is displayed.



Formulas: Part1 BHES
Apply filker on Part1
[ = Impart... |
Double click on a parameter to edit it
(Pararater ]l PGl R | e
PartBaodyhSketch.1® %, Blram
PartBodyhPad. 14FirstLimithLength Alrom
PartBodytPad. 185 econdLimith Lenagth 10rnm
PartBodytHale. 1%HaoleLimit. 150 epth Edrm
PartBodytHole. 14HoleLimit. 14Angle 120deg
PartBodytHale. 1\Diameter ESmm
PartBodyHole. 1 WActivity true :_i
Edit name, walue or formula
[FartBodySketch. 14Fadius.  [30mm = 3
Mews Parameter of bpe ]!Heal _:_j With 1Single Yalue _:_j &dd Farmula I
Delete Parameter I Delete Farmula I
@ 0K ] @ fpply ] W Cancel !
Lo,

3. Inthe 'New Parameter of type' list, select the Lengt h item, then click 'New Parameter of type'.

4. In 'Edit name, value or formula’, replace the Lengt h. 1 string with PadLengt h. Click Apply. A new parameter is
added to the document parameter list both in the "Formulas" dialog box and in the specification tree. You have just
created a user parameter.

5. Click OK in the "Formulas" dialog box to terminate the dialog. Keep your document open and proceed to the next

Formulas

This task can be performed by all CATIA users. Its purpose is to explain how a parameter can be constrained by a formula. Go to
Formulas for more information on formula-related tasks.

E 1. Click the ﬁ‘] icon. The "Formulas" dialog box is displayed.

i,
2. In the parameter list, select the Par t Body\ Sket ch. 1\ Radi us\ Radi us item, then click 'Add Formula'. The "Formula
editor" is displayed.

Formula Editor - PartBody\Sketch 14\Hadius. 3YHadius E

PartBodyhSketch. 4R adiuz. 358 adius

|
Wizard i

@ 0K | w8 Cancel |

3. Use the 'Wizard' button to help you type the 2 * Part Body\ Hol e. 1\ Di anet er relation by selecting items from the
dictionary list.




Pararneters _ PartBodyhSketch 1WAz a
Operators Length PartBodysFad. 15FirstLiT™ |
String Angle FartBodytFad 145 ecor
b ath Boaolean PartBaodytHale. 14Halel
Dezign table Walurne PartBaodytHale. 14Halel—
Mezzages and macros| | Maszz PartBodytHaole. 140iam -
itz Area PartBodyHaole, 1WAt
Consztant String i echanical F'ru:upert_l,l'\"\
Renamed parameters h-'ln=-r~h.=|n|r~.=|| rrnnF-rru'xl'-

4. Click OK in the "Formula Editor" once your relation is typed. The Formula.1 relation is added to the specification tree.
In the parameter list of the dialog box:

@ aformula is now associated with the pad radius
@ the new Relations\Formula.1\Activity parameter is added.

5. In the parameter list, select the PadLength item, click 'Add Formula' to create the formula below:
PadLengt h = Part Body\ Pad. 1\ Fi rstLi m t\Length + Part Body\ Pad. 1\ SecondLi m t\ Length
In the parameter list, the Formula.2 relation is now associated with the PadLength user parameter. In the specification
tree, PadLength is also displayed with the value resulting from Formula.2. This is now what you should see in the
specification tree under "Relations":

Fealations

Ii';-c'il Formula.l: FartB 1V Radiu

. nd Lirnitt Lengtt
6. Click OK in the "Formulas" dlalog box to terminate thls task Keep your document open and proceed to the next

task.
Rules

Unlike the parameter and formula capabilities which are available to all CATIA users, the rule and check capabilities require the
Knowledge Advisor product. This task is a way to introduce the Knowledge Advisor rules without getting bogged down in details.
For more information on rule-related tasks, refer to Rules.

m 1. Select the KwrStartDocument item in the specification tree, then access the Knowledge Advisor workbench (select
bt Knowledge Advisor workbench from the Start->Infrastructure menu).

IFi]
2. Click the rule icon. The following dialog box is displayed:

Rule Editor |

Marne of Rule :

Rule.1

Dezcrption ;

Rule created by CRE 04/26/39

@ 0k | @Cancel] Hep |
ol

3. Replace the Rule.1 string with Cylinder_Rule and click OK. The "Rule Editor" is displayed.
Rule Editor : Cylinder_Rule Achive

fRule created by CRE 04,




4. Type the code below into the edition box or copy/paste it from your browser to the edition box.

Par t Body\ Hol e. 1\ Activity = true
i f PadLength <= 50mm and PadLength > 20nm

{
Par t Body\ Hol e. 1\ Di anet er = 20nm

Message( " PadLength is: # | Internal D ameter is: #",
PadLengt h, Par t Body\ Hol e. 1\ Di anet er)

el se i f PadLength > 50nmm and PadLength < 100mm

{
Par t Body\ Hol e. 1\ Di anet er = 50nm

Message( " PadLength is: # | Internal Dianeter is: #",
PadLengt h, Par t Body\ Hol e. 1\ Di anet er)

el se i f PadLength >= 100mm

{

Par t Body\ Hol e. 1\ Di anet er = 80nm

Message("PadLength is: # | Internal D aneter is: #",
PadLengt h, Par t Body\ Hol e. 1\ Di anet er)

}

el se

{

Part Body\ Hol e. 1\ Activity = fal se

Message( " PadLength is: # | Internal D ameter is: #",
PadLengt h, Par t Body\ Hol e. 1\ Di anet er)

}

5. Click Apply. An information window displays the PadLength and Pad internal diameter values. Click OK in the
Information window. The Cylinder_Rule relation is added to the specification tree.

6. Click OK to terminate this part of the dialog. Keep your document open and proceed to the next task.

Checks

The Knowledge Advisor product is required. Refer to Checks for more information on checks and check-related tasks.

% 1. Click the ﬁ' icon. The first "Check Editor" dialog box is displayed.
2. Replace the Check.1 string with Cylinder_Check,
Check Editor
Marne of Check: ;
[Culinder_Check]

Dezcription ;
Check created by CRE 04/26/93

@ OK | & Cancel| Hep |

then click OK. The "Check Editor" box is displayed. It is similar to the Rule Editor.
3. Select the Information item in the "Type of Check’ list.

4. Enter a string in the message field (for example: Pad t oo short). This message is to be displayed whenever the
statement specified by the check is not fulfilled.

5. Enter the following statement into the edition box:

PadLength > 20mm

6. Click Apply. The Cylinder_Check relation is added to the specification tree. A green icon in the specification tree
means that the check is fulfilled. No message is displayed.

7. Click OK to confirm the check creation.
8. Change the Pad limits so that PadLength <= 20 mm. You should be warned by an information window that the check



is no longer valid.

The resulting document is KwrForRuCh.CATPart.

#7%



Basic Tasks

Here are the Knowledge Advisor features. Click the hyperlinks on figure below to display the list
of interactive tasks whereby you can create and manipulate these features. The principles
behind these features are explained in:

@ About Parameters

@ About Formulas

@ About Rules and Checks.

The Knowledge Inspector is a tool to study impacts and dependencies. It uses as input data the
knowledgeware features described below.

In figure below, click any of the links to
display the related summary of tasks.

f
B ¢ Parameter Tasks

Designation=61506

MassEearing=0.026kg fes Formula Tasks

- ol

Cost=81=3"BallNurnber

Material=Stes|

e
1¥i

Py,

ule Tasks

"= Relations
~fea Formula. 1. Cost=2"BallNumber
-1, L ' Filel

% Check Tasks

== Design Table Advanced Tasks



@ The functions related to parameters and formulas are provided to all CATIA users. They

are part of the CATIA Infrastructure capabilities. But you will make the best use of them in a
Knowledge Advisor application.

The functions related to rules and checks as well as the Knowledge Inspector require the
Knowledge Advisor product.



About Parameters

When you create a part like the hollow cylinder of our "Getting Started" example, you often start by creating a sketch, then
you create a pad by extruding the initial sketch, then you add other features to the pad created. The final document is made
up of features which define the intrinsic properties of the document. Removing one of these features results in a modification
of the document. These features are called parameters. Parameters play a prominent role in knowledgeware applications.
They are features that can be constrained by relations and they can also be used as the arguments of a relation.

In addition to these parameters, CATIA allows you to create user parameters. These user parameters are extra pieces of
information added to a document.

User Parameter Types

User parameters can be of various types:

@ Real @ Mass @ Inertia @ Linear stiffness

@ Integer @ Volume @ Mass flow rate @ Volumetric flow rate
@ String @ Density @ Moment @ Frequency

@ Boolean @ Area @ Pressure @ Electric power

@ Length @ Moment of inertia @ Angular stiffness @ Voltage

@ Angle @ Energy @ Temperature @ Electric resistance
@ Time @ Force @ Linear mass @ Electric intensity

User parameters are very handy in knowledgeware applications:

@ they can be used to add specific information to a document
@ they can be defined or constrained by relations
@ they can be used as the arguments of a relation.

A given relation may take as its arguments both types of parameters (intrinsic and user).

User parameters can be assigned single or multiple values.
Displaying Parameters in the Specification Tree

The user parameters are displayed in the specification tree only if the Tools->Options->Part->Display->Parameters box is
checked. The user parameter list contains at least the Material parameter. Its initial value is set to None.
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Intrinsic parameters

The user parameter values are displayed in the specification tree only if the Tools->Option>Knowledge->Parameter Tree
View->With Value box is checked.

Copy/Pasting Parameters

The Tools->Options->Knowledge->Pasting Parameters check boxes allow you to:

@ paste a parameter without the formula which defines it.
For example: Holeplus= 15 = Diameter + 10 Will be pasted as Real.i=15 (if the With Value box is checked)

@ paste a parameter as well as the formula which defines it, but only if the parameters referred to in the formula are
also selected in the copy.
For example: Holeplus= 15 = Diameter + 10 will be pasted as Real.i= 15 if the Diameter parameter does not belong to the
items selected for the copy but HolePlus will be pasted as Real.i = 15 = Real.j + 10 if Diameter is selected in the copy
(use multi-selection).

@ paste a parameter as well as the formula.
Holeplus= 15 = Diameter + 10 Will be pasted as Real.i = Diameter + 10

Parameters and National Support Languages

CATIA users working with non-latin characters should check the Tools->Options>Knowledge->Parameter Names->Surrounded by '
oprion. Otherwise, parameter names should have to be renamed in latin characters when used in formulas.

Importing User Parameters

User parameters can be imported from an external file. This external file can be either an Excel file(on Windows NT) or a
tabulated text file. Here are examples of import files in an Excel format and in a tabulated text format .

@ ExCompanyFileD ; - : =l B3

1 Force 1000 ; <50M= ; 150M :
2 Area <Am2= ; 20m2

3 Pressure OM_rm2 ; - Force/Area Maximum pressure allowed

4



Bl TxCompanyFileD - Notepad =l B2
Eile Edit - Search - Help

[Fur‘n::e 1884 ; <58H> ; 158H ____j
Area <Em2> ; 20m2
Pressure B4 _m2 ; Force/Area Maximum pressure allowed

5
e

Here are the formatting rules to be applied:

@ Column1l
Parameter names
@ Column2

Parameter values. Multiple values are allowed. Values should then be separate by a ";". The imported value is the

one delimited by the "<" and ">" tags. Use the Tab key to skip from one column to the other in a tabulated text file.
@ Column3

Formula. If no formula is specified, the third column should be left empty. In a tabulated text file, just press the Tab
key twice from column 2 to leave column 3 empty.

@ Column4
Optional comment.

{_ About Parameters iEaﬁng and “aluating a Par E [Deleting a Parameter iﬁm&rﬁﬁ, Boundsz, Toleran ig?uaﬁng the Material Param
iE Lating the Mechanical_Pr E mporting Parameters



About Formulas

Formulas are features used to define or constrain a parameter. A formula is a relation that you write with parameters,
operators and functions. The left part of the relation is the parameter to be constrained, the right part is a statement.

Once it has been created, a formula can be manipulated like any other feature from its contextual manu.

Displaying Formulas in the Specification Tree

Formulas are displayed in the specification tree only if the Tools->Options->Part->Display->Relations box is checked.

it Felations

J(l-ij] Forrulal: BearinglnternalRadius=({D1 - BallGap) / tan (B2 - L2}/ (D1 - BallGap)))

fa1 | Formula2: BallRadius=Bearin glnternalKadius

In addition, whenever a user parameter is constrained by a formula, the formula is displayed with the parameter it
constrains if the Tools->Options->General->Knowledge->Parameter Tree View->With Formula box is checked.

¢& Parameters
Designation

MinFiletRadius=0.15mm

- BallGap))]

The Activity Parameter

A formula is a feature which is assigned a parameter called the activity. The activity value is of boolean type and is
defined as follows:

Activity value fal se true
Parameter value Does not depend on the formula Is calculated from the formula
Relation icon in the specification tree O :ﬁ:-:] ﬁx]

If a formula is created for a parameter which not already constrained by another formula, the activity of the new formula is
set to true by default. A parameter can be constrained by several formulas, but only one formula can be active at a time.
Before activating a formula on a given parameter, you must deactivate the other formulas defined on the same
parameter.

Importing Formulas

Parameters as well as the associated formulas can be imported from an external file. Refer to About Parameters and
Importing Parameters for more information on how to import formulas.




About Farmulas Creating a Formula Deleting & Formula i'vaﬁng and Deactivating : Importing Formulas
*

Wiiting Formulas
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About Rules and Checks

Rules and Checks are relations that can only be created and managed with the Knowledge Advisor product.

A rule is a set of instructions whereby you can control certain parameters and events according to a context. A check is a
set of instructions whereby you are warned that some statements are fulfilled or not.

Once they have been created, rules and checks can be manipulated like any other features:

@ Double-clicking on a rule or on a check in the specification tree displays an edition window
@ Delete, Cut/Copy/Paste and Rename operations can be accessed from the contextual menu.

Displaying Rules and Checks in the Specification Tree

Rules and Checks are displayed in the specification tree only if the Tools->Options->Part->Display->Relations box is checked.

ondLimitiLength

=

The Rule Activity Parameter

Like formulas, rules are assigned a parameter called the activity. The activity value is a boolean defined as follows:

Activity value UL &6 true
ty the rule is not executed the rule is executed
Relation icon in the specification tree ,&Qﬁ ,
The Check Parameters
A check is assigned three parameters defined as follows:
Activity Severity Result
Value @ true @ Silent @ true
the check is executed See Creating a Check the statements specified by the
B o @ @ Information check are fulfilled 3
@ false See Creating a Check @ false
the check is not @ Varning the statements specified by the
executed See Creating a Check check are not fulfilled i

SR or AR

Lg ({\bcuut Fules and Checks ﬁaﬂng and Editing a Rule igiing and Editing & Check lsimgramming Checks
@_ N 1 + + +

Programming Rules

[ I




Using the Knowledge Inspector

The Knowledge Inpector allows you to query a design to determine and preview the results of
changing any parameters without committing themselves to actually changing the design. This
"what if* analysis provides immediate feedback that helps you experiment and refine designs.

While it is important to be able to determine what happens when one or more parameters are
changed, it is equally significant for you to be able to see how a design can be changed to
achieve a desired result. The Knowledge Inspector supports this by allowing you to query "how
to" make a particular change.

In brief, the Knowledge Inspector is a tool to study impacts and dependencies.

What if Helps you understand to what extent changing any parameter of your design
(impacts) (such as material, pressure, or a dimensional parameter) changes the
operation or design of the product on which you are working. Can be used to
examine interactions of parameters with each other and with the rules that
make up the product’s specifications.
A "Geometric Update" option enables you to visualize the result of your
modification in the geometry area.

How To Helps you determine how your design can be changed to achieve a desired
(dependencies) result.

& You shouldn't use the ﬁ:-:] capabilities with Knowledge Inspector.

Ykt If Mode Hovy To Mocde

€ €
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Parameters

Create a user parameter

Select a type in the 'New Parameter of type' list, then click 'New Parameter of
type'.

Edit/modify a user parameter

or

or

Select the parameter to be edited in the "Formulas" dialog box,
then modify its value in 'Edit name, value or formula’ .

In the specification tree, double-click the parameter to be edited,
then modify its value in the "Edit Parameter" editor.

In the specification tree, right-click the parameter to be edited,
then select the Parameter.object->Definition function from the contextual menu.

Add a comment to a user parameter

feo

or

In the "Formulas" dialog box, right-click the value field in 'Edit name, value or

formula’,
then select 'Edit Comment..." from the contextual menu.

Whatever the edition box, right-click the value field(s), then select 'Edit
comment..." from the contextual menu.

Add a tolerance to a magnitude type parameter

feo

or

In the "Formulas" dialog box, right-click the value field in 'Edit name, value or

formula’,
then select 'Add Tolerance' from the contextual menu.

Whatever the edition box, right-click the value field(s), then select 'Add
Tolerance..." from the contextual menu.

Specify lower and upper bounds

feo

In the "Formulas" dialog box, right-click the value field in 'Edit name, value or
formula’, then select 'Add Range' from the contextual menu.



Whatever the edition box, right-click the value field(s),
then select 'Add Range..." from the contextual menu.

Specify an increment/decrement amount

In the "Formulas" dialog box, right-click the value field in 'Edit name, value or
formula’,
then select 'Change Step' from the contextual menu.

or Whatever the edition box, right-click the value field(s), then select 'Change
Step..." from the contextual menu.

Specify the Material parameter value

Y
select the Material parameter in the specification tree, then click &2 .

or Double-click the Material parameter in the specification tree, then enter the
material value in the dialog box.

or f@t] In the "Formulas" dialog box, select the Material parameter in the parameter list,
then modify its value in 'Edit name, value or formula'.

Update the Mechanical Property parameters

Select the Properties->Mass option from the feature contextual menu and click OK.

Import parameters

In the "Formulas" dialog box, click | nport. ... Afile selection dialog box is
displayed. Select either a .xlIs file(Windows NT only) or a .txt file.

Delete a parameter

Select the parameter to be deleted in the "Formulas" dialog box, then click
'‘Delete Parameter'.

or In the specification tree, right-click the parameter to be deleted,
then select the Delete function from the contextual menu.






Creating and Editing a Parameter

A document is defined by features called parameters. When you create a document, you define
interactively a number of parameters. In order to add information to a document, you can create
new parameters that can be used later on when defining formulas, rules or checks (for those of
you using the Knowledge Advisor). Refer to About Parameters for a further information.

Here, we are going to create a time parameter (corresponding for example to the time required
to machine the part).

E 1. Open the KwrStartDocument.CATPart document.

ey : : feo : o
2. Click the Formula icon . The "Formulas" dialog box is displayed.

3. Select the Time item with 'Single Value' in the 'New Parameter of type' list, then
click '‘New Parameter of type'. The new parameter appears in 'Edit name, value
or formula'.

Note that a parameter can be assigned multiple values. You just have to select
the 'Multiple values' option at parameter creation and enter the values
one-by-one to specify the value list.

4. Replace the Ti ne. 1 name with Machi ni ng_Ti me and assign the 1000s value
to this parameter. Then click Apply. The Machining_Time parameter is added to
the specification tree. The dialog box is modified as follows:

R ArAE e e R S P S | Vel e
FartBody\Hole. 15T hreadingDrepth 20

FartB ody Hole. T hWbuctiity true

M echanical_Propertysvolume Orn3
techanical_Property’sM azs Okg
techanical_Property\\w/etbirea Ornt

b aterial Mone

b achining Time 1000z

Edit name, walue or Farmula

P achining_Time 11 000s 2]

| Mew Parameter of lvpe HTime _‘:_j Witk iSingIe Walue _:_’_j

5. Click OK to terminate the dialog.
6. To edit the parameter you have just created, you can:

& either, double-click on the Machining_Time parameter in the specification
tree. This will display an "Edit Parameter" box that you can use to modify
your parameter value.

& or, in the specification tree, select the
Machining_Time.object->Definition function from the contextual menu.




@ or, inthe "Formulas" dialog box, select the Machining_Time parameter,
then modify its value in 'Edit name, value or formula'.

The resulting document is KwrParamO0.CATPart.

@ The parameter list displayed in the "Formulas" dialog box depends:

@ on the current feature. For example, if you select Pad.1 in the
KwrStartDocument.CATPart specification tree, the list will contain only the
Pad.1 parameters. If you select the document global feature by clicking
KwrStartDocument, all the document parameters will be displayed in the list.

@ on the option selected for the Filter field of the "Formulas" dialog box. Setting
the All option displays all the parameters of the current feature. Setting the User
option displays only the parameters you have added to your document with the
‘New Parameter of type' button.

When editing a parameter, a number of functions can be accessed from the contextual
menu of the value field(s). These functions allow you to add attributes to the parameter
and to manipulate the formula which constrains the parameter (when this formula
exists). In addition, when a parameter value is constrained by a formula, the "Edit
Parameter"” dialog box displays a formula icon that allows you to edit the formula.
When a parameter value is driven from a design table , the "Edit Parameter" dialog
box displays a design table icon that allows you to edit the design table.

To display parameter values in the geometry area, you must have the "Formulas”
dialog box open and select a feature in the specification tree. Selecting a parameter in
the parameter list will highlight this parameter in the geometry area.

% About Parameters reating and Waluating & Par % Deleting & Parameter iﬁﬂ'ﬁﬂtﬂ, Boundsz, Toleran
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Parameter Comments and other
Parameter Attributes

To enrich the definition of a parameter, you can add some attributes to it. The attributes you
can add to a parameter depend on the parameter type. These attributes can be specified in two
ways:

1. either from the contextual menu of any edition box. For example, if you edit a pad, the
contextual menu of the value fields provides you with functions to add parameter
attributes

2. or from the 'Edit name, value or formula' contextual menu of the "Formulas" dialog box.
Edit name, value or formula

[PadLenath [EBrar e S Ty =g
Edit...
k
Mew Parameter of type H Lenath Lhde sy juppress
Add Range. .
Delete Parameter | Edit Caomment. .

The second method is described below.

Adding Comments

Comments can be added to all parameter types.

formula’.
Select the Edit Comment... function from the contextual menu
3. Enter your comments in the dialog box which is displayed.

#3

E 1. In the "Formulas" dialog box, right-click the value field in 'Edit name, value or
"
2.

Adding a Tolerance

The tolerance attribute can only be added to magnitude type parameters.



'm 1. In the "Formulas" dialog box, right-click the value field in 'Edit name, value or
e, formula’.

2. Select the Tolerance function from the contextual menu. Then select Edit. A dialog
box is displayed. The default values are those specified in the
Tools->Options->Tolerance tab for the Length and Angle parameters.

3. Enter the maximum and minimum tolerance values.
=l
Modifying the Increment/Decrement Amount

In the parameter value field of 'Edit name, value or formula’, the arrow buttons can be used to
increment or decrement values by a certain amount. You can modify the amount being
incremented or decremented.

'm 1. Inthe "Formulas" dialog box, right-click the value field in 'Edit name, value or
ety formula’.

2. Select the 'Change step' function from the contextual menu.
Select one of the amount displayed.

4. If the new amount you want to apply to the value field is not displayed, select 'new
one' and enter the new amount in the box which is displayed.
Edit name, value or farmula

w

[Feal |23 .
Change step 10
&dd Range... 1
Mew Farameter of type I; Real
Edit Comment. .. HEW one

Delete Parameter |

5. Click Enter to apply the new amount to the value field.

Note that, in addition to the initial increment/decrement amount (1 in the figure above) and
to the 'new one' option, the 'Change step' option displays the list of increment/decrement
amounts which have already been declared.

=l
Specifying Lower and Upper Bounds

Specifying lower and upper bounds provides you with a means to be warned whenever a
parameter value is out of range.



. Select the 'Add Range' function from the contextual menu.
. In the dialog box which is displayed, enter the upper and lower bound values.

. Click OK. If the current parameter value is out of range, a message is displayed.
CATIA proposes to replace the current value with one of the bounds you have

specified.

About Parameters iga’clng and Yalusting & Par Deletlng a Parameter mments Bounds, Toleran
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Specifying the Material Parameter Value

Whatever your document, the Material parameter is always displayed in the specification tree. By default, its value is set to
None. The Mechanical_Property features are calculated from the Material value. You need to specify a material to set the
values of the Mechanical_Property features.

m 1. Open the KwrStartDocument.CATPart document.
ety The Material parameter appears by default in the specification tree. Its value is set to None.

Double-clicking the Material feature in the specification tree

-'i Kwrsamme[] displays the following dialog box
ar xy plane
M aterial |N|:une
< lane
y2p : w Ok ] i!aliar'n::nall'
o 7% plane s
& Parameters Here are the values displayed in the parameter list when clicking feo .
— : M echanical_Property'yolume O3
Ei Material Mechanical PropertyMaszs Okg
Mechanizal_Propertys\etbrea Oz
o ﬁi F"artBt::dy M aterial Mone

2. Click the KwrStartDocument feature in the specification tree.

L
3. Click the &2 icon in the standard toolbar to display the available material library.
4. Select the Metal->Iron material.

Librarp [ReadOnly]

Construction | Fabrics | ketal | Other I Stone I Wood I

Bronze

Gold (el ] bagnesium

Titanium Tungstan




o |

3 Link ta file

S 0k | S appw |

Close ’

5. Click Apply. The Iron feature is added to the specification tree.

ﬁ'i displays the following dialog box

Edit Parameter EE3

|Ir|:|n

- xy plane

o yzplane Q@ 0K ] aﬂl:arn::eli

& 7x plane

t Parameters And here are the values displayed in the parameter list when clicking

kM echanical_Propertyyolume

Ef Material Mechanical Propertysh azs
M echanical_Propertswetdrea

35 PartBody R

Iron

6. Click OK in the "Edit Parameter" and "Formulas" dialog boxes.

7. Keep your document open and go to Valuating the Mechanical Property Parameters.

X

Om3
Qkg
Oz
[ron

Now, double-clicking the Material feature in the specification tree
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Updating the Mechanical Property
Parameters

Once the Material value has been specified, the Mechanical Property parameters are
automatically updated when the Properties option is selected in the contextual menu.
This is what you have to do to display the updated Volume, Mass and WetArea properties after
you have assigned a value to the Material parameter.

E 1. Open the Properties dialog box from the contextual menu.

i 2. Select the Mass tab. The document mechanical properties have been updated
from the value assigned to the Material parameter.

3. Click OK to go back to your document.

feo

4. Click the Formula icon . In the parameter list, the mechanical property

values are updated.

b echanical_Propertys\olume 2193911 e-005...
M echanical_Property M azs 0.158336kg

M echanical_Propertyyiwetirea 0.00939602m:
b aterial Iron

5. Click OK to terminate the dialog. The resulting document is

KwrMaterial0.CATPart.
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Importing Parameters

Parameters and parameter values can be imported from a text file or from an Excel file (Windows™ NT). See About
Parameters for more information on the import file format.

E 1. Open the KwrStartDocument.CATPart.

e . . foa . .
2. Click the Formula icon . The "Formulas" dialog box is displayed.
Click I nport. ... Afile selection dialog box is displayed.

4. Select either the ExCompanyFile0.xls file(Windows NT only) or the TxCompanyFileO.txt file. Then click Open. The
list of parameters to be imported into the KwrStartDocument.CATPart document is displayed.

Farameters and formulas created by the import operation

w

| Hame | Value | Fomula S| HehmineR
Force A0M
Hrea Bm2
Frezsure TOM_rn2 Forcedtrea b axirmunn pressure all...
w Ok Wi Cancel
= [ J

5. Click OK to import all the parameters from the input file to the KwrStartDocument.CATPart document.
The imported parameters are now displayed in the parameter list of the "Formulas” dialog box and in the
specification tree.

Pararneter [ Malue : Faormula
M echanical_Propertyholume Om3

b echanical_Propertysi azs Qkg

b echanical_Propertyswetbiea OmZ

b aterial MHone

Force A0M

Area amz

Prezsure 100 _mz2

6. Click OK to terminate the dialog. The resulting document is Kwrimport.CATPart.
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Deleting a Parameter

The only parameters that you can delete in a knowledgeware application are those created by
the 'New Parameter of type' button.
You can delete a parameter:
1. either from the contextual menu. The Material parameter cannot be deleted.
2. or by using the 'Delete Parameter' button of the "Formulas" dialog box. To do so:
1. In the Parameter list of the "Formulas" dialog box, select the parameter to delete
2. Click Del et e Par anet er. A message prompts you to confirm the deletion.
3. Click Yes. The parameter deleted should no longer appears in the specification
tree.

In the KwrParamO.CATPart document, the only parameter you can delete is the
Machining_Time parameter.

E Abhout Parameters igating and Yaluating a Par { Deleting & Parameter i;ﬁmen’[s, Boundz, Toleran
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Formulas

Createaformula

ﬁﬂ In the "Formulas" dialog box, select the parameter to be constrained, then click
'‘Add Formula'. Enter the formula in the "Formula Editor".

or ﬁxl In the "Formulas" dialog box, select the parameter to be constrained, then
enter the formula in 'Edit name, value or formula'.

or ﬁxj In the "Formulas" dialog box, double-click the parameter to be constrained and
enter the formula in the "Formula Editor".

or When editing a parameter, right-click the value field(s),
then select Formula->Edit from the contextual menu.

Edit/modify a formula

ﬁHJ In the parameter list of the "Formulas" dialog box, select the parameter defined
by the formula,
then modify the formula in 'Edit name, value or formula'.

or In the specification tree, right-click the formula to be edited,
then select the Formula.object->Definition function from the contextual menu.

or In the specification tree, double-click the formula to be edited.

or In the specification tree, double-click the user parameter, then click the f(X)
button in the "Edit Parameter" dialog box.

or When editing a parameter, right-click the value field(s),
then select Formula->Edit from the contextual menu.

Activate/deactivate a formula

ﬁxl In the parameter list of the "Formulas" dialog box, select the parameter which is
constrained by the formula to (de)activate and use the Activate/Deactivate
check box right of the 'Edit name, value or formula’ field.

or f‘m In the parameter list of the "Formulas" dialog box, select the formula/activity
parameter and modify its value in 'Edit name, value or formula'.



or In the specification tree, right-click the formula whose activity is to be modified,
then select the Formula.object->(De)activate function from the contextual

menu.
or When editing a parameter constrained by a formula, right-click the value

field(s),
then select the Formula->(De)activate function from the contextual menu.

Import parametersand formulas

f‘m In the "Formulas” dialog box, click 'Import’, then specify the import file path.
The import file should be either a .txt file or a .xls file.

Delete a formula

f‘w In the parameter list of the "Formulas" dialog box, select the parameter which is
constrained by the formula to be deleted, then click 'Delete Formula'.

or In the specification tree, right-click the formula to be deleted, then select the
Delete function from the contextual menu.

or When editing a parameter constrained by a formula, right-click the value
field(s),
then select the Formula->Delete function from the contextual menu.



|

Creating and Editing a Formula

CATIA Version 5 allows you to define a document parameter with respect to other parameters.
==, The relation which defines how a parameter value is calculated from other parameter values is
called a formula. This task explains how to create a formula specifying that the external radius of a
hollow cylinder is twice its internal diameter.

Make sure the Relations option is active in the Tools -> Options -> Part -> Display tab.

Note that the radius of a sketch can be defined by a formula provided it is declared as a constraint

(EI)-

1. Open the KwrStartDocument.CATPart.

2. Click the Formula icon

:ﬁx] . The "Formulas" dialog box is displayed.

3. Add the formula to the pad radius parameter. To do this, you can follow one of the three
methods described below:

Method
1

Method
2

Method

1.
2.

w NN Ww

Select the PartBody\Sketch.1\Radius.3\Radius in the parameter list.

Enter directly the 2 * Part Body\ Hol e. 1\ Di anet er relation in the right
part of the 'Edit name, value or formula’ field. Go to Writing Formulas for

tips and tricks for writing formulas.
Press the Tab key or the Enter Key.

Double-click the PartBody\Sketch.1\Radius.3\Radius parameter in the
parameter list. The "Formula Editor" is displayed.

Formula Editor - PartBody\5ketch. 1\Radiuz.3YH adius

FaitBodyhSketch. 1458 adius, 35F adius

1
YWizard I

@ 0K | & Cancel]

. Enterthe 2 * Part Body\ Hol e. 1\ Di anet er relation in the formula

field. Go to Writing Formulas for information on how to use the Wizard.

If needed, use the ﬁ? icon to erase a formula.
Click OK in the "Formula Editor".

Select the PartBody\Sketch.1\Radius.3\Radius in the parameter list.
Click 'Add Formula'. The "Formula Editor" is displayed.
Enter the 2 * Part Body\ Hol e. 1\ Di anet er relation in the formula

field. If needed, use the “ icon to erase a formula. Go to Writing
Formulas for tips and tricks for writing formulas.

Click OK in the "Formula Editor".



At this stage of the dialog:

@ the Formula.l relation is added to the specification tree.
@ in the "Formulas" dialog box:
@ the formula is added to the parameter list

& in the parameter list, the PartBody\Sketch.1\Radius.3\Radius parameter is
now defined by a formula

@ in the 'Edit name, value or formula field', the parameter value is now grayed
out. The formula appears in the right part of the field.
In the geometry area, a parameter which is constrained by a formula is indicated by

fea

L

an icon.

4. Click Apply to update the document in the geometry area.
5. Click OK to terminate the dialog. The resulting document is KwrFormula0.CATPart.

E About Formulas { Creating a Farmula s Celeting & Formula igivming and Deactivating :
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Activating and Deactivating a Formula

A parameter value can be defined by a number of formulas. But only one formula can be active at a time.

By default, a formula is active at creation but, if a formula defines a parameter which is already constrained by another
formula, you will be asked whether the new formula:

@ should be activated and the other one deactivated (if previously activated)
@ should be deactivated

@ should be cancelled (no formula created).

A formula can be activated or deactivated: either from the "Formulas" dialog box, or from the contextual menu, or by a rule
execution.

Here is a scenario illustrating how to activate and deactivate a formula.

E 1. Open the KwrFormulal.CATPart. Two formulas are added to the document. One defines the

e, PartBody\Sketch.1\Radius.3\Radius parameter with respect the hole diameter, the other defines the hole diameter
with respect to the Pad limits. Both formulas are active.

2. Click the Formula icon ﬁx] select the Par t Body\ Sket ch. 1\ Radi us. 3\ Radi us parameter, then click '‘Add
Formula'.

3. Enterthe Part Body\ Sket ch. 1\ Radi us. 3\ Radi us = 4 * Part Body\ Hol e. 1\ Di anet er relation in the
"Formula Editor".
4. Click Yes. As the Pad radius is already constrained by the Formula.l relation, a dialog box asks you:

@ either to deactivate Formula.1 and to create Formula.3 as active
@ orto keep Formula.1 active and to create Formula.3 as inactive
@ orto cancel the Formula.3 creation.

5. Click Yes to create the Formula.3 relation as active and deactivate the Formula.1 relation.
Deactivate Formula.3 by using one of the three methods below:

Method 1

Set the Relations\Formula.3\Activity value to false
RelationsFarmula. T A ctivity falze
FielationssFarmula. 258 ctivity brue

HelationssFormula. 358 chisity
b aterial

Mone

Edit name, walue or formula
[Rielations \Formula, 34Activity 1false _:_I =|

Method 2

Use the Activate/Deactivate check box

Double click on a parameter bo edit it

LS 4 1110 T 0 T 1S o
1E0rmm 4 * PartBodyiHaole. 14Diameter no
2* PartBodytHole 14Diarmeter no
FartBodysPad. 14FirstLimitsLength A40mm
PartRndyiPad 145 emandl imith] angth (o
FartBaodysHole. 14HoleLimt. 140 epth 40mm
FartBodytHaole, 14HoleLimit. 14 ngle 120deq
PartBodyHole 14\Diameter 40rmm PartBodyPad. 1%FirstLimithLengt...  pes __T_j
Edit hamne, walue or formula
iF‘artE odytSketch T5Radivg, | [TEOmm % =14 * PantBodysHole. 14Diammeter [ 1

ActivateDeactivate check box
Method 3



1. Click OK to exit the "Formulas" dialog box.
2. Click the Formula.3 relation in the specification tree.
3. Select the Formula.3 object -> Deactivate option from the contextual menu.

6. Re-activate Formula.1 by using one of the three methods above.
7. Click OK to terminate the dialog. The resulting document is KwrFormula2.CATPart.

#7%/
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Importing Formulas

Formulas are imported with the parameters they define. See About Parameters for more
information on the import file format.

& When a parameter is defined by a formula, units should be mentioned in column 2.

Examples of import files with formulas are provided in the ExCompanyFile0.xls and
TxCompanyFileO.txt tables.

About Formulas Cresting & Formula Deleting & Formula ig'!vating and Deactivating
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Deleting a Formula

You can delete a formula in three ways:
1. In the specification tree, right-click the formula to be deleted, then select the Delete
function from the contextual menu.

2. In the parameter list of the "Formulas" dialog box, select the parameter constrained by
the formula to be deleted, then click 'Delete Formula'. A message asks you to confirm the
deletion. Click Yes. The formula deleted should no longer appears in the specification
tree.

3. When editing a parameter constrained by a formula, right-click the value field and select
the Formula->Delete function from the contextual menu.

About Formulas Creating & Formula Deleting & Formula igiva’[ing and Deactivating
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Rules

Createarule

@ Enter the rule name and comments. Then write your rule in the rule editor.
To enter a parameter within a rule, you can:

@ either click the parameter in the specification tree
@ or click the dimension displayed in the geometry area
@ or use the editor dictionary.

Edit/modify arule

In the specification tree, double-click(twice) the rule to be edited.

or In the specification tree, right-click the rule to be edited,
then select the Rule.object->Edition function from the contextual menu.

Activate/deactivatearule

In the specification tree, right-click the rule to be activated or deactivated,
then select the Rule.object->(De)activate function from the contextual menu.

or f‘m In the parameter list of the "Formulas" dialog box, select the rule/activity
parameter modify its value in 'Edit name, value or formula'.

Deletearule

In the specification tree, right-click the rule, then select the Delete function
from the contextual menu.

Checks

Create a check




Enter the check name and comments. Then write your check in the check
E editor. To enter a parameter within a check, you can:

@ either click the parameter in the specification tree
@ or click the dimension displayed in the geometry area
@ or use the Dictionary.

Edit/modify a check

In the specification tree, double-click the check to be edited.

or In the specification tree, right-click the check to be modified,
then select the Check.object->Edition function from the contextual menu.

Activate/deactivate a check

In the specification tree, select the check to be activated or deactivated,
then select the Check.object->(De)activate function from the contextual menu.

or f‘m In the parameter list of the "Formulas" dialog box, select the check/activity
parameter and modify its value in 'Edit name, value or formula'.

Delete a check

In the specification tree, right-click the check to be deleted, then select the
Delete function from the contextual menu.



Creating and Editing a Rule

A rule is a set of instructions whereby you can control certain parameters and events according
to a context.
To create a rule:

1. open your document

2. access the Knowledge Advisor workbench

IFC)
¥}

3. click the Rule icon . The Rule Editor dialog box is displayed. Now it is mainly a
programming task. Refer to Programming Rules.

When creating rules, remember that, if a rule is intended to constrain a parameter, other
relations constraining this parameter will conflict with the rule to be created. To resolve the
conflict, CATIA will ask you to specify which relations are to be declared active or inactive.

To edit a rule from the specification tree, you can:

@ either double-click the rule
@ orright-click the rule and select the Rule.Object->Definition function from the contextual
menu.

E g Ebnu’[ Fules and Checks reating and Editing & Rule igming and Editing & Check
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Programming Rules

The Knowledge Advisor script language provides you with a full range of operators, functions
and keywords that can be used to program your rules.

Rules are a multiple-line pieces of code that you can write either by typing directly the
appropriate syntax in the editor field or by selecting items from the editor dictionary list. Here
are some details about the rule syntax. Other dictionary components are described in Writing

Formulas.

Tips and Tricks for Editing Rules

In the rule editor, to enter a parameter, you can:

@ either click it in the specification tree
@ or click the dimension displayed in the geometry area
@ or use the dictionary

By default, the dictionary displays the list of all the parameters defining your document. But this
list can be restricted to a single-type parameter list. For example. if you select the Length item
in the "Members of Parameters" list, only the Length type parameters will be displayed.

Using Temporary Variables

Temporary variables can be declared by using the let keyword. A temporary variable does not
persist as a parameter after the rule execution is finished.

/*Rul e created by CRE 08/23/99*/
let x =5 nm
i f PartBody\Hol e. 1\ Di aneter > x

{
Par t Body\ Hol e. 1\ Activity = fal se

}

Temporary variables should be declared at the beginning of the rule, before any conditional
instruction is specified.

Including Comments

The /* and */ comment characters are supported.



/* Rule created by CRE 05/03/99 */
i f Part Body\ Sket ch. 1\ Radi us. 3\ Radi us > 45nmm

{
LaunchMacr oFronfi | e(" Macrol. CATScri pt")

}

el se
/*

LaunchMacr oFronFi | e(" Macro2. CATScri pt")
*/

Message(" No macro | aunched")

The Rule Dictionary

The dictionary components which are not already described in Writing Formulas are discussed
below.

Conditional Statements or Keywords

Like in many languages, the if....else...else

1F‘arameter3 «| |if if statements are used to evaluate

slse whether a condition is true or false and,
Operators elze if q : :
Shing ard epending on the result, to specify one or
b ath or more statements to run. Usually the
Design table condition is an expression that uses a
Messages and mac— comparison or logical operator to compare
ﬁ”'timm _J:“ one value or parameter value with another.
1T | » Statements within a condition can be

combined using the and or or keywords.

Operators
Faramatars 1= Operators provided are:
KEEWDrdE R RS @ arithmetical operators
g := @ and comparison operators. Note that
b ath . comparison operators should be only
Diesign table < used in conditional statements. They
Meszages and mace <= can't be used as functions as they
Urits <l | don't return any value.
Crnztant -
sz _f‘J :

Message and Macro Functions



The Rule editor provides you with the

P'aramet-ers « | IMessage j - i )
K.epwords =1 |Launcht acroFromFile functions listed on the figure opposite:
Operatarz

Shing @ Message |

b ath : @ LaunchMacroFromFile.

| Dezign table '

iMeszages and mac

Uitz <
Cnpfstant
1rin 1 ¥l
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file:///E|/users/cre/adele/crecxr3/KwrEnglish/kwrug.doc/src/kwrMessage.htm
file:///E|/users/cre/adele/crecxr3/KwrEnglish/kwrug.doc/src/kwrMacroFromFile.htm

Writing Formulas

The formula editor provides you with a full range of operators and functions that you can use with parameters to create
formulas. A formula is a one-line statement that you can write either by typing directly the appropriate syntax in the editor
field or by selecting items from the editor dictionary list. The formula syntax is easy to use and learn. Here are some
details about how to use the formula editor.

Tips and Tricks for Editing Formulas

In the "Formula Editor", to enter a parameter, you can:

@ either click it in the specification tree
@ or click the dimension displayed in the geometry area
@ or use the Wizard.

To use the Wizard, press the "Wizard' button in the "Formula Editor". The dialog box which is displayed looks something
like this.

By default, the dictionary displays the list of all the
parameters defining your document. But this list can

|PartBody\Pad. 145 econdLimitsLenath = {?’ be restricted to a single-type parameter list. For
example. if you select the Length item in the
| "Members of Parameters” list, only the Length type
parameters will be displayed.
Drictionary Members of Farameters Members of Al ",
Parameters T [r-ifodSketch 1WAz = Use the to erase a formula.
Operatars Length PartBodyFad. 14FirstLi
String Angle FPartBodyFad 1MS5ecor
kd ath Boolzan PartBodytHale. 1%Hale
Dresign table Yolume PartBodytHaole. 1%Holel
M eszages and macros | |Maszs PartBodytHaole. 1%Diam
[nitz Area PartBodytHaole. 1 Wbty
Conztant Severity Mechanical_FPropertyby,
String Merhaniral rnnHrT‘l‘-'_T.I
Renamed parameters |4 i i r

= .

The Formula Dictionary

Here is a description of the language provided by the formula dictionary.

Parameters
P P [F-co0, Shetch R e When a parameter name contains a special characf[er_,
Operators Length PartBodyPad 14Firsti— | | it Should be delimited by back-quotes when used within
String Angle PartBodytPad. 145 ecot a formula.
kdath Boolean FartBody'Hole. 14Haolel
D esign table Wilume PartBodytHole. 1% Holel—! | No extra-space should be left after the first and before
Meszages and macros| |Mazs PartBodytHaole. 1hDiam the last back-quotes.
Uitz Area FartBodyHale. 1 activ Example:
Constant String techanical_Propertys, ple: . . .
Renamed parameters | | Mechanical rmnerw_i* Pad-2\MechanicalPartProperties\Density
4 F

Arithmetic Operators



FParameters

String

b ath

Dezign table
Mezzages and macros
nitz

Conztant

The formula editor provides you with the operators listed
on the figure opposite.

Note that the "+" operator can be used for string
concatenation.

String Functions

FParameters
D peratars

kd ath

Dezign table
Mezsages and macros
ritz

Conztant

Search

Eutract

Length

ToSking
FReplaceSubText
Tollpper
Toloweer

Here are the functions provided to manipulate strings:

@
@
@

Search
Extract

Length

LN

ToString
ReplaceSubText

ToUpper
TolLower.

Mathematical Functions

FParameterz
Operatars
Striry

Drezign table
Mezzages and macros
Unitz

Conztant

acosh
atarh
log

exp
abz
ceil
floar
min
rias

The full range of trigonometric functions is provided to
you as well as some other usual functions.

Note fl oor returns the largest integer value that is
less than or equal to the value specified in the

argument.

cei | i ng returns the smallest integer value that
is greater than or equal to the value specified in

the argument.

Design Table Functions

FParameters
Operatars
String

b ath

Dezign kabl

Meszzages and macros
itz

Constant

CellazReal
Cellt:Boolzan
CelltsString
LocatelnCaolumn

b axlnColumn
MinlnColurn

Clazery alua5uplnCalurn
Clozery aluel nfl nColurmrn

Here are the functions to access the design table:

L S S 2

CellAsReal ¥
CellAsBoolean o
CellAsString o

LocatelnColumn @&

MaxInColumn
MinInColumn
CloserValueSupInColumn

CloserValuelnflnColumn

Units




T —— Ib_h =] 1. Pay attention to unit consistency when writing a
Operators kg_h formula.
String IE_rriry 2. When importing formulas, don't omit to specify a
b ath M | it included) | | >
Design table Ibfsin value (unit included) in column 2.
Messages and macros | MNamm =] 3. Units are written with an underscore instead of the
E!IM N_mz usual "/* (example N_m2 instead N/m2).
Conztant F'E!
p
Mwrm_rad ..‘.'.'..!
Constants

The following constants are specified or recognized by CATIA when programming formulas. As a result, they can be
used anywhere in a formula in place of the actual values.

fal se - one of the two values that a parameter of type Boolean can have

true - one of the two values that a parameter of type Boolean can have

Pl - 3.14159265358979323846 - The ratio of the circumference of a circle to its diameter.

E - The base of natural logarithm - The constant e is approximately 2.718282.

E About Farmulas E Creating a Formula E Deleting a Formula igivaﬁng and Deactivating : E Imparting Formulas

Wiriting Formulas

e

oo e



Search Function

Description

Searches for the first occurence of a substring in a String type parameter. Returns the index of the start of
the substring. Returns -1 is the substring specified is not found.

Syntax

Search(String)

The Search function has one argument:

Argument

Description

String

Required. Name of the substring to be searched for (should be put in quotes) or name of the String parameter.

Example

Responsible =
[I1Search =6 =
[2Search =0 =

Cilas Evans = ...
Responsible.Search("EVANS")
Responsible.Search("Cilas")

I3Search = -1 = Responsible.Search("CILAS")




Extract Function

Description
Returns the substring starting at a given position with a specified length.
Syntax

Extract(Startindex, Length)

The Extract function has two arguments:

Arguments Description

Starlndex Required. Index of the substring first character

Length Required. Substring length

Formula Example

FirstName = Cilas
Name = Cilas = Responsible.Extract(0,FirstName.Length())
Extract = la = FirstName.Extract(2,2)



Length Function

Description

Returns the string length.
Syntax

Length()

The Length function has no arguments
Formula Example

FirstName = Cilas
Name = Cilas = Responsible.Extract(0,FirstName.Length())



ToString Function

Description
Converts an integer into a string.
Syntax

ToString(Integer)
The ToString function has one argument:

Argument Description

Integer Required. Integer to be converted into string.

Formula Example

RevNumber = 1
Revision = Rev: 1 ="Rev: " + ToString(RevNumber)




ReplaceSubText Function

Description

Replaces a substring with another substring within a character string.

Syntax

ReplaceSubT ext(InputString, SubStringl,ubString2)

The ReplaceSubText function has three arguments:

Argument Description

InputString Required. Input string.

SubStringl Required. Substring to be replaced
SubString2 Required. Substring replacing SubStringl

Formula Example

Responsible = Cilas EVANS
NewResponsible = Eazy EVANS = ReplaceSubText(Responsible,"Cilas',"Eazy")




ToUpper Function

Description

Changes al lower-case letters of a string to upper-case.

Syntax

ToUpper (String)
The ToUpper function has one argument:

Argument

Description

Sring

Required. Name of the string to be converted to upper-case (should be put in quotes) or name of the String parameter.

Formula Example

FamilyName = Evans

FirstName = Cilas
Responsible = Cilas EVANS = FirstName + " * + ToUpper(FamilyName)




ToLower Function

Description

Changes all upper-case letters of a string to lower-case.

Syntax

ToL ower (Sring)

The ToL ower function has one argument:

Argument

Description

Sring

Required. Name of the string to be converted to lower-case (should be put in quotes) or name of the String parameter.




CdlAsReal Function Code sample

Input design table

Description

Returns the contents of a cell located in a column intended for rea values. Returns zero if the cell does not contain a
real or if the function parameters are not properly specified (see remarks).

Syntax

CellAsReal (DesignTableName, RowNumber, ColumnNumber)
The CellAsReal function has three arguments:

Arguments Description

DesignTableName | Required. Name of the design table you want to read. This name is the string which identifies the design table in the
specification tree. Should be put in quotes.

RowNumber Required. Line or configuration number. Integer from 1 to n.

ColumnNumber Required. Number or index of the table column. Integer from 1 to n.

Remarks

The real which is returned by the function should be added to your document as a user parameter.

The CellAsReal function returns anil value:
« When the design table passed as its first argument does not exist
« When the row or column numbers are out of range or not specified as integers.
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CellAsBoolean Function Code sample

Input design table

Description

Returns the contents of a cell located in a column intended for boolean values. Returns false if the cell does not contain
aboolean or if the function parameters are not properly specified (see remarks).

Syntax

CellAsBoolean(Des gnTableName, RowNumber, ColumnNumber)

The CellAsBoolean function has three arguments:

Arguments Description

DesignTableName | Required. Name of the design table you want to read. This name is the string which identifies the design table. Should be
put in quotes.

RowNumber Required. Line or configuration number. Integer from 1 to n.

ColumnNumber Required. Number or index of the table column. Integer from 1 to n.

Remarks

The boolean which is returned by the function should be added to your document as a user parameter.

The CellAsBoolean function returns afalse value:
« When the design table passed as its first argument does not exist
« When the row or column numbers are out of range or not specified as integers.
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CellAsString Function Code sample

Input design table

Description

Returns the contents of a cell located in a column. Returns an empty string if the cell is empty or if the function
parameters are not properly specified (see remarks).

Syntax

CédlAsString(DesignTableName, RowNumber, ColumnNumber)
The CellAsString function has three arguments:

Arguments Description

DesignTableName | Required. Name of the design table you want to read. This name is the string which identifies the design table in the
specification tree. Should be put in quotes.

RowNumber Required. Line or configuration number. Integer from 1 to n.

ColumnNumber Required. Number or index of the table column. Integer from 1 to n.

Remarks

The string which is returned by the function should be added to your document as a user parameter.

The CellAsString function returns an empty string:
« When the design table passed as its first argument does not exist
« When the row or column numbers are out of range or not specified as integers.
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L ocatel nColumn Function Code sample

Input design table

Description

Returns the index of the first row which contains a specified value. Returns zero if the valueis not found or if the
function arguments are not properly specified (see remarks).

Syntax

L ocatel nColumn(DesignTableName, ColumnNumber,Value)

The L ocatel nColumn function has three arguments:

Arguments Description

DesignTableName | Required. Name of the design table you want to read. This name is the string which identifies the design table in the
specification tree. Should be put in quotes.

ColumnNumber Required. Number or index of the table column. Integer from 1 to n.

Value Required. Value searched for. Can be a string or a boolean

Remarks

The L ocatel nColumn function returns O:
« when the design table passed as its first argument does not exist
« Wwhen the row or column numbers are out of range or not specified as integers.
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M axlI nColumn Function Code sample

Input design table

Description

Returns the greatest of a column values. Returns O if the column does not contain numerical values or if the function
arguments are not properly specified (see remarks).

Syntax

M axI nColumn(DesignTableName, ColumnNumber)

The MaxInColumn function has two arguments:

Arguments Description

DesignTableName | Required. Name of the design table you want to read. This name is the string which identifies the design table in the
specification tree. Should be put in quotes.

ColumnNumber Required. Number or index of the table column. Integer from 1 to n.

Remarks

The M axInColumn function returns O:
« When the design table passed as its first argument does not exist
« When the row or column numbers are out of range or not specified as integers.
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MinlnColumn Function Code sample

Input design table

Description

Returns the smallest of acolumn values. Returns O if the column does not contain numerical values or if the function
arguments are not properly specified (see remarks).

Syntax

MinlnColumn(DesignTableName, ColumnNumber)

The MinInColumn function has two arguments:

Arguments Description

DesignTableName | Required. Name of the design table you want to read. This name is the string which identifies the design table in the
specification tree. Should be put in quotes.

ColumnNumber Required. Number or index of the table column. Integer from 1 to n.

Remarks

The MinlnColumn function returns O:
« When the design table passed as its first argument does not exist
« When the row or column numbers are out of range or not specified as integers.
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Closer ValueSupl nColumn Function Code sample

Input design table

Description

Scans the values of a column and returns the greatest cell value which is the nearest to a specified one. Returns 0 if no
value isfound or if the function arguments are not properly specified (see remarks).

Syntax

Closer ValueSuplnColumn(DesignTableName, ColumnNumber, Real Value)

The Closer ValueSuplnColumn function has three arguments:

Arguments Description

DesignTableName | Required. Name of the design table you want to read. Should be put in quotes.

ColumnNumber Required. Number or index of the table column. Integer from 1 to n.

RealValue Required. Value searched for. Should be areal.

Remarks

The Closer ValueSupl nColumn function returns O:
» when the design table passed as its first argument does not exist
« When the row or column numbers are out of range or not specified as integers.
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Closer Valuel nflnColumn Function Code sample

Input design table

Description

Scans the values of a column and returns the smallest cell value which is the nearest to a specified one. Returns 0 if no
value isfound or if the function arguments are not properly specified (see remarks).

Syntax

Closer Valuel nfinColumn(DesignTableName, ColumnNumber, RealValue)

The Closer Valuel nflnColumn function has three arguments:

Arguments Description

DesignTableName | Required. Name of the design table you want to read. This name is the string which identifies the design table in the
specification tree. Should be put in quotes.

ColumnNumber Required. Number or index of the table column. Integer from 1 to n.

RealValue Required. Value searched for. Should be areal.

Remarks

The Closer Valuel nflnColumn function returns O:
« when the design table passed as its first argument does not exist
« Wwhen the row or column numbers are out of range or not specified as integers.
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Creating and Editing a Check

Like a rule, a check is a piece of code. But unlike a rule, it has no impact on parameter values.
When executed, a check just gives you a clue as to whether some conditions are verified or not.
There are three types of checks: the silent, the information and the warning checks.

Depending on the type of check and the result of the check, you will be warned as follows:

Check verified Check not verified
Relation icon in the 0 %
specification tree ..
Silent check no message displayed no message displayed
the message specified at check
Information check no message displayed @creation is displayed in an
information box
the message specified at check
Warning check no message displayed @‘} creation is displayed in a warning

box.

Creating a check is partly a programming task. But the check syntax is easy to learn. Refer to
About Rules and Checks and Programming Checks.

E 1. Open the KwrFormula0.CATPart document and access the Knowledge Advisor
iy workbench.

2. Click the Check icon ﬁ The first Check Editor dialog box is displayed.

3. Replace the default name with Cylinder_Check. If needed, add some comments into
the Description fied.

Check Editor B3|

Mame af Check: ;
{Cylinder_Check]

[Description :

Check created by CRE 0442633

@ 0k | &SCancel]  Help |

4. Click OK. The Check Editor is displayed.



Check Editor : Cylinder_Check Achve

Type af Check: : ilnfu:nrmatin:un :_j Mmessage :]E_l,llinu:ler iz boo thick,
|

J .
HCheck Ereateﬁa%m
Warning

. Select a type of check. Enter the message you want to be displayed in the
information or warning box in case the check is not verified.

. Enter the check statements in the edition window. You can simply Copy/Paste the
following statements into the edition window:

if PartBody\Sketch.1\Radius.3\Radius - PartBody\Hole.1\Diameter / 2 > 10mm
then
Relations\Formula.1\Activity == false

. Click Apply to test your check syntax as well as the result on the document. The
Cylinder_Check is added to the relations in the specification tree. Depending on
whether it is verified or not, the light icon associated with the check relation is either
green or red.

. Click OK to terminate the dialog.
. To edit the check you have just created from the specification tree, you can:

& double-click the check
& right-click the check and select the Check.object->Definition function from the

contextual menu.

E g éhnut Fulez and Checks geating and Editing a Rule ?[Eating and Editing a Check

Programming Checks Programming Rules

!—'E.‘L !EL



Programming Checks

The Knowledge Advisor script language provides you with a full range of operators, functions
and keywords that can be used to program your checks.

Checks are a multiple-line pieces of code that you can write either by typing directly the
appropriate syntax in the editor field or by selecting items from the editor dictionary list. Here
are some details about the check syntax. Other dictionary components are described in Writing
Formulas and Programming Rules.

Conditional Statements or Keywords

Paramaters miF Like in many languages,
then the if....then... statements

Operators and are used to evaluate

E;”[‘hg or whether a condition is

a .

Diesign table fulfilled or not and,

Meszages and mac— depending on the result, to

Units specify one or more

[Crpfstant ad :

f;’“ = _"J_J statements to verify.

Usually the condition is an
expression that uses a
comparison or logical
operator to compare one
value or parameter value
with another. Statements
within a condition can be
combined using the and or

or keywords.
E g Ebnu’[ Fules and Checks %eating and Editing & Rule igming and Editing & Check
Programming Checks Programming Rules

& (3 I




Advanced Tasks

Among the knowledgeware capabilities, there are two which are not very basic at all. The
objects you manipulate are a bit complicated and, in addition to interactive tasks, you will often
have to perform programming tasks. Two features describe these knowledgeware capabilities :

1. i the design table

A design table is a tool mainly intended to ease the definition of mechanical parts. It is
provided to all CATIA users. But you will make the best use of it in a Knowledge Advisor
application. A design table can be created from a CATIA document, the document data is
then exported to the design table. It can also be applied to a document, the document
data is then imported from the design table.

The Design Table tasks and concepts are described in the Infrastructure documentation.
Refer to About Design Tables for further information on the design table principles. Go to

Design Table Tasks for a summary of interactive tasks as well as a comprehensive list of
programming functions.

2. the behavior

A behavior is a set of VB Script instructions which are executed when a feature responds
to a given event. Go to Behavior Tasks for information on this very particular feature.



About Design Tables

A design table provides you with a means to create and manage component families. These components can be for example
mechanical parts just differing in their parameter values. Screws are a good example of mechanical parts that can be described by a
design table. To simplify, imagine they all described by four parameters: the head width, the head height, the body width and the body
height. The sets of four parameter values that can be assigned to a screw can be easily regrouped in a design table. This design table
has as many columns as screw parameters and as many rows as sets of parameter values. In a design table, a set of parameter
values is called a configuration and it is registered in a row.

A design table is a tool mainly intended to ease the definition of mechanical parts. It is provided to all CATIA users. But you will make
the best use of it in a Knowledge Advisor application. A design table can be created from a CATIA document, the document data is
then exported to the design table. It can also be applied to a document, the document data is then imported from the design table.

The purpose of the design table is to drive the parameters of a CATIA document from external values. These values are stored in the
form of a table either in a Microsoft ® Excel file on Windows™ or in a tabulated text file. When using a design table the trick is to
associate the right document parameters with the right table parameters. The design table columns may not all correspond to your
document parameters and you may decide to apply only part of the design table values to your document. By creating associations,
you declare what document parameters you want to link with what table columns.

The design table becomes a more powerful tool when it is used with the Knowledge Advisor. You are provided with functions to read
the design table parameters. These design table functions can be used when programming your checks and rules. Using these
functions spares you all the association operations.

The Excel Sheet Format (on Windows)

The values mentioned in the sheet cells have to be expressed in appropriate units. Otherwise, the right values won't be associated
with the document parameters.

If no unit is mentioned within a cell:

@ the unit taken into account is the one mentioned in the first row
@ and if no unit is specified in the first row, the unit taken into account is the relevant MKS system unit.

Here is an example of an Excel sheet:

When a configuration which contains empty cells is
selected, the parameters associated with the empty
cells are not modified. This property enables you to
modify parameters but anly under certain conditions

column narme colurmn unit

2} BallBearing

ol R e RE e ISR H ]
L D1{mm) MinliletRadius{imm) BearingMass Material

| 2 623 15 & 4 : 375 015 1.59 Aluminium
3 6184 2 45 25 26 375 015 0.7g Iron

4 524 2 B5 5 515 0.2 319 Gass

5 634 2 8 5 42 B 0.3 5.49 Aluminium
B (61845 25 55 3 3.4 45 0.15 1.2 Iron

| 7 |B1800 5 95 5 6.3 8.2 0.3 5.5 Pavemnent
B 5000 5 13 8 7 107 03 19 ltalian Marble
9 51802 7E 12 5 1055 0.3 7.4 Iron

10 5302 7E 21 13 11.85 1695 |1 g2 ent
| 11 61504 10 16 7 12 1415 0.3 18 Alumini

12 5404 10 36 19 1855 278 1.1 400 Gass
| 13 (51606 15 21 7 168 191 03 25 Pavermnent
14 5306 15 36 19 223 2895  1.1mm 350 Aluminium
| 15 16008 20 34 9 247 285 03¢ 130 Pavement

Inits can be specified in
cells. If no unit is
mentioned, the parameter
ev aluation is carried out

an -

Within a given column, you
can change the units



Trom WK Units (Kg Instead
of g in the examnple)

The Tabulated Text File Format

Here is an example of a tabulated file format. You can use your favorite text editor to create this design table. Use the Tab key to skip
from one column to the other. Unit rules are the same as for the Excel sheets.

E BallBeanngl - Hotepad

Filz-Edit - Search  Help

Designation d{mm} D{mm}) B{mm) d1{mm)} DI1{mm) HinFiletRadius{mm)
623 1.5 L L 2.6 3.75% a.15 1.5
61874 2 L. 5 2.5 2.6 3.75 a.15 8.7
624 2 6.5 L 3.35 L.15 8.2 3.1
634 2 8 L L. 2 i 8.3 L.h
61875 2.5 L 3 a.h h.b Aa.15% 1.2
618088 L 9.5 L 6.3 8.2 8.3 L..
Y55 ]5] L 13 8 ¥.2 18.7 a.3 19
61882 i.. 12 L 8.95 18.5% 8.3 f.h
6382 7.5 21 13 11.85 16.95% 1 82
61884 18 164 Fi 12 14 1% 8.3 18
Ghih 18 36 19 18 .55 27 .8 1.1 LB8
618806 1% 21 ¥ 16.9 19 .1 8.3 26
6306 15 36 19 22.3 29 .95 1.1 3ca
160088 28 34 9 247 28.5 8.3 138
6388 28 Lo 23 28 .85 37.3% 1.5 63088

The CATIA Design Table

Once it has been read and processed by CATIA, the design table looks something like this:

DeszignT able.? active, configuration row : 1

i DESign tal:llE perErtiES e T A A A T s ...: .
ENamei jDesignTabIe.E W_/—“ Mo units
EEDmment :1Thi$ dezign table was created by CRE on 03/31./95 '

w 0K I q'.-’-‘-.pply! ﬂEanceIl

Displays the design
table raw data.

“Yalues with units

b aterial
1.5mm  Bmm nm Brom - Alurminium
3.75m Iron
518mm  Glass Duplicates the design
Brnrm Alurminiur table external data
4.5 Iron |4 into the CATIA
3. 2mm F'a*_\-'ement document.
10.7mm  Italian karble Check this box
10.55mm  lran .
16.95mm  Pavement whenav er you intend
14.15mm  Aluminium to re-access your
18.55mm  27.8mm  Glass design table on _
B1506 15mm  2lmm 7%, 16.9mm  19Tmm  Pavement i another platform (Linix
B306 18mm  36mm 19mm “223mm 29.95mm Aluminiumn =] or Windaws NT).
Edit table. .. ﬁluplicate data in CAT A model
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Design Table

Create a design table from the document parameter values

G Check the option "Create a design table with current parameter values".
Select the parameters to insert, then specify the .xIs (Windows™) or .txt file
where the design table is to be created.

Create a design table from a pre-existing file

o Check the option "Create a design table from a pre-existing file". Specify the
file containing the design table data, then create the necessary associations.

Edit a design table
In the specification tree, double-click the design table.

or In the specification tree, right-click the design table to be edited,
then select the DesignTable.object->Edition function from the contextual menu.

or If a parameter is constrained by a design table, double-click it in the
specification tree, then click the design table icon in the "Edit parameter"
dialog box.

Delete a design table

In the specification tree, right-click the design table to be deleted, then select
the Delete function from the contextual menu.

Program the design table access




CellAsReal

Returns the contents of a cell located in a column intended for real
values.

CellAsBoolean

Returns the contents of a cell located in a column intended for boolean
values.

CellAsString

Returns the contents of a cell located in a column.
CloserInfConfig

Returns the configuration which contains the largest values less or
equal to the values of the given arguments.

CloserSupConfig

Returns the configuration which contains the smallest values grreater
or equal to the values of the given arguments.
CloserValuelnfinColumn

Scans the values of a column and returns the smallest cell value which
Is the nearest to a specified one.

CloserValueSupInColumn

Scans the values of a column and returns the greatest cell value which
Is the nearest to a specified one.

LocatelnColumn

Returns the index of the first row which contains a specified value.
MaxInColumn

Returns the greatest of a column values.

MinInColumn

Returns the smallest of a column values.

Question

Displays a message in a dialog box, waits for the user to click a button
and returns a value indicating which button the user clicked.



file:///E|/users/cre/adele/crecxr3/BasEnglish/basug.doc/src/kwrCloserInfConfig.htm

Creating a Design Table with the Current Parameter Values

An external design table is created from parameters belonging to the current document.

You just have to select
the parameters you want to insert in the design table.

E 1. Open the KwrStartDocument.CATPart document.
“erzs - o
2. Click the Design Table icon in the standard toolbar.

The "Creation of a Design Table" dialog box is displayed. Enter a name (DesignTableO in the
example below) and a comment for the design table.

Creation of a dezign table
Mame:  |DesignT abled
Camment : [This design table was created by CRE on 03/30/99

(_) Create a design table fram a preesisting file

¥ Create a design table with current pararneters values

-t el = RO
J RN TanieE TTom

Padwsidih frim]
12
T 3cm

o 0Ok I ﬂl:ancell

3. Check the 'Create a design table with current parameter values' option. Click OK. The 'Select
parameters to insert' dialog box is displayed.

4. In the 'Parameters to insert' list, select the Part Body\ Pad. 1\ Fi r st Li m t\ Lengt h then click

Add. Repeat the same operation with the Par t Body\ Pad. 1\ SecondLi m t\ Lengt h item. Both
items are displayed in the 'Inserted parameters' list.



Select parameters to inzert

Filter On Fart]

Filker Marne : [

Filter Type ; |41 =]
Farameters to ingert Inzerted parameters
1=[s h s adius PartB odyPad. 1 4FirstLimitsLength
FartBody 1'Huole hgle PartB odyPad. 145 econdLimit,Length

FartBody'H -:ule:1 "»Diameter-
PartBodysHole. 1 s chivity
b aterial

#dd: E Remowve !

@ 0K l ﬂl:ancell

5. Click OK. A file selection box is displayed.

6. Specify the pathname of the design table to be created. Click OK in the file selection dialog box.
The DesignTableO feature is added to the specification tree and a dialog box displays the newly
created design table. This design table contains only one configuration. By default it is active.

DezignT ablel active, configuration row : 1

:.... DESign T-E||:||E.' P[DpertiES e e e e e o
ENEIITIE 7 ]DesignTabIeD o Activity
il:'I'lTIITIEﬂt iiThis design table was created by CRE on 05406433

i Configurations ! Azsociations

......................................... +
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7. Click Edit table... to start an Excel application (under Windows NT) or open the text editor under

Unix.
Replace the Par t Body\ Pad. 1\ Fi r st Li m t\ Lengt h parameter value with 80mm.

8. Save your Excel or .txt file and close your application.
9. Click Apply into the CATIA design table dialog, the document is updated as well as the CATIA
design table.

10. Click Cancel if you want to undo your last interaction. Otherwise click OK.
KwrDesignTable0.CATPart is the resulting document. KwrCreatedDesignTable.xls is the design

table created.




A design table can only be created from non-constrained parameters, i.e. from parameters which are

& neither referred to in an active design table nor used in any other active relation. If you keep the 'Activity'
option checked for DesignTableO and try to create another design table, you will have to select the
parameters to add to your second design table among a restricted parameter list. Uncheck the 'Activity'
option if you want to deactivate a design table and reuse its parameters in another design table.
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Creating a Design Table from a Pre-existing File

A design table can be created from a pre-existing file:

@ either by associating automatically the document parameters with the table columns. All the parameters common
to your document and the input file columns are added to the design table
@ or by associating one by one the document parameters with the input file columns.

Associating Automatically Table Columns with Parameters

E 1. Open the KwrStartDocument.CATPart document.
= @
2. Click the Design Table icon in the standard toolbar.
The "Creation of a Design Table" dialog box is displayed. Enter a name (DesignTablel for example) and a
comment.
3. Check the 'Create a design table from a pre-existing file' option. Click OK.

4. Select the KwrBallBearing.xls file. Click Open. The following dialog box is displayed.

Automatic aszociations?

5. Click Yes. The Material parameter is the only one which is common to the document parameters and to
the external design table. The following design table is created. The '<' and '>' symbols denote the current
configuration.

DeszignT able1 active. configuration row - 1
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6. Select the configuration you want to apply to the document (line 5 for example). Click Apply.
The Iron parameter value is displayed in the specification tree.

7. Click OK to end the design table creation. KwrDesignTablel.CATPart is the resulting document.

A5




Associating One by One Table Columns with Parameters

E 1. Open the KwrStartDocument.CATPart document.

oA

2. Click the i Design Table icon in the standard toolbar.
The "Creation of a Design Table" dialog box is displayed. Enter a name (DesignTable2 for example) and a
comment.

3. Check the 'Create a design table from a pre-existing file' option. Click OK. A file selection panel is displayed.
Select the KwrBallBearing.xls file. Click Open. The "Automatic associations ?" dialog box is displayed.
5. Click No. The following dialog box is displayed.

DesignT able? active E
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Now, you have to associate one by one the document parameters with the design table columns.

6. Click the 'Associations' option. The table design dialog box now displays side by side the document
parameter list and the input file columns.

7. In the 'Parameters' list, select the Par t Body\ Hol e. 1\ Di anet er item. In the 'Columns' list, select the d
parameter. Then click Associate. A parameter couple is now displayed in the 'Associations between
parameters and columns' list.

8. Repeat the same operation for the Material parameter.
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Selecting a parameter or an association in the list highlights the corresponding values in the geometry area.

The parameter list can be filtered:

@ either by clicking on a feature (either in the specification tree or in the geometry area). All the
parameter values of the selected feature (and children) are highlighted in the geometry area. The
parameter list displays only the parameters of the selected features (and children).

@ Dby specifying a string in the 'Filter Name' field. For example, typing *ength* displays all Length
parameters

@ Dby specifying a type in the 'Filter Type' field.

The 'Create parameters..." button allows you to create automatically parameters and associations for items
of the 'Columns'’ list. The 'Rename associated parameters' button replaces the parameter name with the
column name.

. Click OK to end the DesignTable2 creation dialog.

The DesignTable2 feature is added as a relation to the specification tree. Double-click DesignTable2 in the
specification to edit the table. By default, the configuration <1> is applied to the document. A new material
(Aluminum) is applied to the document and the hole diameter is modified. KwrDesignTable2.CATPart is the
resulting document.

You can select another configuration and apply it to your document.

As long as a design table is active, the parameters which are declared in it are constrained parameters and you
are not allowed to modify them.

Double-clicking a design table in the specification tree displays the design table with its set of configurations and
allows you to select a new configuration.

#7
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Programming the Design Table Access

CATIA provides you with functions to access the values of a design table. These functions are
described below. You will have to use them with other functions and parameters in formulas,
rules or checks (for those of you using the Knowledge Advisor product).

CellAsReal

CellAsBoolean

CellAsString

CloserInfConfig

CloserSupConfig

CloserValuelnfInColumn

CloserValueSupInColumn

LocatelnColumn

MaxInColumn

MinInColumn

Question

You don't need to create associations interactively to use these functions.

¢ ¢

L SO TN T T O O O S

In the design table function documentation, you can access code samples by clicking 'Sample
code'. Click 'Design Table' to display the related design table. When you find an interesting
sample, you can Copy/Paste it to your formula, rule or check editor. The
KwrProgramDT.CATPart document illustrates how to use the design table access functions.

Values returned by functions must be declared as user parameters before being used in

relations.
éhnut the Design Table a Izing a Dezign Takle Programming the Deszign Tak
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Closer SupConfig Function

Description

Returns the configuration which contains the smallest values grreater or equal to the values of the given arguments. When several
configurations meet this condition, the function sorts out the possible configurations with respect to the column order asit is specified in the
argument list.

Syntax

Closer SupConfig(DesignTableName, RowNamel, Valuel, RowName2, Value2 ...)

The Closer SupConfig function takes the following arguments:

Argument Description
DesignTableName Required. Should be put in quotes.
RowNamel Should be put in quotes. At least, one couple RowName/Valueis required
Valuei Required. Y ou should specify the units.
Example
Given the design table below:
Sket chRadi us( nmm) PadLi mL( mm) PadLi n2( mm

1 120 60 10
2 130 50 30
3 120 60 25
4 140 50 40

The statement below returns 3:

C oser SupConfi g("DT1", "PadLinml", 60mm "SketchRadius", 120nm " PadLi n2",
20mm




Question Function

Description

Displays amessage in adialog box, waits for the user to click a button and returns a value indicating which button the user clicked (true if Yes
was clicked, falseif No was clicked)

Syntax

Question(Sring [# Sringl # Sring?2 ..., ParamlName, Param2Name, ...] )

The Question function takes one required argument and several optional arguments depending on whether parameter values are to be
displayed in the message.

Argument Description

Sring Required. String to be displayed in the dialog box (should be put in quotes).

# Sringl, ParamlName... Optional. When parameter values are to be displayed within the message, the arguments should be specified
asfollows:

e oOnestring in quotesincluding a # symbol wherever a parameter valueis to be displayed
e asmany [, parameter name] statements as parameter values declared with a"#" in the message.

Usethe"|" symbol to insert a carriage return in a prompt.
Example

Boolean2 =
Question("SketchRadiusis# | Do you want to change this value ?',PartBody\Sketch.1\Radius.3\Radius )




Using a Design Table

A design table is a feature that you create either from your document parameters or from
external data. No matter the existence of external data, you must create the design table in
CATIA. The design table creation process includes the following steps:

Creating a design table from a pre-existing file

1.
2.

3.

or

select the pre-existing file containing the raw data.

create the associations between the document parameters and the external table
columns. You can choose to create these associations automatically.

edit the CATIA design table generated.

select a configuration in the generated design table. You can modify the default
configuration proposed by CATIA.

apply the design table feature to your document.

Creating a design table from current parameter values

1.

ok wnN

create a table from the document parameters.
select the parameters to add to the design table.
specify a file to contain the design table generated.
edit the CATIA design table generated.
apply the design table to your document.
A design table is a knowledgeware feature which behaves like any CATIA feature. For

example, you can edit it from the specification tree by double-clicking it or by selecting
the feature.object->Definition function from the contextual menu.

When a parameter is constrained by a design table, the "Edit Parameter" dialog box
which is displayed when you double-click it in the specification tree, gives you an
access to the design table through the design table icon.
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Behavior

Create a behavior

E Click the icon and write your script in the editor which is displayed.

M anipulate automation objects

You can only manipulate the objects which are below the Shape object in
E & the automation object hierarchy.
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Creating a Behavior

@ Abehavior is a set of VB Script operations you associate with a feature. These operations are executed
&= Wwhen the feature responds to a given event. At present, only a feature which is dragged and dropped can
be assigned a behavior. This task explains how to proceed to create a behavior.

E 1. Create a box or a pad similar to the one below:

-
-I-E‘ Biox:

& vy plane

|3|| Farameatars

l ¢ FanBio ||1

-'L— ] Boxl
.t!.-_ Ei Sleetch:l
—[ Holel

L

|
=4 Sketchd

Select the Box item in the specification tree.
In the Start menu, select Infrastructure-> Knowledge Advisor workbench
Select the Hole2 feature either from the geometry area or from the specification tree

Click the Behavior icon. The behavior dialog box is displayed. At present the list of events that can
be referred to in a behavior is limited to the Drag & Drop event.

Enter a behavior name
7. Copy/Paste the code below from your browser to the edition box of the behavior editor.

ahrwbd

o

MsgBox( " Hol e2 has been dropped")
MyEvent . Get Dr oppedFeat ure. Type = 2

8. Click OK. A behavior is added to the specification tree.

9. Go back to the Part Design workbench (double-click the document in the geometry area for
example)

10. Drag and drop the Hole2 feature so that it gets closer to Holel. The message box below is
displayed:

This is what y(')'u' can see now onscreen. The Hole2 feature has been converted to a type2 hole (i.e.
a counterbored hole).



This example is a simple illustration of how you can create a behavior and how it operates when it is
applied to a feature. To create a full-featured behavior application, you must have a good handle on
the VB Script language as well as all the automation objects that can be accessed in VB Script.

Up { Creating a Behawvior Eipulaﬁng Feature Attribwd
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Manipulating Feature Attributes

Not all the features can be accessed and modified in a behavior. You can only manipulate the objects which are below the
Shape object in the automation object hierarchy. Here is an example which illustrates how to manipulate feature attributes.

"@" The feature to be dragged and dropped is a simple type hole. When the behavior is executed:
| — 1. the following hole properties are displayed in a Visual Basic message box:

@ the feature type,
& the feature name
& the hole diameter.

2. the user is prompted
@ either to click OK to modify the hole properties after it is dropped. New property values will be:
@ hole (type =2
@ diameter = 10.0

@ head diameter = 20.0.
@ ortoclick Cancel and just drop the initial hole without modifying its properties.

E 1. Create a pad with at least a simple type hole to be dragged and dropped.
s 2. Select the root feature and access the Knowledge Advisor workbench.
3. Select any hole feature either in the geometry area or in the specification tree

4. Click the icon. The Behavior editor is displayed.
5. Copy/Paste the code below from your browser to the behavior editor.

Di m Feat ureType, FeatureNane, Hol eType

Feat ureType = TypeNane( MEvent. Get Dr oppedFeat ur e)

Feat ureName = MyEvent. Get Dr oppedFeat ur e. Nane

Hol eType = MyEvent. Get Dr oppedFeat ur e. Type

Str1="The feature to be dropped"

Str2=Strl & vbCrLf & "is a " & FeatureType & " type feature"

Str3=Str2 & vbCrLf & "Its nane is '" & FeatureNane & "'"

Str4=Str3 & vbCrLf & "Its initial diameter is " & MyEvent. Get DroppedFeat ure. Di aneter. Val ue & vbCrlLf
Str5=Str4 & vbCrLf & "Unless you click Cancel, it will be converted into a counterbored hol e"

Di m MyBox

MyBox = MsgBox (Strb5, 1)

if MyBox = 1 then

MyEvent . Get Dr oppedFeat ure. Type = 2

MyEvent . Get Dr oppedFeat ur e. HeadDi anet er. Val ue = 20.0
MyEvent . Get Dr oppedFeat ure. Di aneter. Value = 10.0

End If
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The behavior editor looks now something like this:
Behaviour

M ame iDrnppedHnle YW'hen 1E.-'-‘«TDn::pFeatureE wet

Dim FeatureT ype, FeatureM ame, HoleT ype

FeatureType = TypeM ame[MyE vent GetDroppedFeature]
FeatureM ame = MyE vent. GetDroppedFeature. Hame
HaoleTppe = MyEwent. GetDroppedFeature. Type

Str1 = "The feature to be dropped"

Stre =5t & wbCrLf & "z a " & FeatureType & "' type feature"
Strad = S5t & wbCrLf & Ytz name iz "' & FeatureM ame & ™
Std = Sk & wbCrLf & Vs imabial diameter 1z ' & MyEvent. GetDroppedFeature.Diameter W alue & «bCrLf |
b5 = Strd & wbCrLf & "Unleszs vou click Cancel, it will be converted into a counterbored hole"

| »

Crirn bAyE o
b pBox = MsgBox [SH5,1] [0

@ 0K | @ Cancel |

Click OK. The DroppedHole behavior is added to the Hole feature in the specification tree.

Go back to the Part Design workbench (double-click the document for example).

Drag and drop the Hole object. The Hole attribute values are displayed within a Visual Basic dialog box.

Click OK to convert the dragged hole into a counterbored hole or click Cancel to drop it and don't modify its properties.

© ® N

& The Name property returns the name of the feature after it has been dragged. This name is not the initial feature
name. It is the name that CATIA assigns by default to the dropped feature.

#3%

Lp Cresting a Behaviar ?anipulating Feature Attribud

l—'E:L !EL



Workbench Description

The Knowledge Advisor Menu Bar

The menu bar which is available in the Expert Knowledge workbench is the standard one.
Refer to the CATIA Menu Bar for more information.

The Knowledge Advisor Toolbar

The figure below describes the Knowledge Advisor toolbar.

SR =<l |  On the figure opposite, click an icon to display the
| o [FE 0y documentation of the task directly associated with the
fay LB ;ﬂ' Lﬁ*E icon.

"

Here is a brief description of each icon.

@ The Rule Editor icon provides access to the rule editor. Click this icon to create a
rule, write its code, test its syntax and apply it to your document.

ﬁ The Check Editor icon provides access to the check editor. Click this icon to create
a check, write its code, tests its syntax and apply it to your document.

;o The Knowledge Inspector icon allows you to query a design to determine and
preview the results of changing any parameters without committing themselves to
actually changing the design.

® The Behavior icon is a means to create a script specifying how to change some
feature attributes when an event occurs. Clicking this icon opens a behavior editor.
A behavior is to be written in Visual Basic language.



Infrastructure Menu Bar
This section presents the main menu bar available when you run the application and before creating or opening a document.

Start File Edit View Insert Tools Windows Help

Start

The Start menu is a navigation tool intended to help you toggle between different workshops. The contents of the Start menu vary according to the
confogurations and/or products installed. For more information about the Start menu, refer to "Accessing the Navigation Tools".

File

= [T Edit  Wiew Insert For... See...
D Mew... Ctrl+M New... Creating New Documents
@ Open... Ctrl+0 . L
Open... Opening Existing Documents
Cloze
. Close Closing Documents

Save Chrl+5

Save fs Save Saving Existing Documents

Save Al Save As  Saving Documents For the First Time or Under Another Name

Saving Documents In Other Formats

= Print..  CtiP

Desk... Save All  Saving All Documents
Send To k
Print... Customizing Print Settings Before Printing Your Documents
Contents...
; Desk... Using the FileDesk Workbench
1 Prink. CAT Part
- Send To Transferring CATIA Version 5 Data
Exi
Edit
[EF For... See...

Undo Undoing Actions

Redo Recovering Last Action Undone
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Quick Reference

Parameters

Create auser parameter

ﬁt] Select a type in the 'New Parameter of type' list, then click 'New Parameter of

type'.

Edit/modify a user parameter

or

or

Select the parameter to be edited in the "Formulas" dialog box,
then modify its value in 'Edit name, value or formula' .

In the specification tree, double-click the parameter to be edited,
then modify its value in the "Edit Parameter" editor.

In the specification tree, right-click the parameter to be edited,
then select the Parameter.object->Definition function from the contextual menu.

Add a comment to a user parameter

or

In the "Formulas" dialog box, right-click the value field in 'Edit name, value or
formula’,
then select 'Edit Comment..." from the contextual menu.

Whatever the edition box, right-click the value field(s), then select 'Edit
comment..." from the contextual menu.

Add a tolerance to a magnitude type parameter

or

In the "Formulas" dialog box, right-click the value field in 'Edit name, value or
formula’,
then select 'Add Tolerance' from the contextual menu.

Whatever the edition box, right-click the value field(s), then select ‘Add
Tolerance..." from the contextual menu.

Specify lower and upper bounds




feo

In the "Formulas" dialog box, right-click the value field in 'Edit name, value or
formula’, then select 'Add Range' from the contextual menu.

Whatever the edition box, right-click the value field(s),
then select 'Add Range..." from the contextual menu.

Specify an increment/decr ement amount

fea

or

In the "Formulas" dialog box, right-click the value field in 'Edit name, value or
formula’,
then select 'Change Step' from the contextual menu.

Whatever the edition box, right-click the value field(s), then select 'Change
Step..." from the contextual menu.

Specify the Material parameter value

or

or

Y
select the Material parameter in the specification tree, then click &2 .

Double-click the Material parameter in the specification tree, then enter the
material value in the dialog box.

In the "Formulas" dialog box, select the Material parameter in the parameter list,
then modify its value in 'Edit name, value or formula'.

Update the M echanical Property parameters

Select the Properties->Mass option from the feature contextual menu and click OK.

Import parameters

In the "Formulas" dialog box, click | nport. ... Afile selection dialog box is
displayed. Select either a .xls file(Windows NT only) or a .txt file.

Delete a parameter

fea

Select the parameter to be deleted in the "Formulas" dialog box, then click
'‘Delete Parameter' .



or In the specification tree, right-click the parameter to be deleted,
then select the Delete function from the contextual menu.
Formulas

Createaformula

or

or

or

feo

feo
feo

In the "Formulas" dialog box, select the parameter to be constrained, then click
'‘Add Formula'. Enter the formula in the "Formula Editor".

In the "Formulas" dialog box, select the parameter to be constrained, then
enter the formula in 'Edit name, value or formula'.

In the "Formulas" dialog box, double-click the parameter to be constrained and
enter the formula in the "Formula Editor".

When editing a parameter, right-click the value field(s),
then select Formula->Edit from the contextual menu.

Edit/modify a formula

or

or

or

or

feo

In the parameter list of the "Formulas" dialog box, select the parameter defined
by the formula,
then modify the formula in 'Edit name, value or formula'.

In the specification tree, right-click the formula to be edited,
then select the Formula.object->Definition function from the contextual menu.

In the specification tree, double-click the formula to be edited.

In the specification tree, double-click the user parameter, then click the f(X)
button in the "Edit Parameter" dialog box.

When editing a parameter, right-click the value field(s),
then select Formula->Edit from the contextual menu.

Activate/deactivate a formula




feo

or ﬁ“]

or

or

In the parameter list of the "Formulas" dialog box, select the parameter which is
constrained by the formula to (de)activate and use the Activate/Deactivate
check box right of the 'Edit name, value or formula' field.

In the parameter list of the "Formulas" dialog box, select the formula/activity
parameter and modify its value in 'Edit name, value or formula'.

In the specification tree, right-click the formula whose activity is to be modified,
then select the Formula.object->(De)activate function from the contextual
menu.

When editing a parameter constrained by a formula, right-click the value
field(s),
then select the Formula->(De)activate function from the contextual menu.

| mport parameters and formulas

feo

In the "Formulas" dialog box, click 'Import’, then specify the import file path.
The import file should be either a .txt file or a .xIs file.

Delete a formula

or

or

Rules

In the parameter list of the "Formulas" dialog box, select the parameter which is
constrained by the formula to be deleted, then click 'Delete Formula'.

In the specification tree, right-click the formula to be deleted, then select the
Delete function from the contextual menu.

When editing a parameter constrained by a formula, right-click the value
field(s),
then select the Formula->Delete function from the contextual menu.

Createarule




R Enter the rule name and comments. Then write your rule in the rule editor.
To enter a parameter within a rule, you can:

@ either click the parameter in the specification tree
@ or click the dimension displayed in the geometry area
@ or use the editor dictionary.

Edit/modify arule

In the specification tree, double-click(twice) the rule to be edited.

or In the specification tree, right-click the rule to be edited,
then select the Rule.object->Edition function from the contextual menu.

Activate/deactivatearule

In the specification tree, right-click the rule to be activated or deactivated,
then select the Rule.object->(De)activate function from the contextual menu.

or f‘ﬁ In the parameter list of the "Formulas" dialog box, select the rule/activity
parameter modify its value in 'Edit name, value or formula'.

Deletearule

In the specification tree, right-click the rule, then select the Delete function
from the contextual menu.

Checks

Create a check

$ Enter the check name and comments. Then write your check in the check
E editor. To enter a parameter within a check, you can:

@ either click the parameter in the specification tree
@ or click the dimension displayed in the geometry area
@ or use the Dictionary.



Edit/modify a check

In the specification tree, double-click the check to be edited.

or In the specification tree, right-click the check to be modified,
then select the Check.object->Edition function from the contextual menu.

Activate/deactivate a check

In the specification tree, select the check to be activated or deactivated,
then select the Check.object->(De)activate function from the contextual menu.

or ﬁt] In the parameter list of the "Formulas" dialog box, select the check/activity
parameter and modify its value in 'Edit name, value or formula'.

Delete a check

In the specification tree, right-click the check to be deleted, then select the
Delete function from the contextual menu.

Design Table

Create a design table from the document parameter values

i Check the option "Create a design table with current parameter values".
Select the parameters to insert, then specify the .xIs (Windows™) or .txt file
where the design table is to be created.

Create a design table from a pre-existing file

Check the option "Create a design table from a pre-existing file". Specify the
file containing the design table data, then create the necessary associations.



Edit a design table

In the specification tree, double-click the design table.

or In the specification tree, right-click the design table to be edited,
then select the DesignTable.object->Edition function from the contextual menu.

or If a parameter is constrained by a design table, double-click it in the
specification tree, then click the design table icon in the "Edit parameter”
dialog box.

Delete a design table

In the specification tree, right-click the design table to be deleted, then select
the Delete function from the contextual menu.

Program the design table access

9

CellAsReal

Returns the contents of a cell located in a column intended for real
values.

CellAsBoolean

Returns the contents of a cell located in a column intended for boolean
values.

CellAsString

Returns the contents of a cell located in a column.

CloserInfConfig

Returns the configuration which contains the largest values less or
equal to the values of the given arguments.

CloserSupConfig

Returns the configuration which contains the smallest values grreater
or equal to the values of the given arguments.
CloserValuelnfiInColumn

Scans the values of a column and returns the smallest cell value which
Is the nearest to a specified one.

CloserValueSupInColumn

Scans the values of a column and returns the greatest cell value which
Is the nearest to a specified one.
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@ LocateInColumn
Returns the index of the first row which contains a specified value.
@ MaxIinColumn
Returns the greatest of a column values.
@ MinInColumn
Returns the smallest of a column values.
@ Question
Displays a message in a dialog box, waits for the user to click a button
and returns a value indicating which button the user clicked.

Behavior

Create a behavior

E Click the icon and write your script in the editor which is displayed.

M anipulate automation objects

E’ All objects below the Shape object can be manipulated in a behavior.



Case Study

A bearing is defined by parameters such as its principal dimensions, its basic load ratings, its limiting speeds
and its mass. It belongs to a category which corresponds a certain range of its parameter values. In a
catalogue, a bearing is referred to by a designation. Bearing types are described by tables which define the
bearing parameter values including the designation.

The bearing example has been chosen here because the bearing tables given in distributor and retailer
catalogues illustrate quite well the design table principles. The bearing itself is a good example of how
components within a mechanical part can be constrained by relations.

The Data you Need to Perform the Scenario

The required data is delivered with the Knowledge Advisor product.
The starting document KwrBallBearing0.CATPart
The bearing design table KwrBallBearing.xls
An import file KwrBallBearinglmport.txt

A CATScript macro KwrMacrol.CATScript

When creating Rule4 in your own environment, you should replace the pathname given as the argument of
the LaunchMacroFromFile function with the pathname corresponding to the file where the macro has been
unloaded.

Some Explanations about your Starting Document

The document we start from in this case study is a part inspired by the SKF deep groove ball bearing with
Designation 623. Our purpose here is not to design an industrial ball bearing but to use a ball bearing as a
basis to illustrate the CATIA knowledgeware capabilities.
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Here are some details about the part design, the document initial parameters and its relations.
The Document Parameters

The bearing rings are coaxial shafts created from the Sketch.1 and Sketch.2 features. The balls are shafts
created from the Sketch.4 feature. To find out the role played by the various parameters, proceed as follows:

1. In the specification tree, expand the PartBody feature and slide the cursor on the Sketch.1 feature The
sketch used to create the outer bearing ring is highlighted in the geometry area.

2. To identify the sketch.1 parameters:
1. double-click sketch.1 in the specification tree
2. click the formula icon
3. in the parameter list:

@ select B.

The B dimension is highlighted in the geometry area. Its value is set to 4mm. It defines
the total bearing width.




@ selectlL2
The L2 dimension is highlighted in the geometry area. Its initial value is set to 1mm and
you can note it is constrained by a formula. Repeat the same operation with L3. L2 and
L3 play a symmetric role in the sketch definition.

@ selectD
The D dimension is highlighted in the geometry area. Its value is set to 5 mm. D defines
the bearing outside radius (or external radius of the outer ring) . Repeat the same
operation with D1 which defines the internal radius of the outer ring.

@ CentreAxel defines the groove center.

3. Use the same method for the other parameters.
The Relations

Take a look at the formulas and rules added to the document. The ball radius is constrained by the groove
radius which is itself calculated from Sketch.1 parameters. The rules allow you to:

@ define geometric parameters with respect to others
@ ensure the sketch.1 and sketch.2 consistency
@ and define the ball number.

All these relations define the bearing geometry. At this stage of the exercise, it is not recommended to
modify them.

The Step-by-Step Procedure

| ]

Ie) A design table is created from a pre-existing file. The data set contained in this pre-existing file
===, IS quite similar to the data set which identifies a bearing in a catalogue. The design table which
is created defines a number of configurations. Applying a new configuration results in a bearing
modification.

E 1. Open the KwrBallBearing0.CATPart document.
i, ﬁ

2. Click the Design Table icon in the standard toolbar.

Check the "Create a design table from a pre-existing file" option. Click OK.

4. Select the KwrBallBearing.xls file and associate automatically the design table columns
and the document parameters.

5. In the "Design table" dialog box, select the configuration 8.
Your ball bearing has changed. It is now a silver bearing. You can tell the difference when
you look at the geometry area. The bearing width is also modified. Click OK to exit the
Design Table dialog box. Keep your document open and proceed to the next task.

#7%

A Cost parameter is defined as a function of the ball number. Creating a check provides you
B With a means to be warned whenever the bearing cost is too high.

w

| ]
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1. Click the ﬁ?] icon.

2. Create a new user parameter of real type and constrained by the Cost = 3 * BallNumber
formula. To do so:

. Select Real in the type list and click 'New Parameter of type'.

. In 'Edit name, value or formula’, replace the Real.1 string with Cost, then press Enter.
. Click 'Add Formula'.

. Enter the 3 * BallNumber formula in the "Formula Editor". Click OK.

. Click OK in the "Formulas" dialog box to add the Cost parameter.

3. Create a check warning you when the Cost value is greater than 80. To do so:

1.

2.
3.
4,

5.

Access the Knowledge Advisor workbench

Click the ”{ icon.
Enter the CostCheck string in the Name field of the first dialog box. Click OK

In the "Check Editor", select the Warning type and enter the string "It is too
expensive" in the message field. Then enter the Cost <= 80 relation in the edition box.

Click OK to create your check and exit the editor. At this stage, no particular message
is displayed.

4. In the specification tree, double-click the design table and select the configuration 12. Click
OK. The message "It is too expensive" is displayed.
Keep your document open and proceed to the next task

#7%

A multiple value parameter is created. Depending on this parameter value, a rule displays a
message or launches a macro.

1. Click the fm icon.
2. Create a new user parameter of string type and multiple values. To do so:

v

v

v

Select 'String' in the type list, select 'Multiple values' then click ‘New Parameter of
type'.

In the "Value List of String" dialog box, enter one-by-one the stepl, step2 and step3
values. Click OK.

In 'Edit name, value or formula’, replace the String.1 string with Status, then click
OK.

3. Create a rule which, depending on the Status parameter value, either displays a message
asking you to import a file, or launches a macro, or does not modify anything. To do so:

v

v
v

Access the Knowledge Advisor workbench

[{e3]
Click the icon.
Enter the Rule4 string in the Name field of the first dialog box. Click OK



& Copy/Paste the code below into the rule edition box.

if Status == "step2"

Message("Import the KwrBallBearinglmport text file™)
else if Status == "step3"
LaunchMacroFromFile("e:/tmp/KwrMacrol.CATScript")

@ Click OK to add the rule to the document and execute it.

4. Click the fw icon. In the "Formulas" dialog box, select the Status parameter and replace its
stepl value with step2. Click OK. A message asks you to import the KwrBallBearinglmport
text file.

5. Click 'Import’ and select the KwrBallBearinglmport.txt file. Three parameters are then
added to the document. Click OK in the dialog box displaying the parameters and formulas
to be imported.

6. Select the Status parameter and replace the step2 value with step3. Click OK. The
KwrMacrol.CATScript is executed and a rod is created.

In the final document, double-click the Material parameter in the specification tree. In the "Edit

Parameter” box which is displayed, click =i to display the design table which constrains the
Material parameter.

The resulting document is KwrBallBearingResult. CATPart.

#5



Glossary

Many of the definitions included in this glossary are only pertinent within the CATIA
knowledgeware context.

Nonalphabetic Terms

| (operator)

Breaks a single line message into a multiple line message. Can only be used in the
Message function when programming rules and checks.

.CATScript

The extension of a macro file generated by CATIA Version 5. A macro file can be
specified as the argument of the LaunchMacroFromFile function which can be called in
rules and checks.

Ixt

The extension of a human-readable file composed of text characters. This file format can
be used as an import file format when importing parameters and formulas.

Xls

The extension of an Excel file. This file format can be used as an import file format when
iImporting parameters and formulas under Windows™.

A

activity

A property which defines whether a relation is applied to a document or not. The activity
value is either t r ue or f al se. It is indicated by an icon in the specification tree and can
also be read in the document parameter list.

association

A link between a document parameter and its equivalent parameter in an external design
table. Associations are to be created when the document parameter names do not
correspond exactly to the parameter names read in the design table.

B

behavior
A set of operations to be executed as a reply to a particular event occurring on a feature.



C

check

A set of statements intended to give you a clue as to whether certain conditions are
fulfilled or not. A check does not modify the document it is applied to. A check is a
feature. In the document specification tree, it is displayed as a relation that can be
activated and deactivated. Like any feature, a check can be manipulated from its
contextual menu.

configuration

A row in the design table. A configuration is a consistent set of parameter values that can
be applied to a document.

D

design table

A table containing values to be potentially applied to a document to manage its parameter
values. It can be created from the document parameters or from an external file. A design
table is a feature. In the document specification tree, it is displayed as a relation that can
be activated or deactivated. Like any feature, a design table can be manipulated from its
contextual menu.

dictionary

The set of parameters, operators, keywords, functions and other components that make
up the language to be used to write formulas, rules and checks. The formula, rule and
check editors provide you with an interactive view of the dictionary.

~

formula

A relation specifying a constraint on a parameter. The formula relation is a one-line
statement. Its left part is the parameter to be constrained, the right part is a relation taking
as its variables other parameters. A formula is a feature. In the document specification
tree, it is displayed as a relation that can be activated or deactivated. Like any feature, a
formula can be manipulated from its contextual menu.



K

knowledgeware

The set of software components dedicated to the creation and manipulation of
knowledge-based information. Knowledge-based information consists of rules and other

types of relations whereby designers can save their corporate know-how and reuse it
later on to drive their design processes.

Knowledge Inspector

An analysis tool which helps users understand how changing any property of their design
(such as material, pressure, or a dimensional parameter) changes the operation or design
of the product on which they are working. The Knowledge Inpector offers two options:

@ "What if" to examine interactions of parameters with each other and with the rules that
make up the product’s specifications

@ "How to" to see how a design can be changed to achieve a desired result

M

magnitude type parameter

A parameter whose value is defined by a quantity expressed in specific units. Length,
Angle, Time parameters are magnitude type parameters. Boolean, Real, String and
Integer parameters are not magnitude type parameters.

P

parameter
A feature defining a document property.

R

relation

A knowledgeware feature which, depending on certain conditions:
@ sets parameter values
@ displays a message
@ orruns a macro.



Knowledgeware relations are formulas, checks, rules and design tables.
rule

A set of instructions, generally based on conditional statements, whereby the relationship
between parameters is controlled. In addition, depending on the context described by the rule
instructions, CATIA macros can be executed and messages can be displayed. A rule is a
feature. In the document specification tree, it is displayed as a relation that can be activated or
deactivated. Like any feature, a rule can be manipulated from its contextual menu.

W

wizard

A form of user assistance that guides the user through a difficult or complex task within
an application. The formula wizard helps the user typing formulas by picking up parameters
either in the dictionary, or in the geometry area or in the specification tree.



