The CATIA Version 5 Part Design application makes it possible to design precise 3D mechanical parts with an intuitive and flexible user interface, from sketching in an assembly context to iterative detailed design. CATIA Version 5 Part Design application will enable you to accommodate design requirements for parts of various complexities, from simple to advanced.

This new application, which combines the power of feature-based design with the flexibility of a Boolean approach, offers a highly productive and intuitive design environment with multiple design methodologies, such as post-design and local 3D parameterization.

As a scalable product, CATIA Version 5 Part Design can be used in cooperation with other current or future companion products in the next CATIA generation such as CATIA Version 5 Assembly Design and CATIA Version 5 Generative Drafting. The widest application portfolio in the industry is also accessible through interoperability with CATIA Solutions Version 4 to enable support of the full product development process from initial concept to product in operation.

The Part Design User’s Guide has been designed to show you how to create a part. There are several ways of creating a part and this book aims at illustrating the several stages of creation you may encounter.
About This Product

This book is intended for the user who needs to become quickly familiar with CATIA-Part Design Version 5 Release 3 product. The user should be familiar with basic CATIA Version 5 concepts such as document windows, standard and view toolbars.

To get the most out of this guide, we suggest you start reading and performing the step-by-step tutorial Getting Started. This tutorial will show you how to create a basic part from scratch.

The next sections deal with the handling of CATPart data, then the creation and modification of various types of features you will need to construct parts. This guide also presents other Part Design capabilities allowing you to design complex parts. You may also want to take a look at the sections describing the Part Design menus and toolbars at the end of the guide.
Where to Find More Information

Prior to reading this book, we recommend that you read the CATIA- Infrastructure User's guide Version 5 and CATIA-Dynamic Sketcher User's Guide Version 5.

## What's New?

### General

- **New task:** [Draft analysis](#)
- **New task:** [Curvature analysis](#)
- **Enhanced:** [Update](#)
- **Enhanced:** [Replace](#)

### Features

- **New task:** [Loft](#)
- **New task:** [Remove lofted material](#)
- **Enhanced:** [Draft](#)
- **Enhanced:** [Pocket, hole](#)
- **Enhanced:** [Rectangular pattern, circular pattern, user pattern](#)
- **Enhanced:** [Variable radius fillet](#)
Getting Started

Before getting into the detailed instructions for using **CATIA Version 5** Part Design, the following tutorial aims at giving you a feel as to what you can do with the product. It provides a step-by-step scenario showing you how to use key functionalities.

The main tasks described in this section are:

- Entering the Part Design Workbench
- Sketching a Profile
- Creating a Pad
- Drafting a Face
- Filleting an Edge
- Editing the Pad
- Mirroring the Part
- Sketching a Circle from a Face
- Creating a Pocket
- Shelling the Part

All together, the tasks should take about ten minutes to complete.

The final part will look like this:

Now, let’s get to sketching the profile!
1. Select the File -> New commands (or click the New icon). The New dialog box is displayed, allowing you to choose the type of document you need.
2. Select Part in the List of Types field and click OK. The Part Design workbench is loaded and an empty CATPart document opens.

The commands for creating and editing features are available in the workbench toolbar. Now, let's perform the following task Sketching a Profile to see the Sketcher workbench.
Sketching a Profile

In this task you will learn how to:

- enter the Sketcher workbench
- create the profile which you will later extrude to create a pad

1. Click the Sketcher icon to start the Sketcher workbench.

2. Select xy plane to define the sketch plane.

Now, the Sketcher workbench is displayed. It contains the tools you need to sketch any profile.

The Select command is the default Sketcher mode.
The grid you can see has been designed to make your sketch easier to do. You can redefine the grid of your choice or simply hide it using the Tools -> Options... Sketcher tab command.

Before starting, we recommend to zoom out. Now, start to sketch your profile.

3. Click the Profile icon 🌋. Activating this command displays three options in the Tools toolbar. The Line command 🔄 is activated by default.

4. First, create a line: click a point, drag the cursor and click a second point to end your first line. CATIA uses a green symbol to call your attention on the line property. This line is horizontal.

5. Click at the points as shown to sketch two additional lines: CATIA uses another green symbol to mention that the second line you created is vertical.

6. To end the profile, click at the starting point. The profile now looks like this:
7. To complete the profile shape, create two arcs tangent to two lines: click the Corner icon. Activating this command displays the Corner toolbar which contains three options. The Corner trim all command is activated by default.
8. Select both lines as indicated.
   The lines are then joined by a rounded corner which moves as you move the cursor.
9. Click in the area as shown to define the first corner:

Your first corner is created. Do not be concerned about the radius value. You will modify it later.
10. Now, click anywhere outside the sketch to unselect the corner and repeat the operation to create a second corner at the bottom of the profile.

You should obtain this:

The alternative method for creating a corner consists in selecting the intersection point between the two lines instead of selecting both lines.

11. Now, set a dimension between two lines. First, multiselect the lines as indicated.
12. Click the Constraint icon.
This command sets a length constraint. The distance between the lines you have selected is 200 mm.
13. Click anywhere to locate the dimension.

14. Now, double-click the radius value of the first corner.
The Constraint Edition dialog box is displayed.

15. Enter 45mm in the Value field to edit the corner radius.
16. Click OK to confirm the operation.

17. Repeat the operation to edit the second corner. Enter 53mm.

Eventually, your profile looks like this:
When performing this task, you may have noticed that CATIA never required you to update your operations. Actually, whatever operations you are accomplishing in the Sketcher, the application automatically updates the geometry.

Now, you are going to quit the Sketcher workbench to continue the rest of the scenario.
Creating a Pad

Now that you have sketched your profile, you can create a pad. This task will show you how to:
- return to the 3D world
- create a pad, that is extrude the profile.

If you have not performed the previous task, open the GS_sketch1.CATPart document from the GSsamples/part_design directory.

1. Click the Exit Sketcher icon.

Now, the Part Design workbench is displayed and your profile looks like this:

2. Click the Pad icon.

The Pad Definition dialog box appears. Default options allow you to create a basic pad.

3. As you prefer to create a larger pad, enter 60 mm in the Length field.

The application previews the pad to be created.

![Pad Definition dialog box](image)
4. Click OK.

The pad is created. The extrusion is performed in a direction which is normal to the sketch plane. CATIA displays this creation in the specification tree:

CATIA lets you control the display of some of the part components. To know more about the components you can display or hide, refer to [Customizing the Tree and Geometry Views](#). For more about pads, refer to [Pad, Up to Next Pad, Up to Last Pad, Up to Plane Pad, Up to Surface Pad, Pad not Normal to Sketch Plane](#).
Drafting a Face

This task will show you how to draft a face.

1. Click the Draft icon .
   The Draft Definition dialog box appears.
2. Check the Selection by neutral face option to determine the selection mode.

3. Select the upper face as the neutral element.
   This selection allows CATIA detect the faces to be drafted. The neutral face appears in blue and the faces to be drafted in dark red.

4. Enter 9 degrees in the Angle field.

5. Click OK. The part is drafted:
For more about edge fillets, please refer to Basic Draft, and to Draft with Parting Element.
Filleting an Edge

In this task you will learn how to use one of the fillet commands designed to fillet edges.

1. Click the Edge Fillet icon.

   The Edge Fillet Definition dialog box appears. It contains default values.

   ![Edge Fillet Definition](image)

   - Radius: 5mm
   - Object(s) to fillet: No selection
   - Propagation: Tangency

2. Select the edge to be filleted, that is, to be rounded.

   A default filleted edge is previewed.

3. Enter 7 mm as the new radius value and click OK.
For more about edge fillets, please refer to Edge Fillet, Round Corner Fillet, Face-Face Fillet, Tritangent Fillet, Variable Radius Fillet.
Actually, you would like the pad to be thicker. This task shows you how to edit the pad, then how to color the part.

1. Double-click the pad.
   You can do it in the specification tree if you wish.

2. In the Pad Definition dialog box that appears, enter 90 mm as the new length value.

3. Click OK.
   The part is modified.

4. Now select the Edit -> Properties command and click the Graphic tab to change the color of your part.

5. Click the color of your choice and click OK.

To have details about how to change graphic properties, please refer to CATIA- Infrastructure User's Guide Version 5.

The part now looks like this:
Mirroring the Part

Now, you are going to duplicate the part using symmetry. This task will show you how easy it is.

1. Click the Mirror icon.

The Mirror Definition dialog box is displayed.
2. Select the reference face you need to duplicate the part.

The name of this face appears in the Mirroring element field.
3. Click OK.

The part is mirrored and the specification tree indicates this operation.

The next task proposes you to use the new large face you have just created on top of the part.
For more about mirror, please refer to Mirror.
Sketching a Circle from a Face

In this task, you will learn how to:
- open a sketch on an existing face
- create a circle in order to create a pocket

1. Select this face to define the working plane.

2. Click the Sketcher icon to enter the Sketcher workbench.

3. Once in the Sketcher workbench, click this Circle icon to create a basic circle.

4. Click the circle center in the middle of the face and drag the cursor to sketch the circle.

5. Click once you are satisfied with the size of the circle.

6. Then, click the exit Sketcher icon to return to the 3D world. This is your part:
For more about Sketcher elements, please refer to Sketching Profiles.
Creating a Pocket

In this task, you will learn a method to create a pocket using the profile you have just created.

1. Select the circle you have just sketched, if it is not already selected.

2. Click the Pocket icon.

The Pocket Definition dialog box is displayed and CATIA previews a pocket with default parameters.

3. Set the Up to last option to define the limit of your pocket.

This means that the application will limit the pocket onto the last possible face, that is the pad bottom.

4. Click OK.

This is your pocket:
For more about pockets, please refer to Pocket, and Pocket not Normal to Sketch Plane.
To end the scenario, you will learn how to shell the part.

1. Select the bottom face of the part.

2. Click the Shell icon. The Shell Definition dialog box is displayed.

3. Select the face to be removed.

4. Click OK to shell the part using the default inner thickness value.

You have defined a positive value, which means that the application is going to enter a thin part thickness.
For more about shells, please refer to Shell.

This completes the Part Design tutorial. Now, let's take a closer look at the application.
Basic User Tasks

The basic tasks you will perform in the Part Design workbench are mainly the creation of features and surfaces you will use to create your part. To create features you will sometimes sketch profiles first or use existing features.

This section will explain and illustrate how to create various kinds of features and surfaces. The table below lists the information you will find.
Opening a New CATPart Document

This task shows you how to open a new CATPart document.

1. Select the File -> New commands (or click the New icon).
The New dialog box is displayed, allowing you to choose the type of document you need.

2. Select Part in the List of Types field and click OK.
The Part Design workbench is loaded and a CATPart document opens.

The Part Design workbench document is divided into:
- two windows: the specification tree and the geometry area
- specific toolbars: refer to Part Design Workbench
- a number of contextual commands available in the specification tree and in the geometry. Remember that these commands can also be accessed from the menu bar.
You will notice that CATIA provides three planes to let you start your design. Actually, designing a part from scratch will first require designing a sketch. Sketching profiles is performed in the Sketcher workbench which is fully integrated into Part Design. To open it, just click the Sketcher icon and select the work plane of your choice.

The Sketcher workbench then provides a large number of tools allowing you to sketch the profiles you need. For more information, refer to Sketcher documentation.
Creating Sketch-Based Features

Features are entities you combine to make up your part. The features presented here are obtained by applying commands on initial profiles created in the Sketcher workbench (See Sketching Profiles).

Some operations consist in adding material, others in removing material. In this section, you will learn how to create the following features:
Up

Dress-Up Features

Displaying and Editing Properties

Opening a New CATPart Document

Surface-Based Features

Modifying Features

Sketch-Based Features

Transformation Features

Replacing Elements

Setting Constraints
Pad

Creating a pad means extruding a profile in one or two directions. CATIA lets you choose the limits of creation as well as the direction of extrusion.

Basic Pads

This task shows you how to create a basic pad using a closed profile, the Dimension and Mirrored extent options.

Open the Pad1.CATPart document from the \online\samples\part_design directory.

1. Select the profile to be extruded.

Profile

By default, CATIA will extrude normal to the plane used to create the profile. To see how to change the extrusion direction, refer to Pad not Normal to Sketch Plane.

2. Click the Pad icon.

The Pad Definition dialog box appears and CATIA previews the pad to be created.

You will notice that by default, CATIA specifies the length of your pad. To see other creation options, see Up to Next Pad, Up to Last Pad, Up to Plane Pad, Up to Surface Pad.

Pad Definition

- **Type**: Dimension
- **Length**: 20mm
- **Limit**: No selection

Mirrored extent

Reverse Direction

More>>
3. Enter 69 in the Length field or select LIM1 and drag it upwards to 69 to increase the length value.

4. Click the Mirrored extent option to extrude the profile in the opposite direction too.

4. Click OK.

The pad is created. The specification tree indicates that it has been created.

A Few Notes About Pads

CATIA allows you to create pads from open profiles provided existing geometry can trim the pads. The pad below has been created from an open profile which both endpoints were stretched onto the inner vertical faces of the hexagon. The option used for Limit 1 is "Up to next". The inner bottom face of the hexagon then stops the extrusion. Conversely, the Up to next option could not be used for Limit2.

Note that reversing the arrow of Limit 2 creates material in the opposite side:
Pads can also be created from sketches including several profiles. These profiles must not intersect.

In the following example, the sketch to be extruded is defined by a square and a circle. Applying the Pad command on this sketch lets you obtain a cavity:
`Up to Next' Pads

This task shows you how to create a pad using the `Up to Next' option. This creation mode lets the application detect the existing material to be used for limiting the pad length.

Open the Pad2.CATPart document from the \online\samples\part_design directory.

1. Select the profile to be extruded, that is the circle.

2. Click the Pad icon.

The Pad Definition dialog box appears and CATIA previews a pad with a default dimension value.

3. Click the arrow in the geometry area to reverse the extrusion direction (or click the Reverse Direction button).

4. In the Type field, set the Type option to `Up to next'.
This option assumes an existing face can be used to limit the pad. CATIA previews the pad to be created. The already existing body is going to limit the extrusion.

5. Click OK.

The pad is created. The specification tree indicates this creation.

By default, the application extrudes normal to the plane used to create the profile. To learn how to change the direction, refer to Pad not Normal to Sketch Plane.
'Up to Last' Pads

This task shows how to create pads using the `Up to last' option.

Open the Pad3.CATPart document from the \online\samples\part_design directory.

1. Select the profile to be extruded, that is the circle.

2. Click the Pad icon.

   The Pad Definition dialog box appears and CATIA previews a pad with 10 mm as the default dimension value.

3. Click the arrow in the geometry area to reverse the extrusion direction (or click the Reverse Direction button).

4. In the Type field, set the Type option to `Up to last'.

   CATIA previews the pad to be created. The last face encountered by the extrusion is going to limit the pad.
5. Click OK.

The pad is created. The specification tree indicates this creation.

By default, CATIA extrudes normal to the plane used to create the profile. To see how to change the direction, refer to Pad not Normal to Sketch Plane.
'Up to Plane' Pads

This task shows how to create pads using the Up to plane option.

Open the Pad4.CATPart document from the \online\samples\part_design directory.

1. Select the profile to be extruded.

2. Click the Pad icon .

The Pad Definition dialog box appears and CATIA previews a pad with 10 mm as the default dimension value.

3. Click the arrow in the geometry area to reverse the extrusion direction (or click Reverse Direction).

4. In the Type field, set the Type option to 'Up to plane'.

5. Select Plane.4.
CATIA previews the pad to be created. The plane is going to limit the extrusion.

6. Click OK.

The pad is created. The specification tree indicates this creation.

By default, CATIA extrudes normal to the plane used to create the profile. To see how to change the direction, refer to Pad not Normal to Sketch Plane.
`Up to Surface' Pads

This task shows how to create pads using the Up to Surface option.

Open the Pad5.CATPart document from the \online\samples\part_design directory.

1. Select the profile to be extruded.

2. Click the Pad icon.

The Pad Definition dialog box appears and CATIA previews a pad with a default dimension value.

3. In the Type field, set the Type option to Up to surface.

4. Select the face as shown.

CATIA previews the pad to be created. The plane is going to limit the extrusion.
5. Click OK.

The pad is created. The specification tree indicates this creation.

By default, the application extrudes normal to the plane used to create the profile. To see how to change the direction, refer to Pad not Normal to Sketch Plane.
Pad not Normal to Sketch Plane

This task shows how to create a pad using a direction that is not normal to the plane used to create the profile.

Open the Pad6.CATPart document from the \online\samples\part_design directory.

1. Select the profile you wish to extrude.

2. Click the Pad icon.

The Pad Definition dialog box appears and CATIA previews the pad to be created.

3. Set the Up to plane option and select plane yz. For more about this type of creation, refer to Up to Plane Pads.

4. Click the More button to display the whole dialog box.

5. Uncheck the Normal to sketch option and select the linee as shown to use it as a reference.
CATIA previews the pad with the new creation direction.

6. Click OK to confirm the creation.

The pad is created. The specification tree indicates this creation.
Pocket

Creating a pocket consists in extruding a profile and removing the material resulting from the extrusion. CATIA lets you choose the limits of creation as well as the direction of extrusion. The limits you can use are the same as those available for creating pads. To know how to use them, see Up to Next Pockets, Up to Last Pads, Up to Plane Pads, Up to Surface Pads.

Basic Pockets

This task shows you how to create a pocket, that is a cavity, in an already existing part.

Open the Pocket1.CATPart document from the \online\samples\part_design directory.

1. Select the profile.

2. Click the Pocket icon.

The Pocket Definition dialog box is displayed and CATIA previews a pocket.
You can define a specific depth for your pocket or set one of these options:

- up to next
- up to last
- up to plane
- up to surface

3. To define a specific depth, set the Type parameter to Dimension, and enter 30mm. Alternatively, select LIM1 and drag it downwards to 30.

The direction of creation is by default normal to the plane used to sketch the profile. To know how to specify another direction, refer to Pocket not Normal to Sketch Plane.
4. Click OK.

The specification tree indicates this creation. This is your pocket:

A Few Notes About Pockets

- CATIA allows you to create pockets from open profiles provided existing geometry can trim the pockets. The example below illustrates this concept.

- If your pocket is the first feature of a new body, CATIA creates material:
Pockets can also be created from sketches including several profiles. These profiles must not intersect.

In the following example, the initial sketch is made of eight profiles. Applying the Pocket command on this sketch lets you create eight pockets:

The "Up to next" creation mode behaves differently depending on the release of the product you are using. Using CATIA Version 5 Release 2, the "up to next" limit is the very first face the application detects while extruding the profile. This is an example of what you can get:
Using CATIA Version 5 Release 3, the "up to next" limit is the first face the application detects while extruding the profile. This face must stop the whole extrusion, not only a portion of it, and the hole goes thru material, as shown in the figure below:
Pocket not Normal to Sketch Plane

This task shows how to create a pocket using a direction that is not normal to the plane used to create the profile.

Open the Pocket2.CATPart document from the \online\samples\part_design directory.

1. Select the profile.

2. Click the Pocket icon.

The Pocket Definition dialog box appears and CATIA previews a pocket normal to the sketch plane:

3. Set the First Limit type to Up to next.

4. Click the More button to display the whole dialog box.

5. Uncheck the Normal to sketch option.

6. Select the bottom edge as indicated to define a new creation direction.
7. Click OK to create the pocket.

The specification tree indicates it has been created.
Hole

Creating a hole consists in removing material from a body. Various shapes of standard holes can be created. These holes are:

- **Simple**
- **Tapered**
- **Counterbored**
- **Countersunk**
- **Counterdrilled**

If you choose to create a...

- **Counterbored hole**: the counterbore diameter must be greater than the hole diameter and the hole depth must be greater than the counterbore depth.
- **Countersunk hole**: the countersink diameter must be greater than the hole diameter and the countersink angle must be greater than 0 and less than 180 degrees.
- **Counterdrilled hole**: the counterdrill diameter must be greater than the hole diameter, the hole depth must be greater than the counter drill depth and the counterdrill angle must be greater than 0 and less than 180 degrees.

Whatever hole you choose, you need to specify the limit you want. There is a variety of limits:

- **Blind**
- **Up to Next**
- **Up to Last**
- **Up to Plane**
- **Up to Surface**

The "Up to next" creation mode behaves differently depending on the release of the product you are using. In CATIA Version 5 Release 2, the "up to next" limit is the very first face the application detects while extruding the profile.
In CATIA Version 5 Release 3, the "up to next" limit is the first face the application detects while extruding the profile, but this face must stop the whole extrusion, not only a portion of it, and the hole goes thru material.

You can also choose the shape of the end hole (flat or pointed end hole) and specify a threading.
Creating a Hole

This task illustrates how to create a counterbored hole while constraining its location.

Open the Hole1.CATPart document from the \online\samples\part_design directory.

1. Click the Hole icon 🔄.
2. Select the circular edge and upper face as shown.

CATIA can now define one distance constraint to position the hole to be created. The hole will be concentric to the circular edge.

For more about locating holes, please refer to Locating a Hole.

The Hole Definition dialog box appears and CATIA previews the hole to be created. The Sketcher grid is displayed to help you create the hole. By default, CATIA previews a simple hole whose diameter is 10mm and depth 10mm.

Contextual creation commands are available on the BOTTOM text.

4. Now, define the hole you wish to create. Enter 24mm as the diameter value and 25mm as the depth value.

6. Set the Bottom option to V-Bottom to create a pointed hole and enter 110 in the Angle field.
You could also define a creation direction normal to the surface of your choice and a threading.

7. Now, click the Type tab to access the type of hole you wish to create. You are going to create a counterbored hole.

You will notice that the glyph assists you in defining the desired hole.
8. Enter 30mm in the Diameter field and 8mm as the depth value.

The preview lets you see the new diameter.

14. Click OK.

The hole is created. The specification tree indicates this creation.

You will notice that the sketch used to create the hole also appears under the hole's name. This sketch consists of the point at the center of the hole.
Locating a Hole

This task shows how to constrain the location of the hole to be created without using the Sketcher workbench`s tools.

1. Multiselect two edges and the face on which you wish to position the hole.

2. Click the Hole icon and specify the required data in the dialog box to create the desired hole (see Creating a Hole).

CATIA previews the constraints you are creating.

3. Click OK to create the hole.

CATIA positions the hole using default constraints.

4. To access the constraints, edit the hole and double-click the constraint of interest or double-click the sketch in the specification tree to enter the Sketcher workbench.

You can edit the constraints if you wish to reposition the hole.
Remember That...

- The area you click determines the location of the hole, but you can drag the hole onto desired location during creation using the left mouse button. If the grid display option is activated, you can use its properties.

- Selecting a circular face makes the hole concentric with this face. However, CATIA creates no concentricity constraint.

- Multiselecting a circular edge and a face makes the hole concentric to the circular edge. In this case, CATIA creates a concentricity constraint.
CATIA always limits the top of the hole using the Up to next option. In other words, the next face encountered by the hole limits the hole.

In the following example, the hole encounters a fillet placed above the face initially selected. The application redefines the hole's top onto the fillet.

Remember that the Sketcher workbench provides commands to constraint the point used for locating the hole. See Setting Constraints.

Selecting an edge and a face allows the application to create one distance constraint. While creating the hole, you can double-click this constraint to edit its value.
Hole not Normal to Sketch Plane

This task shows you how to create a hole whose direction is not normal to the sketch plane.

Open the Hole2.CATPart document from the \online\samples\part_design directory.

1. Select the face on which you wish to position the hole.

2. Click the Hole icon.

3. Create a blind hole entering the values as follows: 18 to define the diameter and 15 for the depth.

4. Examine the preview.

   By default, CATIA creates the hole normal to the sketch face.

5. Now, uncheck the Normal to surface option and select the edge as shown to specify the new creation direction.

   To use a new direction, you could also select a line.

6. Now, select Bottom and right-click to display a contextual menu.
7. Select V-Bottom from the menu. Note that this option is available in the dialog box too.

8. Enter 90deg in the Angle field to define the angle of the V shape.
9. Click OK to confirm the creation.

The hole is created. The specification tree indicates it has been created.
Shaft

This task illustrates how to create a shaft, that is a revolved feature.

The sketch must include a profile and an axis about which the feature will revolve.

Open the Shaft.CATPart document from the \online\samples\part_design directory.

1. Select the closed profile.

2. Click the Shaft icon .

The Shaft Definition dialog box is displayed and CATIA previews a round feature. The First Angle value is by default 360 degrees.

3. CATIA previews the limits LIM1 and LIM2 of the shaft to be created. Select LIM1 and drag it onto 250.
3. Now enter 40 degrees in the Second angle field.

4. Click OK.

The shaft is created. The specification tree mentions it has been created.

You can use open profiles for creating shafts. CATIA uses existing geometry to trim material. In the example below, the red face trims the extremity to the left. The axis about which the feature is created trims the opposite extremity.
Groove

Grooves are revolved features that retrieves material from existing features. This task shows you how to create a groove, that is how to revolve a profile about an axis (or construction line).

Open the Groove.CATPart document from the \online\samples\part_design directory.

1. Click the Groove icon .

2. Select the sketch.

The profile and the axis must belong to the same sketch.

The Groove Definition dialog box is displayed and CATIA previews a groove entirely revolving about the axis.

3. CATIA previews the limits LIM1 and LIM2 of the groove to be created. You can select these limits and drag them onto the desired value or enter angle values in the appropriate fields. For our scenario, select LIM1 and drag it onto 100, then enter 60 in the Second angle field.
4. Examine the preview. Just a portion of material is going to be removed now.

5. Click OK to confirm the operation.

CATIA removes material around the cylinder. The specification tree indicates the groove has been created.

This is your groove:
Stiffener

This task shows you how to create a stiffener by specifying creation directions.

Open the Stiffener.CATPart document from the \online\samples\part_design directory.

1. Select the profile to be extruded.

This open profile has been created in a plane normal to the face on which the stiffener will lie.

If you need to use an open profile, make sure that existing material can fully limit the extrusion of this profile.

2. Click the Stiffener icon.

The Stiffener Definition dialog box is displayed, providing a default thickness value.
CATIA previews a stiffener which thickness is equal to 10mm.

The extrusion will be made in three directions, two of which are opposite directions. Arrows point in these directions.

3. Uncheck the Symmetrical extent option.

The extrusion will be made in two directions only.

To obtain the directions you need, you can also click the arrows. Note that you can access contextual commands on these arrows. These commands are the same as those available in the dialog box.

4. Check the Symmetrical extent option again.

5. Just to examine the Depth option, click the Reverse direction option in the dialog box, or click the arrow in the geometry area.

The result differs very much from the previous stiffener. Just a small portion of material will be created:
6. As you prefer to create material forming a transition between the basis of the part and the triangle, reverse the direction again, and click OK.

The stiffener is created. The specification tree indicates it has been created.
Rib

This task shows you how to create a rib, that is a profile you sweep along a center curve to create material.

Open the Rib.CATPart document from the \online\samples\part_design directory.

1. Click the Rib Icon.

   The Rib Definition dialog box is displayed.

2. Select the profile you wish to sweep. Your profile has been designed in a plane normal to the plane used to define the center curve. It is a closed profile.

You can use an open profile provided existing material can limit the rib.

You can control its position by choosing one of the following options:

- **Keep angle**: keeps the angle value between the sketch plane used for the profile and the tangent of the center curve.
- Pulling direction: sweeps the profile with respect to a specified direction (see pulling direction below).
- Reference surface

3. To go on with our scenario, let's maintain the Keep angle option. Select the center curve.

The center curve is open. To create a rib you can use open profiles and closed center curves too. Center curves can be discontinuous in tangency.

The application now previews the rib to be created.
The Merge ends option is to be used in specific cases. It creates materials between the ends of the rib and existing material.

4. Click OK.

The rib is created. The specification tree mentions this creation.

Using the edge as shown as the pulling direction, you would obtain this:

---

**A Few Words about the Keep Angle Option**

The position of the profile in relation to the center curve determines the shape of the resulting rib. When sweeping the profile, the application keeps the initial position of the profile in relation to the nearest point of the center curve. The application computes the rib from the position of the profile.

In the example below, the application computes the intersection point between the plane of the profile and the center curve, then sweeps the profile from this position.
Slot

This task shows you how to create a slot, that is a profile you sweep along a center curve to remove material.

Open the Slot.CATPart document from the \online\samples\part_design directory.

1. Click the Slot icon.
   The Slot Definition dialog box is displayed.

2. Select the profile.
   The profile has been designed in a plane normal to the plane used to define the center curve. It is closed.

   You can control its position by choosing one of the following options:
   - Keep angle: keeps the angle value between the sketch plane used for the profile and the tangent of the center curve.
   - Pulling direction: sweeps the profile with respect to a specified direction.
   - Reference surface

3. To go on with our scenario, let's maintain the Keep angle option. To know more this option, please refer to [A Few Notes about the Keep Angle Option](#).

Now, select the center curve along which CATIA will sweep the profile.

The center curve is open. To create a rib you can use open profiles and closed center curves too. Center curves can be discontinuous in tangency.

The application previews the slot.
The Merge ends option is to be used in specific cases. It lets the application create material between the ends of the slot and existing material.

4. Click OK.

The slot is created. The specification tree indicates this creation.
This task shows how to create a loft feature.

You can generate a loft feature by sweeping one or more planar section curves along a computed or user-defined spine. The feature can be made to respect one or more guide curves. The resulting feature is a closed volume.

Open the Loft.CATPart document from the samples/part_design directory.

1. Click the Loft icon.

The Loft Definition dialog box appears.
2. Select the three section curves as shown:

They are highlighted in the geometry area.

3. Select the four guide curves.

They are highlighted in the geometry area.

4. It is possible to edit the loft reference elements by first selecting a curve in the dialog box list then choosing a button to either:
   - Remove the selected curve
   - Replace the selected curve by another curve.
   - Add another curve.
By default, the application computes a spine, but if you wish to impose a curve as the spine to be used, you just need to click the Spine tab then the Spine field and select the spine of your choice in the geometry.

5. Click OK to create the volume.

The feature (identified as Loft.xxx) is added to the specification tree.
<table>
<thead>
<tr>
<th>Term</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Up</td>
<td></td>
</tr>
<tr>
<td>Up to Last Pad</td>
<td></td>
</tr>
<tr>
<td>Not Normal to Sketch Pad</td>
<td></td>
</tr>
<tr>
<td>Hole</td>
<td></td>
</tr>
<tr>
<td>Shaft</td>
<td></td>
</tr>
<tr>
<td>Rib</td>
<td></td>
</tr>
<tr>
<td>Pad</td>
<td></td>
</tr>
<tr>
<td>Up to Plane Pad</td>
<td></td>
</tr>
<tr>
<td>Pocket</td>
<td></td>
</tr>
<tr>
<td>Locating Holes</td>
<td></td>
</tr>
<tr>
<td>Groove</td>
<td></td>
</tr>
<tr>
<td>Slot</td>
<td></td>
</tr>
<tr>
<td>Removed Loft</td>
<td></td>
</tr>
<tr>
<td>Up to Next Pads</td>
<td></td>
</tr>
<tr>
<td>Up to Surface Pad</td>
<td></td>
</tr>
<tr>
<td>Not Normal to Sketch Pocket</td>
<td></td>
</tr>
<tr>
<td>Not Normal to Sketch Hole</td>
<td></td>
</tr>
<tr>
<td>Stiffener</td>
<td></td>
</tr>
<tr>
<td>Loft</td>
<td></td>
</tr>
</tbody>
</table>
Remove Lofted Material

This task shows how to remove lofted material.

The Remove Loft capability generates lofted material surface by sweeping one or more planar section curves along a computed or user-defined spine then removes this material. The material can be made to respect one or more guide curves.

Open the Remove_Loft.CATPart document from the samples/part_design directory.

1. Click the Remove Loft icon.

The Remove Loft Definition dialog box appears.
2. Select both section curves as shown Sketch.3 and Sketch.4):

They are highlighted in the geometry area.

3. Select the point as shown on section 2 to define the closing point.

4. Select the four guide curves.

They are highlighted in the geometry area.
5. It is possible to edit the loft reference elements by first selecting a curve in the dialog box list then choosing a button to either:

- Remove the selected curve
- Replace the selected curve by another curve.
- Add another curve.

By default, the application computes a spine, but if you wish to impose a curve as the spine to be used, you just need to click the Spine tab then the Spine field and select the spine of your choice in the geometry.

6. Click OK to create the lofted surface.

The feature (identified as RemovedLoft.xxx) is added to the specification tree.
Creating Dress-Up Features

Dressing up features is done by applying commands to one or more supports. CATIA provides a large number of possibilities to achieve the features meeting your needs. The application lets you create the following dress-up features:

- Edge Fillet
- Round Corner Fillet
- Face-Face Fillet
- Tritangent Fillet
- Variable Radius Fillet
- Chamfer
- Basic Draft
- Draft with parting element
- Shell
- Thickness
A fillet is a curved face of a constant or variable radius that is tangent to, and that joins, two surfaces. Together, these three surfaces form either an inside corner or an outside corner.

In drafting terminology, the curved surface of an outside corner is generally called a round and that of an inside corner is normally referred to as a fillet. Edge fillets are smooth transitional surfaces between two adjacent faces.

The purpose of this task is to create a fillet by selecting a face and four edges. The case illustrated here is a simple one using a constant radius: the same radius value is applied to the entire edge.

Open the Edge_Fillet.CATPart document from the \online\samples\part_design directory.

1. Click the Edge Fillet icon . The Edge Fillet Definition dialog box appears.

2. Select the upper face as well as the four vertical edges.

3. The face and the edges selected then appear in the Objects to fillet field. CATIA previews the fillets to be created. The radius value is displayed too.
3. Click OK to confirm the operation.

The edges are filleted. The creation of this fillet is indicated in the specification tree.
Round Corner Fillet

Round corner fillets are fillets whose ends have been rounded off. This task shows how to create this type of fillet.

Open the Round_Fillet.CATPart document from the \online\samples\part_design directory.

1. Select the edge to be filleted.

2. Click the Edge Fillet icon.

   The Edge Fillet Definition dialog box appears.

3. Enter a radius value. For example, enter 9mm.

   CATIA previews the fillet.

4. Click OK.

   The specification tree indicates this creation. This a round corner fillet:

   You will notice that an edge has been modified.
Face-Face Fillet

You generally use the Face-face fillet command when there is no intersection between the faces or when there are more than two sharp edges between the faces.

This task shows how to create a face-face fillet.

Open the Face_Fillet.CATPart document from the \online\samples\part_design directory.

1. Click the Face-Face Fillet icon.

   The Face-Face Fillet Definition dialog box appears.

2. Select the faces to be filleted.

   The application previews the fillet to be created:

3. Enter a radius value in the Radius field if you are not satisfied with the default one. For example, enter 31mm.
4. Click OK.

The faces are filleted. This fillet is indicated in the specification tree.
Variable Radius Fillet

Variable radius fillets are curved surfaces defined according to a variable radius. A variable radius corner means that at least two different constant radii are applied to two entire edges.

This task shows how to create a variable radius fillet.

Open the Variable_Fillet.CATPart document from the \online\samples\part_design directory.

1. Click the Variable Radius Fillet icon.

   The Variable Radius Fillet Definition dialog box appears.

2. Select the edge to be filleted.

   CATIA detects the two vertices and displays two radius values.

3. Enter a new radius value to change the radius of the vertex on the left.

   The new radius value is displayed.
4. To add an additional point on the edge to make the variable radius fillet more complex, click the Points field.

You can also add points by selecting planes. For more information, refer to the end of the task.

Now, you can add as many points as you wish.

5. Click a point on the edge to be filleted.

CATIA displays a radius value on this point.

Note that to remove a point from the selection, you just need to click this point.

6. Enter a new radius value for this point: enter 4.

7. The propagation mode is set to Cubic: keep this mode. To see the Linear propagation mode, refer to the end of the task.

8. Now, click OK to confirm the operation.

The edge is filleted. The specification tree indicates this creation.
More About Variable Radius Fillets

- This is the fillet you would obtain using the Linear propagation mode. Examine the difference!

- To add additional points on the edge to be filleted, you can select planes. CATIA computes the intersections between these planes and the edge to determine the useful points.

  In this example, three planes were selected.

  Now, if you move these planes later, CATIA will compute the intersections again and modify the fillet accordingly.

- Points can be added too by selecting 3D points.

- You can use the radius value \( R=0 \) to create a variable radius fillet.
The creation of tritangent fillets involves the removal of one of the three faces selected.

This task shows how to create a tritangent fillet.

You need three faces two of which are supporting faces.

Open the Tritangent_fillet.CATPart document from the \online\samples\part_design directory.

1. Click the Tritangent Fillet icon .

The Tritangent Fillet Definition dialog box appears.

2. Select the faces to be filleted.

3. Select the face to be removed, that is the upper face.

The fillet will be tangent to this face.

This face appears in dark red.
4. Click OK.

The faces are filleted. The creation of this fillet is indicated in the specification tree.

Multiselecting three faces then clicking the Tritangent Fillet icon tells the application to remove the third face.
Chamfering consists in removing or adding a flat section from a selected edge to create a beveled surface between the two original faces common to that edge. You obtain a chamfer by propagation along one or several edges.

This task shows how to create two chamfers by selecting two edges. One case illustrates how material is added, the other case shows how material is retrieved.

Open the Chamfer1.CATPart document from the \online\samples\part_design directory.

1. Click the Chamfer icon .

   The Chamfer Definition dialog box appears. The default parameters to be defined are Length and Angle.

2. Select the edges to be chamfered.

3. Keep the default mode: enter a length value and an angle value.

   CATIA previews the chamfers with the given values.
4. Click OK.

The specification tree indicates this creation.
These are your chamfers:

Chamfers can be created by selecting a face whose edges are to be chamfered.
Basic Draft

Drafts are defined on molded parts to make them easier to remove from molds.

The characteristic elements are:

- **pulling direction**: this direction corresponds to the reference from which the draft faces are defined.

- **draft angle**: this is the angle that the draft faces make with the pulling direction. This angle may be defined for each face.

- **parting element**: this plane, face or surface cuts the part in two and each portion is drafted according to its previously defined direction. For an example, please refer to Draft with Parting Element.

- **neutral element**: this element defines a neutral curve on which the drafted face will lie. This element will remain the same during the draft. The neutral element and parting element may be the same element.

There are two ways of determining the objects to draft. Either by explicitly selecting the object or by selecting the neutral element, which makes CATIA detect the appropriate faces to use.

This task shows you how to create a basic draft by selecting the neutral element.

Open the Draft2.CATPart document from the \online\samples\part_design directory.

1. Click the Draft icon .

![Image of a green cube with draft lines]
The Draft Definition dialog box is displayed and an arrow appears on the part, indicating the default pulling direction.

2. Check the Selection by neutral face option to determine the selection mode.

3. Select the upper face as the neutral element. This selection allows CATIA to detect the face to be drafted.

The neutral element is now displayed in blue, the neutral curve is in pink. The faces to be drafted are in dark red. You can also note that the pulling direction is now displayed on top of the part. It is normal to the neutral face.

Note that when using the other selection mode (explicit selection), the selected objects are displayed in dark pink.
4. The default angle value is 5. Enter 7 degrees as the new angle value. CATIA displays the new angle value in the geometry.

You can create drafts using a negative value.

7. Click OK to confirm the operation.

The faces are drafted. You can notice that material has been added.

A Few Notes about Drafts

- If you edit the sketch used for defining the initial pad, CATIA integrates this modification and computes the draft again. In the following example, a chamfer was added to the profile.
If you need to draft several faces using a pulling direction normal to the neutral element, keep in mind the following operating mode that will facilitate your design:

Click and first select the neutral element of your choice. The pulling direction that appears is then normal to the neutral element. Select the face to be drafted and click OK to create your first draft.

Now, to create the other drafts in the same CATPart document, note that by default the application uses the same pulling direction as the one specified for creating your first draft. As designers usually use a unique pulling direction, you do not need to redefine your pulling direction.
Draft with Parting Element

This task shows how to create two basic drafts using parting elements.

Open the Draft1.CATPart document from the \online\samples\part_design directory.

1. Select the face to be drafted.

2. Click the Draft icon .

The Draft Definition dialog box appears and an arrow appears on the part, indicating the default pulling direction.

3. Click the Selection field and select plane xy to define the neutral element.

The application displays the neutral curve in pink.

4. Enter 13 degrees as the new angle value.

You can create drafts using a negative value.

5. Now click the More button to display the whole dialog box and access the Parting Element option. Check the Draft with parting element option if not already done.

6. Select plane xy, that is the sketch plane, as the parting element. The initial part is a pad created using the Mirrored extent option. For more about this option, refer to Basic Pads .
7. Click OK.

The face is drafted. You can notice that material has been removed.
Shell

Shelling a feature means emptying it, while keeping a given thickness on its sides. Shelling may also consist in adding thickness to the outside. This task shows both operations.

Open the Shell.CATPart document from the \online\samples\part_design directory.

1. Click the Shell icon . The Shell Definition dialog box appears.

2. Select the faces to remove.

3. Enter 1mm in the inside thickness field.

4. Click OK.

The feature is shelled: the selected faces are left open. This creation appears in the specification tree.

5. Now, double-click Shell.1 in the specification tree to edit it.
6. Enter 3mm in the outside thickness field.
7. Click OK.

Thickness has been added to the outside.
Sometimes, some thickness has to be added or removed before machining the part. The thickness command lets you do so.

This task shows you how to add thickness to a part.

Open the Thickness.CATPart document from the \online\samples\part_design directory.

1. Click the Thickness icon.  
   The Thickness Definition dialog box is displayed.
2. Select the faces to thicken.  
   CATIA displays the thickness value in the geometry.

3. Enter a positive value. For example, enter 20 mm.

4. Click OK.  
   The part is thickened accordingly. This creation appears in the specification tree.
Creating Surface-Based Features

The features presented here are obtained by applying commands on surfaces or by using surfaces for modifying features of any types.
You can split a body with a plane, face or surface. The purpose of this task is to show how to split a body by means of a surface.

Open the Split.CATPart document from the \online\samples\part_design directory.

1. Select the blue pad as the body to be split.

2. Click the Split icon.

3. Select the splitting surface.

The Split Definition dialog box is displayed, indicating the splitting element.

An arrow appears indicating the portion of body that will be kept. If the arrow points in the wrong direction, you can click it to reverse the direction.
5. Click OK.

The body is split. Material has been removed.

The specification tree indicates you performed the operation.
Close Surface

This task shows you to close surfaces.

Open the Close.CATPart document from the \online\samples\part_design directory.

1. Select the surface to be closed.

2. Click the Close Surface icon.

The Close Surface Definition dialog box is displayed.

5. Click OK.

The surface is closed. The specification tree indicates you performed the operation.
Sew Surface

Sewing means joining together a surface and a body. This capability consists in computing the intersection between a given surface and a body while removing useless material. You can sew all types of surfaces onto bodies. This task shows you how to do it.

Open the Sew.CATPart document from the \online\samples\part_design directory.

1. Select the surface you wish to sew onto the body, that is the orange surface.

2. Click the Sew Surface icon.

The Sew Surface Definition dialog box is displayed, indicating the object to be sewn.

3. An arrow appears indicating the portion of material that will be kept. Click the arrow to reverse the direction. The arrow must point in the direction as shown:
5. Click OK.

The surface is sewn onto the body. Some material has been removed. The specification tree indicates you performed the operation.
Thick Surface

You can add material to a surface in two opposite directions by using the Thick Surface capability. This task shows you how to do so.

Open the ThickSurface.CATPart document from the \online\samples\part_design directory.

1. Select the object you wish to thicken, that is the extrude element.

2. Click the Thick Surface icon.

The Thick Surface Definition dialog box is displayed.

In the geometry area, the arrow that appears on the extrude element indicates the first offset direction.

3. Enter 25mm as the first offset value and 12mm as the second offset value.
5. Click OK.

The surface is thickened. The specification tree indicates you performed the operation.

Note that the resulting feature does not keep the color of the original surface.
Creating Transformation Features

Transformation features are obtained by applying commands on existing features. This section illustrates the creation of the following features:

- **Translation**
- **Rotation**
- **Symmetry**
- **Mirror**
- **Rectangular Pattern**
- **Circular Pattern**
- **User Pattern**
- **Scaling**

---

- **Up**
- **Opening a New CATPart Doc**
- **Sketch-Based Features**
- **Dress-Up Features**
- **Surface-Based Features**
- **Transformation Features**
- **Displaying and Editing Prope**
- **Modifying Features**
- **Replacing Elements**
- **Setting Constraints**
The Translate command applies to current bodies. This task shows you how to translate a body.

1. Click the Translate icon.

The Translate Definition dialog box appears.

2. Select a line to take its orientation as the translation direction or a plane to take its normal as the translation direction. For example, select zx plane.

You can also specify the direction by means of X, Y, Z vector components by using the contextual menu on the Direction area.

3. Specify the translation distance by entering a value or using the Drag manipulator. For example, enter 100mm.

4. Click OK to create the translated element.

The element (identified as Translat.xxx) is added to the specification tree.
Rotation

This task shows you how to rotate geometry about an axis. The command applies to current bodies.

Open the Rotate.CATPart document from the \online\samples\part_design directory.

1. Click the Rotate icon.

The Rotate Definition dialog box appears.

2. Select a line as the rotation axis.
3. Enter a value for the rotation angle.

The element is rotated. You can drag it by using the graphic manipulator to adjust the rotation.

4. Click OK to create the rotated element.

The element (identified as Rotate.xxx) is added to the specification tree.
Symmetry

This task shows how to transform geometry by means of a symmetry operation. The Symmetry command applies to current bodies.

Open the Symmetry.CATPart document from the \online\samples\part_design directory.

1. Click the Symmetry icon .

   The Symmetry Definition dialog box appears.

2. Select a point, line or plane as reference element. For our scenario, select plane zx.

3. Click OK to create the symmetrical element.

   The original element is no longer visible but remains in the specification tree.

   The new element (identified as Symmetry.xxx) is added to the specification tree.
Pattern

You may need to create several identical features from an existing one and to simultaneously position them on an part. Patterns let you do so. CATIA allows you to define three types of patterns: rectangular, circular and user patterns. These features make the creation process easier.

Rectangular Pattern

This task shows you how to duplicate the original feature right away at the location of your choice using a rectangular pattern. Then, you will learn how to modify the location of the initial feature.

Open the Rectangular_pattern.CATPart document from the \online\samples\part_design directory.

1. Click the Rectangular Pattern icon 🔄.

2. Select the feature you wish to copy, that is the pocket.

The Rectangular Pattern Definition dialog box is displayed. Each tab is dedicated to a direction you will use to define the location of the duplicated feature. In this task, you will first set your specification for the first direction.

The feature's name displays in the Object field.

Checking the Keep specifications option lets you create instances with the limit defined for the original feature. In the example below, the limit defined for the pad, that is the "Up to surface" limit, applies to all instances. As the limiting surface is not planar, the instances have different lengths.
But for our scenario, as the pocket's height is specified, activating the Keep specifications option is meaningless.

3. Click the Reference element field and select the edge as shown above to specify the first direction of creation.

An arrow is displayed on the pad. You will notice that you can check the Reverse button or click the arrow to modify the direction.
To define a direction, you may select an edge or a planar face.

4. Let the Instances & Spacing options to define the parameters you wish to specify.

The parameters you can choose are:

- Instances & Length
- Instances & Spacing
- Spacing & Length

Choosing Instances & Spacing dims the Length field because the application no longer needs this specification to space the instances.

5. Enter 3 as the number of instances, that is pockets you wish to obtain in the first direction.

Deleting the instances of your choice is possible when creating the pattern. In the pattern preview, just select the points materializing instances. Conversely, selecting these points again will make CATIA create the corresponding instances.
6. Define the spacing along the grid: enter 14 mm.

Defining the spacing along the grid and length of your choice would make the application compute the number of possible instances and space them at equal distances.

7. Now, click the Second Direction tab to define other parameters.

Note that defining a second direction is not compulsory. Creating a rectangular defining only one direction is possible.

8. Click the Reference element field and select the edge as shown below to define the second direction.

9. Check the Reverse option to make the arrow point in the opposite direction.

10. Let the Instances & Spacing option: enter 3 and 10 mm in the appropriate fields.
11. Examine the preview to make sure the pattern meets your needs. Additional pockets will be aligned along this second direction.

12. Click OK to repeat the pocket nine times. This is the resulting pattern. You now have nine pockets.

13. Let's now edit the pattern to make it more complex: double-click the pattern to display the dialog box.
14. Click the More button to display the whole dialog box. The options available makes it possible to position the pattern.

15. To modify the position of the pockets, enter -5 degrees as the rotation angle value.
16. Click Apply.

You will notice that all pockets have moved slightly:

17. Now, modify the location of the initial pocket. To do so, enter 2 in the Row in Direction 1 field.

The application previews how the pattern will be moved. It will be moved along the direction as indicated:
18. Finally, enter 2 in the Row in Direction 2 field.

The application previews how the pattern will be moved. It will be moved along these two directions defined in steps 17 and 18:

19. Click OK.

The application has changed the location of all pockets. Only four of them remain on the pad.

CATIA Version 5 provides the capability of creating Cartesian patterns with variable steps. To do so, define formulas. More explicitly, act on parameters i and j. For more information, refer to *CATIA- Knowledge Advisor User's Guide Version 5*.
Circular Pattern

This task will show you how to duplicate the original feature right away at the location of your choice using a circular pattern.

Make sure the item you wish to duplicate is correctly located in relation to the circular rotation axis.

Open the Circular_pattern.CATPart document from the \online\samples\part_design directory.

1. Click the Circular Pattern icon.

2. Select the pad you wish to copy.

The Circular Pattern Definition dialog box is displayed and the feature's name appears in the Object field.

Checking the Keep specifications option lets you create instances with the limit defined for the original feature. The example below shows you that the limit defined for the pad, that is the "Up to surface" limit, applies to all instances. As the limiting surface is not planar, the instances have different lengths.

But for our scenario, as the pad is going to be repeated on a planar surface, activating the Keep specifications option is meaningless.
The Parameters field lets you choose the type of parameters you wish to specify so that CATIA will be able to compute the location of the items copied.

These parameters are:
- Instances & total angle
- Instances & angular spacing
- Angular spacing & total angle
- Complete crown

3. Set the Instances & Angular spacing options to define the parameters you wish to specify.
4. Enter 7 as the number of pads you wish to obtain.

5. Enter 50 degrees as the angular spacing.

6. Click the Reference element field and select the upper face to determine the rotation axis. This axis will be normal to the face.

Clicking the Reverse button reverses the direction.

Two arrows are then displayed on the pad.
To define a direction, you can select an edge or a planar face.

7. Define an angular space between each instance: enter 45 degrees.

If you modify the angular spacing, CATIA previews the result: arrows 1 and 2 are moved accordingly.

8. Click OK.

CATIA previews the pattern: the pad will be repeated seven times.

9. Now, you are going to add a crown to your part. To do so, click the Crown Definition tab.

10. Set the Circle & Circle spacing options to define the parameters you wish to specify.

11. Enter 2 in the Circle(s) field.

12. Enter -10 mm in the Circle spacing field.

This figure may help you to define your parameters:

13. Click OK.

These are your new instances:
14. Now, you are going to modify the position of the initial pad. Such a modification will affect all instances too. To do so, click the More button to display the whole dialog box.

![Circular Pattern Definition dialog box]

15. Enter 15 in the Rotation angle field.

CATIA previews the rotation.

16. Click OK.

All instances are moved accordingly.

Applying the Delete command on one instance deletes the whole pattern. However, deleting the instances of your choice is possible when creating or editing the pattern. To do so, just select the points materializing instances in the pattern preview. Selecting these points again will enable CATIA maintain the corresponding instances.
The scenario above does not show the use of the “Radial alignment of instances” option. In addition to performing the steps described, you could have use this option that allows you to define the instance orientations.

The option is checked: all instances have the same orientation as the original feature.

The option is unchecked: all instances are normal to the lines tangent to the circle.

CATIA offers the capability of creating polar patterns (for example, spiral patterns). To do so, define formulas using parameters i and j. For more information, refer to the [CATIA-Knowledge Advisor User's Guide Version 5](#).
User Pattern

The User pattern command lets you duplicate a feature (pad, pocket, shaft, groove, hole) as many times as you wish at the locations of your choice. Locating occurrences consists in specifying anchor points. These points are created in the Sketcher.

This task shows you how to duplicate a hole at the points defined in a same sketch plane.

Open the UserPattern.CATPart document from the \online\samples\part_design directory.

1. Click the User Pattern icon.

2. Select the hole you wish to duplicate.

The User Pattern dialog box is displayed. The hole appears in the Object field.

Checking the Keep specifications option lets you create instances with the limit (Up to Next, Up to Last, Up to Plane or Up to Surface) defined for the original feature. In our scenario, the hole was created using the Up to Next option, but as the support for holes is a pad of an even thickness (20 mm), this makes the use of the option meaningless.

2. Select 'Sketch 4' in the specification tree. This sketch includes the nine points you need to locate the duplicated holes.
3. Actually, you just need seven points. Click both points you do not need to unselect them.

3. Click OK.

The seven holes are created at the points of the sketch. The specification tree indicates this creation.
Mirror

Mirroring a body consists in duplicating the body using a symmetry. You can select a face or a plane about which you will mirror a body.

This task shows how to mirror a body.

Open the Mirror1.CATPart document from the \online\samples\part_design directory.

1. Select the face used as the reference.

2. Click the Mirror icon .

The Mirror Definition dialog box appears.

3. Click OK to confirm the operation.

The body is mirrored and the original element is unchanged.

The specification tree mentions this creation.

Using a plane to mirror a body lets you obtain two independent portions of material in a same body. The following mirror is obtained by using plane zx as the reference.
Scaling

Scaling a body means resizing it to the dimension you specify. This task shows how to scale a body in relation to a point.

Open the Scaling.CATPart document from the \online\samples\part_design directory.

1. Select the body to be scaled.

2. Click the Scaling icon. The Scaling Definition dialog box appears.

3. Select the reference point and enter 1.5 as the factor value.

4. Click OK.

The body is scaled accordingly. The specification tree indicates you performed this operation.
You can also resize a body in relation to a face or plane. In the example below, the upper face is the reference element and the factor value is 1.5. You obtain an affinity.
This section discusses the ways of accessing and editing information concerning parts, bodies and features. The data you access varies depending on the element you select, but you always access it using the Edit -> Properties command.
Displaying and Editing the Part Properties

Gathered in a same dialog box, the part properties consist of different indications you will have sometimes to refer to. This task explains how to access and if needed, edit this information.

1. Select the part in the specification tree.

2. Select the Edit->Properties command or select the Properties command on the contextual menu.

   The Properties dialog box displays, containing the following tabs dealing with the part:
   - Product
   - Mass

3. The Product tab contains editable fields.

   Enter a new name for the part in the Part Number field.

   The new name appears in the specification tree.

4. The other fields allow you to freely describe the part. Enter the information describing your part in the context of your company.

5. Set the Source option. You can choose between Unknown, Made or Bought.
6. Now, clicking the Mass tab displays technical information you cannot edit: Note however that you can edit the density of a part by applying a new material. To know how to apply materials to parts, please refer to *CATIA- Real Time Rendering User’s Guide Version 5*. 

7. Once you are satisfied with your operation, click OK to confirm the operation and close the dialog box.
Displaying and Editing Bodies Properties

This task shows how to display and edit bodies properties. To know how to edit the graphic properties of a body refer to the Infrastructure documentation, Displaying and Editing Graphic Properties.

1. Select the body in the specification tree.

2. Select the Edit->Properties command or select the Properties command on the contextual menu.

The Properties dialog box displays, containing two tabs concerning bodies:
- Feature properties
- Graphic
3. In the Feature properties tab, only the name of the feature is editable. Enter Body1 in the Name field. This name is editable if the part is not read only.

The new name appears in the specification tree.

4. Click the Graphic tab to change the color of the body. To have details about how to change graphic properties, please refer to CATIA- Infrastructure User's Guide Version 5.

5. Click OK.

CATIA takes these modifications into account and displays the new body name.
Displaying and Editing Features Properties

This task shows how to display and edit the properties of a pad.

1. Select the feature in the specification tree, that is pad2.

2. Select the Edit->Properties command or select the Properties command on the contextual menu.

The Properties dialog box displays, containing these tabs:
- Feature Properties
- Mechanical
- Graphic

3. Enter a new name for the pad in the Name field.
   This field is not available if the file is read only.

4. Click Apply to display the new name in the specification tree.

5. Click the Mechanical tab to access other information.
   The Mechanical tab displays the status of the pad.

   The following attributes characterize features:
- **Deactivated**: checking this option will prevent CATIA from taking deactivated features into account during an update operation.
- **To Update**: indicates that the selected feature is to be updated.
- **Unresolved**: indicates that the selected feature has not been computed by the application.

You cannot control the last two options. The symbol displayed in front of each attribute may appear in the specification tree in some circumstances.

For more about updates, refer to [Updating Parts](#).

6. Check the Deactivated option to deactivate the pad.

You will note that a new frame is displayed, providing additional information. CATIA actually warns you that the operation will affect the only child of the pad, that is the hole.

In certain cases, features may have several children. What you need to do is select the children in the list and check the first option if you wish to deactivate them or just check the second option to deactivate all of the children affected.
7. Click the Graphic tab to change the color of the feature. To have details about how to change graphic properties, please refer to *CATIA Infrastructure User's Guide Version 5*.

8. Press OK to confirm the operation and close the dialog box.

The geometry no longer shows the deactivated features and the specification tree displays red brackets on them to symbolize their status.
Modifying Parts

Editing a feature or a sketch is a simple operation but you need to know some details about the way of doing it.

There are many ways of modifying parts. You can redefine parameters before or during updates or use the Reorder capability to rectify design mistakes.

But prior to modifying parts, you can use commands that facilitate the modifications you need to perform. For example, you can view the genealogical relationships between the different components of a part. You can even access bodies locally.

In a nutshell, this section deals with the different modifications you can perform but it also describes how you can delete features.
Editing Parts, Bodies and Features

Editing a part may mean for example modifying the density of the part (See Displaying and Editing Properties ), but most often editing consists in modifying the features composing the part. This operation can be done at any time.

There are several ways of editing a feature. If you modify the sketch used in the definition of a feature, CATIA will take this modification into account to recompute the feature: in other words, associativity is maintained.

Now, you can also edit your features through definition dialog boxes in order to redefine the parameters of your choice.

Redefining Feature Parameters

This task shows how to edit a draft and a pad. The process described here is valid for any other feature to be edited.

Open the Edit.CATPart document from the \online\samples\part_design directory.

1. Double-click the draft to be edited (in the specification tree or in the geometry area). For more about draft, refer to Basic Draft.

The Draft Definition dialog box appears and CATIA shows the current draft angle value. Generally speaking, CATIA always shows dimensional constraints related to the feature you are editing. Concerning sketch-based features, CATIA also shows the sketches used for extrusion as well as the constraints defined for these sketches.

Instead of double-clicking the element you wish to edit, you can also click this element and select the XXX.object -> Definition... command which will display the edit dialog box.
2. Enter a new draft angle value.

3. Click OK.

This is your new feature:

4. Now, double-click the pad.

The Pad Definition dialog box appears and CATIA shows the pad only, not the next operation.

You will notice that the pad was created in symmetric extent mode and that CATIA displays information about the initial profile.

5. Enter a new length value.

6. Uncheck the Mirrored extent option.

7. Enter a length value for the second limit in the Length field.

CATIA previews the new pad to be created.

8. Click OK.

The modifications are taken into account. Your part now looks like this:
You can also access the parameters you wish to edit in the following way:

1. Select the feature in the specification tree and use the feature.n object -> Edit Parameters contextual command.

You can now view the feature parameters in the geometry area.

2. Double-click the parameter of interest.

A small dialog box appears displaying the parameter value:

3. Enter a new value and click OK.
The Reorder capability allows you to rectify design mistakes. This task shows how to reorder, that is move a pad.

Open the Reorder.CATPart document from the \online\samples\part_design directory.

1. Your initial data consists of a pad that was mirrored and a second pad created afterwards. As the order of creation is wrong, you are going to reorder the second pad so as to mirror the whole part. Position your cursor on Pad.2. and select Edit -> Pad.2 object -> Reorder...

The Feature Reorder dialog box appears.

2. Select Pad.1 to specify the new location of the feature.

This name appears in the After: field.
3. Click OK.

The part rebuilds itself. The mirror feature appears after the creation of the second pad, which explains why this second pad is now mirrored.
The Parent and Children command enables you to view the genealogical relationships between the different components of a part. If the specification tree already lets you see the operations you performed and respecify your design, the graph displayed by the Parent and Children capability proves to be a more accurate analysis tool. Before deleting a feature, we recommend the use of this command.

Open the Parent.CATPart document from the \online\samples\part_design directory.

1. Select the feature of interest, that is Pad1.

2. Select the Tools -> Parent / Children... command (or the Parent/Children contextual command).

A new window appears containing a graph. This graph shows the relationships between the different elements constituting the pad previously selected.
3. Position the cursor on Pad 1 and select the Show All Children contextual command. You can now see that Sketch 2 and Sketch 3 have been used to create two additional pads.

4. Now, select EdgeFillet1 in the graph. The application highlights the fillet in the specification tree, in the graph and in the geometry area.

5. Position the cursor on EdgeFillet1 and select the Show Parent and Children contextual command. EdgeFillet1 is now the feature whose relationships you wish to see. Pad1 and Draft.1 are two parents.

6. To see all parents, position the cursor on EdgeFillet1 and select the Show All Parents contextual command. The sketch upon which the pad and therefore the edge fillet depend is displayed.

7. Once you have got the useful information, click OK to quit the command.
This scenario does not show the use of diverse contextual commands allowing you to hide parents and children, which may prove quite useful whenever the view is overcrowded.

Double-clicking on the components lets you show or hide parents and children.
Scanning the Part and Defining Local Objects

In Part Design, you can access, view and operate all features or bodies locally. The Scan and Define in Work Object capability allows you to design part features without taking the complete part into account.

This task shows how to scan the part and define a local object.

Open the Active.CATPart document from the \online\samples\part_design directory.

1. Select the Edit -> Scan or Define in Work Object... command.

The Scan toolbar appears enabling you to navigate through the structure of your part.

You actually need to click the buttons allowing you to move from one local feature to the other. Sketches are not taken into account by the command.
2. Click the Backwards button to move to the previous feature, that is a pocket.

The application highlights the feature in question in the specification tree as well as in the geometry area.

3. Click the Backwards arrow once more to move to the previous feature, that is a mirror.

4. Now that you have accessed the feature of your choice, that is the mirror, isolate it from the current part by clicking the Exit button.

In the geometry area, the application displays the local object only. In the specification tree, this local object is underlined.

You are now ready to work on this feature.
Defining a feature as local without scanning the whole part is possible using the Define in Work Object contextual command on the desired feature.
Deleting Features

Whenever you will have to delete geometry, you will not necessarily have to delete the elements used to create it. CATIA lets you define what you really want to delete.

This task shows how to delete a sketch on which geometry has been defined and what this operation involves.

Open the Delete.CATPart document from the \online\samples\part_design directory.

1. Select the rectangle you wish to delete.

2. Select the Edit -> Delete... commands. The Delete dialog box is displayed, showing the element to be deleted and two options.
   - **Delete exclusive parents**: deletes the geometry on which the element was created. This geometry can be deleted only if it is exclusively used for the selected element.
   - **Children**: deletes the geometry based upon the element to be deleted, in other words, dependent elements.

Here, the first option cannot be used because the rectangle has no parents.

3. Click More.

Additional options and the elements affected by the deletion are displayed. If you can delete the sketch, you can also replace it with another element.
4. Select Sketch4, that is the hexagon to replace Sketch 2. This operation is now displayed in the dialog box.
5. Click OK.

The sketch is deleted as well as its children: two pads one of which is filleted.

A Few Notes About Deletion

- **Deleting Features Built upon Dress-up Features**

  If you delete a feature (dress-up or not) previously used to create a dress-up feature, the dress-up feature is recomputed.
  In this example, thickness was added to the pad, then material was removed from the whole part using the shell capability. In other words, the existence of the shell depends upon the existence of the thickness.

  You will notice that only the thickness has been deleted. CATIA keeps the shell feature.

- Keep in mind you can apply the Undo command if you inadvertently deleted a feature.
- You are not allowed to delete a profile used to define a feature, unless you delete the profile to construct another one.

- **Patterns**

  Concerning patterns, applying the Delete command on one instance deletes the whole pattern.
Updating Parts

The point of updating a part or feature is to make the application take your very last operation into account. Indeed some changes to a sketch, feature or constraint require the rebuild of the part. To warn you that an update is needed, CATIA displays the update symbol next to the part's name and displays the geometry in bright red.

To update a part, the application provides two update modes:

- **Automatic update**, available in Tools -> Options -> General. If checked, this option lets the application updates the part when needed.
- **Manual update**, available in Tools -> Options -> General. Lets you control the updates of your part. What you have to do is just click the Update icon whenever you wish to integrate modifications. The Update capability is also available via Edit -> Update and the Update contextual command.

However, the progression bar indicating the evolution of the operation displays only if you use the icon.

What Happens When the Update Fails?

Sometimes, the update operation is not straightforward. In this case, CATIA requires you to reconsider your design.

The following scenario exemplifies what you can do in such circumstances.

Open the Update.CATPart document from the \online\samples\part_design directory.

Suppose you have just entered 14mm as the new value radius to edit your fillet. You actually attempted to fillet the following edge:

![Initial radius value = 5mm](image)

Fortunately, CATIA detects an invalid operation. A yellow symbol displays on the Part Body and the feature causing trouble and a dialog box appears providing the diagnosis of your difficulties:
2. What you need to do is click the name of the fillet causing trouble. Three options are then available. You can
- edit the feature
- deactivate the feature
- delete the feature

3. Click the Edit button to modify the fillet. The Edge Fillet Definition dialog box appears to let you enter a correct radius value.

4. Enter 8 mm.

5. Click OK to confirm the operation. The fillet is now valid:
Replacing Elements

This theme shows you how to modify features by replacing surfaces, faces, planes or sketches used for defining them.

Replacing a Surface

Replacing a Sketch

Changing Sketch Supports

Up

Dress-Up Features

Displaying and Editing Properties

Opening a New CATPart Document

Surface-Based Features

Modifying Features

Sketch-Based Features

Transformation Features

Replacing Elements

Setting Constraints
Replacing a Surface

The Replace command lets you replace sketches, faces, planes and surfaces by other appropriate elements.

This task shows you how to replace a surface used for creating geometry with another surface. The operating mode described here is valid for replacing sketches (for an example, see Replacing a Sketch), faces and planes too.

Open the Replace1.CATPart document from the \online\samples\part_design directory.

1. Select Extrusion1, that is the red surface used for trimming both the pocket and the hole.

2. Right-click to display the contextual menu and select the Replace... command.

The Replace dialog box is displayed, indicating the name of the surface to be replaced.

3. Select Extrusion 2 as the replacing surface. Extrusion 2 now appears in the With field of the dialog box.
4. Check the Delete option to delete Extrusion1.

5. Click OK to confirm the operation.

The pocket and the hole are now trimmed by Extrusion 2. Extrusion 1 has been deleted.
Replacing a Sketch

The Replace command lets you replace sketches, faces, planes and surfaces by other appropriate elements.

This task shows you that features based on sketches can have their sketches replaced by new ones.

Open the Replace.CATPart document from the \online\samples\part_design directory.

1. Select Sketch2, that is the square used in the definition of the blue filleted pad.

Note that this pad has been copied eight times. This is the result of the use of the Rectangular Pattern command. For more about this command, refer to Rectangular Pattern.

2. Right-click to display the contextual menu and select the Replace... command.

The Replace dialog box is displayed, indicating the name of the sketch to be replaced.

3. Select sketch3 as the new sketch. Sketch 3 now appears in the With field of the dialog box.
Sketch 3 is an hexagon created in the Sketcher.

Note that if you wish to, you can delete Sketch 2 by checking the Delete option.

4. Click OK to confirm the operation.

A new pad based on sketch 3 is created. The pattern is updated too, and the fillets are maintained.

Sketch 3 is now displayed below Pad 2, that is the original pad, in the specification tree and Sketch 2 is still available.
Changing Sketch Planes

You can replace sketch planes with new ones. Replacing a sketch plane with another one is a way of moving a sketch but it may also be a way of modifying design specifications. This task shows you how to do so.

1. The initial data is composed of a green open body and a gray pad. You are going to replace the plane used for the sketch of this pad with another plane. Select Sketch1 in the specification tree.

2. Select the Sketch1.object -> Change Sketch Support command.

3. Now, select the replacing plane.

The operation is immediately performed. You will notice that the bottom side of the pad adjusts itself to the open body shape. Actually, the original profile of the pad was partially created with the Intersect command, which explains why the pad integrates the open body shape.
Setting Constraints

CATIA Version 5 lets you set geometrical and dimensional constraints on various types of elements in the 3D geometry area.

This section shows you how to use both constraint commands:

- Constraint defined in Dialog Box.
- Constraint

and how to modify them. Note also that you can customize symbols dedicated to constraints. To have details about it, please refer to Customizing Constraints.
Setting Constraints in the 3D Area

3D area constraints are defined by means of the commands. Depending on the creation mode chosen for creating wireframe geometry and surfaces (see CATIA Wireframe and Surface User’s Guide), constraints set on these elements may react in two ways. You create measures if support elements were created with the Datum mode disactivated. Conversely, you create constraints with no links to the other entities that were used to create them if you constrain datums. For more about datums, please refer to Creating Datums.

This task shows you how to set a distance constraint between a face and a plane.

1. Select the face you wish to constrain.

2. Select the plane.

3. Click the Constraint icon.

CATIA detects the distance value between the face and the plane. Moving the cursor moves the graphic symbol of the distance.

4. Click where you wish to position the constraint value.

Now, if you wish to set another constraint between the plane and another face, CATIA will create a measure. Creating a measure means that each time CATIA integrates modifications to the geometry, this measure reflects the changes too.

The measure is displayed in brackets.

Likewise, you cannot constrain a distance between two faces. In the example below, CATIA creates a measure constraint between the faces, not a driving constraint.
To know how to modify a constraint, refer to **Modifying Constraints**.
This task shows you how to use this constraint command which detects possible constraints between selected elements and lets you choose the constraint you wish to create.

1. Multiselect the elements you wish to constrain, that is both faces as shown.

2. Click the Constraint Defined in Dialog Box icon. CATIA detects three possible constraints you can set between the faces:
   - Distance
   - Angle
   - Fix

The other constraints are grayed out indicating that they cannot be set for the elements you have selected.
3. Check the Distance option and click OK to confirm.

The distance constraint is created.

To know how to modify a constraint, refer to *Modifying Constraints*.
Modifying Constraints

Editing Constraints

You can edit constraints by:

- double-clicking on the desired constraints and modify related data in the Constraint Definition dialog box that displays.

- selecting the desired constraints and use the XXX.N.object -> Definition.. contextual command...

...to display the Constraint Definition dialog box and modify related data.

Renaming Constraints

You can rename a constraint by selecting it and by using the XXX.N.object -> Rename parameter contextual command.... In the dialog box that appears, you just need to enter the name of your choice.

Deactivating or Activating Constraints

You can deactivate a constraint by selecting it and by using the XXX.N.object -> Deactivate contextual command. Deactivated constraints appear preceded by red brackets.

Conversely, to activate a constraint, use the Activate contextual command.
Lp

3D Constraints

Setting constraints defined in

Modifying Constraints
Advanced Tasks

- Associating Bodies
- Tools
- Multi-Document
To design a part, you need to create features within the same Part body but you also need to insert additional bodies which you will combine together in various ways to create material. Once your bodies are well-defined, you can assemble them performing an assembly or request CATIA to compute their possible intersections. You can also add or remove bodies from other bodies or even use the Trim capability, which combines addition and removal of material.

This section will show you the different ways of associating bodies to form a part in the .CATPart document, the first task being the insertion of a new body.
Inserting a New Body

This task shows you how to insert a new body into the part.

1. To add a body to the part, select the Insert -> Body command.

   CATIA displays this new body in the specification tree. It is underlined, indicating that it is the active body.

2. Now, let’s construct this new body: for example, sketch a circle on one of the part faces.

3. Leave the Sketcher and extrude this circle to create a pad.

   Eventually, the specification tree looks like this:
You will notice that the Part body and Body1 are autonomous. The operations you would accomplish on any of them would not affect the integrity of the other one. Now, if you wish to combine them, refer to the following tasks which show the different ways of attaching bodies.
Adding Bodies

This tasks illustrates how to add a body to a part.

Open the Add.CATPart document from the \online\samples\part_design directory.

1. This is your initial data: the pads are independent. To perform the addition, you need to select Body.1. and click the Add icon (or select the Edit -> Body.1.object -> Add... command).

The result is immediate. However, if the specification tree is composed of several bodies, a dialog box displays to let you determine the second body you wish to use. By default, the application proposes to add the selected body to the Part body.

The specification tree and the part now look like this:
You will note that both pads keep their original colors.
Assembling Bodies

Assembling is an operation integrating your part specifications. This task shows you two assemble bodies to let you see how the resulting parts look different depending on your specifications.

Open the Assemble.CATPart document from the \online\samples\part_design directory.

First, you are going to assemble a pocket to the Part Body. You will note that as this pocket is the first feature of the body, material has been added (see Basic Pockets, key point).

1. To assemble them, you need to select Body 2 and click the Assemble icon (or select the Edit -> Body2.object -> Assemble... command).
The Assemble dialog box displays to let you determine the assembly you wish to perform. By default, CATIA proposes to assemble the selected body to the Part body, and displays the name of the last feature of the Part body in the After field.

2. As you wish to perform this operation, click OK.

During the operation, CATIA retrieves the material defined by the pocket from the Part body.

This is your new Part body:

3. Now delete the assemble operation to go back to the previous state. You are going to perform a new assemble operation.


The Assemble dialog box displays again.

5. Select Body1 in the specification tree to edit the After field. Pad2 appears in the field, indicating that you are going to assemble Body2 to Body1.
6. Click OK.

The material defined by the pocket from Body1 has been retrieved during the operation.
Removing Bodies

This task illustrates how to remove a body from a part.

1. Open the Remove.CATPart document from the \online\samples\part_design directory.
   
   1. The part is composed of two pads. To remove Body 1 from the Part body, select Body.1

   2. Click the Remove icon (or select the Edit -> Body.1.object -> Remove... command).

   The result is immediate. However, if the specification tree is composed of several bodies, a dialog box displays to let you determine the second body you wish to use. By default, the application proposes to remove the selected body from the Part body.

   The cylinder is removed from the Part body:
The material resulting from an intersection operation between two bodies is the material shared by these bodies. This task illustrates how to compute two intersections.

Open the Intersect.CATPart document from the \online\samples\part_design directory.

This is your initial data: the three pads belong to distinct bodies.

7. To compute the intersection between the Part body and Body 2, select Body.2.

8. Click the Intersect icon (or select the Edit -> Body.2.object -> Intersect... command).

The Intersect dialog box displays to let you determine the second body you wish to use. By default, the application proposes to intersect the selected body to the Part body.
9. As you wish to perform this operation, click OK.

CATIA computes the intersection between the two bodies.

The Part body now looks like this:

10. Now delete the intersection to go back to the previous state. You are going to create a new intersection.

11. Position your cursor on Body 2 and select the Edit -> Body2.object -> Intersect contextual command to display the Intersect dialog box.

12. Select Body1 in the specification tree to edit the After field. Pad2 appears in the field, indicating that you are going to compute the intersection between Body2 and Body1.
13. Click OK. Body1 now looks like this:
Trimming Bodies

Applying the Union Trim command on a body entails defining the elements to be kept or removed while performing the union operation.

The following rules are to be kept in mind:

Concretely speaking, you need to select the two bodies of interest and specify the faces you wish to keep or remove. This section provides two parts you can obtain using the Union Trim capability: a flange and a stiffener.

**Flange**

This task illustrates how to create a flange using the Union Trim capability.

Open the Union_Trim1.CATPart document from the \online\samples\part_design directory.
1. Select in the specification tree the body you wish to trim.

2. Click the Union Trim icon (or select the Edit -> Body.1.object -> Union Trim... command).

   The Trim Definition dialog box is displayed, and the part becomes red, meaning that an operation is being performed.

3. Click the Faces to keep field and select the side face.

   The selected face now appears in blue, meaning that the application is going to keep it.

4. Click the field again and select the top face.

   This face becomes blue too.
5. Click OK.

The application computes the material to be removed to leave the part open. The operation (identified as Trim.xxx) is added to the specification tree.
Stiffener

This task illustrates how to create a stiffener using the Union Trim capability.

Open the Union_Trim2.CATPart document from the \online\samples\part_design directory.

1. Select in the specification tree the body you wish to trim.

2. Click the Union Trim icon (or select the Edit -> Body1.object -> Union Trim... command).

The Trim Definition dialog box appears:

3. Click the Faces to remove field and select the face as shown.

The selected face now appears in pink, meaning that it will be removed during the Trim operation.
4. Click OK.
The stiffener is created.
Keeping and Removing Faces

The Remove Lump command lets you reshape a body by removing material. To remove material, either you specify the faces you wish to remove or conversely, the faces you wish to keep. In some cases, you need to specify both the faces to remove and the faces to keep.

This task illustrates how to reshape a body by removing the faces you do not need. Depending on the faces you select for removal, you will obtain two distinct bodies.

Open the Remove_Lump.CATPart document from the online\samples\part_design directory.

1. Select the body you wish to reshape, that is Part Body.

2. Click the Remove Lump icon (or select the Part Body object -> Remove Lump... contextual command).

   The Remove Lump dialog box appears. The application prompts you to specify the faces you wish to remove as well as the faces you need to keep.

3. Click the Faces to remove field and select the face as shown.

   The selected face now appears in pink, meaning that it will be removed during the operation.
4. Click OK.

The new body looks like this:

5. Now, double-click Remove Lump in the specification tree to edit it.

6. In the Dialog box that appears, click the Faces to remove field and select the face as shown.

This face appears in pink.

The faces selected as the faces to be kept are displayed in blue.

5. Click OK.

The new body looks like this:
Tools

This theme shows you how to measure distances and angles between geometrical entities or between points. It also explains how to measure the properties associated to a selected item.

**Draft Analysis**

**Measuring Minimum Distances and Angles**

**Curvature Analysis**

**Measuring Elements**

**Up**

**Associating Bodies**

**Tools**

**Multi-Document**
Performing a Draft Analysis

This task explains how to detect if the part you drafted will be easily removed from the associated mold. For more about drafts, please refer to Basic Draft.

The discretization option should be set to a maximum (the 3D Accuracy -> Fixed option should be set to 0).

Prior to analyzing the draft, you need to define a direction by using the compass. This direction is supposed to be the pulling direction used for removing the part from its mold.

1. Drag the compass and drop it onto plane zx.

Y axis always indicates the direction of analysis.

Once the compass is snapped to the plane, you can begin to start using the Draft Analysis command.

2. Click the Draft Analysis icon.

3. Select the part. Selecting a face is enough for taking the whole part into account. To improve the display, drag the compass away from the plane and drop it.

The Draft Analysis dialog box is displayed, and the analysis is visible on the part. The part has three colors: red, light blue and green. Each color is defined in the dialog box. Each color is associated to a range of draft angle values, as specified in the fields below. The values range from -20 to 20 degrees. However, these colors defined for minimum and maximum ranges apply to values inferior to -20 or superior to 20 degrees too.
4. You can customize these colors. For example, double-click the light blue arrow to display a color palette you are going to use for creating your own yellow.

5. In the palette that appears, drag the cross inside the spectrum to instantaneously change the color in the small box below the spectrum. Drag the cross so as to obtain a yellow color.

6. If needed, move the arrow up or down to vary the brightness of the custom color and click OK to create your own color.

The Color palette closes and the Draft Analysis displays the yellow color instead of the light blue one.

To get the most out of colors, use the View + Lighting capability, as explained in the *CATIA- Infrastructure User’s guide Version 5*.

7. Select the dark blue arrow and move it down to remove the associated dark blue field.

The dialog box now displays three colors only.
8. Keep the Sharp left option. The different displays for the color range are:
   - linear,
   - sharp left,
   - sharp center (reserved for surfaces, see the CATIA FreeStyle Shaper & Optimizer User's Guide),
   - sharp right (reserved for surfaces, see the CATIA FreeStyle Shaper & Optimizer User's Guide)

The linear option is available too for analyzing drafted faces. Depending on the complexity of the part, it may sometimes be more efficient.

9. Enter 2.0 in the field associated to the green arrow. Note that you can manipulate the draft angle values by clicking on the arrows too. This value is the minimum draft angle value which makes the removal of the part possible.

The dialog box now looks like this...

![Draft Analysis dialog box](image)

.. and the part like this:
Using the values and colors set and the direction defined at the beginning of this task, you can analyze the results as follows:

- the red areas cannot be removed from the mold. These areas are assigned a draft angle value set between -90 and 0 degrees.
- the yellow areas cannot be removed from the mold either. These areas are assigned a draft angle value set between 0 and 2 degrees.
- the green areas can be removed from the mold. These areas are assigned a draft angle value set between 2 and 90 degrees.

10. Check the On the fly analysis option and move the pointer over a yellow area. Arrows are displayed under the pointer, identifying the normal to the face at the pointer location (green arrow). As you move the pointer over the surface, the normal display is dynamically updated.

The displayed value indicates the angle between the draft direction and the normal to the surface at the current point.
If you click the green arrow (Normal) you can invert it. You can therefore obtain the opposite result.

If you click the red arrow, it freezes the location for the arrow allowing general manipulations according to the compass.

11. Once you have finished analyzing the draft, click Close. Otherwise click Reset to come back to default values for the color range.
This task explains how to analyze the Gaussian curvature of a body.

The visualization mode should be set to Shading with Texture and Edges, and the discretization option should be set to a maximum (the 3D Accuracy -> Fixed option should be set to 0).

1. Select a body.

2. Click the Curvature Analysis icon.

The Curvature Analysis dialog box is displayed, and the analysis is visible on the selected element.

3. Choose the linear option from the dialog box. Available options to display the color range are:
   - linear,
   - sharp left,
   - sharp center,
   - sharp right.

The values are ranging from 0 to 1, corresponding to the minimum and maximum Gaussian curvature respectively.

4. Modify the values in the color range to highlight specific areas of the selected face. To do this, click and drag the arrows delimiting the colors, or directly enter the values.

5. Click Close to exit the command, or reset to come back to default values for the color range.
Measuring Minimum Distances \& Angles between Geometrical Entities or Points

This task explains how to measure distances and angles between geometrical entities (surfaces, edges, vertices and entire products) or between points.

To get the most out of this tool, set the Render Style to Shading with Edges.

For example, open the Measure_Between.CATPart document from the \online\samples\part_design directory.

1. Click the Measure Between icon.

The Measure Between dialog box appears.

2. Set the desired measure type in the Measure type drop-down list box.
Defining measure types:
- Between (default type): measures distance and angle between defined reference and target items
- Chain: sets the target item as the reference item for the next measure
- Fan: fixes the reference item selection so that you always measure from this item

3. Set the desired measure mode in the Target and Reference drop-down list boxes

Defining measure modes:
- *Any geometry* (default mode): measures distances and angles between defined geometrical entities (points, edges, surfaces, etc.)
- *Any geometry, infinite*: measures distances and angles between planar faces mapped onto infinite planes and straight line segments mapped onto infinite lines. For all other selections, the measure mode is the same as any geometry
- *Point on geometry*: measures distances and angles between points selected on defined geometrical entities
- *Point only, Edge only, Surface only*: measures distances and angles between points, edges and surfaces respectively. Dynamic highlighting is limited to points, edges or surfaces and is thus simplified compared to the Any geometry mode.
- *Intersection*: measures distances and angles between intersection points between two edges or an edge and a surface. In this case, two selections are necessary to define target and reference items
- *Edge limits*: measures distances and angles between endpoints or midpoints of edges. Endpoints only are proposed on curved surfaces.
- *Arc center*: measures distances and angles between the centers of arcs
- *Coordinate*: measures distances and angles between coordinates entered for target and/or reference items

4. Click to select a surface, edge or vertex.

The appearance of the cursor has changed to reflect the measure command you are in. A number (1 for the reference item and 2 for the target item) also helps you identify where you are in your measure.
Dynamic highlighting as you move your cursor over surfaces, faces and vertices helps you locate the reference and target items.

5. Click to select another surface, edge or vertex.

A line representing the minimum distance vector is drawn between the selected items in the geometry area. Appropriate distance values are displayed in the dialog box.
The overall minimum distance as well as distance vector components between the selected items and $x,y,z$ coordinates of points between which the minimum distance was measured are given in the Measure Between dialog box.

The number of decimal places is controlled by the DMU Navigator tab in the Options dialog box (Tools -> Options, Product).

6. If necessary, adjust the presentation of the measure. You can move the lines and text of the measure

7. Select another reference item

8. Set the Measure type to Fan to fix the reference item selection so that you can always measure from this item

9. Select the target item

10. Select another target item

Customizing Your Measure:

You can, at any time, customize the display of the results in both the geometry area and the dialog box. To do so, click Customize... in the Measure Between dialog box and set your display in the Measure Between Customization dialog box. By default, all results are displayed.
11. Click Close.
Measuring Elements

This task explains how to measure the properties associated to a selected item (points, edges and surfaces)

To get the most out of this tool, set the Render Style to Shading with Edges.

For example, open the Measure_Between.CATPart document from the online\samples\part_design directory.

1. Set View -> Render Style to Shading with Edges

You cannot use this command, if Shading only is selected.

2. Click to select the desired item.

3. Click the Measure Item icon.

The appearance of the cursor has changed to reflect the measure command you are in.

Dynamic highlighting as you move your cursor over objects helps you locate the reference item.

The dialog box is updated.
The dialog box gives information about the selected item, in our case a surface. The center of gravity of the surface is visualized by a point. In the case of non-planar surfaces, the center of gravity is attached to the surface over the minimum distance.

5. Click Customize... in the Measure Item dialog box to see the properties the system detects for the various types of item you can select.

Customizing Your Measure:

You can, at any time, customize the display of the results in both the geometry area and the dialog box. To do so, click Customize... in the Measure Item dialog box and set your display in the Measure Item Customization dialog box. By default, all results are displayed.
6. Try selecting other items to measure associated properties

The system detects whether the edge is a line, curve or arc, taking model accuracy into account. If a line or curve is detected, the dialog box indicates the length as well as X, Y, Z coordinates of the start and end points. If an arc is detected, the dialog box also indicates the arc angle, radius or diameter and the X, Y, Z coordinates of the center point.

7. If necessary, adjust the presentation of the measure:

You can move the lines and text of the measure

The number of decimal places is controlled by the DMU Navigator tab in the Options dialog box (Tools -> Options).

8. Click Close when done.
Handling Parts in a Multi-Document Environment

In this task, you are going to copy a part body from one CATPart document to another, then edit the initial part body. This scenario shows you how the application harmonizes this type of ulterior modifications. Thanks to the underlying methodology, you can work in concurrent engineering.

Open the Multi_Document.CATPart document from the \online\samples\part_design directory.

This scenario assumes there are two CATPart documents. Part2.CATPart is the target document, Part1.CATPart contains the part body that will be copied, then edited in Part2.

The part body to be copied looks like this:

1. Select Part Body.

2. Select the Edit -> Copy command to copy the part body.

3. Open a new CATPart document 'Part2.CATPart' and position the cursor anywhere in the specification tree.
4. Select the Edit -> Paste Special... command.

The Source Definition dialog box appears. Two paste options are available:
- AsSpec: the object is copied as well as its design specifications
- AsResultWithLink: the object is copied without its design specifications

4. For our scenario, select the AsResultWithLink option if not already selected, and click OK.

The Part Body is copied into the Part2.CATPart document. You will notice that the specification tree displays it under the name of `Solid'.
5. Now, if you wish, you can fillet four edges. You can actually perform any modifications you need.


7. Use the Remove command to remove material from the part body.

8. In the Part2.CATPart document, the graphic symbol used for Solid.1 in the tree is now orange. This means that the initial Part Body underwent transformations.

   You can also notice that the update symbol is displayed next to Part2.
9. What you need to do is update the copied object. Just click Solid in the specification tree.

10. Select the Update command to update the whole part.

The Solid.1 object -> Update Link command lets you update the link between the original part body and the new body.

The solid is updated to reflect the change: material is removed.

The specification tree indicates the part body has integrated the modifications made in the original part body. Note the white sheet symbol next to Solid.1.
Part Design Workbench

The Part Design 5 window looks like this:

Click the sensitive areas to see the related documentation.

Part Design Menu bar
- Sketch-Based Features
- Dress-Up Features
- Transformation Features
- Surface-Based Features
- Constraints
- Boolean Operations
Part Design Menu Bar

This section presents the main menu bar tools and commands dedicated to Part Design.

**Edit**

- **For...**
  - Undo
  - Redo
  - Update
  - Cut
  - Copy
  - Paste
  - Delete
  - Search...
  - Properties

- **See...**
  - Updating Parts or Features
  - Handling Parts in a Multi-Document Environment
  - Deleting Features
  - Displaying and Editing Properties
  - Scanning the Part and Defining Local Objects
  - Redefining Feature Parameters
  - Displaying and Editing Properties
  - Reordering Features

**Insert**

- **For...**
  - Body
  - Constraints
  - Sketcher...
  - Sketch-Based Features
  - Dress-Up Features
  - Surface-Based Features
  - Transformation Features
  - Boolean Operations

- **See...**
  - Inserting a New Body
  - Setting Constraints
  - Sketcher User's Guide
  - Creating Sketch-Based Features
  - Creating Dress-Up Features
  - Creating Surface-Based Features
  - Creating Transformation Features
  - Associating Bodies
Tools

For... See...

Parent/Children Parent and Children

Options... Customizing
Sketch-Based Features Toolbar

This toolbar is available in extended or compact display mode. To choose your display mode, use the View -> Toolbars -> Sketch-Based Feature (Extended/Compact) command.

See Pad

See Rib

See Pocket

See Slot

See Shaft

See Stiffener

See Groove

See Loft

See Hole

See Removed Loft
Dress-Up Features Toolbar

See Edge Fillet
See Variable Radius Fillet
See Face-Face Fillet
See Tritangent Fillet

See Chamfer
See Basic Draft and Draft with Parting Element
See Shell
See Thickness
Surface-Based Features Toolbar

This toolbar is available in two extended or compact display modes. To choose your display mode, use the View -> Toolbars -> Surface-Based Feature (Extended/Compact) command.

See Split

See Close Surface

See Thick Surface

See Sew Surface
Transformation Features Toolbar

See **Translation**
See **Rectangular Pattern**

See **Rotation**
See **Circular Pattern**

See **Symmetry**
See **User Pattern**

See **Mirror**
See **Scaling**

Up
Part Design Menu Bar
Sketch-Based Features
Transformation Features

Dress-Up Features
Surface-Based Features
Transformation Features
Measure

Boolean Operations
Sketcher Toolbar
Constraints
Boolean Operations Toolbar

This toolbar is optional. You can access it using the View -> Toolbars -> Boolean Operations command.

See Assembling Bodies
See Adding Bodies
See Removing Bodies

See Intersecting Bodies
See Trimming Bodies
See Keeping and Removing Faces
See CATIA Version 5 Release 3 Sketcher User’S Guide
Measure Toolbar

See Measuring Minimum Distances & Angles between Geometrical Entities or Points

See Measuring Elements

Up
Dress-Up Features
Boolean Operations
Part Design Menu Bar
Surface-Based Features
Sketcher Toolbar
Constraints
Sketch-Based Features
Transformation Features
Measure
Constraints Toolbar

See Setting Constraints in the 3D Area

See Setting Constraints in the 3D Area
Customizing

This section describes the different types of setting customization you can perform. All tasks described here deal with permanent setting customization. These tasks are:

- Constraints
- Tree View
- General Settings
- Measurement Display
Glossary

B

body  See part body.

C

chamfer A cut through the thickness of the feature at an angle, giving a sloping edge.

child  A status defining the genealogical relationship between a feature or element and another feature or element. For instance, a pad is the child of a sketch. See also parent.

constraint  A geometric or dimension relation between two elements.

D

draft angle  A feature provided with a face with an angle and a pulling direction.

F

feature  A component of a part. For instance, shafts, fillets and drafts are features.

fillet  A curved surface of a constant or variable radius that is tangent to, and that joins two surfaces. Together, these three surfaces form either an inside corner or an outside corner.

G

groove  A feature corresponding to a cut in the shape of a revolved feature.

H

hole  A feature corresponding to an opening through a feature. Holes can be simple, tapered, counterbored, countersunk, or counterdrilled.
**M**

**mirror**  A feature created by duplicating an initial feature. The duplication is defined by symmetry.

**P**

**pad**  A feature created by extruding a profile.

**parent**  A status defining the genealogical relationship between a feature or element and another feature or element. For instance, a pad is the parent of a draft.

**part**  A 3D entity obtained by combining different features.

**part body**  A component of a part made of one or several features.

**pattern**  A set of similar features repeated in the same feature or part.

**pocket**  A feature corresponding to an opening through a feature. The shape of the opening corresponds to the extrusion of a profile.

**profile**  An open or closed shape including arcs and lines created by the profile command in the Sketcher workbench.

**R**

**reorder**  An operation consisting in reorganizing the order of creation of the features.

**rib**  A feature obtained by sweeping a profile along a center curve.

**S**

**scaling**  An operation that resizes features to a percentage of their initial sizes.

**shaft**  A revolved feature

**shell**  A hollowed out feature

**sketch**  A set of geometric elements created in the Sketcher workbench. For instance, a sketch may include a profile, construction lines and points.

**slot**  A feature consisting of a passage through a part obtained by sweeping a profile along a center curve.

**split**  A feature created by cutting a part or feature into another part or feature using a plane or face.

**stiffener**  A feature used for reinforcing a feature or part.