The CATIA Version 5 Plant Layout product enables you to easily create a layout design for a manufacturing plant or other type of plant. The main focus of the product is to allow preliminary or conceptual design of a plant to be accomplished quickly. It provides an efficient, cost-effective way to lay out an initial plant design for review and validation. The initial plant design may then be expanded, evolved, and modified to continue the plant design process. The entire process is accomplished through a simple, highly intuitive interface, combining traditional 2D layout paradigms with full CATIA 3D capabilities to allow you to build a 3D digital representation of the plant.

The Plant Layout product can be used with other digital plant design products, such as CATIA Version 5 Systems Routing, to satisfy plant design requirements. These products, together with the CATIA Version 5 product portfolio, provide you with the complete ability to design and optimize your plant layout.

The Plant Layout User's Guide has been designed to show you how to create plant layout designs. Based on design factors and various industries and domains, different design approaches may be undertaken. This book provides an overview of the product and aims at illustrating specific design procedures to aid your plant design efforts.
About This Book

This book describes how to use the **CATIA Version 5 Plant Layout** product. Before you read it, you should be familiar with basic CATIA Version 5 concepts such as document windows, standard tool bars, and view tool bars.

To get the most out of this guide, you should start with the tutorial in the Getting Started section.

The remaining sections of the book describe in detail the procedures for using all of the features of the Plant Layout product. The procedures are divided into basic, advanced, and customization sections.
Getting Started

The following short tutorial provides an introduction to the CATIA Version 5 Plant Layout product. It is intended to give you a feel for the product's capabilities in a few step-by-step scenarios, which are listed below.

- Entering the Plant Layout Workbench
- Customize Working Units
- Create a Plant Site
- Create a Building
- Create an Equipment Reservation
- Create a Walkway

These tasks can be completed in about 15 minutes.
Entering the Plant Layout Workbench

This task explains how to enter the Plant Layout workbench.

1. Select the **Start** menu.

2. Select **AEC Plant** -> **Plant Layout**.

The Plant Layout workbench is loaded, and an empty CATProduct document is opened.
This task describes how to set working units.

1. Select Tools -> Options command.

2. Select Units tab from the General menu
3. Select the Length Magnitude and set the units to Foot.
4. Select the Area Magnitude and set the units to Square foot.
5. Select the Product menu from the left side of the Options window.
6. Select the Plant Layout tab.
7. Set the Grid Step field to be 1 ft. This sets the default grid step for all the snapping capabilities provided with the Plant Layout product.
5. Click the OK button to complete the customization of the working units.
Create a Plant Site

This task describes how to create a plant site.

1. Click the Area icon.
2. Select Site as the Area type.
3. To define the size of the site, key in these values:
   - X Length 1000 ft
   - Y Length 1000 ft
   - Height 100 ft
4. Click at the location 0, 0, 0.
   The plant site is created, centered at the origin.
5. To display the entire site, click the Fit All In icon.

   Up
   Create a Plant Site
   Enter the Workbench
   Create a Building
   Create a Walkway
   Set Working Units
   Create an Equipment Reserve
Create a Building

Now that you have defined a plant site, you will create a building on the site.

1. In the specification tree, double-click the site you created in the previous task. The site is now the active area in the Plant Layout product.

2. Click the Boundary icon.
3. Select Wall as the Boundary type.
4. Set the temporary grid to 10 ft.
5. Click several points inside the plant site to create a closed, non-rectangular polygon.

When you click the first point, a cross marks the spot. To close the polygon, select the cross.

6. Click the Area icon.

7. Select the Boundary Inside creation mode.
8. Select Building as the area type.
9. Click anywhere inside the wall you just created. This defines your building.
10. To see the building and walls in the specification tree, click on the plus sign (+) next to the site name.
Create an Equipment Reservation

With a building now in place in your plant site, you can create an equipment reservation.

1. In the specification tree, double-click the building you created in the previous task to make it the active element.

2. Select the Item Reservation icon.

3. Select Equipment Reservation as the type of reservation.

4. To define the size of the reservation, key in these values:
   - X Length 20 ft
   - Y Length 15 ft
   - Height 10 ft

5. Click anywhere in the building to define a location for the equipment reservation.

6. Zoom the window in to get a closer view of your equipment reservation.

7. To see the newly created equipment reservation in the specification tree, click on the plus sign (+) next to the building name.
Create a Walkway

In this final task, you will create a walkway in your building.

1. Click the Path Reservation icon.
2. Select Walkway as the type of path reservation.
3. Click the Section type icon.
4. To define the size of the walkway, key in these values in the Section dialog box:
   - Height 8 ft
   - Width 6 ft
5. Click OK.
6. Click several points in the building to create the walkway. Double-click the last point to complete the walkway definition.
Basic Tasks

The basic tasks for laying out a design using the Plant Layout workbench are listed below.

<table>
<thead>
<tr>
<th>Theme</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Using Basic Layout Tools</td>
<td>Describes how to work with a step grid, change the current axis,</td>
</tr>
<tr>
<td></td>
<td>and manipulate elements.</td>
</tr>
<tr>
<td>Using Areas</td>
<td>Describes how to create and modify areas.</td>
</tr>
<tr>
<td>Using Boundaries</td>
<td>Describes how to create and modify boundaries.</td>
</tr>
<tr>
<td>Using Item Reservations</td>
<td>Describes how to create and modify item reservations.</td>
</tr>
<tr>
<td>Placing Resources</td>
<td>Describes how to place resources.</td>
</tr>
<tr>
<td>Creating Path Reservations</td>
<td>Describes how to create path reservations.</td>
</tr>
<tr>
<td>Modifying Path Reservations</td>
<td>Describes how to modify path reservations.</td>
</tr>
</tbody>
</table>
Using Basic Layout Tools

The following procedures describe the basic tools available in the Plant Layout product for general layout functions.

- Making an Element Active
- Aligning Elements
- Changing the Current Axis
- Using a Step Grid
- Using Boundaries
- Using Item Reservations
- Using Areas
- Placing Resources
- Creating Path Reservations
- Modifying Path Reservations
Making an Element Active

This task shows you how to make an element in a drawing active. An element is active when it is highlighted in blue in the specification tree, as shown below.

1. You can make an element active by following any of these steps:
   - Double-click the element in the drawing or in the specification tree.
   - Select Activate Parent icon to make the active element's parent active.
   - To activate an area, select the Activate Area icon and then select the area.

2. Optional. You can change the display of elements that are not active using the Toggle Dimming Mode icon on the General Environment Toolbar:
   - When Dimming Mode is on, elements that are not active are dimmed.
   - When Dimming Mode is off, inactive elements are not dimmed.
Aligning Elements

This task shows you how to align elements in your layout. You can align the center or the sides of an element to a reference plane that you define. You can also rotate an element to align it with a reference plane.

1. Select the element(s) that you want to align.

2. Select the icon for the type of alignment you want to perform:
   - Align Sides
   - Align Center
   - Rotate to Align

3. Define the plane to use as a reference for the alignment by doing the following:
   a. Place your cursor over a geometric element that defines the plane (e.g., a construction plane, boundary, area contour, item reservation).

   As you move the cursor, a small white rectangle is displayed to show the selectable planes, as shown below. A line normal to the rectangle shows the direction in which the alignment would be performed.
If you do not see the white rectangle, zoom out from the drawing. The white rectangle cannot be displayed if the element under your cursor is displayed too small.

b. Click to select the plane.

The selected elements are aligned along the plane.
4. Optional. If you selected Align Sides or Rotate to Align, you can indicate (press the left mouse button) to adjust the element as described below.

- If you selected Align Sides, indicating flips the aligned elements to the other side of the reference plane.
- If you selected Rotate to Align, indicating rotates the aligned elements in increments of 90 degrees.

Select a command icon or an element in the model to exit the alignment command.
Changing the Current Axis

This task shows you how to change the current axis. By default, the current axis is located on the active area or item reservation. If neither an area nor an item reservation is active, the current axis is located on the parent area for the active element.

The current axis is the reference point by which elements are routed and placed. It is also the reference point from which an element's position is determined (as displayed in the X,Y,Z fields on the Definition dialog box for an element).

1. Do either of the following to change the current axis:

   - Place your cursor on the Change Current Axis icon and drag it to the element you want to use as a reference.
   - Click the Change Current Axis icon and then select the element you want to use as a reference.

The axis is displayed on the element.
Using a Step Grid

This task shows you how to define the increments for a grid to control the routing or placement of elements in a drawing.

1. Select the increment field and key in a value for the grid units.
2. Set any of the following step grid options on the General Environment Toolbar:

   - **Snap to steps off current axis**
     Coordinates displayed are relative to the current axis.

   - **Snap to steps off last position**
     Coordinates displayed are relative to the current axis until you indicate a point; after that, coordinates displayed are relative to last point that you indicate.

   - **Snap to Drafting elements**

If you have defined construction planes in the drawing, you can also use these options:

   - **Snap to XY construction planes**
   - **Snap to elevation planes (in the Z direction)**
   - **Snap to all construction planes**

For instructions on defining construction planes, see [Using Construction Planes](#).
Using Areas

You can create areas in any of the following ways.

Define a Size and Location  Define Two Corners

Select Inside a Boundary  Select the Lines of a Boundary

You can modify areas in the following ways.

Move a Rectangular Contour of an Area  Resize the Contour of an Area

Move an Area
Creating an Area by Defining its Size and Location

This task shows you how to create an area by keying in a size and clicking a location.

1. Click the Area icon.
   The Area Creation dialog box is displayed.

2. Select the Rectangular - Location icon.
3. Select the Type of area you want to create:
4. Define the Axis Position:
   - Center
   - Same as Parent

5. Define the size of the area:
   - X Length
   - Y Length
   - Height

6. Select a display option:
   - [Solid] (Solid) displays the area at full height.
   - [Flat] (Flat) displays the area with no height.

7. Optional. To display descriptive text on the area, activate either or both of these options:
   - Display Text for Name
   - Display Text for Size
8. Indicate a location for the center of the area.

The area is displayed.
Creating an Area by Defining Two Corners

This task shows you how to create an area by defining two corners.

1. Click the Area icon.

The Area Creation dialog box is displayed.

2. Select the Rectangular - Corners icon.

3. Select the Type of area you want to create:
4. Define the Axis Position:
   - Center
   - Same as Parent

5. Define a height for the area.

6. Select a display option:
   - ![Solid](image) (Solid) displays the area at full height.
   - ![Flat](image) (Flat) displays the area with no height.

7. Optional. To display descriptive text on the area, activate either or both of these options:
   - Display Text for Name
   - Display Text for Size

8. Indicate a location for the first corner.
9. Indicate a location for the second (opposite) corner. The area is displayed.
Creating an Area by Selecting Inside a Boundary

This task shows you how to create an area inside a boundary by clicking anywhere inside the boundary lines.

1. Create a boundary.
   See Creating a Boundary for instructions.

2. Click the Area icon.
   The Area Creation dialog box is displayed.

3. Select the Bounded - Inside icon.
4. Select the Type of area you want to create:

5. Define the Axis Position:
   - Center
   - Same as Parent

6. Define a height for the area.

7. Select a display option:
   - [Solid] (Solid) displays the area at full height.
   - [Flat] (Flat) displays the area with no height.

8. Optional. To display descriptive text on the area, activate either or both of these options:
   - Display Text for Name
   - Display Text for Size
9. Click anywhere inside the boundary.
The area is displayed.
Creating an Area by Selecting the Lines of a Boundary

This task shows you how to create an area inside a boundary by selecting each of the lines that make up the boundary.

1. Create a boundary.
   See [Creating a Boundary](#) for instructions.

2. Click the Area icon
   The Area Creation dialog box is displayed.

3. Select the Bounded - Select icon

4. Select the Type of area you want to create:
5. Define the Axis Position:
   - Center
   - Same as Parent

6. Define a height for the area.

7. Select a display option:
   - (Solid) displays the area at full height.
   - (Flat) displays the area with no height.

8. Optional. To display descriptive text on the area, activate either or both of these options:
   - Display Text for Name
   - Display Text for Size

9. Select the boundary lines that you want to outline the area.
   The area is displayed.
Moving a Rectangular Contour of an Area

This task shows you how to move a rectangular contour of an area.

1. Make the area active.

See Making an Element Active for instructions.

2. Click the contour for the area.
The contour is highlighted.

3. Place your cursor at the desired location on the contour.

As you move the cursor over the contour, visual "cues" are displayed to show how you can move contour.

- A plane is displayed when the cursor is over a line to show that you can move the contour along that line.
- A cross hair is displayed when the cursor is on a corner. From a corner, you can move the contour in any direction.

4. Drag the contour to a new location.

5. Select the Update icon to see the modification.
This task shows you how to resize the contour of an area.

1. Right-click the contour.

2. From the pull-down menu, put your cursor over the name of the contour (e.g., Rectangle 7.1.object) and select the Definition option.

The Rectangular Contour Definition dialog box is displayed, and manipulation handles are displayed on the contour.

3. Do either of the following:
   - Key in new values for the X length and/or the Y length.
   - Place the cursor over one of the handles and drag it to resize the contour.

4. Select Apply on the Rectangular Contour Definition dialog box.

5. Select the Update icon to see the modification.
Moving an Area

This task shows you how to move an area.

1. Make the parent element of the area active.
   See Making an Element Active for instructions.

2. Select an element in the area.
   The area axis is displayed.

3. Place the cursor over the axis and drag it to the new location.
   - Select one of the axis arrows to move along a plane.
   - Select the center of the axis to move in any direction.
Using Boundaries

The following procedures describe how to create and modify boundaries.

Creating a Boundary

Stretching a Boundary

Up
Basic Layout Tools
Using Boundaries
Using Areas
Using Item Reservations
Placing Resources
Creating Path Reservations
Modifying Path Reservations
Creating a Boundary

This task shows you how to create a boundary.

1. On the Path Reservation/Boundary icon, click the Boundary icon.
   The Routing window is displayed.

2. Select the Type of boundary you want to create:

3. Define the Mode for routing
   - Point-to-Point
   - Orthogonal
4. Define the Section type:

- No Section
- Rectangular Section

If you select Rectangular Section, define these parameters:

- Set Point:
  - Bottom left
  - Bottom center
  - Bottom right
- Height
- Width
- Display:
  - No section
  - True Size
  - Flat

5. Indicate a location for the endpoint of each side.

The boundary is displayed as you move the cursor.

6. Double-click to end the boundary definition.
Stretching a Boundary

This task shows you how to re-define a boundary by stretching its sides.

1. Right click the boundary you want to stretch.

2. From the pull-down menu, place the cursor over the boundary object name (e.g., Boundary1.1.object) and select the Definition option.

The points, lines and section outlines (if any) that define the boundary are displayed, along with the Definition window.

3. Grab the end point of the boundary and drag it to the new location.
4. Select Apply on the Definition window to complete the change.
Using Item Reservations

The following procedures describe how to use item reservations.

Creating an Item Reservation

Resizing an Item Reservation

Moving an Item Reservation
Creating an Item Reservation

This task shows you how to create an item reservation.

1. Select the Item Reservation icon.

   The Item Reservation dialog box is displayed.

   ![Item Reservation dialog box]

2. Specify the type of reservation you want to create:

   ![Item Reservation types]

3. Specify the size of the item reservation by keying in these values:
   - X Length
   - Y Length
   - Height

4. Specify the visual mode for the item reservation:
   - Box
   - Axis
5. Specify the location for the item reservation.
Moving an Item Reservation

This task shows you how to move an item reservation.

1. Make the item reservation's parent the active element.
   See [Making an Element Active](#) for instructions.

2. Click the item reservation.
   The item reservation is highlighted.

3. Place your cursor at the desired location on the item reservation.
   As you move the cursor over the item reservation, visual "cues" are displayed to show how you can move it.
   - A plane is displayed when the cursor is over a line to show that you can move the item reservation along that line.
   - A cross hair is displayed when the cursor is on a corner. From a corner, you can move the item reservation in any direction.

4. Drag the item reservation to a new location.

5. Select the Update icon to see the modification.
Resizing an Item Reservation

This task explains how to resize an item reservation.

1. Right-click the item reservation.
2. Select the item reservation object on the pull-down menu.
   
   If the item reservation is empty, this menu is displayed:

   ![Edit Menu](image1)

   If the item reservation contains a resource, this menu is displayed:

   ![Edit Menu](image2)

3. Do any of the following to change the size:

   To key in a new size, do the following:
   a. Select Edit -> Definition.
   
      The Item Reservation Definition dialog box is displayed.
   b. Key in new values for the X Length, Y Length, and/or Height.
   c. Select OK on the Item Reservation Definition dialog box.

   To resize the item reservation using the cursor, do the following:
   a. Select Edit -> Definition.
   
      Manipulation handles are displayed on the item reservation.
   b. Place the cursor over one of the handles and drag it to resize the item reservation.
   c. Select OK on the Item Reservation Definition dialog box.
To resize the item reservation so that it just encloses the resource it contains, select Edit -> Update Dimensions.
Placing Resources

This task shows you how to place a resource from a catalog into a CATProduct drawing.

1. To open a resource catalog, follow these steps:
   a. From the menu bar, select the Open icon or File -> Open.
   b. Navigate to the directory in which the catalogs are stored.
   c. Click the name of a catalog to open it.
      A pop-up message tells you that the catalog is read-only file.
   d. Click OK on the warning window.
   e. Double-click the catalog icon to display a list of contents.

2. Resize the catalog and the CATProduct windows so that you can see both of them at once.
   You can select Window -> Tile Vertically to display the windows side by side.

4. Click the CATProduct window to make it active.

5. If you want to place the resource into an item reservation, make the item reservation (or one of the elements in the same branch of the specification tree) the active element.

6. Place your cursor over the resource in the catalog and drag it over the desired location in the CATIA drawing.
   The resource is displayed in the drawing.

See Moving an Item Reservation or Resizing an Item Reservation for instructions on how to adjust item reservations.
Creating a Path Reservation

The basic methods for creating path reservations are listed below.

Creating a Path Reservation on an Area

Routing a Path Reservation From the End of a Path Reservation, Boundary, or Run

Branching a Path Reservation

See also Advanced Tasks for Path Reservations.
Creating a Path Reservation on an Area

This task shows you how to create a path reservation on an area.

1. Make the appropriate area active.
   See Making an Element Active for instructions.

2. Select the Path Reservation icon.
   The Routing dialog box is displayed.

3. Define the type of path reservation you want to create.

4. Define the routing mode for the path reservation:
   - Point-to-point
   - Orthogonal

5. To define Section parameters, do the following:
a. Select the Section type icon.  

The Section dialog box is displayed.

b. Define the section type and the corresponding parameters for each of them:

- **No Section**

- **Rectangular**
  - Set Point: 
    - Bottom center
  - Height: 0.1 m
  - Width: 0.3 m
c. Select OK on the Section dialog box.

6. Optional. Key in a value for the turn radius.

7. Click in the drawing to define the routing points.

8. Double-click the last point to stop routing.
Branching a Path Reservation

This task explains how to route a path reservation that branches from any of these elements in a drawing:

- Another path reservation
- Boundary
- Contour
- Equipment
- Run

If the "source" element (i.e., the element from which the path reservation branches) is moved or resized, the path reservation is adjusted accordingly.

1. Select the Path Reservation icon

The Routing dialog box is displayed.
2. Define the parameters for the path reservation.

See Creating a Path Reservation on an Area for instructions.
3. Select the element from which you want to route the path reservation.
   - For a contour, select the edge.
   - For an equipment, select an alignment vector.
   - For path reservations, boundaries, and runs that are displayed with a section, base your selection on the "cues" that are displayed as you move the cursor over the element:
     - A dashed line is displayed when your cursor is over the center of a section.
     - A solid line is displayed when the cursor is over the support line (defined by the set point of the section).

If you want to create a path reservation that "branches" from the end of a path reservation, boundary, or run, see Routing From the End of a Path Reservation, Boundary, or Run.
Routing From the End of a Path Reservation, Boundary, or Run

This task explains how to route from the end of path reservation, boundary, or run.

If you route an element with the same type and parameter values as the "source" element (i.e., the element from which the path reservation is routed), you can specify whether the new element you route is a continuation of the source element or a separate element. If you want to use the "Continue" option, be sure that the parent for the source element is active before you begin.

1. Select the Path Reservation icon.

   The Routing dialog box is displayed.

2. Define the routing parameters.

   See Creating a Path Reservation on an Area for instructions.

3. Select the element from which you want to route.

   For path reservations, boundaries, and runs that are displayed with no section, select the filled circle displayed when the cursor is at the end point of the line.

   For path reservations, boundaries, and runs that are displayed with a section, base your selection on the "cues" that are displayed as you move the cursor over the element:

   - An outlined circle is displayed when your cursor is over the end point of the section's centerline.
   - A filled circle is displayed when the cursor is over the end point of the support line (defined by the set point of the section).

   If you want to route the path reservation, boundary, or run as a continuation of the existing element, you must select the solid circle (i.e., the support line endpoint).
If the new element you route has the same type and parameter values as the element you selected, these options are added to the Routing Dialog box:

- Continue Routing
- Create New Route

4. Select the appropriate Continue option.
5. Click in the drawing to define the routing points.
6. Double-click the last point to stop routing.
Modifying Path Reservations

You can modify path reservations in any of the following ways.

Changing a Section

Changing the Angle of a Segment

Moving Nodes
Changing a Section

This task explains how to change parameters that control how the section of an element is displayed.

1. Place your cursor over the element and click the right mouse button.

2. From the pull-down menu, select the element you want to modify and select Definition.

The Definition dialog box is displayed.

3. Select the Section option.

The Section dialog box is displayed.

4. Select No Section or Rectangular Section.

   If you select Rectangular Section, you can define or change these parameters:
   - Set Point
   - Height
   - Width
   - Display

5. Click OK on the Section dialog box and OK on the Definition box to complete the change.
Changing the Angle of a Segment

This task shows you how to change the angle of a path reservation, boundary, or run segment.

1. Place your cursor over the element and click the right mouse button.

2. From the pull-down menu, select the element you want to modify and select the Definition option.

The Definition dialog box is displayed.

3. Place the cursor over the support line for that element and click the right mouse button.
2. Select Definition from the pop-menu.

The Segment Definition dialog box is displayed.

4. Specify a new value for the Turn Angle.

A line is displayed in the drawing to show the new position for the segment.

5. Click OK on the Segment Definition dialog box.

6. Click OK on the Definition dialog box to complete the change.
Moving Nodes

This task shows you how to move the nodes on a path reservation, boundary, or run.

1. Place your cursor over the element and click the right mouse button.
2. From the pull-down menu, select the element you want to modify and select the Definition option.

The Definition dialog box is displayed, and symbols are displayed on the element to show the location of nodes: Xs represent non-connected nodes, and Os (circles) represent connected nodes.

3. Do either of the following to move the node:
   - To move the node by keying in coordinates, do the following:
     a. Right-click the node symbol and select Definition from the pop-menu.
        The Node Definition dialog box is displayed.
     b. Key in new values for X, Y, or Z.
     c. Click OK on the Node Definition dialog box.
   - To move the node using the cursor, place the cursor over the node symbol and drag it to a new location.

A line is displayed to show the new location for the segment.

5. Click OK on the Definition dialog box to complete the change.

Up  Changing a Section  Changing the Angle of a Segment
      Moving Nodes
## Advanced Tasks

<table>
<thead>
<tr>
<th>Theme</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Advanced Layout Tools</td>
<td>Describes how to use constructions planes mirror elements, and rearrange elements in the hierarchy tree.</td>
</tr>
<tr>
<td>Advanced Tasks for Path Reservations</td>
<td>Describes how to route path reservations with a slope, route path reservations in any direction, and generate a system list report.</td>
</tr>
<tr>
<td>Advanced Tasks for Areas</td>
<td>Describes how to perform an inclusion analysis and generate a footprint report.</td>
</tr>
</tbody>
</table>
Advanced Layout Tools

The following procedures describe the tools available in the Plant Layout product for advanced layout functions.

- Using Construction Planes
- Using Offset Planes
- Mirroring Elements
- Distributing Elements
- Rearranging Elements in the Specification Tree

Advanced Layout Tools
Advanced Tasks for Path
Advanced Tasks for Areas
Using Construction Planes

This task shows you how to create planes to use as references as you construct and position the elements in a drawing.

Construction planes are created relative to the axis of the active element, so make sure that the appropriate element (usually an area) is active.

1. Select Construction Planes icon. The Grid Creation dialog box is displayed.

2. Specify the parameter values for the grid:
   - Grid Type -- The axis/axes along which the construction planes are created.
     - X
     - Y
     - Elevation (Z)
     - XY
   - Step Size -- The distance between construction planes.

   Construction planes are created outward from the element's axis. If you are creating construction planes in an area along the X or Y axis, as soon as you enter a step size, the system calculates the number of construction planes that will fit in each direction and displays the values in the following fields:
If you select an XY Grid Type, the number of steps is calculated, and the Number(+) and Number (-) fields are not displayed. If you are creating construction planes in free space or along the Elevation (Z) axis, the number of steps cannot be calculated. A default value is used for the number of steps. When the Grid Type is set to Elevation (Z), the number of steps is displayed as:

- Upper
- Lower

You can change the number of steps.

3. Select OK to create the construction planes.

To use construction planes for routing or positioning elements, set the Snap Mode to one of the construction plane options on the General Environment Tool Bar.
Using Offset Planes

This task shows you how to define a plane to use as a temporary reference for positioning other elements.

1. Select the Offset Plane icon.

2. Define the reference plane by doing the following:
   a. Place your cursor over a geometric element that defines the plane (e.g., a construction plane, boundary, area contour, item reservation).
      As you move the cursor, a small white rectangle is displayed to show the selectable planes, as shown below.
      If you do not see the white rectangle, zoom out from the drawing. The white rectangle cannot be displayed if the element under your cursor is displayed too small.
   b. Click to select the plane.
      The white rectangle changes to a blue rectangle, and remains displayed on the reference element, as shown below.
The reference plane can now be used as a reference to position other elements.
Mirroring Elements

This task shows you how to move one or more elements to the opposite side of a selected plane, as a mirror image.

1. Select the element(s) you want to move.

2. Select the Mirror icon.

3. Define a reference plane across which to mirror the element by doing the following:
   - Place your cursor over a geometric element that defines the plane (e.g., a construction plane, boundary, area contour, item reservation).

   As you move the cursor, a small white rectangle is displayed to show the selectable planes, as shown below.

   If you do not see the white rectangle, zoom out from the drawing. The white rectangle cannot be displayed if the element under your cursor is displayed too small.

   b. Click to select the plane.

   The selected elements are mirrored to the other side of the plane, as shown below.
Distributing Elements

This task shows you how to distribute elements within parameters that you define.

1. Select the elements you want to move.

2. Select the Distribute icon.

3. Define a reference plane for the distribution by doing the following:
   a. Place your cursor over a geometric element that defines the plane (e.g., a construction plane, boundary, area contour, item reservation).

As you move the cursor, a small white rectangle is displayed to show the selectable planes, as shown below. A line perpendicular to the rectangle shows the direction in which the distribution would be performed.

If you do not see the white rectangle, zoom out from the drawing. The white rectangle cannot be displayed if the element under your cursor is displayed too small.

b. Click to select the plane.
The selected elements are distributed along the line perpendicular to the plane, as shown below.
Rearranging Elements in the Specification Tree

This task shows you how to transfer elements in your layout from one level of the specification tree to another.

1. Make the appropriate element active.

You must make active an element that is at least one level higher than both the source element (i.e., the one that is being transferred) and the target element.

For example, in order to transfer ArrBox5, ArrBox6, ArrBox7, ArrBox8, and ArrBox9 to ArrArea3, shown below, ArrArea1 or Product1 must be active.

2. Select the elements you want to transfer.
3. Select the Transfer Nodes icon.

4. Select the element to which you want the elements transferred.

⚠️ The target element must also be a child of the active element.
The elements you select in step 2 become children of (i.e., subordinate to) the element you select in step 4.
Advanced Tasks for Path Reservations

The following procedures describe how to perform advanced path reservation routing.

Routing Path Reservations With a Slope

Routing Path Reservations in Any Direction

Advanced Layout Tools

Advanced Tasks for Areas

Advanced Tasks for Path Reservations
Routing Path Reservations With a Slope

This task shows you how to route a path reservation with a slope.

1. Click the Path Reservation icon. The Routing dialog box is displayed.

2. Click the Slope icon.

3. Key in a value for the slope and press Enter.

4. Click in the drawing to define routing points, changing the slope as needed.

5. Double-click the last point to stop routing.
Routing Path Reservations in Any Direction

This task shows you how to route a path reservation in any direction.

1. Click the Path Reservation icon.

   The Routing dialog box is displayed, and crosshairs track the movement of your cursor in the drawing.

2. Click the Directional icon.

   The compass is displayed in the drawing.

3. Define the first point to begin routing.

   If the first point is a free point, the default direction for routing is along the X axis. If the first point is the end point of a line, the default direction is along that line.

4. Do either of the following to change the direction for routing:
   - Press the Shift key repeatedly until the desired axis is highlighted.
   - Select and drag an axis to rotate it. The angle at which the axis is turning is displayed.

5. Click in the drawing to define additional routing points, changing the direction for routing as needed.

6. Double-click the last point to stop routing.
Advanced Tasks for Areas

The following procedures describe how to extract data about an area.

- Performing an Inclusion Analysis
- Generating a Footprint Report
Performing an Inclusion Analysis

This task shows you how to find out if elements that are logically contained in an area (in the specification tree) are also physically located within the contour of the area (in the drawing).

1. Right-click the area on the specification tree.
2. From the pull-down menu, select the area object and select the Space Inclusion option.
The Inclusion dialog box is displayed.

3. Define the parameters for the analysis:
   - **Type**
     - **Inclusion** reports which elements are partially inside or touching the selected area.
     - **Inclusion No Contact** reports which elements are completely outside of the selected area.
   - **Scope**:
     - 1 Level checks the inclusion status of elements one level down from the area in the specification tree.
     - All levels checks the inclusion status of all elements below the area in the specification tree.

4. Select OK.
The Results Window is displayed.

You can select entries in the report to highlight the corresponding element in the drawing.
Generating a Footprint Report

This task shows you how to generate a report showing the following information about an area:

- Name of the area
- Size of the area
- Names of the elements in the area
- Size of the elements in the area
- Total used and unused space expressed in units, squared
- Total used and unused space expressed as a percentage of the total area

To accomplish this procedure, you must have installed Microsoft Excel 97 or later version. You should also be familiar with the file navigation and file editing capabilities of your system.

1. Copy the following files from \intel_a\code\command to a drive or directory for which you have read and write permissions:
   - PSLFootprint.CATScript
   - PSLFootprintTemplate.xls

2. Edit the PSLFootprint.CATScript using a text editor such as WordPad as follows:
   - Define the path for strGReportTemplate to point to the directory to which you copied the files in step 1.

3. Save and close the file.

4. Start CATIA.

5. Select the area for which you want to run the footprint report.

6. From the menu bar, select Tools -> Macro -> Macros.

7. Select Macro In: External File.

8. Select the Select button, and use the Windows dialog box to navigate to the appropriate file.

9. Select the file PSLFootprint.CATScript.

10. Select Run.

The report is generated in a Microsoft Excel file, Excel is launched, and the report file is displayed, shown in the example below.
Customizing

This section describes the ways in which you can customize the Plant Layout workbench.

Themes

- Customizing the Dictionary of Types
- Creating a Catalog
Customizing the Dictionary of Types

This section explains how to customize the list of types that are displayed when you create any of these elements:

- Areas
- Routing elements
- Item reservations
- Distribution systems
- Network reservations
- Grids

A basic dictionary of these element types is provided with the product. You can add entries to or delete entries from the basic dictionary, or you can replace it entirely. The example and procedure below provide details.
Customizing the Dictionary of Types: Example

The capability for customizing the Dictionary of Types is available only on the Windows NT platform.

To customize the dictionary of element types provided with the Plant Layout product, you need to run two scripts:

**PSLNomenAccessFeat.CATScript** reads the existing dictionary and writes it to a preformatted Microsoft* Excel file.

**PSLNomenBuildFeat.CATScript** takes a properly formatted Excel file and generates a new dictionary.

The example below illustrates how the type **Work Cell** is added to the list of types available when you create an area.
Customizing the Dictionary of Types: Procedure

This task explains how to customize the list of types that are displayed when you create any of these elements:

- Areas
- Routing elements
- Item reservations
- Distribution systems
- Network reservations
- Grids

The capability for customizing the Dictionary of Types is available only on the Windows NT platform.

To accomplish this procedure, you must have installed Microsoft Excel 97 or later version. You should be familiar with the basic editing features of Excel, as well as with the file navigation and file editing capabilities of your system.

1. Copy the following files from `\intel\a\code\command` to a drive or directory for which you have read and write permissions:
   - PSLNomenAccessFeat.CATScript
   - PSLNomenBuildFeat.CATScript
   - PSLNomenAccessFeatTemplate.xls

2. Start CATIA.

3. From the menu bar, select Tools -> Macro -> Macros.

4. Select Macro In: External File.

5. Select the Select button, and use the Windows dialog box to navigate to the appropriate file.

6. Select the file `PSLNomenAccessFeat.CATScript` and select OK.

7. Edit `PSLNomenAccessFeat.CATScript` as follows:

   Define the path `strEXCELTemplateFileName` to point to the directory to which you copied the files in step 1.

8. Save and close the file.


   Microsoft Excel is launched, and a file is created.

10. Edit the Excel file to add or delete entries, as appropriate.

11. Save the Excel file with a unique name.

12. From the CATIA menu bar, select Tools -> Macro -> Macros again.

13. Select the Select button, and select the file `PSLNomenBuildFeat.CATScript`.

14. Edit `PSLNomenBuildFeat.CATScript` as follows:

   Define the input path `strEXCELInputFileName` to point to the Excel file you saved in step 11.

   Define the output path `strCATIAV5FeatOutputFileName` to point to `\intel\a\resources\graphic\CATArrNomenclature.feat`.

   If you do not have write permissions for this output path directory, you can define a temporary location. Contact your system administrator to move or copy the file to the correct location after it has been created.

15. Save and close the file.

The output file is created in the directory you specified. If you defined a temporary location for the file, it must be moved or copied to `\intel_a\resources\graphic\CATArrNomenclature.feat` before the modifications can take effect.

The modifications will take effect when you restart CATIA.
Creating a Catalog

The following three tasks are required for creating a catalog that can be used to place parts in the Plant Layout product.

- Creating Parts
- Creating a Catalog
- Making a Catalog Accessible
Creating Parts

This task explains how to create parts for the Plant Layout Product.

1. Create the geometry for the part.
   Use the CATIA Version 5 Part Design product to create the geometry. See the CATIA Version 5 Part Design User's Guide for instructions about how to use this product.
   - If you want to be able to place the part parametrically, go on to step 2.
   - For non-parametric parts, save the part as a CATPart document. The procedure is complete.

2. Define parameters for the geometry.

3. Save the part as a CATPart document.

4. Create the design tables.
   See the CATIA Version 5 Infrastructure User's Guide for detailed instructions on how to create a design table and associate it to a part.
Creating a Catalog

This task explains how to create a catalog. The Catalog facility is a standard facility provided with the V5 CATIA Product line. For detailed information regarding Catalogs, please see the CATIA Infrastructure documentation - Advanced Tasks - Using Catalogs.

The following steps outline how to create a catalog of parts. These steps use an existing sample catalog from the Systems Routing product to illustrate the procedures.

1. Open the file ..\intel_a\startup\components\piping\data\master_piping.xls, shown below:

<table>
<thead>
<tr>
<th></th>
<th>CHAPTER</th>
<th>Category</th>
<th>Points to</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Piping</td>
<td>I_ArrPipingLL</td>
<td>PIPE.catalog</td>
</tr>
<tr>
<td>2</td>
<td>String</td>
<td>PIPE</td>
<td>ELBOV.catalog</td>
</tr>
<tr>
<td>3</td>
<td>PIPE</td>
<td>ELBOV</td>
<td>TEE.catalog</td>
</tr>
<tr>
<td>4</td>
<td>ELBOV</td>
<td>TEE</td>
<td>VALVE_BALL_FL.catalog</td>
</tr>
<tr>
<td>5</td>
<td>TEE</td>
<td>VALVE_BALL_ST.catalog</td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>VALVE_BALL_ST каталог</td>
<td>VALVE_BALL_ST.CATPart</td>
<td></td>
</tr>
<tr>
<td>7</td>
<td>VALVE_BALL_ST.CATPart</td>
<td>VALVE_BALL_ST.CATPart</td>
<td></td>
</tr>
<tr>
<td>8</td>
<td>VALVE_BALL_ST.CATPart</td>
<td>VALVE_BALL_ST.CATPart</td>
<td></td>
</tr>
<tr>
<td>9</td>
<td>VALVE_BALL_ST.CATPart</td>
<td>VALVE_BALL_ST.CATPart</td>
<td></td>
</tr>
<tr>
<td>10</td>
<td>PIPE</td>
<td>PIPE</td>
<td>PIPE.CATPart</td>
</tr>
<tr>
<td>11</td>
<td>TEE</td>
<td>TEE</td>
<td>TEE.CATPart</td>
</tr>
<tr>
<td>12</td>
<td>ELBOV</td>
<td>ELBOV</td>
<td>ELBOV.CATPart</td>
</tr>
<tr>
<td>13</td>
<td>TEE</td>
<td>TEE</td>
<td>TEE.CATPart</td>
</tr>
<tr>
<td>14</td>
<td>VALVE_BALL_ST</td>
<td>VALVE_BALL_ST.CATPart</td>
<td></td>
</tr>
<tr>
<td>15</td>
<td>VALVE_BALL_ST.CATPart</td>
<td>VALVE_BALL_ST.CATPart</td>
<td></td>
</tr>
<tr>
<td>16</td>
<td>VALVE_BALL_ST.CATPart</td>
<td>VALVE_BALL_ST.CATPart</td>
<td></td>
</tr>
<tr>
<td>17</td>
<td>VALVE_BALL_ST.CATPart</td>
<td>VALVE_BALL_ST.CATPart</td>
<td></td>
</tr>
<tr>
<td>18</td>
<td>VALVE_BALL_ST.CATPart</td>
<td>VALVE_BALL_ST.CATPart</td>
<td></td>
</tr>
<tr>
<td>19</td>
<td>VALVE_BALL_ST.CATPart</td>
<td>VALVE_BALL_ST.CATPart</td>
<td></td>
</tr>
<tr>
<td>20</td>
<td>VALVE_BALL_ST.CATPart</td>
<td>VALVE_BALL_ST.CATPart</td>
<td></td>
</tr>
</tbody>
</table>

This file is used to define all information required to create the catalog. It contains the hierarchy of the catalog and all of the associated parts. For each part, the part name, an associated icon, and associated Part or Product document name is specified. For example, TEE is one of the parts included in the above example. For this part, the part name is TEE, the icon name is I_catalog_piping_TEE, and the document is TEE.CATPart.

2. Using the master_piping.xls file as an example, create a catalog hierarchy node for your catalog. For each node, create the part entries for the parts to be included under this node of the hierarchy.

3. Switch to the Commands sheet within the Excel document. It looks like this:
4. Modify the Output Directory file to point to the appropriate directory.

5. Select the Create Catalog.CSV files button. This will generate the required CSV files for the catalog creation. As this macro runs, you will be prompted to confirm creation of each CSV file. For each confirmation request, hit OK.

6. Use the File-SaveAs to save this as a new document.

7. Before being able to proceed to the next step, you must make sure the CclTypeLib library is loaded. This library declares the catalog creation method. To do this, select the Tools->Options... command. The Options dialog box appears with the General category selected in the left-hand column.

8. Click the !Automation! tab. The following dialog box appears:
9. If the CclTypeLib library is not in the Selected list click on the Add button and retrieve the library from intel_a/code/bin. Make sure it is in the Selected list before clicking OK.

10. You are now ready to run the batch operation. Select the Tools ->Macro->Macros command. The following dialog box appears:

11. Select the BuildCatalogVB.CATScript file. Make sure that at the bottom of the box External File is selected indicating the location of the macro. Click on Run.

12. A window will be displayed that prompts you for the input path. This input path defines where the macro will find the CSV files. For the input path, specific the directory you defined in step 4 above.

13. A window will be displayed that prompts you for the output path. This is used to specify where the directory where the catalog will be filed. This process will also generate a report file in this directory. This directory will allow you to verify the successful creation of the catalog.
Making a Catalog Accessible

This task explains how to specify the location of a catalog so that it can be accessed from the Systems Routing product in order to place parts.

1. From the menu bar, select Tools -> Search Order.

The Search Order dialog box is displayed.

2. Specify a search order that points to the directory in which the catalog is located.

For specific instructions about how to specify a search order, see the CATIA Version 5 Infrastructure User's Guide (Workbench Description -> Menu Bar -> Tools -> Creating a Document Search Order).
Workbench Description

The CATIA Plant Layout workbench includes the following toolbars:

<table>
<thead>
<tr>
<th>Toolbar Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>Plant Layout Toolbar</td>
</tr>
<tr>
<td>General Design Toolbar</td>
</tr>
<tr>
<td>General Environment Toolbar</td>
</tr>
</tbody>
</table>
Plant Layout Toolbar

The Plant Layout Toolbar contains the following tools:

See **Using Areas**.

See Creating Distribution Systems.

See Network Reservations.

See **Creating Path Reservations** and **Modifying Path Reservations**.

See **Using Boundaries**.

See **Using Item Reservations** and **Placing Resources**.

See **Using Construction Planes**.
General Design Toolbar

The General Design Toolbar contains the following tools:

See Aligning Elements for these icons:

- Align Side
- Align Center
- Rotate to Align

See Distributing Elements.

See Mirroring Elements.

See Rearranging Elements in the Specification Tree.

Update the Display.
The General Environment Toolbar contains the following tools:

See [Changing the Current Axis](#).

See [Using Offset Planes](#).

See [Using a Step Grid](#) for these icons:

- Snap to steps off current axis
- Snap to steps off last position
- Snap to XY construction planes
- Snap to all construction planes
- Snap to elevation (Z) construction planes
- Snap to Drafting elements

See [Making an Element Active](#).

See [Making an Element Active](#) for these icons:

- Activate parent
- Activate area
Glossary

**C**

chamfer  A cut through the thickness of the feature at an angle, giving a sloping edge.

child  A status defining the genealogical relationship between a feature or element and another feature or element. For instance, a pad is the child of a sketch. See also parent.

constraint  A geometric or dimension relation between two elements.

**D**

draft angle  A feature provided with a face with an angle and a pulling direction.

**F**

feature  A component of a part. For instance, shafts, fillets and drafts are features.

fillet  A curved surface of a constant or variable radius that is tangent to, and that joins two surfaces. Together, these three surfaces form either an inside corner or an outside corner.

**G**

groove  A feature corresponding to a cut in the shape of a revolved feature.

**H**

hole  A feature corresponding to an opening through a feature. Holes can be simple, tapered, counterbored, countersunk, or counterdrilled.

**M**

mirror  A feature created by duplicating an initial feature. The duplication is defined by symmetry.

**P**

pad  A feature created by extruding a profile.

parent  A status defining the genealogical relationship between a feature or element and another feature or element. For instance, a pad is the parent of a draft.

part  A 3D entity obtained by combining different features.
part body  A component of a part made of one or several features.

pattern   A set of similar features repeated in the same feature or part.

pocket    A feature corresponding to an opening through a feature. The shape of the
          opening corresponds to the extrusion of a profile.

profile   An open or closed shape including arcs and lines created by the profile
          command in the Sketcher workbench.

reorder   An operation consisting in reorganizing the order of creation of the features.

rib       A feature obtained by sweeping a profile along a center curve.

scaling  An operation that resizes features to a percentage of their initial sizes.

set point The alignment point for a boundary or path reservation for which a section
          is defined. The set point determines, for example, whether the routing line
          drawn for a boundary represents the bottom left, bottom right, or bottom
          center of the boundary. There are three possible set points for a boundary
          and nine possible set points for a path reservation.

shaft     A revolved feature

shell     A hollowed out feature

sketch    A set of geometric elements created in the Sketcher workbench. For
          instance, a sketch may include a profile, construction lines and points.

slot      A feature consisting of a passage through a part obtained by sweeping a
          profile along a center curve.

split     A feature created by cutting a part or feature into another part or feature
          using a plane or face.

stiffener A feature used for reinforcing a feature or part.

turn angle The angle formed between two imaginary lines that are perpendicular to
             adjacent segments, as shown at right.

stiffener A feature used for reinforcing a feature or part.
Index

A
aligning elements ➤
axis
  changing the current axis ➤
area
  creating ➤
  inclusion analysis of ➤
  moving ➤
  resizing the contour of ➤

B
boundary
  creating ➤
  stretching ➤

C
construction planes
  using ➤
contour
  moving a rectangular ➤
  resized ➤
current axis
  changing ➤
D

dictionary of types
  customizing

E

elements
  aligning
  distributing
  making active
  mirroring
  rearranging in the hierarchy tree
  snapping to a grid

F

footprint report

G

grid
  using
I

inclusion analysis for an area ➞

item reservation
  creating ➞
  moving ➞
  resizing ➞

M

mirroring elements ➞

N

nodes
  moving ➞

P

path reservations
  branching ➞
  changing the angle of a segment ➞
  creating
    point to point ➞
    orthogonally ➞
    with a slope ➞
    in any direction ➞
  modifying ➞
  routing from the end of a path reservation, boundary, or run ➞
  section setting
    changing ➞
R

reports
  footprint report
  inclusion analysis

resource
  placing

S

section setting for path reservations
  changing

segments of a path reservation
  changing the angle of

step grid
  using

T

tool bars
  Plant Layout
  General Design
  General Environment

types
  customizing the dictionary of