Preface

CATIA Version 5 Real Time Rendering is a next generation CATIA Solutions product that allows you to define material specifications that will be shared across your entire product development process as well as map materials onto parts to produce photo-realistic images.

Material specifications define the characteristics of materials:
- Physical and mechanical properties (Youngs modulus, density, thermal expansion, and so forth.)
- 3D representation: textures on geometry
- 2D representation: patterns for drafting purposes.

Other CATIA Version 5 products such as Analysis, Generative Drafting and Knowledge Advisor share the material specifications defined using Real Time Rendering.

Materials are organized and managed in libraries. A default material library is provided with Real Time Rendering.

When mapping materials, Real Time Rendering is available only in conjunction with a .CATPart document type. Users can apply materials in Part Design, Shape Design, FreeStyle Shaper and FreeStyle Optimizer workbenches.
Using This Guide

This guide is intended for administrators who need to create and manage families of materials, as well as to any users wishing to apply materials to parts.

All users should be familiar with basic Infrastructure concepts such as document windows, standard and view toolbars as well as the 3D compass.

To get the most out of Real Time Rendering, check in the table below where to find information for your selected profile.

Go to:

I am a first time user

The getting started tutorial. Once you have finished, you should move on to the user task section of this guide. This steps you through basic procedures.

I have used Real Time Rendering before

If you need some help in understanding tools and commands, use the on-line help. You can also take a look at the basic user task section of this guide to locate information with which you are not already familiar.

I am an administrator

The advanced task section of this guide. This steps you through how to organize and manage your own collections of materials.
Where to Find More Information

Prior to reading this book, we recommend that you read the CATIA.Infrastructure User's Guide.
What's New?

New: you can now use the [Interoperability with V4 textures](#)

New: "Shading with Texture" option has changed to [Customized View Mode](#) when applying materials
Getting Started

This task will guide you step-by-step through your first rendering session. You are going to apply pre-defined materials (brass then blue onyx) to a part (that is your .CATPart document) and then edit the last material mapped.

Open the gettingstarted.CATPart document from the online/Samples/realtimerendering directory.

You should be familiar with basic concepts such as document windows, standard and view toolbars as well as the 3D compass.

You should be able to complete this task in about 10 minutes.
Applying Materials

This task shows you how to apply pre-defined materials. In this example, you will map brass and then blue onyx onto your part (that is your .CATPart document).

1. Select any element of the part on which the material should be applied.

2. Click the Apply Material icon.

The Library dialog box opens, containing sample materials from which to choose.

3. Click the Metal tab.

4. Select Brass.

5. Click Apply to map the material onto the part.
6. Select the **Apply Customized View** icon in the **View -> Render Style** command.

7. Make sure that the **Shading and Materials** options are checked in the **Custom View Modes** dialog box.

8. Click OK.

The material is mapped onto the selected part and is identified in the specification tree.

9. Click the **Stone tab** and change the material to Blue Onyx.

10. Click OK in the Library dialog box.

11. Click in the free space.

Blue Onyx is now mapped and the specification tree is updated to include the material you just applied.
Modifying the Mapped Material

This task shows you how to edit materials. You will change the color and density as well as re-position the material mapped onto the part.

1. Right-click the mapped material (Blue Onyx) in the specification tree and select the Properties item from the contextual menu.

The Properties dialog box is displayed.

Note: The mapping support (in this case a box support) appears in the geometry area. This will assist you later when you interactively position the material.

2. Click the Rendering tab if not already active.
3. Change the color of the material to green:
- Click [...] opposite Color under the Lighting tab
  The Color dialog box is displayed
- Click in the preview area to select the green you want
- Click OK in the Color dialog box
  The selected color is displayed in the Color field.

4. Change the material density:
- Click the Analysis tab in the Properties dialog box
  Key in a new density, 2000 kg/m³ for example
- Click Apply
  Appropriate licenses are required to use these products.

5. Click OK in the Properties dialog box
6. Change the mapped material to Wall of Bricks using the Apply Material icon.

7. Right-click the mapped material in the specification tree and select the Properties item from the contextual menu.

8. Change the material size (in the Rendering tab of the Properties dialog box) so that the texture shrinks in size relative to the part. In our example, a material size of 100mm was used.

9. Position the material interactively using the 3D compass:
   - Drag and drop the 3D compass onto the part
   - Select the material in the specification tree:

   The box support appears in the geometry area.
Rotate the 3D compass and see how the material is rotated around one of the compass axes.

For more information on manipulating objects using the compass, see the *Infrastructure User's Guide*. 
Basic Tasks

The Basic Tasks section shows how to use Real Time Rendering and is intended for the end-user.

<table>
<thead>
<tr>
<th>Task</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Applying a Material to a Part</td>
<td>Apply a pre-defined material to a part (that is a .CATPart document)</td>
</tr>
<tr>
<td>Modifying Materials</td>
<td>Edit material specifications</td>
</tr>
<tr>
<td>Finding Materials</td>
<td>Search for materials in large assemblies</td>
</tr>
<tr>
<td>Using Paste Special...</td>
<td>Copy and paste materials as linked objects</td>
</tr>
<tr>
<td>Using Knowledge Advisor</td>
<td>Change materials in Knowledge Advisor and use material as a parameter in a rule</td>
</tr>
</tbody>
</table>
Applying a Material to a Part

This task explains how to apply a pre-defined material to a part (.CATPart document) as well as interactively re-position the mapped material.

1. Select the part on which the material should be applied.
2. Click the Apply Material icon. The Library dialog box opens. It contains several pages of sample materials from which to choose. Each page is identified by a material family name on its tab.
3. Select a material from any family, by a simple click.

   Double-click on a material to display its properties for analysis purposes.
4. Click the Link to file checkbox if you want to map the selected material as a linked object and have it automatically updated to reflect any changes to the original material in the library.

Two different icons (one with \( \text{\includegraphics[width=0.05\textwidth]{icon_link.png}} \) and one without \( \text{\includegraphics[width=0.05\textwidth]{icon_unlink.png}} \) a link) identify linked and unlinked materials respectively in the specification tree.

**Note:** You can edit linked materials. Doing so will modify the original material in the library. If you want to save changes made to the original material, use the File->Save All command.

Select the Edit->Links... command to identify the library containing the original material. You can then open this library in the Material Library workbench if desired.

You can also use the Paste Special... command to paste material as a linked object. You can copy both unlinked and linked materials. You can, for example, paste a linked material on a different part in the same document as well as on a part in a different document. For more information, see [Copying & Pasting Using Paste Special...](#).

5. Click Apply to map the material onto the part

The selected material is mapped onto the part and the specification tree is updated. In our example, the material was not mapped as a linked object.
Material specifications are managed in the specification tree: all mapped materials are identified. To edit materials (for more information, see Modifying Materials), simply right-click the material and select Properties from the contextual menu or double-click the material. You can also run searches to find a specific material in a large assembly (for more information, see Finding Materials) as well as use copy & paste or drag & drop capabilities.

6. Select the Apply Customized View icon in the View ->Render Style command.

7. Make sure that the Shading and Materials options are checked in the Custom View Modes dialog box.

8. Click OK.

9. Click OK in the Library dialog box.

Applying materials to parts affect the physical and mechanical properties, for example the density, of elements.

10. Right-click the material just mapped in the specification tree and choose the Properties item.

The Properties
dialog box is displayed.

11. Choose the Rendering tab to edit the rendering properties you applied on the part.

From this dialog box you can adjust and reset position of the material. You can also modify all material definition parameters as described in Modifying Materials.

12. If necessary; change the material size to adjust the scale of the material relative to the part.

13. Click OK in the Properties dialog box, when you are satisfied with the material mapping on the part.
14. Use the 3D compass to interactively position the material:

- Drag and drop the compass onto the part:
  - The compass snaps to the part
- Select the material in the specification tree:
  - The mapping support (in this case, a box) appears.
  - If necessary, zoom in and out to visualize the mapping support which reflects the material size.
- Pan and rotate the material until satisfied with the result. You can:
  - Pan along the direction of any axis (x, y or z) of the compass (drag any compass axis)
  - Rotate in a plane (drag an arc on the compass)
  - Pan in a plane (drag a plane on the compass)
  - Rotate freely about a point on the compass (drag the free rotation handle at the top of the compass)

Note that material positioning with the 3D compass is only available with P2 solutions.

For more information on manipulating objects using the 3D compass, see the
CATIA.Infrastructure User's Guide.
Modifying Materials

You can change the material size and mapping type as well as edit material specifications (lighting and texture parameters) of both linked and unlinked materials.

Notes:
- Editing materials linked to libraries will modify the original material in the library. If you want to save changes made to the original material, use the File -> Save All command.
- Editing linked materials on parts in the same document or on parts in different documents will change all linked materials.

This task explains how to edit a material

1. Select the Mirror material in the specification tree
2. Click the Edit Properties icon, select the Edit -> Properties command or right-click and select Properties from the contextual menu
   The Properties dialog box is displayed.

   Double-click a material to edit its properties.

3. Make sure the Rendering tab is active.
   Using this dialog box, you can edit the lighting and texture parameters of the material you are currently editing.

   A preview area, in which different mapping types can be visualized, is also available:

   Different mapping types are proposed to let you select the most appropriate mapping for the shape of the geometry, for example a cylinder support to map a label onto a can of food.

   Manipulations are available within the preview area: zooming in and out, rotating the support, translating it. Use the icon to reframe the support within the preview area.
Note: Material specifications defined using Real Time Rendering are shared with other CATIA V5 products. For information on Drafting and Analysis tabs, see CATIA.Generative Drafting and CATIA.Generative Part Stress Analysis guides respectively. Appropriate licenses are required to use these products.

4. If necessary, change the material size to adjust the scale of the material relative to the part.

5. Modify the Lighting parameters: color, luminosity, contrast, shininess, transparency, and reflectivity.

<table>
<thead>
<tr>
<th>Lighting</th>
<th>Texture</th>
</tr>
</thead>
<tbody>
<tr>
<td>Color</td>
<td><img src="image" alt="Color" /></td>
</tr>
<tr>
<td>Luminosity</td>
<td><img src="image" alt="Luminosity" /></td>
</tr>
<tr>
<td>Contrast</td>
<td><img src="image" alt="Contrast" /></td>
</tr>
<tr>
<td>Shininess</td>
<td><img src="image" alt="Shininess" /></td>
</tr>
<tr>
<td>Transparency</td>
<td><img src="image" alt="Transparency" /></td>
</tr>
<tr>
<td>Reflectivity</td>
<td><img src="image" alt="Reflectivity" /></td>
</tr>
</tbody>
</table>

6. Click [...] opposite Color and choose the color to be used for the material texture.

The Color dialog box is displayed allowing you to choose the exact color you wish to define as a material texture.

You can click in the preview area to choose the color, or even key in the exact value of the desired color.

When satisfied, simply click OK, and the color is applied to the shape in the Properties preview.

7. Set the other material parameters:

**Luminosity**: the intensity of light diffused in any direction by the object, even if not lit by any light source.

This parameter affects the whole object, including the shadowed area.
**Contrast**: the intensity of light diffused by the object when lit by light sources.

Typically, a shiny metal surface would have a diffuse reflectance value close to 0, while a piece of cardboard would have a value probably above 0.9.

**Shininess**: dullness of an object

Set the value to a minimum to generate very sharp highlights on very shiny surfaces. Set the shininess to a higher value to generate large specular spots creating a duller effect.

**Transparency**: the degree of transparency of an object.

The higher the value, the more transparent the object (in the example the value is 0.75), the lower the value, the more opaque the object.

**Reflectivity**: the degree of reflectivity of an object.

Set to a high value, the object reflects its environment.

8. Click Apply to validate the material lighting definition.

The material icon reflects the material as defined.

- All lighting parameter values range from 0 to 1.
- Any amount of reflectivity, however small, means that you will no longer visualize the mapped texture simultaneously with the reflected scene. If you want to see the texture, make sure you set the Reflectivity parameter to 0 in the Lighting tab.

9. Click the Texture tab in the Properties dialog box.

10. In the Image Name field, navigate to locate the desired image, and click OK to map it onto the preview element as the texture.

In the example, we choose the sky.rgb image available with the default catalog. The following image formats can be used: TIFF, JPEG, RGB, BMP.

11. Define the image repetition along U and V, as well as its scale, its position and its orientation:

U and V correspond to parameters of the local parametric surface.
Repeat U, V: lets you specify whether or not you want the texture repeated ad infinitum along u- and v-axes.

Scale U, V: determines how the texture is stretched along u- and v-axes.

Position U, V: determines the position of the texture along u- and v-axes. By default, the image is centered.

Orientation: defines the rotation of the texture on surfaces.

12. Click Apply to validate the material texture definition.

The material icon reflects the material as defined.

There is no specific order when defining parameters.
Finding Materials

This task explains how to use the search for materials in documents.

This is useful in large assemblies where you will be able to rapidly identify materials of interest. You can then, if desired, individually edit selected materials.

For more information on the Search command, see the Infrastructure User's Guide.

1. Select the Edit -> Search... command
   The Search dialog box appears.

2. Set the Type field to Material

3. Ensure the Look in box is set to Everywhere to search the whole product structure

4. Click Search to start the search
   The search results are listed in the area in the lower half of the Search dialog box.
5. Click Select to select found items and then OK to exit the dialog box

6. Expand all entries in the specification tree to see that all mapped materials have been selected
7. Select the Edit -> Properties command:

The Properties dialog box appears letting you edit the properties of selected materials. Click the Current selection drop-down list box and select the materials in turn to edit them. For more information on editing materials, see [Modifying Materials](#).

To edit other materials in your document, de-select the first material in the specification tree then select the Edit - Properties command again.
When you use the Paste Special... command, material is pasted as a linked object. You can copy a:

- Material from a library:
  The part will be automatically updated to reflect any changes to the original material in the library. This is also useful in large assemblies if you have material specifications that may change and that you use in more than one place.

Materials can also be mapped as linked objects from libraries using the Link to file checkbox in the Library dialog box.

- Paste the material on a different part in the same document:
  The link is made from the second part to the first part. Editing the material on either part will automatically update the material on the other part

- Paste the material on parts in different documents:
  Editing the material on any part will automatically update all linked materials on all parts in all documents. You can in this way change the material specifications in all places where they appear without having to edit each individual occurrence.

This tasks explains how to copy and paste materials using the Paste Special... command.

1. Select the material you want to copy
2. To copy, you can either:
   - Click the Copy icon
   - Select the Edit -> Copy command or
   - Select the Copy command in the contextual menu
3. Select the part onto which you want to map the material
4. To paste, you can either:
   - Select the Edit -> Paste Special... command or
   - Select the Paste Special... command in the contextual menu
The Source Definition dialog box appears.

5. Click AsMaterialLink in the dialog box, then click OK.

The material is mapped onto the selected part and the specification tree updated.

A linked material icon identifies the material in the specification tree.

**Note:** You cannot change the material name in the Feature Properties tab of the Properties dialog box.

Simple copy and paste as well as drag and drop operations can also be performed. In both cases, the mapped material is not linked.
Using Knowledge Advisor Capabilities

Material specifications defined using Real Time Rendering are shared with Knowledge Advisor. This is illustrated in the two tasks below.

In our examples, you will change the material mapped onto a part directly in the knowledgeware Formulas dialog box as well as write a rule using material as a parameter to, for example, change the mapped material as a function of hole diameter.

For more information on Knowledge Advisor, see the CATIA.Knowledge Advisor User’s Guide. Note that to use this product you need the appropriate license.

Changing the Material Mapped onto a Part Directly in the Formulas Dialog Box

This task explains how to change the material mapped onto a part directly in the knowledgeware Formulas dialog box.

1. Click the Formula icon in the Standard toolbar.
   The Formulas dialog box appears listing all the part parameters.

2. Select the Material parameter.
   The Edit name, value or formula fields are updated.

3. Enter another material, Gold for example, directly in the value field.
   The dialog box, part itself and specification tree are all updated. You have changed the material mapped onto the part directly in the dialog box.
You can only change materials mapped in the Formulas dialog box to those available in the default material library. Any material changed in this way will be mapped as linked objects and will be automatically updated to reflect any changes to the original material in the library.

Note: The material icon in the specification tree appears with a link to indicate that the material gold is mapped as a linked object.

Writing a Rule

This task explains how to write a rule using material as a parameter to, for example, change the mapped material as a function of hole diameter.

1. Select Tools -> Options... and click the Relations checkbox in the Display tab (under Part) to display relations in the specification tree.
2. Select the part.
3. Select Knowledge Advisor from the Start -> Infrastructure menu.

4. Click the Rule icon:
The Rule Editor dialog box appears.
5. Click OK to identify your rule in the Rule Editor dialog box.

The Rule Editor : Rule 1 dialog box is displayed. You can now write your rule.

6. Write the following rule:

```
if (PartBody\Hole.1\Diameter > 60mm) 
    Material = "Gold"
else
    Material = "Aluminium"
```
7. Click OK when done:
The system checks that your syntax is valid. If it is not, you are prompted to correct it.

⚠️ You cannot edit or apply materials that have been incorporated as parameters into rules.

You can now check your rule.

8. Select Part Design from the Start -> Mechanical Design menu
9. Right-click the hole and select Hole1.Object -> Edit Parameters from the contextual menu
10. Double-click the hole diameter and enter a new value in the Constraint Edition dialog box, for example 70, then press Enter

The material changes from aluminium to gold.

Before: After:

Note: Materials incorporated as parameters into rules are mapped as linked objects. Linked materials are identified in the specification tree by a material icon with link.
The Advanced Tasks section shows you how to organize and manage materials in libraries. It is intended for the administrator.

CATIA Version 5 Real Time Rendering lets you define materials specifications that will be shared across your entire development process. Material specifications define the characteristics of materials:

- Physical and mechanical properties (Youngs modulus, density, thermal expansion, and so forth.)
- 3D representation: textures on geometry
- 2D representation: patterns for drafting purposes.

---

**Task**

- Before You Start
- Opening the Workbench
- Creating a Material Library
- Interoperability with V4 Textures
- Sorting Materials
What You Should Know Before You Start

A default material library file is provided with Real Time Rendering. By default, this file is located:
- under Windows NT: $CATStartupPath\startup\materials\Catalog.CATMaterial
- under UNIX: $CATStartupPath/startup/materials/Catalog.CATMaterial

Note: For languages other than English, a folder identified by the appropriate language contains the Catalog.CATMaterial.

This is where you should store any new library so that it is taken into account when users want to apply a material to a part (that is a .CATPart document) in the Part Design, Shape Design, FreeStyle Shaper or FreeStyle Optimizer workbenches.

The environment variable CATStartupPath concatenates start-up directories. When applying a material, the first occurrence of the Catalog.CATMaterial found in the directories listed in the variable is loaded. If you wish to assign different Catalog.CATMaterial files to different users, you need to modify their environment so that their respective CATStartupPath variable references the adequate catalogs.
Opening the Material Workbench

This task explains how to load the Material Workbench and open a CATMaterial document.

1. Select the Start-> Infrastructure-> Material Library menu item.

The Material Workbench is loaded, and a CATMaterial document is created.

By default a family and a material are in the document, ready to be renamed and edited.
Creating a Material Library

This task shows you how to add materials to a family, and create more families for your material libraries.

1. Click the Rename Family icon to give an explicit name to the default tab.

   The New Name dialog box is displayed.

2. Key in the new name for the family, and press OK.

   Here we called it Wood.
3. Click on the New Family icon to create a new family.

A New Family tab is displayed in the document.

4. Repeat step 2 and 3 to create more families such as Metal, Stone, Cloth and so forth.

You can copy and paste families.
None of the new families contain any material yet.

5. Click the Wood tab to activate the wood family.

There is only the default material in this family so far.
6. Select the material.

7. Click the Rename Material icon to rename the material via the New Name dialog box.
   Let's call it Bark.

8. Click the New Material icon to add material to this family.
   You can add, and rename the Beech, Cork, Teak, Wild Cherry types of wood for example, and many more.
Now that your library is defined, you will need to modify each material to give it specific material properties. For more information on how to do so, see [Modifying a Material](#).

You can also remove a family or a material, simply by selecting the object then clicking on the Remove Family or Remove Material(s) icon respectively.
Interoperability with V4 Textures

This task shows you how to apply a V4 2D texture to a V5 material.

1. Open the V4 template

2. Double-click on MASTER to display the tree

3. Click on the plus sign beside IMDE1

4. Click on the name of the texture you want to copy
5. Copy the texture by selecting Edit -> Copy in the menu bar or by right-clicking and selecting Copy in the contextual menu.

6. Paste the new texture in the family on which you want to create a material based on it.
   - You can paste the texture in a part.
When you double-click on the applied texture, you can display properties:

- If you are working with UNIX, the right path is immediately displayed. The texture is displayed in the dialog box.
- If you are working with Windows NT, a UNIX path is displayed and you must change it into a NT path.

A V4I licence is necessary to copy a V4 texture.
Sorting Materials Within a Family

This task explains how to arrange materials alphabetically within a family in ascending and descending order.

Open the editmaterial.CATMaterial document from the online/Samples/realtimerendering directory.

1. Click on the Sort Material (A->Z) icon

The materials are automatically arranged in ascending alphabetical order, from left to right and top to bottom.
2. Click on the Sort Material (Z->A) icon to reverse the sort order of materials.

You are not obliged to sort materials alphabetically. Simply click on one or more materials and drag them to their new location if you wish to set them in a specific order. You can do this material by material, or use the multi-selection capabilities (Shift and Ctrl keys).
Workbench Description

The CATIA - Material Library Version 5 application window looks like this:

Click the hotspots to see related documentation

Material Library Menu Bar

Material Library Toolbar
Menu Bar

This section presents the menu bar tools and commands dedicated to the Material Library workbench.

### Edit

<table>
<thead>
<tr>
<th>Tool</th>
<th>Function</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Undo/Redo</td>
<td>Reverse actions of previous editing steps</td>
<td>Ctrl+Z/Ctrl+Y</td>
</tr>
<tr>
<td>Cut/Copy/ Paste</td>
<td>Copy selected content to clipboard</td>
<td>Ctrl+X/Ctrl+C/Ctrl+V</td>
</tr>
<tr>
<td>Paste Special...</td>
<td>Copy and paste content to Material Library</td>
<td></td>
</tr>
<tr>
<td>Search...</td>
<td>Find materials in the library</td>
<td></td>
</tr>
<tr>
<td>Links...</td>
<td>Manage links to other materials</td>
<td></td>
</tr>
<tr>
<td>Properties</td>
<td>View material properties</td>
<td></td>
</tr>
</tbody>
</table>

### Insert

<table>
<thead>
<tr>
<th>Tool</th>
<th>Function</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>New Family</td>
<td>Create new families in library</td>
<td></td>
</tr>
<tr>
<td>New Material</td>
<td>Create new materials for library</td>
<td></td>
</tr>
</tbody>
</table>

See... for details on each function.
Material Library Toolbar

See Creating a Material Library
See Creating a Material Library
See Creating a Material Library
See Creating a Material Library
See Creating a Material Library
See Creating a Material Library
See Modifying a Material
See Sorting Materials Within a Family
Index

C

color

commands
Apply Material ➤
Links ➤
New Family ➤
New Material ➤
Paste Special... ➤
Remove Family ➤
Remove Material ➤
Rename Family ➤
Rename Material ➤
Search ➤
Shading with Texture ➤
Sort Material ➤
compass ➤
contrast ➤
copying materials ➤
creating
material families ➤
material library ➤
materials ➤
materials from V4 materials ➤

D

default
family ➤
library ➤
material ➤
E

editing
  materials ★
  properties ★

F

finding materials ★

L

library
  creating ★
  lighting parameters ★
  link to file ★
  luminosity ★

K

Knowledge Advisor ★

M

material size ★
materials
  color ★
  contrast ★
  copying ★
  creating ★
  editing ★
  finding ★
  linked to library ★
  luminosity ★
  material size ★
orientation ▶
positioning using 3D compass ▶
position u,v ▶
reflectivity ▶
repeat u,v ▶
scale u,v ▶
shininess ▶
sorting ▶
specifications ▶
transparency ▶

O

opening
material workbench ▶
orientation ▶

P

parameters
lighting ▶
texture ▶
Paste Special... command ▶
positioning materials using 3D compass ▶
position u,v ▶

R

reflectivity ▶
repeat u,v ▶

S

scale u,v ▶
shininess ▶
sorting materials ➤
specifications ➤
texture parameters ➤
transparency ➤