Sketcher
Preface

CATIA Version 5 Sketcher application makes it possible for designers to sketch precise and rapid 2D profiles.
Using This Book

This book is intended for the user who needs to become quickly familiar with CATIA Sketcher Version 5 product. The user should be familiar with basic CATIA Version 5 concepts such as document windows, standard and view toolbars.

To get the most out of this guide, we suggest you start reading and performing the step-by-step tutorial Getting Started. This tutorial will show you how to create a basic profile using autodetection. The next sections deal with various types of profiles and associated operations as well as more details on constraints that can be applied to these profiles. You may also want to take a look at the sections describing the Sketcher menus and toolbars at the end of the guide.
Where to Find More Information

Prior to reading this book, we recommend that you read the CATIA - Infrastructure User's guide Version 5.
What's New?

**Simple Profiles**
New: Creating Parabola by Focus
New: Creating Hyperbola by Focus
New: Creating Arcs (Three Points) Using Limits
Enhanced: Points
New: Creating Symmetry Lines
Enhanced: Creating Axes

**Operations on Profiles**
New: Closing Elements
Enhanced: Creating Symmetrical Elements
New: Translating Elements
New: Rotating Elements
New: Offsetting Elements
New: Copy/Pasting Projected/Intersected Elements
New: Scaling Elements

**Constraints**
Enhanced: Using Autodetection
Enhanced: Creating Constraints via a Dialog Box
Enhanced: Quickly Creating Dimensional Constraints
New: Defining Constraint Measure Direction
Enhanced: Auto-Constraining a Group of Elements
Getting Started

The Sketcher workbench provides a set of functionalities for creating and modifying sketched elements. Note that you can apply constraints to the elements.

### Tasks

- Entering Sketcher Workbench
- Creating a Profile
- Editing a Profile Shape and Size
- Leaving Sketcher Workbench

This tutorial should take about ten minutes to complete.
Entering Sketcher Workbench

This task shows how to enter the Sketcher workbench.

1. Select Start -> Mechanical Design -> Sketcher from the menu bar.

Three reference planes are available. They are displayed both in the geometry area and in the specification tree.

2. Click the desired reference plane either in the geometry area or in the specification tree.

You can also enter the Sketcher workbench by:
- multi-selecting two edges (to define h and v - the axis is aligned on these two edges)
- selecting one surface (reference plane)
- selecting the Sketcher icon

You can also enter the Sketcher workbench by double-clicking one sketch element.

Note that if you select one or two edges, h will be parallel to the projection of the first edge in the sketch plane. If the two projected edges appear as two lines that intersect in the sketch plane, the origin of the sketch axis will correspond to the two lines intersection point.

The Sketcher workbench appears as follows:
A grid is displayed which is optional. You can modify the grid characteristics via Tools->Options->Part. For more information, see *CATIA- Infrastructure User's guide Version 5*. 
Creating a Profile

This task shows how to create a profile beneath an existing profile. You will use autodetection as a guide for creating profiles.

Before starting to learn how to sketch, just remember that whatever operations you are performing in the Sketcher, the application automatically updates the geometry.

1. Click on the Profile icon.
2. Click to position the top right-hand corner of the new profile.

If you move the cursor around the screen, a line to be used for autodetection follows the cursor.

3. Click to position the top left-hand corner of the new profile.
4. Click the required points on the profile.

The current values of the profile being created are simultaneously displayed in the Tools status bar. Note that you can drive the profile to be created by entering the values in this status bar.
5. Click to end the profile.
In this particular case, what you do is select the start point.

A line is set to the red color each time this line is to be used as reference for autodetection.

A line is set to the blue color each time it is detected as an horizontal or a vertical line.

6. If needed, drag the cursor for modifying the profile location.
7. Click to position the profile.
The profile newly created is assigned what we call a constraints. In other words, and as you can see above, the profile newly created is assigned parallelism constraints. A green-colored parallelism symbol is assigned between both profiles.
Editing a Profile Shape and Size

This task shows how, when you first access the Sketcher, you can use the modification mode. Most of your sketching will involve the modification of the shape and size of your sketched elements.

Create two profiles with parallelism constraints.

1. Select one end side of the profile.

2. Drag one of the right end sides of the profile anywhere to the right.
The parallelism constraint remains active.

3. Drag diagonally one corner of the profile.

The parallelism constraint remains active.

You have just stretched the profile (shape and size) without having to use any intermediary menu options. You can modify the profile directly simply using the mouse.
Leaving Sketcher Workbench

This task shows you how to leave Sketcher workbench.

1. Click the Exit icon.

You are now in the Part Design Workbench.
Basic User Tasks

The Sketcher workbench provides a simple method for creating and editing two-dimensional geometry as well as creating relations between geometrical elements. Once created, you can set constraints between geometrical elements, if you need more complex sketches.
Before You Begin

Before you begin, you should be familiar with the following.

<table>
<thead>
<tr>
<th>Sketcher Element</th>
<th>Sketcher Color</th>
</tr>
</thead>
<tbody>
<tr>
<td>Current element</td>
<td>white</td>
</tr>
<tr>
<td>Selected element</td>
<td>highlighted (red)</td>
</tr>
<tr>
<td>Protected element</td>
<td>yellow</td>
</tr>
<tr>
<td>Fixed element</td>
<td>green</td>
</tr>
<tr>
<td>Isoconstrained element</td>
<td>green</td>
</tr>
<tr>
<td>Overconstrained element</td>
<td>violet</td>
</tr>
</tbody>
</table>

Tasks

- Using Tools For Sketching
- Cutting the Part by the Sketch Plane
- Creating Standard or Construction Elements
- Converting Standard into Construction Elements

Up

Pre-Defined Profiles

Before you Begin

Editing Profiles

Simple Profiles

Operations on Profiles

Setting Constraints
Using Tools For Sketching

This task shows how CATIA can assist you when sketching elements.

The Tools toolbar is displayed in the bottom right part of the CATIA screen and provides the following options:

- Snap to Point options
- Construction/Standard Element options
- Internal Constraints options
- Value fields (Tools toolbar)

The toolbar is not necessarily entirely visible. We advise you undock it for displaying all the available options and fields.

Snap to Point

If activated, this option makes your sketch begin or end on the points of the grid. As you are sketching the points are snapped to the intersection points of the grid. Note that this option is also available in the Tools -> Options -> Sketcher tab. For more information, see CATIA.Infrastructure user's guide (Customization Settings).

In the following example, the white spline was created with Snap to Point on. The points are on the grid.

Conversely, the here highlighted spline was created with the Snap to Point option deactivated.
Note that when you zoom in, snapping option remains active both on primary and secondary grids, even though the secondary grids are not visualized any more.

When Autodetection is active, points may not position at the intersection points of the grid. Care that they will necessarily position on an horizontal or a vertical grid subdivision.

The autodetection capability works even if this option is on.

Construction/Standard Elements

You can create two types of element: standard elements and construction elements.

If standard elements represent the most commonly created elements, on some occasions, you will have to create a geometry just to facilitate your design. Construction elements aim at helping you in sketching the required profile.

To know more about these elements, please refer to Differentiating Between Elements and Construction Elements.

Internal Constraints

If activated, the application creates the constraints specific to the elements you are sketching. In the following example, only the white oblong profile was created with this option.

To know more about sketcher constraints, please refer to Setting Constraints, and CATIA.Infrastructure user's guide (Customization Settings).

Value Fields (Tools Toolbar)
The values of the elements you sketch appear in the Tools toolbar as you move the cursor. In other words, as you are moving the cursor, the Horizontal (H), Vertical (V) Length (L) and Angle (A) fields display the coordinates corresponding to the cursor position.

You can also use these fields for entering the values of your choice. In the following scenario, you are going to sketch a line by entering values in the appropriate fields.

1. Click the Line icon.

   The Tools toolbar displays information in the four value fields.

2. Enter the coordinates of the First Point.

3. Enter the coordinates of the Second Point.

   OR

4. Enter the length (L) of the line.

5. Enter the value of the angle (A) between the line to be created and the horizontal axis.

6. Click the first point on the line.

   The line is created.

   Depending on the number of fields available and the way you customize your toolbars, some fields may be truncated. What you need to do is just undock the Tools toolbar.
Cutting the Part by the Sketch Plane

This task shows how to make some edges visible. In other words, you are going to simplify the sketch plane view by hiding the portion of material you do not need for sketching.

1. Select the plane on which you need to sketch a new profile and enter the Sketcher workbench.

Once in the Sketcher, you obtain this view, which does not show the edges generated by the shell feature.

2. Now, click the Cut Part by Sketch Plane option to hide the portion of part you do not want to see in the Sketcher.

You obtain this view without the material existing above the sketch plane.

The edges corresponding to the shell are now visible. The edges resulting from the intersection are not visualized and therefore cannot be selected.

3. You can now sketch the required profile taking these edges into account.
Using Tools For Sketching

Creating Standard or Constr. Converting Standard into Co...
Creating Standard or Construction Elements

This task shows how to create standard elements or construction elements. Note that creating standard or construction elements is based upon the same methodology.

If standard elements represent the most commonly created elements, on some occasions, you will have to create geometry just to facilitate your design. Indeed, construction elements aim at helping you in sketching the required profile.

1. Click the command from the Tools toolbar so that the elements you are now going to create be either standard or construction element.

In this task, you will transform the newly created elements into construction elements.

As construction elements are not taken into account when creating features, note that they do not appear outside the Sketcher.

Here is an example of the use of both types of elements. The hexagon was sketched using three construction circles:
This type of sketch is interesting in that it simplifies the creation and the ways in which it is constrained. Setting a radius constraint on the second circle is enough to constrain the whole hexagon. Just imagine what you would have to do to constrain hexagons sketched with no construction circles!
Converting Standard into Construction Elements

This task shows how to convert standard elements into construction elements and vice versa.

1. Select the line (standard type) you wish to convert into a construction line.

2. Click the Construction/Standard Element option from the Tools toolbar.

   The line you previously selected appears dotted to show it is a new type of line.

   Double-clicking on the line displays the Line Definition dialog box in which you can activate the Construction element option. For more information, refer to Modifying Profile Shape and Size.

3. Click the Construction/Standard Element command again.

   The construction line is converted into a standard line.
Applying the Construction/Standard Element option on axes has no effect.
Sketching Simple Profiles

Before you begin, make sure you are familiar with [Tools For Sketching].

As soon as a profile is created, it displays in the specification tree.

You can sketch profiles using:

- the corresponding icons:

- the menu bar:

Tasks

- Profiles
- Rectangles
- Circles
- Circles 3 points
- Circles Coordinates
- Arcs
- Arcs Three Points
- Arcs Three Points via Limits
Creating Profiles

This task shows how to create a open or closed profiles. Profiles may be composed of lines and arcs.

Remember that you can also use the value fields of the Tools toolbar.

1. Click the Profile icon from the Profiles toolbar.

   The Tools toolbar displays with Lines, Tangent Arcs and Three Point Arcs switchs.

   The Line switch is activated by default.

2. Click two points to create a line.

   A rubberbanding line follows the cursor, showing the next line which will be created.

3. Click the Tangent arc switch that is now available from the Tools toolbar.

4. Drag the cursor and click where you wish to end the tangent arc.

   The tangency symbol is displayed.

5. Click the Three Point Arc switch.

6. Click two points as indicated.

   An arc is created. In other words, only the arc end points are created.
The Line switch is set by default.

7. Drag the cursor to create a line.

Now you are going to create another line then a tangent arc but this time without using the Tangent Arc switch.

8. To create an arc as part of a profile drag and release at the point where you want to begin your arc.

A rubberbanding arc follows the cursor, showing the arc which will be created. The arc is automatically tangent to the previous element.

9. Double-click in the free space to end the profile creation or click the profile starting point.

In other words, you end the profile creation and close it according to the element last created.

Tangent arcs are always positioned in the direction of the element previously created.
Creating Rectangles

This task shows how to create a rectangle by clicking.

Remember that you can also use the value fields of the Tools toolbar.

1. Click the Rectangle icon from the Profiles toolbar.
2. Point to where you wish the first corner of the rectangle to appear.
3. Drag to see the rectangle being created.
4. Click to create the rectangle.

A rubberbanding rectangle follows the cursor as you drag it.

The logical constraints detected during the creation of the rectangle are memorized.
Creating Circles

This task shows how to create a basic circle.

Remember that you can also use the value fields of the Tools toolbar.

1. Click the Circle icon from the Profiles toolbar (2D Circle subtoolbar).

2. Click where you wish the center of the circle to appear.

By default, centers are created but if you do not need them you can specify this in the Tools->Options dialog box. For more information, see CATIA - Infrastructure User's guide Version 5.

3. Move the cursor to see the circle being created.

A rubberbanding circle follows the cursor as you drag it.

4. Click once you are satisfied with the size of the circle.

The circle is created. The specification tree displays this circle as well as its center point.

The logical constraints detected during the creation of a circle are memorized.
Creating Circles Through Three Points

This task shows how to create a circle clicking three points.

Remember that you can also use the value fields of the Tools toolbar.

1. Click the Three Point Circle icon from the Profiles toolbar (2D Circle subtoolbar).

2. Click two points.
   The application previews a circle.

3. Click the third point.
   The circle as well as its center point are created.

By default, centers are created but if you do not need them you can specify this in the Tools->Options dialog box. For more information, see CATIA - Infrastructure User's guide Version 5.
Creating Circles Specifying Center Point Coordinates

This task shows how to create a precise circle.

Remember that you can also use the value fields of the Tools toolbar.

1. Click the Circle Using Coordinates icon from the Profiles toolbar (2D Circle subtoolbar).

The Circle Definition dialog box is displayed.

The default point coordinates that appear in the Circle Definition dialog box are the origin axis coordinates.

If, before clicking the Circle Using Coordinates icon, you select a point, this point will be used as a reference point and the coordinates of this point will appear in the Circle Definition toolbar.

2. Enter the coordinates of the center point.
3. Enter the desired circle radius value.
4. Press OK.

The circle and its center point are created. By default, **constraints** are also set. The specification tree indicates all the elements that were created.
Creating Arcs

This task shows how to create an arc from a center point.

Remember that you can also use the value fields of the Tools toolbar.

1. Click the Arc icon from the Profiles toolbar (2D Circle subtoolbar).

2. Click to the intended center of the arc and drag the cursor.
   A circle appears.

By default, centers are created but if you do not need them you can specify this in the Tools->Options dialog box. For more information, see CATIA - Infrastructure user's guide.

3. Click when you are satisfied with the radius of your circle.
   This sets the first limit of the arc.

4. Now, moving the cursor clockwise and clicking, you will obtain this arc:

5. Moving the cursor counterclockwise and clicking, you will obtain this arc:
Creating Arcs Through Three Points

This task shows how to create an arc using three reference points in order to define the required size and angle.

Remember that you can also use the **value fields** of the Tools toolbar.

1. Click the Three Point Arc icon from the Profiles toolbar (2D Circle subtoolbar).

2. Click where you wish the arc to begin.
3. Click to position the second point of the arc.

An arc appears.

4. Point elsewhere and click again to create the last point of the arc.

The logical constraints detected during the creation of an arc are memorized.

By default, centers are created but if you do not need them you can specify this in the Tools->Options dialog box. For more information, see CATIA - Infrastructure User's guide Version 5.
<table>
<thead>
<tr>
<th>Up</th>
<th>Profiles</th>
<th>Rectangles</th>
</tr>
</thead>
<tbody>
<tr>
<td>Circles</td>
<td>Circles 3 points</td>
<td>Circles Coordinates</td>
</tr>
<tr>
<td>Arcs</td>
<td>Arcs Three Points</td>
<td>Arcs Three Points via Limits</td>
</tr>
<tr>
<td>Splines</td>
<td>Ellipses</td>
<td>Parabola by Focus</td>
</tr>
<tr>
<td>Hyperbola by Focus</td>
<td>Lines</td>
<td>Symmetry Lines</td>
</tr>
<tr>
<td>Axes</td>
<td>Points</td>
<td>Points By Coordinates</td>
</tr>
<tr>
<td></td>
<td>Equidistant Points</td>
<td></td>
</tr>
</tbody>
</table>
Creating Three Point Arcs Using Limits

This task shows how to create a three point arc by first creating the start point and the end point. Remember that you can also use the value fields of the Tools toolbar.

1. Click the Three Point Arc Starting with Limit from the Profiles toolbar (2D Circle subtoolbar).

2. Click the arc start point.

3. Click the arc end point.

An arc appears.

4. Click again to create the arc intermediate point (the point which the arc will go through).
For creating the arc intermediate point, you can drag the cursor and define the arc desired shape and size. Of course, you can also use autodetection.

The logical constraints detected during the creation of an arc are memorized.

By default, centers are created but if you do not need them you can specify this in the Tools->Options dialog box. For more information, see CATIA - Infrastructure User's guide Version 5.
Creating Splines

This task shows you how to create a spline by clicking.

Remember that you can also use the value fields of the Tools toolbar.

1. Click the Spline icon from the Profiles toolbar.

2. Click to indicate two points through which the spline passes.

3. Click as many times as needed to create the whole spline.

4. Double-click to end the spline. Clicking the Select icon ends the spline too.

The spline and associated control points are displayed in the specification tree.

You can set tangency when editing spline control points. For more information, please refer to Modifying Splines.
Creating Ellipses

This task shows how to create an ellipse (made of two infinite axes) by clicking.

Remember that you can also use the value fields of the Tools toolbar.

1. Click the Ellipse icon from the Profiles toolbar.

2. Click to create a first point that corresponds to the ellipse center.

By default, centers are created but if you do not need them you can specify this in the Tools -> Options dialog box. For more information, see CATIA - Infrastructure User's guide Version 5.

3. Click a second point to locate the Major semi-axis endpoint.

4. Move the cursor for positioning the axis with the desired shape and size. In this particular case, only the Minor semi-axis is modified.

5. Click a point on the ellipse.
Creating Parabola by Focus

This task shows you how to create a Parabola by Focus.

Remember that you can also use the value fields of the Tools toolbar.

1. Click the Parabola by Focus icon from the Profiles toolbar (2D Conic subtoolbar).

2. Select a point or click to locate the focus.

3. Select a point or click to locate the apex.

4. Select a point or click to locate the first point on the Parabola.

5. Select a point or click to locate the second point on the Parabola.
Creating Hyperbola by Focus

This task shows you how to create a Hyperbola by Focus.

1. Click the Hyperbola by Focus icon from the Profiles toolbar (2D Conic subtoolbar).

2. Select a point or click to locate the focus.

3. Select the center of the hyperbola to be created (asymptote intersection).

4. Select a point or click to locate the apex and define the excentricity.

5. Select a point or click to locate the first point on the hyperbola.

6. Select a point or click to locate the second point on the hyperbola.

Remember that you can also use the value fields of the Tools toolbar.
Creating Lines

This task shows how to create a line from two points by clicking.

Remember that you can also use the value fields of the Tools toolbar.

1. Click the Line icon from the Profiles toolbar.

2. Click to create the first point, and point elsewhere.

A rubberbanding line follows the cursor, showing the shape of the line which will be created.

3. Click to create the second point.

The logical constraints detected during the creation of a line are memorized. CATIA displays the line and its endpoints in the specification tree.

At any time, you can create a symmetry line from this line.
Creating Symmetry Lines

This task shows how to create a symmetry line. In other words, you are going to create a median.

Remember that you can also use the value fields of the Tools toolbar.

1. Click the Line icon \[\text{Line}\] from the Profiles toolbar.

2. Click the Create Symmetry Line icon \[\text{Symmetry Line}\] that displays in the Tools toolbar.

3. Click the center point of the line which is to be assigned a symmetry line.

4. Drag the cursor to the desired location.

5. Click to locate the symmetry line.

The median appears. It is perpendicular to the line, at the line mid-point.
The symmetry line is created.
Creating Axes

This task shows how to create an axis by clicking two points. You will need axes whenever creating shafts and grooves. Axes cannot be converted into construction elements.

Remember that you can also use the value fields of the Tools toolbar.

1. Click the Axis icon from the Profiles toolbar.

2. Select the first point, and point elsewhere.

   A rubberbanding line follows the cursor, showing the shape of the line which will be created.

3. Click to create the second point.

   An axis is created where you clicked.

   The axis and corresponding endpoints display in the specification tree.

   This cone exemplifies the use of axes:
If, before you select the Axis icon, you have already selected a line, this line will automatically be transformed into an axis.

Note that you can create only one axis per sketch. If you try to create a second axis, the axis first created is automatically transformed into a line (construction type element).
Creating Points By Clicking

This task shows you how to quickly create points.

Remember that you can also use the value fields fields of the Tools toolbar.

1. Click the Point icon from the Profiles toolbar.

2. Click once for each point to be created.

The logical constraints detected during the creation of a point are memorized.

The symbol used for points in the geometry area can be customized using the Edit -> Properties command.

For creating an isobarycenter, click (or multi-select) at least two points before clicking the Point command. Note that an isobarycenter can only be created between points. In other words, if you multi-select a rectangle, the four points of this rectangle, and only these four points, will be used for defining the isobarycenter. Associativity remains valid.
Creating Points by Specifying Coordinates

This task shows you how to create points by indicating their coordinates.

1. Click the Point By Using Coordinates icon \[\text{[Image]}\] from the Profiles toolbar (2D Point subtoolbar).

2. In the Point Definition dialog box that appears, enter your point coordinates \(h\) and \(y\). If, before clicking the Point By Using Coordinates icon, you select a point, this point will be used as a reference point and the coordinates of this point will appear in the Point Definition toolbar.

3. Click OK.

The point is created.

The symbol used for points in the geometry area can be customized using the Edit -> Properties command.
**Equidistant Points**

This task shows how to create a set of equidistant points on a line. You can create equidistant points on the support of your choice: a line, an arc or a circle. You only need to select the origin point and specify the spacing and the number of points you wish.

1. Click the **Equidistant Points** icon from the Profiles toolbar (2D Point subtoolbar).
2. Select the line on which you wish to create four equidistant points.
3. Select one of the origin points of the line to define the starting point.

The Equidistant Points Definition dialog box is displayed. By default, ten equidistant New Points are previewed and the default spacing is set at 10mm.

4. Enter the space value you need between each point.
5. Enter four as the desired number of points.
6. Press OK.

The points are created and distributed along the line. Coincidence constraints are created between each point and the line. Offset constraints are created between the points. The offset between the origin point and the first point is a driving constraint.

Note also that formulas are created too. For more information about formulas, see CATIA - Knowledge Advisor User's guide.
You can edit points individually. If the support is edited, the points are not affected by modifications.

The symbol used for points in the geometry area can be customized using the Edit -> Properties command.
Sketching Pre-Defined Profiles

Before you begin, make sure you are familiar with Tools For Sketching.

You can sketch pre-defined profiles:

- via the corresponding icons:

- via the menu bar:

<table>
<thead>
<tr>
<th>Insert</th>
<th>Tools</th>
<th>Window</th>
<th>Help</th>
</tr>
</thead>
<tbody>
<tr>
<td>Object</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Constraint</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Profile</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Operation</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Tasks**

- Oriented Rectangles
- Parallelograms
- Oblong Profiles
- Oblong Arcs
- Keyholes
- Hexagons
Creating Oriented Rectangles

This task shows how to create a rectangle in the direction of your choice.

Remember that you can also use the value fields of the Tools toolbar.

1. Click the Oriented Rectangle icon from the Profiles toolbar (Predefined Profile subtoolbar).

2. Click two points to create the first side of the rectangle.

3. Drag to see the rectangle being created.

4. Click to create the rectangle.

The logical constraints detected during the creation of the rectangle are memorized. CATIA displays the lines and points composing the oriented rectangle in the specification tree.
Creating Parallelograms

This task shows how to create a parallelogram by clicking.

Remember that you can also use the **value fields** of the Tools toolbar.

1. Click the Parallelogram icon from the Profiles toolbar (Predefined Profile subtoolbar).

2. Click two points to create the first side of the parallelogram.

3. Drag to see the parallelogram being created.
   A rubberbanding parallelogram follows the cursor as you drag it.

4. Click to create the parallelogram.
   The logical constraints detected during the creation of a parallelogram are memorized. The lines and points composing the parallelogram display in the specification tree.
Up
Oblong Profiles

Oriented Rectangles
Oblong Arcs
Hexagons

Parallelograms
Keyholes
Oblong Profiles

This task shows how to create an oblong profile by clicking.

Remember that you can also use the value fields of the Tools toolbar.

1. Click the Oblong Profile icon from the Profiles icon (Predefined Profile subtoolbar).

2. Click to create the first point and drag the cursor.

3. Click to create the second point.
   The first axis of the profile is created.

4. Drag the cursor and click to create the third point.
   The second semi-axis is created and the oblong profile is displayed.
Oblong Arcs

This task shows how to create a curved oblong profile by clicking. A construction arc assists you in creating this element.

Remember that you can also use the **value fields** of the Tools toolbar.

1. Click the Oblong Arc icon from the Profiles icon (Predefined Profile subtoolbar).

2. Click two points to define the radius of the construction arc. The second point you clicked is the first endpoint of the construction arc.

3. Move the cursor and click to define the second construction arc endpoint. The profile shape looks like this:

4. Move the cursor away from the construction arc to define the radius of both of the arcs at the end of the profile.

5. Click when you are satisfied with the radius value.
The specification tree indicates this creation. The construction arc radius as well as the profile ends radius are displayed. This a curved oblong profile:
This task shows how to create a keyhole profile by clicking.

Remember that you can also use the value fields of the Tools toolbar.

1. Click the Keyhole Profile icon from the Profiles icon (Predefined Profile subtoolbar).

2. Click one point.
   This point is the centerpoint of the arc.

3. Click another point.

4. Drag and click to define the width of the lower part of the profile.
5. Drag the cursor to define the circle radius of the upper part of the profile.

6. Click when you are satisfied with the radius value.
Hexagons

This task shows you how to create a hexagon. A construction circle assists you in creating this profile.

Remember that you can also use the value fields of the Tools toolbar.

1. Click the Hexagon icon from the Profiles icon (Predefined Profiles subtoolbar).

2. Click a point to define the center point of the construction circle.

3. Drag the cursor to define a radius value. CATIA previews the hexagon to be created.

4. You can move the cursor clockwise or counter-clockwise to position the hexagon.

5. Click a second point when you are satisfied with the radius value and the orientation of the hexagon.

The hexagon is created.

The specification tree indicates the different lines, circles and points making up the hexagon.
Editing Profiles

The Sketcher workbench provides a set of functionalities for editing two-dimensional geometry.

For information about applying constraints, refer to Setting Constraints.
Modifying Splines

This task shows how to edit one control point and set a tangency. In other words, you will modify the location of control points on the spline and define or delete tangency on these control points.

Create a spline.

1. Double-click the control point you wish to edit.

The Control Point dialog box appears.
2. Enter new coordinates. For example, enter -40 mm as the new horizontal (h) coordinate.

4. Check the Tangency option to impose a tangency on this control point.
5. Click OK.
The point is moved and an arrow appears on this point to indicate a tangency. Tangents can be constrained. The behaviour is the same as for lines.

Keep in mind that selecting a point then dragging it will modify the spline shape:
Modifying Element Coordinates

This task shows you how to modify a line. Modifying your sketch coordinates will affect the feature defined on this sketch. In other words, associativity remains valid.

Create a line.

Profiles are not considered as entities when it comes to editing them. To edit a profile, you will need to edit the sub-elements composing it.

Multiselection is not allowed for editing Sketcher elements.

1. Double-click the line you wish to edit.

The Line Definition dialog box appears indicating the line end point coordinates.

2. Enter new coordinates for changing your end points.

3. Check the Construction Elements option, if you wish to change the line type.

4. Press OK.

Remember that the Edit -> Properties command lets you access and edit sketch properties.
Modifying Profile Shape and Size

This task shows you how to edit the profile shape and size using the Selection command.

Create a profile.

You edit sketches in the Sketcher workbench, which means that if the Sketcher is closed, you need to **double-click the sketch** in the specification tree or in the 3D area to access it. Selecting the sketch plane on which the sketch was initially constructed then clicking the Sketcher command does not allow you to edit the sketch.

1. Click the Select icon.

2. Drag the right line of the profile anywhere to the right.

   The profile is stretched to the right if you stretch it to the right:

3. You can also stretch a profile diagonally using one of its corners.
You can also edit the profile shape and size using commands such as edit, trim, and break.

If you want the profile to revert to its original shape, click the Undo command.

If the Grid option is on, you can also modify the profile using the grid. In this case, and for example if the Zoom is on, the point you select will be automatically repositioned at the closest grid intersection point. The profile new position may result awkward.
Deleting Sketcher Elements

This task shows how to delete sketched elements. To delete constraints, you will follow the same instructions.

Create sketched elements.

Deleting sketched elements affects associated features.

1. Select the element you wish to delete.

2. Click the Edit -> Delete command.

The element is deleted.

3. Now, to delete a set of elements, just multiselect them and apply the Delete command.

You can also select the Delete command from the contextual menu. For this right-click the element to be deleted.
You cannot delete elements that are not currently edited sketch elements. This is particularly true for the reference planes. You can multi-select these elements but they will not be deleted.
The Sketcher workbench provides a set of functionalities for performing operations on profiles.

Tasks
- Corners
- Corners (Trim First Element)
- Corners (No Trim)
- Chamfers
- Chamfers (Trim First Element)
- Chamfers (No Trim)
- Trim
- Break & Trim
- Close
- Break
- Symmetrical Elements
- Translate
- Rotate
- Scale
- Offset
- Project
- Intersect
- Copy/Paste
- Isolate

You can sketch pre-defined profiles either via corresponding icons or via the menu bar (Insert/Operation/Predefined Profiles).
Creating Corners With Both Elements Trimmed

This task shows how to create a rounded corner (arc tangent to two curves) between two lines using trimming operation. You can create rounded corners between consecutive lines, arcs, circles and all types of curves.

In the case of curves, even if the curves are not consecutive, the corner will be created.

1. Click the Corner icon \(\text{\image} \) from the Operations toolbar.

The possible corner options are displayed in the Tools toolbar.

The Trim All Elements command is activated by default.

2. Select the first line.

The selected line is highlighted.

3. Select the second line.

The second line is also highlighted, and the two lines are joined by the rounded corner which moves as you move the cursor. This lets you vary the dimensions of the corner.

4. Click when you are satisfied with the corner dimensions.

Both lines are trimmed at the points of tangency with the corner.

By default, centers are created but if you do not need them you can specify this in the Tools->Options dialog box. For more information, see CATIA - Infrastructure user's guide.
An Alternative Method

This task shows how to create a corner between two consecutive lines created using the Profile, rectangle, oriented rectangle or Parallelogram icons.

1. Click the Corner icon and for example, leave the default trim option.

2. Select the point intersecting the lines.
   The selected point is highlighted and the two lines are joined by the rounded corner which moves as you move the cursor.

3. Click when you are satisfied with the dimensions of the corner.
   Both lines are trimmed to the points of tangency with the arc.

A Few Words About Multiselection

This task shows you that creating several corners is possible just by multiselecting points.

1. Multiselect the rectangle endpoints.
2. Click the Corner icon.
3. Enter a radius value in the Radius field (Tools toolbar).
   Four corners are created at the same time with the same radius value.

Clicking on the Formula icon displays the parameter driving the radius value of the corners you have just created.
Corners with One Element Trimmed

This task shows how to create a corner between two lines and trim only one line.

1. Click the Corner icon \(\text{的操作区工具栏} \) from the Operations toolbar.
   
The possible corner options are displayed in the Tools toolbar.

2. Click the Trim the First Element icon \(\text{工具栏} \).

3. Select the line you wish to trim.
   
The selected line is highlighted.

4. Select the second line.
   
The second line is also highlighted, and the two lines are joined by the rounded corner which moves as you move the cursor. This lets you vary the dimensions of the corner.

5. Click when you are satisfied with the dimensions of the corner.
   
The first line is trimmed.

By default, centers are created but if you do not need them you can specify this in the Tools->Options dialog box. For more information, see CATIA - Infrastructure User's guide Version 5.
Up
Corners (No Trim)
Chamfers (No Trim)
Close
Translate
Offset
Corners
Chamfers
Trim
Break
Rotate
Project
Symmetrical Elements
Scale
Intersect
Copy/Paste
Isolate
Creating Corners with No Elements Trimmed

This task shows how to create a corner between two lines without trimming any lines.

1. Click the Corner icon \(\text{\footnotesize \begin{array}{c}
\text{Operations toolbar.}
\end{array}\vphantom{\text{\footnotesize \begin{array}{c}A\end{array}}}}\) from the Operations toolbar.

The possible corner options are displayed in the Tools toolbar.

2. Click the No trim icon \(\text{\footnotesize \begin{array}{c}
\end{array}\vphantom{\text{\footnotesize \begin{array}{c}A\end{array}}}}\).

3. Select the first line.

The selected line is highlighted.

4. Select the second line.

The second line is also highlighted, and the two lines are joined by the rounded corner which moves as you move the cursor. This lets you vary the dimensions of the corner.

5. Click when you are satisfied with the dimensions of the corner.

The corner is created.

By default, centers are created but if you do not need them you can specify this in the Tools->Options dialog box. For more information, see CATIA - Infrastructure user's guide.
Creating Chamfers With Both Elements Trimmed

This task shows how to create a chamfer between two lines using trimming operation. You can create beveled corners between any type of curves (lines, splines, arcs and so forth).

In the case of curves, even if the curves are not consecutive, the chamfer will be created.

1. Click the Chamfer icon from the Operations toolbar.

   The possible chamfer options are displayed in the Tools toolbar.

   The Trim All Elements command is activated by default.

2. Select the line.

   The selected line is highlighted.

3. Select the second line.

   The second line is also highlighted, and the two elements are connected by a line representing the chamfer which moves as you move the cursor. This lets you vary the dimensions of the chamfer.

4. Click when you are satisfied with the dimensions of the chamfer.

   The chamfer is created.
An Alternative Method

To create a chamfer between two consecutive lines created with the Profile, Rectangle, Oriented Rectangle or Parallelogram icon, you can also use the following method:

1. Click the Chamfer icon and for example, leave the default trim option.

2. Select the intersection point as shown.

The selected point is highlighted and the two lines are joined by the chamfer which moves as you move the mouse.

3. Click when you are satisfied with the dimensions of the chamfer.

Both lines are trimmed.
Chamfers with One Element Trimmed

This task shows how to create a chamfer and trim one element only.

1. Click the Chamfer icon from the Operations toolbar.

   The possible chamfer options are displayed in the Tools toolbar.

2. Click the Trim First Element icon.

3. First select the line you wish to be trimmed.

   The selected line is highlighted.

4. Select the second line.

   The second line is also highlighted, and the two elements are connected by a line representing the chamfer which moves as you move the cursor. This lets you vary the dimensions of the chamfer.

5. Click when you are satisfied with the dimensions of the chamfer.

   The chamfer is created.
Chamfers with No Elements Trimmed

This task shows how to create a chamfer and trim no element.

1. Click the Chamfer icon \(\text{from the Operations toolbar.}\)

   The possible chamfer options are displayed in the Tools toolbar.

2. Click the No trim icon \(\).

3. First select the line.

   The selected line is highlighted.

4. Select the second line.

   The second line is also highlighted, and the two elements are connected by a line representing the chamfer which moves as you move the mouse. This lets you vary the dimensions of the chamfer.

5. Click when you are satisfied with the dimensions of the chamfer.

   The chamfer is created and the original lines are still displayed.
Trimming Elements

This task shows how to trim a line or a circle (either one element or all the elements).

1. Click the Trim icon from the Operations toolbar.

The Trim toolbar options display in the Tools toolbar.

The Trim All option is the command activated by default.

2. Select the first line.

The selected element is highlighted.

3. Select the second line.

The second element is highlighted too, and both lines are trimmed.

If you select the same first element, it will be trimmed at the location of the second selection.

The location of the relimitation depends on the location of the cursor.

4. Click where you are satisfied with the relimitation of the two lines.

First example  Second example

Third example  Fourth example
This task shows how to trim just one element.

1. Click the Trim icon from the Operations toolbar.

   The Trim toolbar options display in the Tools toolbar.

2. Click the Trim One Element option.

3. Select the first line or circle.

   The selected line or circle is highlighted.

4. Select the second line or circle.

   The first line or circle selected is trimmed.

   If you select the same first element, it will be trimmed at the location of the second selection.

   The location of the trim depends on the location of the cursor:

   * First example
   * Second example
Breaking and Trimming

This task shows how to quickly delete elements intersected by other Sketcher elements using breaking and trimming operation.

1. Click the Trim icon from the Operations toolbar.
   The possible trim options are displayed in the Tools toolbar.
2. Click the Quick Trim command.
3. Select the arc you wish to delete.
   The arc is deleted.
Closing Elements

This task shows how to close circles, ellipses or splines using relimiting operation.

1. Click the Trim icon to display the Tools toolbar.

The possible trim options are displayed in the Tools toolbar.

3. Click the Close Element icon.

2. Select the element to be relimited. For example, a three point arc.

The arc is now closed.

In the case of a spline that was relimited by using the Trim icon, the spline is set to its original limitation.

Spline after it was relimited

Spline after you clicked the Close icon
Breaking Elements

The purpose of this task is to show how to break a line using a point on the line and then a point that does not belong to the line. The Break command lets you break any types of curves. The elements used for breaking curves can be any Sketcher element.

1. Click the Break icon from the Operations toolbar.
2. Select the line to be broken.
3. Select the breaking element, that is a point.

The selected element is broken at the selection point. The line is now composed of two movable segments.

1. Click the Break icon from the Operations toolbar.
2. Select the line to be broken.
3. Select the breaking point.

The application projects the point onto the line and creates another point.
The line is broken at the projected point. The line is now composed of two segments that can be moved.

Using the Break icon, you can also isolate points:
- if you select a point that limits and is common two two elements, the point will be duplicated.
- if you select a coincident point, this point becomes independent (is no more assigned a coincidence constraint).
Creating Symmetrical Elements

This task shows you how to repeat existing Sketcher elements using a line, a construction line or an axis. In this particular case, we will duplicate a circle.

1. Select the circle to be duplicated by symmetry.

2. Click the Symmetry icon from the Operations toolbar.

3. Select the axis you previously created.

   The selected circle is duplicated and a symmetry constraint is created.

You can also use multi-selection. Drag the cursor and create a trap. Then select the symmetry axis.

To know how to set symmetry constraints on already existing elements (without duplicating them), refer to Defining a Symmetry Constraint.
Translating Elements

This task will show you how to perform a translation on 2D elements by defining the duplicate mode and then selecting the element to be duplicated. Multi-selection is not available.

The application provides a powerful command for translating elements. You may either perform a simple translation (by moving elements) or create several copies of Two-dimensional elements.

1. Click the Translation icon from the Operations toolbar (Transformation subtoolbar).

The Translation Definition dialog box displays and will remain displayed all along your translation creation.

2. Enter the number of copies you need. The duplicate mode is activated by default.

3. Select the element(s) to be translated.
4. Click the translation vector start point or select an existing one.

5. In the Translation Definition dialog box, enter a precise value for the translation length. For example, 10 mm.

6. Use Autodetection to keep lines horizontal.

7. Click OK in the Translation Definition dialog box to end the translation.

8. The last translation is always highlighted. You may restart from this one if you need more copies.
The Undo command is available from the toolbar, while you are translating elements.

- When Duplicate mode is activated, only 2D geometry is translated, dimensions are not.
- When Duplicate mode is deactivated, 2D geometry and the associated dimensions are translated. Therefore, associativity is still valid.

You may select one 2D element to be translated or mutiselect the entire two-dimensional geometry. Please refer to A Few Words About Multiselection.
This task will show you how to rotate elements by defining the duplicate mode and then selecting the element to be duplicated.

In this scenario, the geometry is simply moved. But note that, you can also duplicate elements with the Rotation command.

1. Click the Rotation icon from the Operations toolbar (Transformation subtoolbar).

The Rotation Definition dialog box displays and will remain displayed all along your translation creation.

2. Deactivate the Duplicate mode.

3. Enter the number of copies you need.

4. Select the geometry to be rotated. Here, multiselect the entire profile.

5. Click the rotation center point position or enter a value in the fields displayed.

6. Click a point for defining the reference line that will be used for computing the angle.

7. In the Rotation Definition dialog box, enter a value for the rotation angle. The Snap mode rotates in steps of 15 degrees. You may enter the value of your choice (for example, 92 degrees), whether this mode is active or not.
7. Click OK to end the rotation.

- When the Duplicate mode is activated, only 2D geometry is rotated, dimensions are not.
- When the Duplicate mode is deactivated, 2D geometry and the associated dimensions are rotated, therefore associativity is maintained.
This task will show you how to scale an entire profile. In other words, you are going to resize a profile to the dimension you specify.

1. Click the Scale icon from the Operations toolbar (Transformation subtoolbar).

The Scale Definition dialog box displays and will remain displayed all along your operation.

2. Select the element(s) to be scaled.

Note that you can first select either the geometry or the scaling icon. If you select the Scale icon first, multiselection capability is available.
The value fields display in the Tools toolbar.

3. Enter the newly scaled element center point value.

In the displayed Scale Definition dialog box:

5. Enter 0.5 as Scale Value:
Offsetting Elements

This task shows how to duplicate a line, arc or circle type element.

1. Click the Offset icon from the Operations toolbar (Transformation subtoolbar).

2. Select the line to be duplicated by offset. The new line to be created appears.

3. Select a point or click for locating the new element.
The selected line is duplicated and the application creates an offset constraint.
Projecting 3D Elements onto the Sketch Plane

This task shows how to project edges (elements you select in the Part Design workbench) onto the sketch plane.

1. Click the Project 3D Elements icon from the Operations toolbar (3D Geometry subtoolbar).

2. Multiselect the edges you wish to project onto the sketch plane.

The edges are projected onto the sketch plane. These projections are yellow (in others words, you cannot move them).

You can apply the Relimitation, Corner and Chamfer commands on projections.
If you select a face, the edges are projected.
Intersecting 3D Elements with the Sketch Plane

This task shows how to intersect a face and the sketch plane.

1. Click the Intersect 3D Elements icon from the Operations toolbar (3D Geometry subtoolbar).

2. Select the face of interest.

CATIA computes and displays the intersection between the face and the sketch plane. The intersection is yellow (in others words, you cannot move it).

You can apply the Trim, Corner, and Chamfer commands on intersections.
This task shows how sketched elements behave when copying/pasting elements that were created via projection or intersection. For general information on copy/paste, see CATIA - Infrastructure User's guide Version 5.

1. Perform copy/paste operation.

External references are deleted:
- Constraints on external geometry are deleted.
- Projections/Intersections are isolated: each trace is replaced with an equivalent geometrical element. Projection/intersection cannot be performed any more. There is no associativity either.
Isolating Projections and Intersections

This task shows how to isolate the elements resulting from the use of the Project 3D Elements or Intersect 3D Elements icons.

1. Select the 3D curve you wish to isolate.
2. Select Insert -> Operation -> 3D Geometry -> Isolate command from the menu bar.

The curve is no longer linked to the initial geometry, which means that you can edit it the way you wish.

3. For example, drag and drop the curve to the desired location.

Once isolated, the curve becomes white. You can edit the curve graphical properties using the Edit -> Properties command.
Setting Constraints

CATIA Version 5 lets you set geometrical and dimensional constraints on various types of elements both in the Sketcher workbench and the 3D geometry area.

This section shows you how to use the different constraint commands for sketches, and the constrain commands dedicated to 3D geometry.

Note also that you can customize constraints symbols. To have details about it, please refer to Customizing Constraints.

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Constraint type</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Perpendicullarity</td>
</tr>
<tr>
<td></td>
<td>Coincidence</td>
</tr>
<tr>
<td></td>
<td>Verticality</td>
</tr>
<tr>
<td></td>
<td>Horizontality</td>
</tr>
<tr>
<td></td>
<td>Fix/Unfix</td>
</tr>
<tr>
<td></td>
<td>Parallel</td>
</tr>
<tr>
<td></td>
<td>Radius/Diameter</td>
</tr>
</tbody>
</table>

Tasks

Before you Begin
Autodetection
Quick Dimensional Constraints
Measure Direction
Dialog Box
Definition Modification
Auto-Constraining a Group of Elements
Modifying Constraints Between Two Elements

Animating Constraints

Up

Pre-Defined Profiles

Before you Begin

Editing Profiles

Simple Profiles

Operations on Profiles

Setting Constraints
Before You Begin

What is Autodetection?

Autodetection is an intuitive, easy-to-use tool designed to make all your Sketcher creation and edition tasks as simple as possible.

Autodetection dynamically detects the following geometrical constraints:
- support lines and circles
- alignment
- parallelism
- perpendicularity
- tangency
- concentricity
- horizontality
- verticality
- middle point

What are Constraints?

There are times when simple sketches are adequate for your design process, but you will often need to work on more complex sketches requiring a rich set of geometrical or dimensional constraints. The Sketcher workbench provides constraint commands which will allow you to fully sketch your profiles.

Geometrical Constraints

A geometrical constraint is a relationship that forces a limitation between one or more geometric elements. For example, a geometrical constraint might require that two lines be parallel.

You can set a constraint on one element or between two or more elements.
When creating your constraint, remember that a green constraint is a valid constraint by default. Conversely, a yellow constraint indicates that the definition is not valid. CATIA lets you customize the colors and more generally the style of the constraints you use. To have details about these capabilities, see CATIA - Infrastructure User's guide Version 5.

When you position the cursor on constraint symbols, CATIA calls your attention on the elements involved in the constraint system. Here are two examples of what you may get.

**Dimensional Constraints**

A dimensional constraint is a constraint which value determines geometric object measurement. For example, it might control the length of a line, or the distance between two points.

You will use the Constraint command to finalize your profile. The Constraint command allows you setting dimensional or geometrical constraints but you will mainly use it to set dimensional constraints.

You can combine dimensional constraints to constrain a feature or sketch.

You can set a dimensional constraint on one element or between two elements.
Particular Cases

You can apply a diameter constraint between two lines provided one of these lines is an axis line.

What About Constraining While Sketching?

Provided you previously activated the Constraint command, sketching certain elements automatically generates constraints although you did not specify that you wanted these elements to be actually constrained.

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Constraint type</th>
</tr>
</thead>
<tbody>
<tr>
<td>⊥</td>
<td>Perpendicularity</td>
</tr>
<tr>
<td>⊥</td>
<td>Coincidence</td>
</tr>
<tr>
<td>⊥</td>
<td>Verticality</td>
</tr>
<tr>
<td>⊥</td>
<td>Horizontality</td>
</tr>
<tr>
<td>⊥</td>
<td>Fix/Unfix</td>
</tr>
<tr>
<td>⊥</td>
<td>Parallel</td>
</tr>
<tr>
<td>⊥</td>
<td>Radius/Diameter</td>
</tr>
</tbody>
</table>
Before you Begin

Quick Dimensional Constraints

Definition Modification

Autodetection

Measure Direction

Auto-Constraining a Group

Modifying Constraints Between

Animating Constraints
Using Autodetection

This task shows you how Autodetection assists you as you create and edit elements. Autodetection lets you intuitively derive positions and directions from existing elements. Everything that Autodetection displays as an aid to creating geometry depends on the position of the cursor at a given moment and on the set of visible elements.

For example, when you are creating a line, you may want the line to be parallel to another line, or tangent to a circle.

1. Move the cursor around.

Autodetection highlights the different lines to which your line could be parallel, or the circles to which it could be tangent.

When detecting logical constraints, the Autodetection capability displays them in the form of graphic symbols illustrating the relationship between the element you are creating and another element.

SHIFT keyboard key allows deactivating autodetection.

CONTROL keyboard key allows locking the constraint currently created and to create others.

To know how to control the detection of logical constraints, refer to Customizing Autodetection.
Quickly Creating Dimensional Constraints

This task shows you how to set dimensional constraints between a line and a circle.

You may also define constraints using the Constraint Definition dialog box, the command, or by means of the contextual command (right-click).

1. Select the Constraint icon.
2. Select the circle first.

The circle diameter is computed.
3. Select the line.

The relation between the two elements is reconsidered. In other words, the diameter of the circle is no longer displayed.

The non-minimal distance between the two selected elements will be computed according to the point selected on the circle.

4. Use the contextual menu (Tangency) to set a tangency constraint between the line and the circle.

The circle and the line are now tangent.
5. Select the Constraint icon.

6. Select the line and click the Fix contextual command to prevent the line from moving.

The line is fixed and the anchor, that is the fix symbol, appears.

To unfix the line, you can use the Unfix contextual menu item.

You can also set dimensional constraints by multi-selecting the circle and line, and then clicking the Constraint icon. At any time, you may move the cursor: the distance value will vary accordingly. Click for positioning the newly created dimensional constraint.

SHIFT keyboard key allows deactivating autodetection.

CONTROL keyboard key allows locking the constraint currently created and to create others.
Defining Constraint Measure Direction

This task shows you how to define the measure direction as you create a dimensional constraint. For example, you will assign the horizontal measure direction to a constraint to be created between two circles.

Create two circles and create a constraint between them via the Constraint icon.

1. Right-click the displayed constraint and display the contextual menu.
2. Select the Horizontal Measure Direction.

The constraint is now positioned according to the horizontal direction.

Via the contextual menu, you can also create a radius/diameter constraint on half a profile that will then be used as a revolution profile. The constraint diameter will correspond to the shaft diameter.
The constraint measure direction may also be defined, and in other words modified, after the constraint was created. You will then simply select the constraint before displaying the contextual menu.
Creating Constraints via a Dialog Box

This task shows you how to set various geometric constraints using a dialog box. For example, you can use the Constraint command to finalize your profile and set constraints consecutively.

You may define several constraints simultaneously using the Constraint Definition dialog box, or by means of the contextual command (right-click).

1. Multiselect the lines to be constrained as indicated.

2. Click the Constraints Defined in Dialog Box icon.

The Constraint Definition dialog box appears indicating the types of constraints you can set between the selected lines. They may be constraints to be applied either on each element (Length, Fix, Horizontality, Verticality) or constraints between the two selected elements (Distance, Angle, Coincidence, Parallelism or Perpendicularity).

If constraints already exist, they are checked in the dialog box.

Multi-selection is available.

3. Check the Perpendicularity option to specify that you want the lines to always remain perpendicular whatever ulterior modifications.
4. Click OK.
   The perpendicularity symbol appears.

5. Now, select the bottom line and click the Constraints Defined in Dialog Box icon.
   The dialog box indicates you can set the line as a reference.
6. Check the Fix option and click OK.
   The anchor symbol appears indicating that the line is defined as a reference.

7. Select the corner on the left of the profile and click icon.
   The dialog box indicates you can choose the Radius/Diameter or Fix option.
8. Check the Radius/Diameter option and click OK.
   The radius value is displayed.

9. Multiselect both vertical lines and click icon.

10. Check the Distance option and click OK.
    The distance between both lines appears.

At any time after the constraint was created, you can modify the constraint measure direction and/or reference. See Defining Constraint Measure Direction for more details.
Modifying Constraint Definition

This task shows you how to edit constraints defined in the Sketcher or in the 3D area.

1. Double-click the sketch to be edited.
   You are now in the Sketcher.

2. Double-click the constraint you wish to edit. In our example, double-click the radius value, that is 35.
   You could also use the ConstraintDYS.object -> Definition... contextual menu item.
   The Constraint Edition dialog box is displayed.

3. Check the Measure option to change the constraint into a measure. The Radius field is deactivated, indicating that the value is now driven by modifications to the sketch.
   The radius value is displayed in brackets in the geometry area.

If you drag the corner, you can check that the radius value is updated.
4. Double-click the angle value, that is 110. In the dialog box that appears, enter 125 and click OK.

The new value is displayed in the geometry area. It affects the angle. The sketch shape is also modified due to the radius previously converted into a measure.

5. Now, double-click the offset value between the bottom construction line and the profile bottom line.

6. The Constraint Edition dialog box is displayed. Click the More button to access additional information.

7. Click Line5. Line 5 is highlighted in the geometry area.

8. Click Reconnect to redefine the offset constraint. You are going to choose a new reference.

You can reconnect constraints by means of elements such as planes, edges and so forth.

9. Select Line6, that is the other construction line in the geometry.

15. Click OK to apply the modification.

The offset value is unchanged. The position of the profile is modified.
10. Quit the Sketcher.
The application has integrated the modifications to the sketch. The value of the 3D measured constraint is updated.

11. Double-click the value of the offset constraint, that is 50.
The Constraint Edition dialog box is displayed.

12. Enter 30 mm in the Value field.

13. Click OK to edit the offset.

In the 3D area, if you select the blue pad, the Edit Parameters contextual command allows you to display all parameters and constraints defined for that pad.
Auto-Constraining a Group of Elements

The AutoConstraint command detects possible constraints between the selected elements and imposes these constraints once detected. This task shows you how to apply this command on a profile crossed by a vertical line.

1. Select the profile to be constrained.

2. Click the AutoConstraint icon.

The AutoConstraint dialog box is displayed. The Elements to be constrained field indicates all the elements detected by the application.

3. Click the Symmetry lines field and select the vertical line in the geometry area.

All the elements in the profile that are symmetrical to the Line will be detected.

The Reference Elements option allows you to select Once the profile is fully constrained, the application displays it in green.
4. Click OK to constrain the sketch including the profile and the vertical line.

The constraints created are:
- Angle (116.565)
- Radius (8)
- Length (28.2)
- Horizontality
- Tangency
- Concentricity
- Symmetry

The sketch is not displayed in green because it is not constrained in relation to external elements (edges, planes and so on).

You can switch between stacked and chained constraint presentation mode.
This task shows you how to edit geometric constraints defined in the Sketcher or in the 3D area.

1. Select the right vertical line and click the Constraint command.

The Constraint Definition dialog box appears.

2. Check Length and Verticality.

3. Click OK to apply the modification.

The line is vertical.

4. Select the left vertical line and click the Constraint command.

The Constraint Definition dialog box appears, indicating that a verticality constraint is already defined for the line.

5. Uncheck Verticality to remove the
verticality constraint.

The symbol for verticality is removed.

The profile now looks like this:
Animating Constraints

This task shows you how constrained sketched elements react when you decide to make one constraint vary. In other words, you will assign a set of values to the same angular constraint and examine how the whole system is affected. You will actually see the piston working.

1. Select the angular value, that is 75.

2. Click the Animate Constraints icon.

The Animate Constraint dialog box is displayed.

The First value and Last value fields let you define the maximum and minimum values for the constraint. For example, enter 0 deg and 360 deg respectively.
The Number of step field defines the number of values you wish to assign to the constraint between the first and last values.

3. Enter 15 as Number of step value.

4. Click the Run animation button to see how the sketch is affected by the different values assigned to the constraint. The edited sketch displays step by step.

The constrained value is set to 115 degrees. The line and the rectangle have been moved.

The constrained value is set to 246 degrees. The command induces a clockwise rotation while moving the rectangle up and down.

6. Check the Hide constraints box for hiding constraints. This can be useful when there are a lot of elements in the sketch.
7. Uncheck the Hide constraints option to display the constraints again. Once the maximum value is reached, that is 360 degrees, the sketch looks like this:

Now, let's have a closer look at the dialog box.

**ACTIONS:**
- **run back**: shows the different constraint values starting from the last value. In our scenario, we saw a counterclockwise rotation.
- **pause**: stops the animation on the current value
- **stops**: stops the animation and assigns the first value to the constraint
- **run**: starts the command using the option defined (see below)

**OPTIONS:**
- **one shot**: shows the animation only once
- **reverse**: shows the animation from the first to the last value, then from the last to the first value
- **loop**: shows the animation from the first to the last value, then from the last to the first and so on
- **repeat**: repeats the animation many times from the beginning to the end
Customizing

The different types of setting customization you can perform are:

<table>
<thead>
<tr>
<th>Tasks</th>
</tr>
</thead>
<tbody>
<tr>
<td>Constraints</td>
</tr>
<tr>
<td>Grid</td>
</tr>
<tr>
<td>Sketch Plane</td>
</tr>
<tr>
<td>Geometry Creation</td>
</tr>
<tr>
<td>Autodection</td>
</tr>
</tbody>
</table>
Workbench Description

This section contains the description of the workbench icons and menus. Many of these commands are discussed in greater details in other parts of the guide.
Sketcher Menu Bar

This section presents the main menu bar and commands dedicated to the Sketcher.

## Edit

For...  
See...

- Cut...  
- Copy  
- Paste  

Delete...  
Deleting Sketcher Elements

xxx.object  
Editing the Profile Shape and Size

**Insert**

For...  
See...

- Constraint...  
Setting Constraints  
- Profile...  
Sketching Profiles  
- Operation...  
Performing  
Operations on Profiles

**Tools**

For...  
See...
Sketcher Toolbars

The table below lists the information you will find in this section:

<table>
<thead>
<tr>
<th>Tasks</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tools</td>
</tr>
<tr>
<td>Sketcher</td>
</tr>
<tr>
<td>Constraints</td>
</tr>
<tr>
<td>Profiles</td>
</tr>
<tr>
<td>Operations</td>
</tr>
</tbody>
</table>

Up

Sketcher Menu Bar

Sketcher Toolbar
See Snap to Point
See Creating Standard or Construction Elements
See Setting Internal Constraints
See Creating Corners with both Elements Trimmed
See Creating Corners with One Element Trimmed
See Creating Corners with No Element Trimmed
See Creating Chamfers with Both Elements Trimmed

See Creating Chamfers with One Element Trimmed
See Creating Chamfers with No Element Trimmed
See Trimming Elements
See Creating Symmetrical Elements
See Closing Elements
See Breaking and Trimming Elements
Sketcher Toolbar

See Starting a Sketch

See creating a Pad from "Part Design" user's guide
Constraints Toolbar

See **Fully Sketching Profiles**  
See **Using the Autoconstraint Command**

See **Setting Dimensional Constraints**  
See **Animating Constraint**

[Constraints Toolbar]

[See Fully Sketching Profiles]
[See Using the Autoconstraint Command]

[See Setting Dimensional Constraints]
[See Animating Constraint]
Profiles Toolbar

See Profiles
See Rectangles
See Oriented Rectangles
See Parallelograms
See Oblong Profiles
See Oblong Arcs
See Keyhole
See Hexagons
See Basic Circles
See Three Point Circles
See Circles Using Coordinates
See Ellipses

See Parabola
See Hyperbola
See Basic Arcs
See Arc Arcs Three Point
See Arcs Three Point via Limits
See Splines
See Lines
See Axes
See Points
See Points Using Coordinates
See Equidistant Points
Operations Toolbar

See Corners with Both Elements Trimmed
See Corners with One Element Trimmed
See Corners with No Elements Trimmed
See Chamfers with Both Elements Trimmed
See Chamfers with One Element Trimmed
See Chamfers with No Elements Trimmed
See Trimming Elements
See Breaking and Trimming
See Breaking Elements
See Symmetrical Elements
See Translate Elements
See Rotate Elements
See Scale Elements
See Offsetting Elements
See Projecting 3D Elements onto the Sketch Plane
See Intersecting 3D Elements with the Sketch Plane
Glossary

A

autoconstraint  A constraint applied to an iso-element (a group of elements).
autodetection  An assistant for creating constraints between elements using the Sketcher.

C

consecutive element  An element that does not intersect with another element.
constraint  A geometric or dimension relation either on one element or between two or three elements.
construction element  A construction element is an element that is internal to, and only visualized by, the sketch. This point is used as positioning reference. It is not used for creating solid primitives.
control point  A control point is a point which a spline (tangent) passes through.
chamfer  A cut through the thickness of the feature of an angle.

D

driving constraint  A constraint that drives the behaviour of the corresponding geometry.

I

isocenter  A center of gravity created between previously selected elements.

O

offset  A distance at which a duplicated line type element or curve type element can be positioned.

P

profile  An open or closed shape including arcs and lines created by the profile command in the Sketcher workbench.
rotation
An operation for moving elements via duplication.

scaling
An operation that resizes features to a percentage of their initial sizes.

sketch
A set of geometric elements created in the Sketcher workbench. For instance, a sketch may include a profile, construction lines and points.

standard element
Any type of element.

symmetry
An operation for repeating elements.

translation
An operation for moving elements or creating several copies of two-dimensional elements.

trace
A result from the intersection between an element and sketch face.

use edge
A 2D trace resulting from a 3D projection or intersection.
Index

A

anchor ➤
Arc command ➤
Arc through three points command ➤
arcs ➤ , ➤
Animate constraint command ➤
Autoconstraint command ➤
autodetection
detecting directions ➤
settings ➤
Axis command ➤

B

Break command ➤

C

centers ➤
Chamfer with both elements trimmed command ➤
Chamfer with no trimmed element command ➤
Circle through three points command ➤
coincidence ➤
colors
customizing ➤
setting ➤
yellow ➤ , ➤
commands
Animate constraint ➤
Autoconstraint ➤
Axis ➤
Break
Chamfer with both elements trimmed
Chamfer with no trimmed element
Chamfer with one trimmed element
Circle
Circle through three points
Circle with center point coordinates
Constraint
Constraint with dialog box
Construction element
Corner with no trimmed element
Corner with only one line trimmed
Cut part by sketch plane

Ellipse
Equidistant point
Fix
Geometric constraint
Hexagon
Intersect 3D Elements
Isolate
Keyhole
Line
Oblong arc
Oblong profile
Oriented rectangle
Parallelogram
Point by clicking
Point specifying coordinates
Profile
Project 3D Elements
Quick trim
Rectangle
Symmetry
Unfix

concentricity
Constraint command ➤
constraints ➤ , ➤
Construction element command ➤
construction elements ➤
Corner with both trimmed elements command ➤
corners ➤ , ➤ , ➤
creating
  arcs ➤
  axes ➤
  chamfers ➤ ,
  circles ➤
construction elements ➤ , ➤
corners ➤
ellipses ➤
oriented rectangles ➤
parallelograms ➤
points ➤ , ➤
profiles containing arcs ➤
rectangles ➤
symmetrical elements ➤
customizing
  constraints ➤
grid ➤
sketch plane ➤
Sketcher settings ➤
Cut part by sketch plane command ➤

deleting
  profiles ➤
dimensional constraints ➤
dimensions ➤ , ➤
E

editing
    profiles
Ellipse command
ellipses
equidistant point
Equidistant point command

F

Fix command

G

geometrical constraints
grid

H

hexagon
Hexagon command

I

Intersect 3D Elements command

K

Keyhole command

L

Line command
lines
menu bar
  Sketcher
  midpoints

Oblong arc
Oblong profile
Oriented rectangle command

Profile command
Project 3D Elements command

Rectangle command
rectangles

sketch plane
Sketcher
elements
settings
standard elements
starting a sketch
toolbar
Sketcher

Unfix command
updating
sketches

workbench

yellow