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Preface

The Extended Enterprise can at last become reality! The V4 Integration product
includes unique two-way interoperability between CATIA Version 5 and CATIA Version
4 data. This means that:

L

V4 designs can be accessed, exchanged and processed thus ensuring
continuity and protecting V4 customer investment while taking advantage of
Version 5's full functionality.

Using an integration tool called the CATIA Site Navigator in CATIA Version 5,
CATIA Version 4 data can be read and, if actual editing is required inside CATIA
Version 5 application workbenches, this data can also be converted into V5
format. This can be done either in the Windows or UNIX environment.

CATIA Version 5 data can be loaded and processed in a CATIA Version 4
session enabling V5 data to benefit from the breadth of the CATIA Solutions
Version 4 portfolio.

As CATIA Version 5 comprises an integrated package including interoperability
between CATIA Version 4 data and the application portfolio V4/V5 interaction can take
many forms:

L

L

L

a Version 5 design using Version 4 data (see Copying CATIA Version 4 Model
Data to CATIA Version 5)

a V5 drawing using V4 data (see Converting CATIA Version 4 Drawing Data into
CATIA Version 5 Data)

a V5 assembly combining both V4 and V5 data (see Inserting Existing
Components in the CATIA - Assembly User's Guide).

As an open solution, it includes interfaces with the most commonly used data
exchange industry standards.

igﬁaging Y4 Modelz, PRJFi iLEere to Find More Informst
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Managing CATIA Version 4 Models,
PROJECT Files and Library Objects
In CATIA Version 5

To ensure CATIA Version 4->CATIA Version 5 interoperability, CATIA Version 5
provides the CATIA Site Navigator allowing you to read, in a CATIA Version 5
session, CATIA Version 4 models on both Windows NT and UNIX and both PROJECT
files and library objects on UNIX. Any geometric element (whether the model involved
has an internalized PROJECT file or is linked to an external PROJECT file) can be
read and copied to a CATIA Version 5 document.

In a CATIA Version 5 session, CATIA Version 4 models can be displayed on both NT
and UNIX and library objects can be displayed on UNIX. Basic read-only operations
can then be performed, such as:

@ displaying and selecting geometric elements and workspaces, in the geometry
area and/or the specification tree (except for the HLR mode)

displaying graphic properties (color, show/hide, layers, filters, pick/nopick)
zooming, rotating and panning

printing (except for the HLR mode)

applying, creating, deleting, and modifying layer filters

verifying the geometry (and, in the case of exact solids, the specifications) of
one or more Version 4 elements prior to copy-pasting it into a CATIA Version 5
workbench.

OO OE

In CATIA Version 5, you cannot edit CATIA Version 4 models or library objects but
you can paste all or part of a model or library object into a CATIA Version 5 document
and then edit it. Once this has been done, it is of course no longer a Version 4 model,
but a CATIA Version 5 document.

E p ?anaging Y4 Modelz, PRJ Fi ikﬁere to Find More Informsat



Where to Find More Information

Prior to reading this book, we recommend that you read the CATIA - Infrastructure
User's Guide.
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What's New?

Enhanced: Connecting an ORACLE or DB2 Database to Your CATIA Version 5 Environment (on UNIX
Onl

New: Preparing the VPM and CATIA Environments for the Use of VPM Data in CATIA Version 5
New: Creating and Saving a CATIA Version 5 Product for Save or Commitment in VPM1.1

Enhanced: Selecting Geometric Elements on CATIA Version 4 Models
Enhanced: Copying CATIA Version 4 Drawing Data to CATIA Version 5

New: Saving CATIA Version 5 CATPart Documents As CATIA Version 4 Models
New: Converting CATIA Version 4 Libraries into CATIA Version 5 Catalogs




Getting Started

F@”_ This task shows you how to open a CATIA Version 4 model in CATIA Version 5.
=,

® , This task should take approximately 1 minute.

Open the document \Online\Samples\V4Integration\xwings.model.

2

1. Click the Open icon @ or select the File->Open command.

‘H

2. In the File Selection Box, select the file location.

3. Select the model.

(Where there are many different types of files, it may be useful to click the Files of type list and specify model
as the document type.)

The following document will appear:

XW'INES.mudEI | |O] =]
MASTER | "DRAFT | HEAD | L&ZER | COOLER | E.COOUNG | BODY | WING | ENGINE [HIGH ENGI ||

"MASTER

For other ways of opening existing Version 4 models, see "Opening Existing Documents" and "Opening Most
Recently Used Documents"” in the CATIA - Infrastructure User's Guide.
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Basic Tasks

Theme Purpose
Manipulating CATIA Version 4 Models in  Perform basic operations on CATIA Version
CATIA Version 5 4 models in CATIA Version 5

Copy CATIA Version 4 models to CATIA

Copying CATIA Version 4 Models to _ :
Version 5 and perform associated

CATIA Version 5

operations
Manipulating CATIA Version 5 Data in Specify requirements for the use of CATIA
CATIA Version 4 Version 5 data in CATIA Version 4

Using CATIA Version 4 Library Objects  Perform basic operations on CATIA Version
(on UNIX Only) 4 library objects




Manipulating CATIA Version 4
Models in CATIA Version 5

Purpose
Opening CATIA Version 4 Models in CATIA Open CATIA Version 4 models in CATIA
Version 5 Version 5
Selecting Geometric Elements on CATIA  Display and select Version 4 model
Version 4 Models workspaces and their geometric elements
Managing Layer Filters on CATIA Version 4 Create, apply, modify and delete layer
Models filters on Version 4 models
Enabling Read Only Access to CATIA Provide CATIA Version 5 with information

it requires to locate and process Version 4
data adequately

Opening CATIA Version 4 Models Open a CATIA Version 4 model
Referencing an External PROJECT File referencing an external PROJECT file

Displaying Faces and Surfaces Visible in  Display all faces and surfaces that were
Shading Mode in CATIA Version 4 visible in CATIA Version 4

Version 4 Data in CATIA Version 5

E (]4] anipulating 4 Models in % giying W Modelz to V5
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Opening CATIA Version 4 Models in CATIA Version 5

"@" This task shows you how to open a CATIA Version 4 model in CATIA Version 5.
=

el
e . . . .
"7 You should have already completed the task Enabling Read Only Access to CATIA Version 4 Data in CATIA Version 5.

Open the document \Online\Samples\V4Integration\XWINGS.model.

% 1. Click the Open icon % or select the File->Open command.
2. In the File Selection Box, select the file location.

3. Select the model.

(Where there are many different types of files, it may be useful to click the Files of type list and specify model as the document type.)

A document like this will appear:



§|CATI F
Stat  Fl=  Edl  Yew Inaef Jook  Windom  Filier Hel

WM IES  model

CATIA P2

Select an chjact I ﬁll




If, in CATIA Version 4, you defined specific views for a model by means of IMAGE/WINDOW+DEFINE, you can still use these views by clicking the
View->Defined Views... command.

For other ways of opening existing CATIA Version 4 models, see "Opening Existing Documents" and "Opening Most Recently Used Documents" in the CATIA
- Infrastructure User's Guide.

V4 models residing on UNIX can be accessed from Windows using the http protocol. (Make sure beforehand that an http server has been installed on the

machine where the models reside.)
The address to be specified should look something like this:
http://UNIXserver: port/VAmodellocation

#7/
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Selecting Geometric Elements on CATIA Version 4
Models

This task shows you how to display a CATIA Version 4 model workspace and select its geometric elements in
CATIA Version 5.

Open the document \Online\Samples\V4Integration\XWINGS.model.

1. Above the geometry area where the Version 4 model is displayed, click the workspace tab you wish to

display (the FUSELAGE workspace in the model shown below, for example), The tab selected then "rises
relative to the other tabs.

EWINES.mudEI | _ O] x|
E.COOLING | BODY | WING | ENGINE | HIGHENGINE | LOWENGINE | sRID | cockPT | o)
FUSELAGE

2. If you then wish to select a geometric element,
expand the specification tree by clicking on the
FUSELAGE item and then on one of the items with a

plus sign, *SET5, for example. The specification tree
will then look like this:



FUSELAGE
—"4X56

L SvM
§—"SETE
LN
CRY
SUR
soL
DIT
§-"GPARZ
—*ANAI2

—"TEx54

A set is made up of subsets each containing lines, curves, surfaces, solids, dittos, etc. In the specification tree
shown above these are easily identifiable (LN, CRV, SUR, etc.). A subset can be selected just like any other
item for copy/paste, show/no-show operations, etc.

However, you can of course select one or more of the lines, curves, solids, etc. contained in the subsets.

3. Click on the plus sign of the DIT subset and select the contents, *DIT13. Notice that the corresponding part
of the model in the geometry area is highlighted as shown below.

PR XWINGS. mode! (= E3
WING | ENGINE | HIGHENGINE | LOWENGINE | FUSELAGE | GRID | COCXPIT | wzoR | =wiNGs | 4]

FUSELAGE
=45 Sh
=M
=="SETS
LM
CRW
& SUR
L "SURT
& SO|
*50L13

*S0LT4

& 0T
Lo
F—"GPARZ

— AN AIZ

L TEXS4

e

You can of course select an element by clicking on it in the geometry area.

4. Click on the central part of the fuselage (not on the blue component shown above). The corresponding
solid is highlighted in the specification tree:



: 1':4?H'|NE'5.||MHI|:-|

WING | ENGINE | HIGHENGINE | LOWENGINE | FUSELAGE | GRID | COCKRIT | vizom | sowmGs | «fr)

FUSELAGE

—"AXSh

— =M

S—"SETE

LM

CRW

SUR

L"‘SUFI'I

& SOL

SO

*SOL14

& DIT
*TIT1E

#="GRARZ

—“ANAIZ

—"TEXS4

L

As you can see above, in the specification tree, double-clicking boxes with a plus sign shows the component
elements of that particular workspace or set. Clicking the minus sign hides the elements contained in the

workspace or set.
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Managing Layer Filters on CATIA Version 4 Models

I'@' This task shows you how to apply, create, modify and delete layer filters on a CATIA Version 4 model.

=1

§T’ Open the document \Online\Samples\V4integration\LAYER_FILTER.model.

m 1. Open the model.

iy
M= E

% |LATER_FILTER_model [ReadDnly)

"MASTER | -DRAFT |
2. To apply, create, modify or delete an existing filter that was defined in Version 4, select the Filter->Layer
Filter... command. The Layer Filter dialog box appears.

"MASTER [

L

A

Lawper Filler " HE

—Awvailable Fikars ————————— — Vigible Lapatg ————————— Cimsis I

| ORI [~ ~vERS Wity

| e bl
[Jel=l= I

||ALL E=CEPT LAYER 2

@ ot | @ b | ﬂt-:md]

.

The first two filters in the Available Filters list are always ALL and LAYCUR (current layer).



3. To apply an existing filter, select the filter ALL EXCEPT LAYER 2 in the Available Filters list. and click the OK
or Apply button.

Lagper Filler BHE
—Awailable Fikars ————————Visible Layots ————————| e i

|[&C Laper =TT
LevTLIR Lap=i 1 :J Lo

Lapar 3 JEiR]e |

Lapar 4

Lapara

Lapsi &

Lapar 7

Laperd

Lapsr 9

Lap=i 10

Lapar 1

Laper 12 _T.J

@ 0t | & sk | @ Cancel|

-

In the Layer Filter dialog box, click the Apply button if you have other operations to perform. If not, click the OK
button.

The model then looks like this:

[%|LAYER_FILTER.model [ReadDnly) - (O] =]
"MASTER | -DReFT |

"MASTER

A

4. To create a new filter, select, in the Layer Filter dialog box, the Create button. The Create Filter dialog box
appears.



Creata Filtar HE

Hame
[Fiter 1
Wisible Layez
L e Al
Layer 0 EI Hone
Layer 1
Layer 2
Layer 3
Lauver 4
Layer &
Layer &

Layer 7 it =l

& 0k | & Cancel]

5. In the Create Filter dialog box, select one or more of the layers in the list displayed. If you want to give the
new filter a name you can enter it in the Name field. Click the OK button.

Creata Filtar HE

Hame
[rFILTER

Wisible Layes

@ ok | & Cancel]

6. The filter created is added to the Available Filters list in the Layer Filter dialog box.

Lawer Filler HE
—Aalable Fikars —————————VisibleLapas ———————  maaia |
AL Laperd '
L CUR Lap=i 4 | Mu
ALL ECEPT LAYER 2 Lap=i B | Dekle |
|
[
i

@ or | @ sppk | @ Cancel |

7. In the Layer Filter dialog box, click the Apply button if you have other operations to perform. If not, click
the OK button.

8. To modify a filter, select, in the Layer Filter dialog box, a filter that you have created. Click the Modify
button. The Modify Filter dialog box appears.




Creata Filtar HE

Hame

[ FILTER

Wisible Loz

@ 0k | & cancd

9. Make the changes. You may wish to change the name of the filter(s) and/or modify filter selection. Click
the OK button.

Creata Filtar HE

Hame

HERFILTER
Wisible Layes

b
@ 0k | & cancd]

10. The filter modified is added to the Available Filters list in the Layer Filter dialog box.

Lawer Filler BE
— Avallable Fikars —— —Visible Layeny ——————— o |
AL L Lapar [
LevCUA * Laper 10 Moy |
ALL EXCEPT LAYER 2 Lap=r 11 [| Dekt= I
‘HEHFILTER Lapar 12 |
Laper 13

@ 0k | @ fpok | @ Cancel |

11. In the Layer Filter dialog box, click the Apply button if you have other operations to perform. If not, click
the OK button.

.~ Bear in mind that you cannot modify filters defined in CATIA Version 4 (the Modify button is grayed out). Only
§ those filters defined in CATIA Version 5 using the Create button can be modified.

12. To delete a filter, select one or more filters in the Layer Filter dialog box.

13. Click the Delete button.



14. In the Layer Filter dialog box, click the Apply button if you have other operations to perform. If not, click
the OK button.

. Bear in mind that you cannot delete filters defined in CATIA Version 4 (the Delete button is grayed out). Only
1 those filters defined in CATIA Version 5 using the Create button can be deleted.

#%
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Enabling Read Only Access to CATIA Version 4 Data in
CATIA Version 5

r@* This task shows you what preparatory steps to perform to ensure access to CATIA Version 4 data i.e. a model or library object in a
== CATIA Version 5 session.

If a Version 4 user, you will remember that the declaration parameter catsite. DEFAULT_DS_CODE_PAGE declares the language to
identify the data read if this data is not labeled (i.e. if it is just labeled EBCDIC or ASCII, and not labeled with a standard code page such
as 1SO8859-x, IBM-392, EUC-KR, EUC-CN, and so forth).

In Version 4, information such as the language used to identify unlabeled readable data was specified by means of the parameter
settings in the declaration files. These declaration parameters are no longer supported in CATIA Version 5 and there is no way to
transfer them automatically to CATIA Version 5. Such information must be provided by means of the dialog boxes described below,
before attempting to read Version 4 data.

E 1. Select the Tools->Options... command. The Options dialog box appears with the General category selected in the left-hand
ittty column.
2. Click the Compatibility tab.

I phnns
o Loz | ClenchS -t wzs I:-:-u-q:u:tl:llrz.-h L1 Tzlzrarcc | Wiz_aizalizh |=-:'I-:|'m'; 4k
iZ2rweral Cunreeaaun
el [ ey =l=rerks by Hie 1apags o leneeres somues -
i D lzialivrr:

“aflie FROLECT Fike Pzth [

ar CEFALLT_DS_CODE_Fass [0 Eeden |- Tick here for
list of languages
tdentifyring

unlabeled data



For Version 4 data that is not labeled with a standard code page (for example, ASCII-DS-xxx or EBCDIC-DS-xxx) other than US English,
you must specify the appropriate language from the list provided.

3. To do this, click on the DS_DEFAULT_CODE_PAGE list in the V4 LIS_English |

Declarations part of the dialog box and select the appropriate language. Frerch
Chineze
German
[talian
Japanesze
K.orean

1K, Englizh
15 English

4. Click OK to confirm.

#3%/
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Opening CATIA Version 4 Models Referencing an
External PROJECT File

r@" This task shows you how to display a Version 4 model referencing an external PROJECT file.

=1

If a Version 4 user, you will remember that certain model data must be contained in a PROJECT file which
can either be internal to the model or external. If it is external, the only way to access such data is to provide
Version 5 with precise information about the PROJECT file's whereabouts.

E 1. Select the Tools->Options... command. The Options dialog box appears with the General category
ety selected in the left-hand column.

2. Click the Compatibility tab.

Options EHE
General ;I General I l&utomation! | Compatibility | Deneh Compatibility | Knowledge I LiCEhSingﬁ 4| b
— Corversioh
Product

[ Digplay elements with the Dizplay Mode Sensitive attribute off

Process — W4 Declarations
PROJECT File Path |

Drafting DEFAULT_DS_CODE_PAGE [0S _Engish -]
Meshing WRITING_CODE_PAGE ||503359-1 v[
Part

3. Enter, in the field indicated above, the location and name of the PROJECT file referenced by the V4
model you wish to display.

Make sure you complete this field before displaying a Version 4 model.

&If you do not specify the PROJECT file path before opening the model, a warning message will appear.

You can display such models on Windows or on UNIX.
However, the external PROJECT file referenced by the model can only be on UNIX. Also, you must
first make sure an http server has been installed on the machine where the PROJECT file resides.

@ On Windows, the address to be specified should look something like this:
http://UNIXserver: port/PRJlocation

@ On UNIX, just specify the path, for example:
/ulusers/username/PRJname

The following reference tables in the PROJECT files can now be accessed in CATIA Version 5:

@ attribute and class tables
@ annotations/dimensions.



There are no restrictions as regards the PROJECT file's code page. However, you must make sure that the
u—'code pages of the model and the PROJECT file are compatible.

#7/

g I ﬁening Wi Modelz in V'S igic’cing Zeometric Element
ifﬁaging Lavyer Filters on % iEbling Read Only Access igilaying All Faces and Su

%ﬂ_ening W hodels with an




Displaying Faces and Surfaces Visible in Shading Mode in
CATIA Version 4

(@ This task shows you how to display all faces and surfaces that were visible in CATIA Version 4.

=,
If a Version 4 user, you will remember that the display attribute CURRENT DISPLAY MODE SENSITIVE enables you to decide
whether to display the hidden parts or not.

In Version 5, by default, only faces and surfaces that were in Shading mode in Version 4 are shown in models displayed by means
of the CATIA Site Navigator. To display all faces and surfaces, you must therefore disable the CURRENT DISPLAY MODE
SENSITIVE attribute.

E 1. Select the Tools->Options... command. The Options dialog box appears with the General category selected in the left-hand
et column.

2. Click the Compatibility tab.

=l Germal | Licersing | Symbols I Dienebis eltng: | Compatibiiy | Unite | Toleance| i
General Corvearsnn i
Broduct T2y clermarks vl the Dieplay Mods Senshive alnbats of Check thishox
Wi Diaclarshons ]
Drafiing FROJECT Fie Path | :
DEFAULT D5 _CODE_PAGE WS _Erglish =
Part ik 22 Jus £ng =i

3. Check the box indicated by the arrow above.

You can now visualize in Version 5 all Version 4 faces and surfaces, even those that were not in Shading mode.

#3
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Copying CATIA Version 4 Models to
CATIA Version 5

Task

About Copying CATIA Version 4 Models to

CATIA Version 5

Checking CATIA Version 4 Model Data
Before Copying It to CATIA Version 5

Copying CATIA Version 4 Model Data to

CATIA Version 5

Copying CATIA Version 4 Drawing Data to

CATIA Version 5

Interoperability with V4 Textures

Converting CATIA Version 4 Kinematic Data

into DMU Kinematic Version 5 Data

Purpose

Provide hints and tips in the event of
difficulty copying CATIA V4 models into
CATIA Version 5

Check CATIA Version 4 model data
before copying it to CATIA Version 5

Copy CATIA Version 4 model
specifications and geometry to CATIA
Version 5

Copy CATIA Version 4 drawing data to
CATIA Version 5

Apply a CATIA Version 4 2D texture to a
CATIA Version 5 material

Apply a CATIA Version 4 2D texture to a
CATIA Version 5 material

igﬁlpulmlng Y4 Models in Y u:upwng W4 Models to WS
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About Copying CATIA Version 4 Models to CATIA
Version 5

If you encounter any difficulty copying CATIA V4 models to CATIA Version 5, there are a certain number of
precautions you should take prior to the copy operation.

Precautions to be taken in CATIA Version 4 prior to the copy operation
@ If the model to be copied is an exact solid it must be processed using the Force Update option in the Smart
Solid mode. This operation must be done on CATIA 418 or higher.
@ |Itis also advisable to run the CATCLN utility on the model to be copied. Again, this operation must be done on
CATIA 418 or higher.
@ Remember to run the specification check on all the V4 models you wish to copy to CATIA Version 5 as it
provides you with the following invaluable information:

@ identification of the primitives which are converted to datums, indicating loss of canonical information
(see the Restrictions section below for the complete list).
This is shown in the Message column of the Check Validity dialog box, for example:
2 primitives checked as geometry only

@ identification of the operations which are not supported in V5R2 and MUST BE DELETED before
proceeding with the copy operation (see the Restrictions section below for the complete list).
This is shown in the Message column of the Check Validity dialog box, for example:
2 operations not implemented

@ identification of the non-supported primitives (see the Restrictions section below for the complete list).

For more detailed information, you only have to double-click on the appropriate message in the rightmost
column of the Check Validity dialog box. This displays the contents of the model in the form of a specification
tree (see Checking CATIA Version 4 Model Data Before Copying It to CATIA Version 5).

@ |If, in CATIA Version 5, you intend to make only cosmetic changes to a Version 4 solid with no impact on the
specification tree you can simply copy the solid's geometry. However, if your modifications are major and will
considerably alter the specification tree you would be better advised to copy the solid's specifications (see
Copying CATIA Version 4 Model Data to CATIA Version 5).

@ Make sure that the update option selected in the General tab of the Options dialog box (displayed using the
Tools->Options command) is NOT set to Automatic.

@ When updating, make sure that you select the Inactivate option in the Update Diagnosis dialog box to
deactivate any troublesome operations or primitives in CATIA Version 4. Do NOT delete them as such data,
although not copied, can, once the rest of the model has been successfully copied, be recreated in CATIA
Version 5 in a more satisfactory way. In a future version of CATIA Version 5, this requirement will no longer

apply.

Restrictions
As mentioned above, certain restrictions apply when copying models from CATIA Version 4 to CATIA Version 5:

The primitives converted to datums are:

@ pyramids
@ sweep spines, sweeps with a non-close profiles, until a sweep
@ import primitives (linked to a solid in another model).

The non-supported operations are:

@ certain draft types, for example, keep edges with more than two neutrals
@ certain fillet types, for example, rolling edges.

The non-supported primitives are:

@ macroprimitive multibodies
@ non-isometric transformations.

The elements copied as geometry only i.e. not as history are:
@ all elements (including SKD) with the exception of exact and mockup solids.



#7
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Checking CATIA Version 4 Model Data
Before Copying It to CATIA Version 5

& This task shows you how to check CATIA Version 4 model data before copying it to CATIA
==, Version 5.

<P

«=%<-0Open the document \Online\Samples\V4Integration\CheckGeometry Specifications.model.

Before checking either the geometry or specifications of Version 4 data, you should understand
the distinction between the two:

The geometry is just the three-dimensional representation of the elements contained in the
data. An example would be the set of faces that make up a solid. It is roughly equivalent to the
Brep representation used in CATIA Version 4.

The specifications are made up of the entire history of the actions performed to obtain the
data. They are shown in the form of a tree and are roughly equivalent to the CSG tree used in
CATIA Version 4.

Note that a specification check is only meaningful when applied to exact and mockup solids.

E 1. Select one or more geometrical elements in the geometry area.

“icons in the Version 4

This activates the Check Geometry ===
model toolbar.



2. In the Check Valadity

Version 4 -

Idiemtifiar _Foamat bt Meszzage |
model toolbar, ¥ 50LZ355 Cpacificalior: 4 operations pal implerentzd
click the Check 0 prmvitrves checked as geamety cnb

Specifications
or Check
Geometry icon.
The Check
Validity dialog
box opposite o D Ok
appears:

; In the Check Validity dialog box there are four columns:

@

L

the first column showing the overall result, color-coded as follows:

@ G (green): will be copied as is to CATIA Version 5
@ R (red): will NOT be copied to CATIA Version 5 as is
@ Y (yellow): will NOT be copied to CATIA Version 5 as is because of a link to a
red-coded item.
the Version 4 identifier
the format i.e. Specifications
the Message column providing the number and type of problems.

3. To view the results of a specification check, double-click on the contents of any of the
columns in the Check Validity dialog box.The tree structures of some models are very
large. Use the scrollbars to locate any red elements. There are several in the model
shown below. Here is just one example

:ll ]
=
s | 4
- o]
4. Right-click
the red
element to find EPIPE]20)
out exactly Mat a smart zolid
what the

problem is.



t Clicking on the background and not on an element displays a menu containing two options:
@ Reframe graph, which centers the tree structure
@ Print whole, which prints it (for details, see "Printing Documents" in the CATIA -

Infrastructure User's Guide).

#7/
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Copying CATIA Version 4 Model Data

to CATIA Version 5

@ This task shows you how to copy the specifications or geometry of a CATIA Version
==, 4 model to CATIA Version 5.

&

=r

The following data can be copied from CATIA Version 4 to CATIA Version 5:

oGO COCOCOOOTOOOCOOCOESE

surfaces (both polynomial and BSpline)
faces

volumes

skins and exact solids

mockup solids (see remarks regarding copy/pasting mockup solids below)
polyhedral surfaces and solids

circles

ellipses

points

lines

planes

clouds of points

edges

parabolas

hyperbolas

curves (both polynomial and BSpline)
CCVs

NURBs (curves and surfaces).

The following task describes how an entire model is pasted from Version 4 to
Version 5. You can also select the geometric elements listed above and insert them
into an already existing Version 5 document.

Open the document \Online\Samples\V4Integration\LAMP.model.

“**" You should have already completed the tasks Enabling Read Only Access to CATIA

Version 4 Data in CATIA Version 5 and Checking CATIA Version 4 Model Data

Before Copying It to CATIA Version 5.




1. Open a new CATIA Version 5 CATPart document. To do this, refer if
necessary to "Creating New Documents" in the CATIA - Infrastructure User's

Guide.

2. In the specification tree or geometry area where the Version 4 model is
displayed, select the geometrical element or elements you wish to convert.

3. If you intend to copy the geometry you can either:

@ drag and drop the element(s) onto the appropriate location in the CATIA
Version 5 document.

The cursor changes slightly i.e. the symbol appears indicating where a

Y

drop is allowed. If the cursor changes to the symbol , the drop is not
allowed in that location.
@ or

a. Put the element(s) you have selected in the clipboard by clicking the Copy

NEE . .
icon , select the Edit->Copy command or select the Copy command in
the contextual menu.

b. In the specification tree of the CATIA Version 5 document, select the
appropriate item (for example, PartBody or Body.1, Body.2, etc. in the
PartDesign workbench).

c. Click the Paste icon [% or select the Edit->Paste command or select the
Paste command in the contextual menu.

This operation recovers the specifications previously put in the clipboard.


file:///E|/users/jmy/jmydocr3/BasEnglish/basug.doc/src/basugbt0403.htm

4. If you intend to copy the specifications:

a. Put the element(s) you have selected in the clipboard by clicking the Copy

N _ _ _
icon , selecting the Edit->Copy command or selecting the Copy command
in the contextual menu.

b. In the specification tree of the CATIA Version 5 document, select the
appropriate item (for example, PartBody or Body.1, Body.2, etc. in the
PartDesign workbench).

c. Select the Edit->Paste Special... command or select the Paste Special...
command in the contextual menu.

The dialog box opposite appears.
Select CATIA_SPEC and click OK.

. . Source Definition
This operation recovers the K E
specifications previously put in the Saurce Unknown
clipboard. @ Pazte ||:&T|ﬂ« RESLILT
() Paste with link

@ 0K | & Cancel|

5. Click the Update icon @ to view the copied data.

6. You may want to click the Fit All In icon EEI to fit all data in the window.

Notice that the toolbars change depending on whether a CATIA Version 4 model or
a CATIA Version 5 document is selected.

If you copied the geometry the result should look something like this:



et e [0 ges et Jek e Heb

‘YR LMEEY R Ee R

% 1
Al P

L

NFPLDL @D MBR S BAREEAGAIAEE SO @ fgarLen

ool it

If you copied the specifications the result should look something like this:
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['_Bear in mind the following when copy/pasting mockup solids:

@ If the solid has a history then the V5 specifications are created.

@ However, if the solid has no history or if the CATIA_RESULT option is
selected(using the Paste Special... command) then a cqgr file is generated
containing the visualization information of the solid. The name of this file is

"mymodel _SOLMxxx" and is located in the same directory as the V4 CATIA

model. This file can be visualized separately or inserted into the Product

Structure application.
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Copying CATIA Version 4 Drawing Data
to CATIA Version 5

'}@” This task shows you how to convert the data of a CATIA Version 4 drawing into CATIA Version 5.

Open the document \Online\Samples\V4Integration\Draftinginterop.model.

@ The following data can be copied from CATIA Version 4 to CATIA Version 5:

@ circles

n\‘aw @ dittos, symbols (exploded in V5 geometry)

@ ellipses
@ points
@ lines

@ parabolas
@ hyperbolas
@ curves

n:é'_‘ﬁw @ AUXVIEW?2 views as result i.e. as geometry only with no associativity with 3D

@ texts and dimensions.

The text and dimension types supported by V5R3 are converted into V5 geometry.
Those types not supported by V5R3 appear as broken
i.e. non-associative dimensions.

= You cannot directly migrate V3 texts and dimensions into V5. They must first be migrated
to V4.

The following task shows how drafting data is pasted from an existing Version 4 model
to a new Version 5 document. You can of course also insert the V4 data into an
existing Version 5 document alongside V5 drafting data.

E 1. Open the model.

2. Open a CATDrawing document.

3. In the specification tree or geometry area where the Version 4 drawing
is displayed, select the view you wish to copy into CATIA Version 5.
You can select several views if you prefer.



4. Put the view(s) you have selected in the clipboard. To do this, either click

the Copy icon , select the Edit->Copy command or select the Copy
command in the contextual menu.

5. In the specification tree of the CATIA Version 5 CATDrawing document,
select the appropriate sheet.

6. Now either click the Paste icon % , select the Edit->Paste
command or select the Paste command in the contextual menu.
This operation recovers the view previously put in the clipboard.

7. You may want to click the Fit All In icon @ to fit all data in the window.

Notice that the toolbars change depending on whether a CATIA Version 4 model
or a CATIA Version 5 document is selected.

The result should look something like this:
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(= When copying V4 drawing data to V5, bear the following in mind:

@ Whatever the standard of the V4 view was prior to being copied into
CATIA Version 5, once in V5 its standard is that selected when you
open the CATDrawing document.

@ The smallest unit that you can copy is the view. All the elements that go
to make up this view are included in the copy

@ In the V5 Drafting mode Working Views (Edit->Working Views) the copy
described above creates a V5 view with the same name as in V4.
In the V5 Drafting mode Background (Edit->Background) the V4 elements
are copied into the background view of the V4 view.

#3%
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Manipulating CATIA Version 5 Data in
CATIA Version 4

Task

Purpose
About Manipulating CATIA Version 5 Data Specify requirements for the manipulation
in CATIA Version 4 of CATIA V5 data in CATIA Version 4

Saving CATIA Version 5 CATPart Save CATIA Version 5 CATPart documents
Documents As CATIA Version 4 Models as CATIA Version 4 models

E g iﬁipulaﬁng Y4 Models in Y Eiying W4 Models to WS
anipulating %5 Data in V4 igig "4 Libraries (on LM



About Manipulating CATIA Version 5

2
5

=

Data in CATIA Version 4

In order to read and use CATIA Version 5 CATPart documents in CATIA Version
4, the following steps must be carried out:

1. First of all, CATIA Version 4 Release 3.1 must be installed on a UNIX
machine.

2. You must then install a CATIA V5R3 configuration which includes the V4
Integration product (V4l),

for example the MD2 configuration (Mechanical Design 2) and set up the
appropriate licenses.

3. In order to be able to access the CATIA Version 5 software from a
CATIA Version 4 session you must

add to the USRENV.dcls file, both in the user and administrator
environments, the following:

CATIA.ENVTVS : STRING;

CATIA.ENVTV5 = '$HOME/CATENV/CATIA.V5R3.B03.sh’;
CATIA.MACHVS5 : STRING;

CATIA.MACHV5 ="'my_server_machine’;

where $HOME is the root SHOME and where CATIA.V5R3.B03.sh is the
shell downloaded to
$HOME/CATENV/ using the CATIA Version 5 installation procedure.

Make sure that:

9

the path used to access the CATPart document is the same and the file
system containing the CATPart

and the file system containing the CATPart is shared between the V4 and
V5 machines

the user $HOME is the same on the V4 and V5 machines and is shared

between both.



&

Once the above statement is added to the USRENV.dcls file it is possible to use

Version 5 data in a Version 4

session within a client/server environment with the appropriate V5 license set up

on the server machine. However,

if the last two lines of the declaration above are not specified it is assumed by the
system that both V4 and V5 are

installed on a local machine.

This avoids the error message "Dynamic storage cannot be allocated"” displaying
when you attempt to read
CATIA Version 5 data.

4. You are now ready to manipulate CATIA Version 5 data in CATIA
Version 4. You can, for example:

@ Dbrowse V5R3 documents as passive models using FILE/OPEN
@ read a V5R3 CATPart document and copy exact solids and surface
entities into CATIA Version 4

using MODELS/COPY.

E g ?!::ucuut Manipulating W5 Data igﬁ.ﬂing avaoPart Az avd M
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=
-

n®w Saving CATIA Version 5 CATPart Documents As CATIA
Version 4 Models

This task shows you how to save CATIA Version 5 CATPart documents as CATIA Version 4 models.

Open the document \doc\samples\V4Integration\MultiBodyAssembly.CATPart. It looks like this:

[ MuhiBody#szembly CATPan
NUMBEE_O
2wy plane
L YT plane
<L e plang
@ Beference Elaments
- FartBody
Fad.1

[ sketch.
—-Q* Craft.]

— B EdgeFillt. |
—y EdgeFilet 2

$—\ Sketch 2

By EdgeFilet 3

§F shel2




You will remember that in Version 4 the declaration parameter catsite. WRITING_CODE_PAGE declares the

@code page to be stored in the CATIA data to be written. Such information such as the writing code page was
specified in V4 by means of the parameter settings in the declaration files. These declaration parameters are
no longer supported in CATIA Version 5. Such information must therefore be provided by means of the dialog
boxes described below, before attempting to save a V5 CATPart document as a V4 model.

If you want to use the writing code page ISO-8859-1 go straight to step 4. It is the default value so normally,
unless another code page was already specified, you can go ahead with the save.

However, if you want to use a writing code page other than 1SO-8859-1 start with step 1.

E 1. Select the Tools->Options... command. The Options dialog box appears with the General
T category selected in the left-hand column.

2. Click the Compatibility tab. The following dialog box appears:

21 General I I&utamation! | Compatibility | Deneb Compatibility | Fnowledge | Liu:ensing: 1 | >
Zeneral = :
— Canversion
FProduct [ Display elements wilh the Display Mode S ensitive sttibute of
= — %4 Declaralions
rocess PRIJECT Fil: Path I
Drafting DE=AULT_DS_CODE_PAGE I_IS_Eninsh H
Meshing WRITING CODE PAGE | o B i

3. Open the WRITING_CODE_PAGE list in the
V4 Declarations part of the dialog box (indicated
by the arrow above), select the appropriate
code page and click OK.

Click here for code page list




A5CI-D5
&SCI-DS-HGL
ASCI-D5-EJ
EBCDIC-DS
EBCDIC-DS-HGL
EBCDIC-DS -k
EBCDIC-HGL
EBCDIC-KJ
B+ -250

(B M-032
[Bk-5332-5BCS
(5088531
[508353-2
[508353-5
EUC-CH
EUC-IP
EUC-KR
ELIC-T'

4. Select the File->Save As... command.

5. In the Save As dialog box, select the location of the .model document to be saved and rename it (or not)
as required.

6. Click the Save as type: list and select model in the list displayed as shown below.

Save As
Save it I =2 imy an wiloca' [H:) j ﬁl
b ail 1 natesrd ] pIL_is0
it [ nemail (1 Prafs
Model_in 3 rwrn. 1 4578, _exec @ projects
model_jry ([ csirix 3 zamples
MODEL_OUT CAPIlJap 3 Save
models 3 il ([ 59905
\ i i
File name: Ih’lultiEiu:u:I_l,'.-'l'-.SSIE:mI:ulj,I Save I
Save as type: |CATPart j Cancel |
CATPart
atl
igz
wil

stp




7. In the same box, click on Save. The MultiBodyAssembly.model just created can now be opened

in CATIA Version 4 and will look something like this:

~| CATIA - MDLOZ2_MultiBodyaAssembly

Eile SeleEt Eiew Filter UEﬁions TDDlS Eplﬂr Hiﬂﬂnw

e

MSELW ELEM
TO AU/USERS/GYVT/THFP I

FILE
READ
WRITE
COPY
DELETE
MOYE
RENAME
CREATE
CALL SV
COMMENT
KEYBOARD
EXIT
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Using CATIA Version 4 Libraries (on
UNIX Only)

Task Purpose
Opening CATIA Version 4 Library Objects in  Open CATIA Version 4 library objects in
CATIA Version 5 on Windows CATIA Version 5 on Windows
Opening CATIA Version 4 Library Objects in  Open CATIA Version 4 library objects in
CATIA Version 5 on UNIX CATIA Version 5 on UNIX
Displaying CATIA Version 4 Library Keywords Display CATIA Version 4 library
in CATIA Version 5 keywords in CATIA Version 5
Applying Filters to CATIA Version 4 Library  Apply filters to CATIA Version 4 library
Families families

Convert a CATIA Version 4 library

Converting a CATIA Version 4 Library Objects >~ "~ .
d —— object into a CATIA Version 5 Part

into CATIA Version 5 CATPart Documents

document
Converting CATIA Version 4 Libraries into Convert a CATIA Version 4 library into a
CATIA Version 5 Catalogs CATIA Version 5 catalog

E (]4] igﬁipulaﬂng Y Models in W giying W Modelz to V5
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Opening CATIA Version 4 Library Objects in CATIA
Version 5 on Windows

r@* This task shows you how to open a CATIA Version 4 library object in CATIA Version 5 on Windows.
=,

r;ﬂ' Make sure that an http server has been installed on the machine where the objects reside.

A CATIA Version 4 library is a means of storing objects such as details, symbols, NC mill and lathe tools and beam sections. A
library is made up of a number of families each of which contains objects. Keywords are attributed to these families to enable

classification and easy retrieval of the objects contained in them.

Just like Version 4 models, Version 4 library objects cannot be edited as such. However, it is possible to convert the library
objects into CATPart documents. Read-only operations are of course allowed. Accessing CATIA Version 4 library objects does
not modify these objects.

Only SPACE details can be read in CATIA Version 5. Other library objects such as DRAW details, symbols, sections and tools
cannot be read in CATIA Version 5. A SPACE detail that points to external library objects can be read only if all the objects
pointed to are SPACE details. This means, for example, that no detail containing structure pointing to a section can be read.

E 1. Click the Open icon @? or select the File->Open command.
2. In the File Selection dialog box, enter, in the field File name, the whole address of the library object you want to open,
including the library name, as shown below. If you enter the wrong location or if the library name cannnot be found, exit
the dialog box and start over.

The address to be specified should look something like this:
http://UNIXserver: port/libraryobjectlocation/libraryname



File Selection |

Lok |aa E) = B ek [ =
dey v featContE mord ) |
D avnloadOFC:R 2irel Tred_graphc. dxf faztur. ffa |
DownloadOFCR Jirel d12red_old.d«f EE R Bl
Recycler featContE morl E fraztun. ffo
trip featContE mor2 fraztunl. =
LISETS featContE mor’3 ListPaintedFiles

L] | i

File name: I-l'lttl:li.-".-'llj,ll:lr'liB|:|.-"L.I.-"LISE-'[S.-"|I3|:l.-"|_il:lral_|rl.-"|:||:l.-"|i|:lrar_'.-'.'"|:lf { ST

Enter the full address here
icluding the libe aty name

Files af wpe: I.-'-‘-.II [*.%] j Cancel
[~ Open as read-only

[T Load partially

The name of the library appears.

4. Double-click on the library name to display the library families. Then double-click on one of the objects belonging to
these families, CUBOID in the example shown below, to see the whole structure of the library. A dialog box similar to this
is then displayed:



[®]"LISFAM._libsary [ReadDnly]

&F browser
[ SPHERE
&—| ] cuBoID
42
o

| of”

5. To open a library object, double-click on it. Alternatively, select the library object, right-click and select Open. The result,
providing you with CATIA Site Navigator capabilities, is as follows:




Library objects residing on UNIX can of course also be accessed from UNIX. To see how, refer to Opening CATIA Version 4
Library Objects in CATIA Version 5 on UNIX.

#5/
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Opening CATIA Version 4 Library Objects in CATIA
Version 5 on UNIX

"@" This task shows you how to open a CATIA Version 4 library object in CATIA Version 5 on UNIX.
=,

Just like Version 4 models, Version 4 library objects cannot be edited as such. However, it is possible to convert the library
objects into CATPart documents. Read-only operations are of course allowed. Accessing CATIA Version 4 library objects does
not modify these objects.

Only SPACE details can be read in CATIA Version 5. Other library objects such as DRAW details, symbols, sections and tools
cannot be read in CATIA Version 5. A SPACE detail that points to external library objects can be read only if all the objects
pointed to are SPACE details. This means, for example, that no detail containing structure pointing to a section can be read.

.% 1. Click the Open icon @ or select the File->Open command.
2. In the File Selection Box, select the file location.

3. Click the Files of type: list, select library as the document type. The File Selection dialog box is displayed.



*LISF AR library
“rAASTER.library
C1.library
CZ library
Calibrary

e ]

-

fufusersichiLibrary/dbilibrary/browsers

- Note that the items displayed in this dialog box do not correspond to the hierarchical structure of the library. Families and library
1 objects are displayed at the same level.For more information about this, refer to the relevant CATIA Version 4 documentation.



4. To access the library family list, double-click on either *LISFAM.library or *MASTER:.library. Both these files are required
for library management purposes.

The name of the library appears. Double-click on the library name to display the library families. Then double-click on the
objects belonging to these families to see the whole structure of the library. The following dialog box is then displayed:

[%] *LISFAMlibrary (ReadOnly)

[ browser

+_D SPHERE
-—

%cuamm

5. To open a library object, double-click on it. Alternatively, select the library object, right-click and select Open. The result,
providing you with CATIA Site Navigator capabilities, is as follows:



%] Czlibrary




6. To access a family directly, double-click one of the following:

@ family_name FAMILY DESCRIPTOR:.library
@ family_name FAMILY ELEMENT .library.

Both these files are required for library management purposes.

A dialog box appears showing the name of the family. Double-click on this family name to display the whole structure of the

family then double-click on a library object to open it. Alternatively, select the library object, right-click and select Open. The
result is the same as above.

7. To access a library object directly, select it in the File Selection dialog box. The result is the same as above.

Library objects residing on UNIX can also be accessed from Windows using the http protocol. To see how this is done, refer to
Opening CATIA Version 4 Library Objects in CATIA Version 5 on Windows.

#3
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Displaying CATIA Version 4 Library
Keywords in CATIA Version 5

"@" This task shows you how to display CATIA Version 4 library keywords in CATIA Version 5.

=,
Remember that in CATIA V4, some properties associated with a family, called keywords, can be
assigned to objects of the given family. For more information, see the relevant CATIA Version 4
documentation.

- Have a library structure open in CATIA Version 5 showing the families and objects it contains as
.=%._shown below.

[ "LISFAM. lilsarp [ReadDnly)

&F browser
[ sPHERE
&—| ] cuBoID
3 c2
73 C3

i/ J;l;‘

E 1. Select the library object whose keywords you want to display (C2, for example) and
o right-click.
2. In the menu that appears, select Show Keyword...




2 In the Show Kepword. .

menu that Open...

appears,

sggct Show Corwert to Part &z Spec...
Keyword... Corwvert to Part &z Result..

C2's keywords !Ii[ E

3. There OIS =Urweal

) BEO01=Falze
appears a -, my_THESEE
list of the

HUM1=12

keywords
for the
library
object
selected.

4. Click OK to close the list.

file path in the Compatibility tab of the Options dialog box (displayed using the Tools->Options

command).
AR

E g igining “Wd Library Ohjects igining W Library Ohjects
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&If a family's keywords are linked to PROJECT file attributes make sure you specify the PROJECT



Applying Filters to CATIA Version 4 Library
Families

"@" This task shows you how to apply a filter to a CATIA Version 4 Library family in CATIA Version 5.
=1
- Have a Version 4 library and its contents open as shown below.
.-'-u-%f‘.\-
[] "LISFAM. litsrary [ReadOnly)
¥ browser
[ sPHERE
g CUBOID
12 o2
73 C3
g ] .|—"
E 1. In the dialog box above, display all the objects contained within a family, CUBOID for
Sttty example, by clicking on the plus sign opposite the family name, select the family name and
right-click.
2. Select
Filter in the
menu that

appears.



i ot Chrl+x
Copy Ctl+C

[% Baste [Crl+

Fazte Special ..

Delete Del
Properties  Alt+Enter

Selection Sets. .

Define Selection Set

= | Hide/Shaw

Search in family: CUBDID _ (O] x|
D|51|Unval j
3. The NUM1[ Rl
dialog box '.-3,'|_|:--||
opposite is 8001
displayed. [Unval El

1] | i

@ Apply I Reset I - Eancell Help I

4. Complete the fields, then click Apply to redisplay the whole family structure.

5. Click Reset to display the whole family structure as it was prior to the filter application.
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Converting CATIA Version 4 Library Objects
Into CATIA Version 5 CATPart Documents

@ This task shows you how to convert a CATIA Version 4 library object into a CATIA Version 5 Part
==, document.

-p Have a library structure open in CATIA Version 5 showing the families and objects it contains.
e

.

[ "LISFAM. libwary [Readlnly)

&F browser
[] SPHERE

- CUBOID
eyer
+% 3

E 1. Select the library object and right-click.

2. In the menu that appears, select either:

Convert to Part As
Spec... to convert
the object into a V5
CATPart document
as specifications
(identical to the Open...
operation described
in Copying CATIA
Version 4 Model Catweert ta Part Az Besult..
Data to CATIA
Version 5).

Shiow Feywiord. .

Corrvert to Part &3 Spec...

or:



Convert to Part As
Result... to convert
the object into a V5

CATPart document Show Keyword...

as

geometry(identical Open...

to the_ oper_atlon Coreeert to Part Az Spec. ..
described in

Copying CATIA Correert to Part As Result,

Version 4 Model
Data to CATIA
Version 5).

A new window is displayed showing the converted object. The selected library object is now
displayed as a new Part (equivalent to creating a Part and performing a copy/paste operation) and
you are provided with all the Part Design workbench capabilities.

You may now want to click the Fit All In icon @ to fit all data in the window.

@Alternatively, you can of course:
1. open the library object

2. copy/paste it into a Part already open in your CATIA session.

In both cases, only solid-type elements (exact solids i.e. Version 4 CATGEO 17-1 and polyhedral solids
i.e. Version 4 CATGEO 17-2) can be pasted into a Part document.

If details reference other subdetails the whole of the geometry is exploded in one single CATPart
document.

#3%
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n@&w Converting CATIA Version 4 Libraries into CATIA
Version 5 Catalogs

"@" This task shows you how to convert a CATIA Version 4 library into a CATIA Version 5 catalog.
=

- Before embarking on any conversion make sure you are familiar with the concepts described in "About Catalogs” in the CATIA
o

~- Version 5 Infrastructure User's Guide.

—

It would also be instructive to read "Converting CATIA Version 4 Library Objects into CATIA Version 5 CATPart Documents".

Have the documents table.txt and ConvertLibrary.CATScript in the directory \Online\Samples\VV4Integration.

@ Migrating the data structure

The batch operation creates a catalog chapter for each DETAIL type library family (see "Creating a Catalog" in the CATIA
Version 5 Infrastructure User's Guide).

Other types of families (SYMBOL, SECTION, NCMILL, NCLATHE) cannot be converted.

The keywords relating to the library family are converted into catalog keywords as shown in the table below. These keywords
define the associated chapter.

|V4 Keywords |V5 Keywords
’Discrete |String

Alphanumeric |String

Numeric |Rea| (no unit retrieval)
Boolean Boolean

The batch operation creates a chapter referencing each of the previously described terminal chapters. The chapter created
becomes the main entry point of the library converted into a catalog.

Migrating the actual data

Bear in mind the following:
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No V4 link is kept between the V4 library and the new V5 catalog.
Only SPACE details can be migrated to CATIA Version 5 i.e. converted into CATPart documents. Other library objects
such as DRAW details, symbols, sections and tools cannot be migrated.
@ Only solid-type elements (exact solids i.e. Version 4 CATGEO 17-1 and polyhedral solids i.e. Version 4 CATGEO 17-2)
can be pasted into a Part document.
If details reference other subdetails the whole of the geometry is exploded in one single CATPart document.
@ Only DETAIL type families are converted into a catalog chapter.

L

E 1. Before being able to use the CATScript file in order to run the batch operation you must make sure the CclTypeLib
library is loaded. This library declares the library conversion method. To do this, select the Tools->Options... command.
The Options dialog box appears with the General category selected in the left-hand column.

2. Click the !Automation! tab. The following dialog box appears.

oprions g |

General 21  Geneal | L& utomation! | Compatibiliy | Deneb Compatibilit | K.nowledae | Licensini 1| 3
Selected Awailable
Product ::nfo_l,l_rHITih B
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y Inload
MectiodTypelib
Process PSTypeLib
. MartT ypeliz
Dirafting CATGItT wpelib
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i AECRT ppeLib
Meshlng =M | paelib
oot mﬁm—

3. If the CclTypeLlib library is not in the Selected list click on the Add button and retrieve the library from intel_a/code/bin.
Make sure it is in the Selected list before clicking OK.

& If the batch operation is unsuccessful check to make sure that CclTypeLib has been declared.

4. Open the file ConvertLibrary.CATScript: and select the appropriate setting where you see an arrow.



Language="VBSCRI PT"

Sub CATMai n()

"Defines the conversion fornat option of the space details in parts
AS_SPEC = 0

AS RESULT =1

' Choose the conversion format you want of details in parts: as spec or as result

CONVERSI ON_FORVAT = AS_SPEC -
'Defines the batch node option

M GRATION = 0

SI MULATION = 1

' Choose the batch node you want

BATCH MODE = M GRATI ON -
'Specify the absolute UNI X directory of the library

"(for access from Wndows use the http protocol)

libraryDirectory = "http://..." -

"Specify the absolute directory of the catal og

-+

catal ogDirectory ="
"Specify the absolute UNI X directory of the project if the library needs one.

"If not, specify an enpty location (projectDirectory=" ")

-4

projectDirectory = "http://..."



' Specify the absolute path of the character conversion table
"to convert V4 file nanmes of details and famlies
‘into Vb file nanes of parts and chapters. If the default rules are sufficient

'(see Consequences of mgration on filenanes bel ow) specify an enpty |ocation (tablePath=" ")

tablePath = "..." -
'Creates a Catal ogDocunent type document

Di m Cat al og As Docunent

Set Catal og = CATI A Docunent s. Add(" Cat al ogDocunent ")
"Call's CreateCatal ogFronli brary nmethod on Cat al og

Cat al og. Creat eCat al ogFronLi brary libraryDirectory, projectDirectory, catalogDirectory, tablePath,
CONVERSI ON_FORNMAT, BATCH MODE

'Cl oses the docunent
Cat al og. d ose
End Sub

As you can see, this file, written in the VBScript language, contains the information required to batch-convert a V4 library into a
V5 catalog file in the location you specify. It can be used on both Windows and UNIX. (Do not forget to use the http protocol on
Windows to access the library and the PRJ file.)

In the example above the CATScript file contains just one set of instructions to batch-convert a single library. However, a
CATScript file can of course include several series of instructions for the conversion of several libraries.

5. Select the appropriate setting where you see an arrow and close the file when you have finished.



@ Consequences of migration on filenames

On Windows, it is extremely important to be aware of the consequences of migration on filenames. Before reading any further
see "About Filenames" in the CATIA Version 5 Infrastructure User's Guide. In view of the restrictions described in this section,

the following default conversion table will apply to new CATPart documents converted from library objects:

Original Character
Character's [to be
ASCII Code |Replaced
| 0x22 | '
| Ox2a | &
| |

|

New Character
String

_Inch
X

Ox2f
0x3a
0x3c
0x3e
0x3f
0x5¢
| Ox7c |

—| —| 9l v Al -

National characters will be replaced by default by _xxx where xxx is the ASCII code of the character replaced. The default
correspondence table can be modified but you cannot avoid the replacement of these characters. If, for example, you delete
the line I"*' the table will be declared invalid. The two characters most likely to occur are:

@ Oxbl
@ Oxb4

which correspond to the characters used in V4 model names as replacements for the blank character " " and slash character "/"
respectively. To avoid excessively long document names it is advisable to modify the default conversion table.

Only national characters and those characters not supported by Windows can be declared in the correspondence table. For
= example, you cannot decide that you want to change all characters from "a" to "w".

6. If you now wish to act on the information above and modify the string to replace one of the characters in the default
conversion table, open the file table.txt and make the changes required.
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7. You are now ready to run the batch operation. Select the Tools ->Macro->Macros command.

8. In the dialog box that appears, select the appropriate ConvertLibrary.CATScript file. Make sure that at the bottom of
the box External File is selected indicating the location of the macro. Click on Run.

If you chose SIMULATION the batch operation will:
@ generate a report in the same location as the catalog file, allowing you to verify whether migration would be successful
or not
@ detect errors in data migration
@ detect possible occurrences of V5 names following the conversion of V4 names into V5 names.
If more than one occurrence of the same V5 name is detected the older CATPart documents are overwritten. You are therefore
strongly advised to modify the conversion table so that CATParts are not created with the same name.
If you chose MIGRATION the batch operation will generate:

@ areport in the same location as the catalog file, allowing you to verify successful migration
@ and a catalog with the name of the library.

9. If you want to open the catalog you have just created see "Navigating Through a Catalog"” in the CATIA - Infrastructure
User's Guide.

= If a library is migrated to the same directory twice the catalog (both catalog and CATParts) generated by the previous
migration is overwritten by the new one.
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Advanced Tasks

Theme Purpose
Using CDMA Data in CATIA Use CDMA data in CATIA Version 5 and perform
Version 5 associated operations

Using VPM Data in CATIA Version Use VPM data in CATIA Version 5 and perform
5 associated operations




Using CDMA Data in a CATIA Version
5 Assembly (on UNIX Only)

Task Purpose
Connecting an ORACLE or DB2 Database Connect an ORACLE or DB2 database
to Your V5 Environment to your V5 environment
Mapping CDMA and Assembly Attributes on Map CDMA and Assembly attributes on
UNIX UNIX
Adding a CDM Representation to a Product Add a CDM representation to a product
on UNIX on UNIX
Adding a CDM Product to a Product on

UNIX Add a CDM product to a product on UNIX

E p ing COMA in WS (on LM iﬁig PN Data in WS (on U



Connecting an ORACLE or DB2 Database to
Your CATIA Version 5 Environment (on UNIX
Only)

r--—l|
= _
This task shows you how to connect an ORACLE or DB2 database to your
CATIA Version 5 environment, so that you can later use CDMA data as
representations or products in a CATIA Version 5 assembly.
- Have your CATIA Version 5 environment prepared for receiving Version 4 CDMA data.

= Bear in mind the following:

-

@ Before importing CDMA data residing on ORACLE databases, you should check
that these databases are properly described in the tsnames.ora UNIX file and
export the TNS_ADMIN variable by specifying the path of the tsnames.ora file directory.
When using ORACLES, you must export the ORA_NLS33 variable by specifying the
path of the directory containing the Ix... .nlb files (normally located in
I$ORACLE_HOME/common/nls/admin/data).

@ Before importing CDMA data residing on a DB2 database, you should check
that the client DB2 database installation has been performed for the database
you plan to use.

For further information, see the appropriate CDMA, Assembly, ORACLE or DB2
documentation.

@ Only data from CDMA databases in the RAW_COID = TRUE mode (binary COID type
attributes) and the NEW_MATRIX = "YES' mode (positioning matrices in FLOAT format)
can be imported.

Models intended to be used as representations should have been stored by using the:
@ DBLFCAT
@ DBLFAIX

nﬁ-}w @ DBLFCDM



s

access methods. CATIA Version 5 cannot access models stored by means of any
other method.

The product generated by adding some CDM representations and/or models can be
modified just like any CATProduct document in CATIA Version 5. However,
modifications cannot be written back to the CDMA database.

1. Select the Tools->Options... command. The Options dialog box appears.

2. Select the Product category in the left-hand column and click on the
Enovia/CDMA tab.

General

Crafting
Part

3. Select the option Database Administration to declare the logical name of your
database in your Version 5 environment and click on the Apply button.

This step is intended to define the parameters for connecting to the CDMA databases you wish
to use.

The Database Server Administration dialog box is displayed.



The Known Servers frame should initially be empty.

4. Click on New to declare a new server. The dialog box below is displayed.

e
]
oo | BB

e

5. In this dialog box, enter the server's logical name in the Name field.



6. In the Connection String field, enter connection string declared in the
tsnames.ora file (ORACLE) or the database alias declared by the configuration
utility (DB2).

7. In the Dictionary field, enter the CDMA dictionary name and click OK.

The updated Database Server Administration dialog box is displayed. The name

of the server you have just declared should appear in the Known Servers box as well
as the description of the server in the Selected Server box.

autphin

Oracle

SErver

sutphin. W73z

COk

8. Click on Save to save your new server configuration.

9. Click on Test to see whether the required server can be properly connected.
The following dialog box is displayed.



10. Complete the User Name and Password Name fields. Click OK.
The following dialog box is displayed.

11. Click OK to terminate the Database Administration dialog.

You have just completed the first administration step. All the declarations required
to connect your database have been made.

#F
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Mapping CDMA and Assembly Attributes on UNIX

@ This task shows you how to map CDMA and Assembly attributes.
E R
You should have already connected an ORACLE or DB2 database to your CATIA Version 5 environment (see Connecting an
w5 ORACLE or DB2 Database to Your CATIA Version 5 Environment).

@

‘E 1. In the Options dialog box, click on the CDMAInterop tab and select the option CDMA / Product Structure Mapping to
s, define the mapping between the CDMA and Assembly attributes. Click on the Apply button.

@As Assembly imposes a predefined set of attributes on a product and CDMA lets you define your own attribute schema, a
mapping is proposed to ease recognition of CDMA extracted parts in CATIA Version 5.

The following dialog box is displayed:



CDMA_MAPPING

Sutphin COAEMNY

No mapping should initially appear in the Known Mappings box.



2.Click on New to create your mapping.

The Context dialog box is displayed.

3. Enter in the Server field the logical name you
declared using the Database Administration utility.
Specify in the Environment field the name of the

CDMA environment you want to access. Then enter Server. Sutphir
your CDMA user name and password. Click OK. o
el CDAENY

-

The dialog box opposite is displayed.

4. Using the selector list, associate each Assembly
attribute with a CDMA attribute.

Note that for a given Assembly attribute, a number of
CDMA attributes may be proposed. The PartNumber
attribute is used to perform the query operations
when using the Assembly product and is the only



attribute that cannot remain unmapped whereas the §
other attributes can remain ** NOT_MAPPED **.

The Shape Type and Value for Master Shape fields
allow you to define which models will be associated

with a product as a Master Representation. When a :
model whose CDMA attribute associated with Shape

Type is assigned the value declared in the Value for
Master field, this model will be associated with a

product as a master representation. Master Shape is _ ; '
the preferential shape handled by Assembly. ! ] = PART MUMBER ki
Otherwise, it will be considered as an Alternate = -

Representation. Note that only CDMA attributes #% NOT MAPPED **
comparable to character strings are proposed for —
PartNumber and Shape Type mappings. ' w6 NOT MAPPED **

NOT_MAPPED **

ENOT_MAPPED **

*NOT_MAPPED **

For example, in the dialog box above, all the models whose CDMA attributes S_TYPE_REP are assigned the DETAILED value
will be considered as Master Representations.

5. Click OK to confirm your mapping declarations.

An updated Mapping Administration dialog box is displayed. A new line is added in the Known Mappings group box.



CDMA_MAPPING

S_PART MUMBER

STATUS
ENOT_MAPPED **
NOT_MAPPED **

FART_DESCRIPTION

S TYPE_REP
DETAILED

6. Click on the Save button to save your declared mapping before exiting.

7. To modify mapping, double-click on it in the Known Mappings group box. You will then be able to repeat the mapping
operation.



You have just completed the second administration step which consists in declaring a mapping between CDMA and Assembly
attributes.
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Adding a CDM Representation to a Product on UNIX

Lﬂ;, This task shows you how to use CDMA data stored as CATIA Version 4 model representations in a CATIA Version 5 assembly.

&L

m 1. In the CATProduct document, select the product you want to associate a CDM representation with. In the contextual menu, select the
et Representation->Associate CDM command.

Have your CATIA Version 5 environment prepared to receive CDMA data and have a CATProduct document open.

A Connection dialog box similar to the one below is displayed.

2. Complete the fields, then click OK.

Note that the string to be entered in the Server field is the logical name of your CDM database (the one declared by means of the Database Administration utility).

The CDMA Table Selection dialog box is displayed. This dialog box should initially be empty.
3. At this stage, you can either:

@ click OK to display the list of products (which may be time-consuming if there are too many parts in the database), or
@ specify afilter (CX1, for example) in the PartNumber LIKE field to display a restricted list of products and click OK.
Any part for which the value of the CDMA attribute mapped on "PartNumber" contains that string as a substring will be displayed.



CDMA Tahle Selection

CH1 PO Cx1PARTO
CH1PM CH1PART M
Cx1 P01 R PART 011
Cx1 PO1Z CHA1PART M2
Cx1 P13 Cx1PART 013

Cx1 P04 Cx1PARET 014
Cx1 POE Cx1PART 015
CH1 PG Cx1PART 016

4. In the CDMA Table Selection dialog box, select a product.
A new CDMA Table Selection dialog box displays the list of the models for the selected product.



CDMA Table Selection

5. Select a model and click OK.
The CDMA representation is added to your product.
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Adding a CDM Product to a Product on UNIX

L@;. This task shows you how to use CDMA assemblies as products in a CATIA Version 5 assembly.

-

m 1. In the CATProduct document, select the product you want to associate a CDM product with.
iy Right-click to select the New CDM Component command.

Have your CATIA Version 5 environment prepared to receive CDMA data and have a CATProduct document open.

A Connection dialog box similar to the one opposite is displayed.
2. Complete the fields, then click OK.

Note that the string to be entered in the Server field is the logical name
of your CDM database (the one declared by means of the Database Administration utility).

The CDMA Table Selection dialog box is displayed. This dialog box should initially be empty.

3. At this stage, you can either:

@ click OK to display the list of products (which may be time-consuming if there are too many parts in the database), or
@ specify a filter (CX1, for example) in the PartNumber LIKE field to display a restricted list of products and click OK.
Any part for which the value of the CDMA attribute mapped on "PartNumber" contains that string as a substring will be displayed.



CDMA Tahble Selection

CHR1PARTO
CR1 PART 01
CH1PART 011
CATPART ME
CH1PART 013

Cx1PART 014
Cx1PART 015
CH1PART 016

4. In the CDMA Table Selection dialog box, select a product.

The selected product is added to the assembly structure.
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Using VPM Data in CATIA Version 5
(on UNIX Only)

Task Purpose
Describes the preparatory steps to be
Preparing the VPM and CATIA performed by the administrator enabling
Environments for the Use of VPM Data in  the building of a CATIA Version 5 product
CATIA Version 5 from a VPM1 PSN window (on UNIX
only)
Building a CATIA Version 5 Product from a Build a CATIA Version 5 product from a
VPM1 PSN Window VPM1 PSN window (on UNIX only)

Create and save a CATIA Version 5
Product for subsequent save or
commitment in VPM1.1 (on UNIX only)

Creating and Saving a CATIA Version 5
Product for Save or Commitment in VPM1.1
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n@&w Preparing the VPM and CATIA Environments Before
Using VPM Data in CATIA Version 5 (on UNIX Only)

"@' This task shows you how to prepare the VPM and CATIA environments before building a CATIA Version 5 product from a
VPM1.1 PSN window (see Building a CATIA Version 5 Product from a VPM1.1 PSN Window.

| =
'|!~=t 1. On the VPM side, add the following declaration parameters to the USRENV.dcls declaration file:
CATCDMA.METHOD_LIST(*).CATAB ='CATIA_MODEL";

CATCDVA. METHOD_LI ST(*). TYPE = ' Reserved';

CATCDVA. METHOD_LI ST(*) . COMVAND = ' CATI AV5' ;

CATCDVA. METHOD LI ST(*). WHERE = ' PSN ;

CATCDVA. METHOD LI ST(*). ROLE = ' Tool s';

CATCDVA. METHOD LI ST(*) . TAG = ' CdmaPr i ncPanel OpenCATI AVS' ;
where * isthe number just above that of the last viewer declared.

2. If you do not know the number of the last viewer declared, enter catpath CATCDMA.*.WHERE -A -|
This displays a list of all declared viewers.

3. Use the buttons at the bottom of the Database Access window to choose whether or not to display the models using
CATIA V5, DMUNavigator and Deneb.



¢ @& & ©

4. On the CATIA V5 side, export the variables required to enable you to connect to DB2 (to be valuated in the CATEnv of
the installation):

export DB2INSTANCE_HOME=/.../

(name of the DB2 instance user's Home directory)
source $DB2INSTANCE_HOME/sqllib/db2profile

(DB2 shell execution)

export LIBPATH=$DB2INSTANCE_HOME/sqllib/lib:$LIBPATH
(DB2 library path)

4. Export the variables required to enable you to connect to ORACLE (to be valuated in the CATEnv of the root):

export ORACLE_HOME=/.../

(ORACLE user's home directory, where the ORACLE libs are)
export TNS_ADMIN=/.../

(thsnames.ora file's directory)

export LIBPATH=$ORACLE_HOME/lib:$LIBPATH>

(ORACLE library path: libclntsh.xxx where xxx is OS-dependent)
export ORA_NLS33=$0RACLE_HOME/ocommon/nls/admin/data

(Only necessary if ORACLE Version 8 is used:

directory containing Ix....nlb type files)

If an ORACLE version lower than 8.04 is used (for example, V7.3.2 which is the version referenced by VPM1.1) a
libDbuOracleStubs.xxx library must be rebuilt for V5. To enable this, a shell called oracleglue.sh is supplied in the same location

as the startup shell i.e. /code/commands. Do not forget that the IRIX operating system requires the n32 libraries. Make sure that
the ORACLE local client server is running and that the V5 and ORACLE variables are correctly valuated. A library called
CATDbuStubsOracle is then recompiled with the correct ORACLE level.
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Building a CATIA Version 5 Product from a
VPM1.1 PSN Window (on UNIX Only)

@ This task shows you how to build a CATIA Version 5 product from a VPM1.1 PSN window.

j—|
This means in effect that CATIA Version 5 is used as an external viewer to load models stored in VPM1.1 and thus benefit from
V5 functionality. For more information about how to use VPM1.1, refer to the VPM1.1 User's Guide.

On the CATIA Version 5 site, the support of interoperability with ENOVIA VPML1.1 requires
[[?(depending on whether the database is an IBM DB2 or an ORACLE server):

@ |IBM DB2 Universal Database Version 5.2 (for UNIX clients)
@ ORACLE Version 8.0.4 (for AlX, HP-UX and Solaris clients) and ORACLE Version 8.0.x (BD for IRIX clients).
If you have a lower version of ORACLE refer to the relevant CATIA installation documentation.

Your administrator should have already prepared the VPM and CATIA environments to enable this task to be performed.

g]" Have open the VPM1.1 main panel and a Product Structure Workbench in a CATIA V5R2 session.

1. In the VPM1.1 main panel, double-click on the Environment field. The Select Environment dialog box will appear:

2. Select the project name in the Project list and the VPM environment in the Environment list as shown below. Click OK.
The name of the environment selected now appears in the Environment field in the VPM main panel.



Envirortent— ——- — ———
CATSAMPLE ICDAENY .PART_LIST

META-PROJE ||| CSBXLEY .PART_LIST
MfoResourc| || YPMENY1.PART_LIST

Selection:

3.In the VPM main panel, make sure that PART is selected in the Object menu.

4. In the the top right-hand corner of the panel,
specify a filter (CX1, for example)

in the second of the Simple query: fields.

Simple query: MWith ¥ X1

This displays a restricted list of products in the main panel:



= -]

|Eile Object Relation Tools Admin Configuration Hindow Help

B E RIS EER

Environment : CDAENY Simple query: Hith TlZCHl Tl

+| Parts

Part Number Eng. Change Description Date

CX1 PO CX1 PART 0 1998-04-21-16.47.02.

CX1 POl CX1 PART 01 1998-04-21-16.47.11.
CX1 Po11 CX1 PART 011 1998-04-21-16.47.16.
CX1 PO12 CX1 PART 012 1998-04-21-16.47.22.
CX1 PO13 CX1 PART 013 1998-04-21-16.47.26.
CX1 PO14 CX1 PART 014 1998-04-21-16.47.29.
CX1 PO15 CX1 PART 015 1998-04-21-16.47.32.
CX1 PO16 CX1 PART 016 1998-04-21-16.47.36.
CX1 PO161 CX1 PART 0161 1998-04-21-16.47.39.
CX1 P0162 CX1 PART 0162 1998-04-21-16.47.42.
CX1 PO1/ CX1 PART 017 1998-04-21-16.47.46.
Cx1 P02 CX1 PART 02 1998-04-21-16.47.49.
CX1 PO21 CX1 PART 021 1998-04-21-16.47.52.
CX1 P022 CX1 PART 022 1998-04-21-16.47.55.
CX1 P03 CX1 PART 03 1998-04-21-16.47.59.
CX1 PO31 CX1 PART 031 1998-04-21-16.48.02.
CX1 P032 CX1 PART 032 1998-04-21-16.48.05.
CX1 PO33 CX1 PART 033 1998-04-21-16.48.08.
CX1 Po4 CX1 PART 04 1998-04-21-16.48.11.

PR PR RPRPRRPRPRPRPRPRRPRPRRRPRPRRPRRPERE P*P*II




Result ‘Replacev— |Clear|ﬂdd ob ject 1

5. Double-click on one of the part numbers displayed, CX1 PO for example. This displays the Product Structure Navigator (PSN)
window showing the selected part number in the form of a box. Fully expand this box. In the lower left-hand corner of the window,
make sure that Models and CATIA are selected as shown below:

= |
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Open | Models — with CATIA ¥5 —

6. Now, before being able to open any VPM data in CATIA Version 5, you must establish the connection between VPM 1.1 and CATIA V5. To
do this, go into your V5 session. If you have opened the Product Structure workbench, you will see the toolbar shown opposite.




icon or select the command Tools->New VPM Session. This creates a new product from the PSN with the default name

7. Click on the I

DbProductl.
The dialog box opposite appears. Enter the name of your server, your user identification and the appropriate password. Click on OK.

The No Connection icon

If the No Connection icon is still visible this means that the connection has not yet been made. Click on this icon or select the
command Tools->New VPM Session.

The icon ' now appears confirming connection to the Product Structure Navigator (PSN).

From now on, make sure that the appropriate windows in both VPM and CATIA are active each time you perform an operation.



8. In the dialog box that now appears, choose ADD to view the model in your CATIA V5 session. (Selecting REPLACE resets the current
viewer.)

Do you want to REPLACE or ADD to the models
in your current viewer session?

REPLACE Cancel

9. In the PSN window, click on the model you want to view in CATIA V5. The color of the model selected changes to orange.
Now either click on the CATIA V5 icon in the top left-hand corner of the PSN window or right-click and select Open.

The model viewed in CATIA V5 could look like this:



B ChProduct m

¥ C%1 P01 (CX1 PO
¥ ©x1 P03 (CX1 PO
( )
( )

#5831 P02 (CX1 PO2.1
+— ©%1 P04 (0K P41
#—*NASTER

L

Note that this image reflects operation in Design Mode (hence the *MASTER item in the tree).

1=

You can also open a PSN graph from the CATIA V5 session by clicking the icon.
Once in the PSN graph, you can right-click on a component to use the Cut function i.e. delete a branch of the structure displayed.
(All other functions in this menu are VPM-specific and have no corresponding functions in CATIA V5.)



10. Select a model in the CATIA V5 session.This activates the icon. Click on this icon to highlight the corresponding
model in the active PSN graph. Alternately, if you select a model in the PSN graph and click on this icon the corresponding
model in the CATIA V5 session will be highlighted. This can be customized to set systematic highlighting.

See Customizing Enovia/CDMA Settings (on UNIX Only) in the CATIA Version 5 Infrastructure User's Guide.

11. Perform a move on one or more components of the model displayed in the CATIA V5 session, as shown below:

I ChProduct

@.
T—%% CX1 POT (X1 POT,T)
%' it

-3 Cx1 POz (CX1 POZ.1)
%8 C1 P04 (CX1 PO4T)
#—*MASTER
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———

Note that this image reflects operation in Design Mode (hence the *MASTER item in the tree).

If the move is successful you will see that the PSN graph is updated accordingly i.e. the color of the corresponding link

changes to purple, in this particular case between the part numbers CX1 PO and CX1 P03.
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ART 033 DETAILED

Open Models r— with | CATIA ¥5 —

Rollback any unsaved changes

For the move to be taken into account you must have the required write authorization (see the appropriate VPM documentation).

You can perform a commit in the database from the PSN window.

[._Bear in mind that the V5 model is non-persistent and that any changes made in the CATIA Version 5 session are not

necessarily reflected in VPM.
(5] Preparing WP and CATIA E ?}I}:ﬂing a %5 Product from s ing and Zaving a v3 Pr
e ﬁ & 6




n@w Creating and Saving a CATIA Version 5 Product
for Save or Commitment in VPM1.1 (on UNIX Only)

@  This task shows you how to create and save a CATIA Version 5 Product for subsequent save or commitment in

==, VPM1.1on UNIX.
1. In the VPM main panel, make sure that DOCUMENT is selected in the Object menu.

The Create & Save dialog box appears.

2. Provide the required information about the product created putting CATIA V5 in the Source field.

3. Make sure that the document you want to save is active in the V5 session.

4. Click OK.

In the VPM Access panel you will see that a row appears for the new product created.

5. In the CATIA V5 session, you must now either select the Tools->Save in Database command to save the

product in the database or click on the = |icon to commit the product to the database.

Committing the document saves it inside another active document.

1=

Saving the document saves the active document of the current document.

& The document created can neither point to another document in the database nor can it be pointed to.
E g Pgiaring WPM and CATIAE ig ding a 5 Product from s

eating and Saving & Y5 Pr



Customizing Settings

Settings
Compatibility
IGES
Enovia/CDMA (on UNIX only)
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Workbench Description

The V4 integration user interface looks like this:

CATIA V5.2 _ O]

Statt  File  Edt Wiew |ngert  Toolz  Window  Filker Help

&

MASTER | *DRAFT | VENT.SUP. * | PATal | PaTa2 | VENPAT | VENP&2 | REVPRIN | VENLAT b

1ﬁ 1

MASTER




The section is organized as follows:

V4 Integration Menu Bar

Toolbar



V4 Integration Menu Bar

This section presents the V4 integration menu bar available whenever you open a
Version 4 model:

Start File Edit View Insert Tools Window Filter Help

Note that the V4 Integration menu bar is only slightly different from the main
menu bar described in the CATIA - Infrastructure User's Guide.

Filter
[[:F For... See...
- ‘Layer Filter Managing Layer Filters on CATIA Version 4
Models
g henu Bar Toaolbars


file:///E|/users/jmy/jmydocr3/BasEnglish/basug.doc/src/basugfrs.htm

Toolbar

The only toolbar that is specific to the V4 Integration workbench is the Geometry and
Specification Check toolbar:

For more information about either of these icons, see Checking CATIA
Version 4 Model Data Before Copying It to CATIA Version 5

p Menu Bar Toolbars

3 - 3 . L



active

active object
active window

application window

apply

cancel

Glossary
A

The state when an object is the focus of user input and its
operations are available.

Object currently being edited.

The window in which a user is currently working or directing
input. An active window is typically at the top of the Z order and
Is distinguished by the color of its title bar.

Window containing the CATIA Version 5 application.

To commit a set of changes or pending transactions made in a
secondary window, typically without closing that window.

C

To halt an operation or process and return to the state before it
was invoked.

CATIA Site Navigator A viewer allowing you to display CATIA Version 4 data in the

click

clipboard

close
character set

code page
code set

current

CATIA Version 5 environment.

(v.) To position the pointer over an object and then press and
release a mouse button.

(n.) The act of clicking.

The area of storage for objects, data or their references after a
user carries out a Cut or Copy command.

To remove a window.

A character is any symbol used for the organization, control, or
representation of data. A group of such symbols used to
describe a particular language. Each language (or group of
languages) has its character set

A collection of characters that make up a character set.

A code page (or code set) is a table mapping a given
character (from a given character set) to a hexadecimal code
position, or code point, for that code page. It contains the
encoding values for a character set or several character sets.
The encoding values in a code set provide the interface
between the system and its input and output devices.

State of an object when selected.



cursor

default

dialog box

document

document window

double-click

edit field

enter

geometry

geometry area

hold down

A generic term for the visible indication of where a user's
interaction will occur.

D

An operation or value that the system or application assumes,
unless a user makes an explicit choice.

A secondary window that gathers additional information from a
user. A dialog box usually contains one or more controls, such
as buttons, list boxes, combo boxes, and edit boxes, with which
the user enters text, chooses options, or directs the action of
the command.

A common unit of data (typically a file) used in user tasks and
exchanged between users. When saved on disk, a document is
given a unique filename by which it can be retrieved.

A window that provides a primary view of a document (typically
its content).

(v.) To press an release a mouse button twice in rapid
succession.

(n.) The act of double-clicking.

E

See text box.

(v.) To type a character from the keyboard.
(n.) A classification of an object based on its characteristics,
behavior, and attributes.

G

Three-dimensional representation of the elements contained in
the data. An example would be the set of faces that make up a
solid. Roughly equivalent to the Brep representation used in
CATIA Version 4.

Area of a document window in which application data are
displayed and edited.

H

To continue pressing a keyboard key, or mouse button.



icon
inactive

inactive window

Insertion point

interoperability

link

menu
menu bar

menu button
menu item

menu title

message box
mode

model

model document

A pictorial representation of an object.
The state of an object which it is not the focus of a user's input.

A window in which a user's input is not currently being directed.
An inactive window is typically distinguished by the color of its
title bar.
The location where text or graphics will be inserted (also
referred to as the caret). Also used for text box controls to
indicate input focus.
@ Ability to exchange data between CATIA Version 4 and
CATIA Version 5.
@ Ability to exchange CATIA Version 5 data between
CATIA Version 5 workshops
@ Ability to exchange data between CATIA Version 5 and
OLE-compliant applications.

L

(v.) To form a connection between two objects.
(n)) A reference to an object that is linked to another object.

M

A list of textual or graphical choices from which a user can
choose.

A horizontal bar at the top of a window, below the title bar, that
contains menus.

A command button that displays a menu.
A choice on a menu.

A text or graphic label that designates a particular menu. For
drop-down menus, the titles is the entry in the menu bar; for
cascading menus the menu title is the name of its parent menu
item.

A secondary window that is displayed to inform a user about a
particular condition.

A particular state of interactions, often exclusive in some way to
other forms of interactions.

CATIA Version 4 model.
Document containing a CATIA Version 4 model.



mouse

object
operation

option button

point

pointer

press
PROJECT file

property

right-click

scroll

scroll bar
select

selection

A commonly used input device that has one or more buttons
used to interact with a computer. It is also used as a generic
term to include other pointing devices that operate similarly (for
example, trackballs and headpointers).

O

An entity or component identifiable by a user that can be
distinguished by its properties, operations, and relationships.
A generic term that refers to the actions that can be done to or
with an object.
A standard Windows control that allows a user to select from a
fixed set of mutually exclusive choices (also referred to as a
radio button).

F)

(v.) To position the pointer over a particular object an location.
(n.) A unit of measurement for type (1 point equals
approximately 1/72 inch).

A graphic image displayed on the screen that indicates the
location of a pointing devices (also referred to as a cursor).

To press and release a keyboard key.

A CATIA Version 4 entity containing project standards. This is
the heart of the CATIA Version 4 site without which no
significant operations can be carried out. The "building blocks"
of a project are stored in the form of tables, each of which
corresponds to a member of the PROJECT file.

Attribute or characteristic of an object that define its state,
appearance, or value.

R

Click using the right mouse button (to display contextual menu).

S

To move the view of an object or information to make a
different portion visible.

A standard Windows control that supports scrolling.

To identify one or more objects upon which an operation can be
performed.
An object or set of objects hat have been selected.



settings

specifications

specification tree

status bar

stop

text box

title bar

toolbar

unavailable

undo

window

workbench

Set of setup parameters and user preferences stored in
non-editable files.

Made up of the entire history of the actions performed to obtain
the data. Shown in the form of a tree and roughly equivalent to
the CSG tree used in CATIA Version 4.

Area of the document window reserved for viewing the design
specifications of a part, presented in the form of a tree
structure.

An area that allows the display of state information of the
information being viewed in the window, typically places at the
bottom of a window.

To halt a process or actions, typically without restoring the state
before the process began.

T

A standard Windows control in which a user can enter an edit
text (also referred to as the edit field).

The horizontal area at the top of a window that identifies the
window. The title bar also acts as a handle for dragging the
window.

A frame or special area that contains a set of other controls.

U

The state of a control or data whose normal functionality is not
presently available to a user (also referred to as dimmed).

To reverse one operation performed on an object.

W

A standard Windows object that displays information. A window
IS a separately controllable area of the screen that typically has
a rectangular border.

Set of tools for completing specific tasks. Each type of
document can be edited with a document-specific set of tools.
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