Preface

CATIA Version 5 Wireframe and Surface allows you to create wireframe construction elements during preliminary design and enrich existing 3D mechanical part design with wireframe and basic surface features. As a complement to CATIA Part Design, this product meets the requirements of solids-based hybrid modeling.

The features-based approach offers a productive and intuitive design environment to capture and re-use design methodologies and specifications.

As a scalable product, CATIA Version 5 Wireframe and Surface can be used in cooperation with companion products such as CATIA Part Design, CATIA Assembly Design and CATIA Generative Drafting. The widest application portfolio in the industry is also accessible through interoperability with CATIA Solutions Version 4 to enable support of the full product development process from initial concept to product in operation.

The CATIA Wireframe and Surface User's Guide has been designed to show you how to create and edit wireframe and surface features as well as hybrid parts. There are often several ways to reach the final result. This guide aims at illustrating these various possibilities.
Using This Guide

This guide is intended for the user who needs to become quickly familiar with the CATIA Wireframe and Surface product. The user should be familiar with basic CATIA Version 5 concepts such as document windows, standard and view toolbars.

To get the most out of this guide, we suggest you start reading and performing the step-by-step tutorial Getting Started. This tutorial will show you how to create a basic part.

The next sections deal with the creation and modification of various types of wireframe and surface geometry you will need to construct parts.

You may also want to take a look at the section describing the Wireframe and Surface workbench menus and toolbars.
Where to Find More Information

Prior to reading this guide, we recommend that you read the *CATIA Version 5 Infrastructure User's Guide*.

What's New?

**Wireframe geometry creation**
Enhanced **spline** creation capabilities
New **circle** and **corner** creation capabilities
Enhanced **projection** creation capabilities

**Surface creation**
Enhanced **sweep** creation capability

**Shape geometry modification**
Enhanced **splitting** and **trimming** capabilities
Getting Started

Before getting into the detailed instructions for using CATIA Version 5 Wireframe and Surface, the following tutorial aims at giving you a feel about what you can do with the product. It provides a step-by-step scenario showing you how to use key functionalities.

The main tasks described in this section are:

1. Entering the Workbench
2. Creating Wireframe Geometry
3. Creating First Loft
4. Creating Swept Surfaces
5. Creating Second Loft
6. Joining the Surfaces
7. Closing the Surfaces

This tutorial should take about ten minutes to complete.

The final part will look like this:
Entering the Workbench

This first task shows you how to enter the Wireframe and Surface workbench and open a design part.

Before starting this scenario, you should be familiar with the basic commands common to all workbenches. These are described in the *CATIA Version 5 Infrastructure User’s Guide*.

1. Select Mechanical Design > Wireframe and Surface Design from the Start menu.

   The Wireframe and Surface workbench is displayed.

2. Select File > Open then select the GettingStartedWireframeAndSurface.CATPart document from the online/samples/WireframeAndSurface directory.

   The following design part is displayed.

In the rest of this scenario, you will add to the existing elements of this part to complete the design.
Creating Wireframe Construction Elements

This task shows you how to create wireframe construction elements using the vertices of solids.

1. Click the Line icon.

   The Line Definition dialog box appears.

2. Create a line by selecting a vertex on Pad 1 and the corresponding vertex on Pad 2.

3. Repeat this step to create four lines as shown in the opposite figure.
Creating a First Loft Surface

This task shows how to create a lofted surface.

1. Click the Loft icon.

The Lofted Surface Definition dialog box appears.

2. Select the curved edge on each pad as sections for the loft.

3. Click OK to create the surface.

Make sure that arrows point the same way.
Up  Entering the Workbench  Creating Wireframe Geometric
Creating First Loft  Creating Swept Surfaces  Creating Second Loft
Joining the Surfaces  Closing the Surfaces
Creating Two Swept Surfaces

This task shows how to create two swept surface between opposite edges of the two pads.

1. Click the Sweep icon.
   The Swept Surface Definition dialog box appears.
   The profile type is Explicit by default.

2. Select the bottom line as first guide curve.

3. Select the vertical edge of Pad 2 as profile.

4. Click in Guide curve 2 field then select the inclined line as second guide curve.

5. Click OK to create the swept surface.

6. Repeat these steps on the other side to create a second swept surface.

In the opposite figure the previously created lofted surface is hidden in order to illustrate the swept surfaces better.
Creating a Second Loft Surface

This task shows how to create the second lofted surface at the bottom of the part.

1. Click the Loft icon.

The Lofted Surface Definition dialog box appears.

2. Select the horizontal edges on the pads as sections for the loft.

Make sure arrows point the same way.

3. Click OK to create the surface.

The specification tree is updated to show the created surfaces.
Joining Surfaces

This task shows how to join the lofted and swept surfaces.

1. Click the Join icon. The Join Definition dialog box appears.
2. Select the two lofted surfaces and the two swept surfaces.
3. Click OK to create the joined surface.

The specification tree is updated to include the joined surface.
Closing the Surfaces

This task shows you how to create a solid by closing the joined surface.
For this you must call up the Part Design workbench.

1. Select Mechanical Design > Part Design from the Start menu.
The Part Design workbench is displayed.

2. Click the Close Surface icon.
Note that the Join element should be active in tree.
The CloseSurface Definition dialog box appears.
3. Click OK to create the closed surface feature.
The specification tree is updated.
Basic Tasks

The basic tasks you will perform in the Wireframe and Surface workbench are mainly the creation of wireframe and surface geometry you will use to build your part design.

This section will explain and illustrate how to create and manage various kinds of wireframe and surface geometry.

Theme

Creating Wireframe Geometry

Creating Surfaces

Performing Operations

Using Tools
Creating Wireframe Geometry

Wireframe geometry is the geometry that helps you create features when needed. Creating this geometry is a simple operation you can perform at any time.

Two creation modes are available: either you create geometry with its history or not. Geometry with no history is called a datum. Please refer to Creating Datums for more information.
Corners

Creating Wireframe Geonet
Creating Surfaces

Performing Operations
Using Tools
Points

This task shows the various methods for creating points:

- by coordinates
- on a curve
- on a plane
- on a surface
- at a circle center
- tangent points on a curve.

1. Click the Point icon .
   The Point Definition dialog box appears.
2. Use the combo to choose the desired point type.

**Coordinates**
- Enter the X, Y, Z coordinates.
  The corresponding point is displayed.

**On curve**
- Select a curve
- Optionally, select a reference point.
  If this point is not on the curve, it is projected onto the curve.
  If no point is selected, the curve's extremity is used as reference.
- Use the option button to determine whether the new point is to be created:
  - a given distance along the curve from the reference point
a given ratio between the reference point and the curve's extremity.

Enter the distance or ratio value.

The corresponding point is displayed.

You can click the Nearest extremity button to display the point at the nearest extremity of the curve.

You can click the Middle Point button to display the mid-point of the curve.

You can use the Reverse Direction button to display:
- the point on the other side of the reference point (if a point was selected originally)
- the point from the other extremity (if no point was selected originally).

**On plane**
- Select a plane.
- Optionally, select a point to define a reference for computing coordinates in the plane.

If no point is selected, the projection of local axis system's origin onto the plane is taken as reference.
- Click in the plane to display a point.
On surface
- Select the surface where the point is to be created.
- Optionally, select a reference point.
- Select a line to take its orientation as reference direction or a plane to take its normal as reference direction.
  You can also use the contextual menu to specify the X, Y, Z components of the reference direction.
- Enter a distance along the reference direction to display a point.

Circle center
- Select a circle or circular arc.
  A point is displayed at the circle center.

Tangent on curve
- Select a curve and a direction line.
  A point is displayed at each tangent.

3. Click OK to create the point.
The point (identified as Point.xxx) is added to the specification tree.
This task shows the various methods for creating lines:

- **point to point**
- **point and direction**
- **angle or normal to curve**
- **tangent to curve**
- **normal to surface**

1. Click the Line icon.
   The Line Definition dialog box appears.
2. Use the combo to choose the desired line type.

   A line type will be proposed automatically in some cases depending on your first element selection.

   **Point - Point**
   - Select two points.
   - The corresponding line is displayed.

   **Point - Direction**
   - Select a reference point and a direction line.
   - A vector parallel to the direction line is displayed at the reference point.
   - Proposed Start and End points of the new line are shown.
   - Specify the Start and End points of the new line.
   - The corresponding line is displayed.

   Start and End points are specified by entering distance values or by using the graphic manipulators.

   You can reverse the direction of the line by either clicking the displayed vector or selecting the Reverse Direction button.

   **Angle or normal to curve**
   - Select a reference curve and a support surface containing that curve.
   - Select a point on the curve.
   - Enter an angle value.
   - A line is displayed at the given angle with respect to the tangent to the reference curve at the selected point. These elements are displayed in the plane tangent to the surface at the selected point.
You can click on the Normal to Curve button to specify an angle of 90 degrees. Proposed Start and End points of the line are shown.
- Specify the Start and End points of the new line.
- The corresponding line is displayed.

**Tangent to curve**
- Select a reference point and a curve.

  A vector tangent to the curve is displayed at the reference point. Proposed Start and End points of the new line are shown.
- Specify Start and End points to define the new line.
- The corresponding line is displayed.

**Normal to surface**
- Select a reference surface and a point.

  A vector normal to the surface is displayed at the reference point. Proposed Start and End points of the new line are shown.
- Specify Start and End points to define the new line.
- The corresponding line is displayed.

3. For most line types you can select the Geometry on Support check box if you want the line to be projected onto a support surface. In this case just select a support surface. The figure below illustrates this case.
4. Click OK to create the line.

The line (identified as Line.xxx) is added to the specification tree.
This task shows the various methods for creating circles and circular arcs:

- center and radius
- center and point
- two points and radius
- three points
- bitangent and radius
- bitangent and point
- tritangent

1. Click the Circle icon. The Circle Definition dialog box appears.
2. Use the combo to choose the desired circle type.

### Center and radius

- Select a point as circle center.
- Select the support plane or surface where the circle is to be created.
- Enter a radius value.

Depending on the active Circle Limitations icon, the corresponding circle or circular arc is displayed. For a circular arc, you can specify the Start and End Angles of the arc.

If a support surface is selected, the plane tangent to the surface at the selected point is used.

Start and End
Angles can be specified by entering values or by using the graphic manipulators.

**Center and point**

- Select a point as circle center.
- Select a point where the circle is to pass.
- Select the support plane or surface where the circle is to be created.

Depending on the active Circle Limitations icon, the corresponding circle or circular arc is displayed. For a circular arc, you can specify the Start and End Angles of the arc.

**Two points and radius**

- Select two points where the circle is to pass.
- Select the support plane or surface where the circle is to be created.
- Enter a radius value.

Depending on the active Circle Limitations icon, the corresponding circle or circular arc is displayed. For a circular arc, you can specify the trimmed or complementary arc using the two selected points as end points.

You can use the Second Solution button to display the alternative arc.
Three points

- Select three points where the circle is to pass.

Depending on the active Circle Limitations icon, the corresponding circle or circular arc is displayed. For a circular arc, you can specify the trimmed or complementary arc using the two selected points as end points.

3. In each of the methods above, you can select the Geometry on Support checkbox if you want the circle to be projected onto a support surface.

   In this case, just select a support surface.

Bitangent and radius

- Select two curves to which the circle is to be tangent.
- Select a support surface.
- Enter a radius value.
- Several solutions may be possible, so click in the region where you want the circle to be.

Depending on the active Circle Limitations icon, the corresponding circle or circular arc is displayed. For a circular arc, you can specify the trimmed or complementary arc using the two tangent points as end points.

Bitangent and point

- Select two curves to which the circle is to be tangent.
- Select a point on the second curve.
- Select a support plane or surface.
- Several solutions may be possible, so click in the region where you want the circle to be.

Depending on the active Circle Limitations icon, the corresponding circle or circular arc is displayed.
For a circular arc, you can specify the trimmed or complementary arc using the two tangent points as end points.

**Trimmed circle**

**Complementary trimmed circle**

**Tritangent**

- Select three curves to which the circle is to be tangent.
- Select a support surface.
- Several solutions may be possible, so click in the region where you want the circle to be.

Depending on the active Circle Limitations icon, the corresponding circle or circular arc is displayed.

For a circular arc, you can specify the trimmed or complementary arc using the two tangent points as end points.

4. Click OK to create the circle or circular arc.

The circle (identified as Circle.xxx) is added to the specification tree.
Parallel Curves

This task shows you how to create a curve that is parallel to a reference curve.

Open the Parallelcurves.CATPart document from the online/Samples/WireframeAndSurface directory.

1. Click the Parallel Curve icon. The Parallel Curve Definition dialog box appears.

2. Select the reference curve to be offset.

3. Select the support plane or surface.
4. Specify the offset by entering a value or using the graphic manipulator.

The parallel curve is displayed on the support surface and normal to the reference curve.

You can use the Reverse Direction button to display the parallel curve on the other side of the reference curve.

5. Click OK to create the parallel curve.

The curve (identified as Parallel.xxx) is added to the specification tree.
This task shows how to create boundary curves.

Open the Boundary.CATPart document from the online/Samples/WireframeAndSurface directory.

1. Click the Boundary icon 📉.

The Boundary Definition dialog box appears.

2. Use the combo to choose the Propagation type:
   - **Complete boundary**: the selected edge is propagated around the entire surface boundary.
   - **Point continuity**: the selected edge is propagated around the surface boundary until a point discontinuity is met.
   - **Tangent continuity**: the selected edge is propagated around the surface boundary until a tangent discontinuity is met.
   - **None**: no propagation or continuity condition is imposed, only the selected edge is kept.

---

None

Tangent Continuity
3. Select the edge curve of a surface. The boundary curve is displayed according to the selected propagation type.

4. You can relimit the boundary curve by means of two elements.

5. Click OK to create the boundary curve. The curve (identified as Boundary.xxx) is added to the specification tree.
Intersections

This task shows you how to create wireframe elements by intersecting two elements.

You can intersect:
- two wireframe elements
- two surfaces
- a wireframe element and a surface.

Open the Intersectsurface.CATPart and Intersectsurf.CATPart documents from the online/Samples/WireframeAndSurface directory.

1. Click the Intersection icon.

The Intersection Definition dialog box appears.

2. Select the two elements to be intersected.

The intersection is displayed.

This example shows the line resulting from the intersection of a plane and a surface.

This example shows the curve resulting from the intersection of two surfaces.
3. Click OK to create the intersection element.

This element (identified as Intersect.xxx) is added to the specification tree.
Projections

This task shows you how to perform projections. The projection may be normal or along a direction.

You can project:
- a point onto a surface or wireframe support
- wireframe geometry onto a surface support.

Open the Projection.CATPart document from the online/Samples/WireframeAndSurface directory.

Click the Projection icon.

1. If you select Normal as projection type:
   - The Projection Definition dialog box appears.

2. Select the element to be projected.
   - For example, in this figure select the spline.
3. Select the support element.
   For example, in this figure select the surface.

4. Use the combo to specify the direction type for the projection:
   - **Normal.**
     In this case, projection is done normal to the support element.

5. Whenever several projections are possible, you can select the Nearest Solution check box to keep the nearest projection.
6. Click OK to create the projection element.

The projection (identified as Project.xxx) is added to the specification tree.

If you select Along a direction as projection type:

1. Select the element to be projected.

2. Use the combo to specify the direction type for the projection:
   - **Along a direction.**
     In this case, projection is done along the selected direction.

3. Select the direction, that is a line to take its orientation as the projection direction or a plane to take its normal as the projection direction.

   You can also specify the direction by means of X, Y, Z vector components by using the contextual menu on the Direction area.

4. Whenever several projections are possible, you can select the Nearest Solution check box to keep the nearest projection.
5. Click OK to create the projection element.

The projection (identified as Project.xxx) is added to the specification tree.
CATIA allows you to model both simple and complex surfaces using techniques such as extruding, lofting and sweeping.

Two creation modes are available: either you create geometry with its history or not. Geometry with no history is called a datum. Please refer to Creating Datums for more information.
Extruded Surfaces

This task shows how to create a surface by extruding a profile along a given direction.

1. Click the Extrude icon. The Extruded Surface Definition dialog box appears.

2. Select the profile to be extruded and specify the desired extrusion direction. You can select a line to take its orientation as the extrusion direction or a plane to take its normal as extrusion direction.

3. You can also specify the direction by means of X, Y, Z vector components by using the contextual menu on the Direction area.

4. Enter numerical values or use the graphic manipulators to define the start and end limits of the extrusion.

4. You can click the Reverse Direction button to display the extrusion on the other side of the selected profile.
5. Click OK to create the surface.

The surface (identified as Extrude.xxx) is added to the specification tree.
Surfaces of Revolution

This task shows how to create a surface by revolving a profile around an axis.

1. Click the Revolute icon. The Revolution Surface Definition dialog box appears.

2. Select the profile.

3. Select a line indicating the desired axis of revolution.

4. Enter angle values or use the graphic manipulators to define the limits of the revolution surface. For example, enter 360 as the Angle 1 value.

5. Click OK to create the surface. The surface (identified as Revolute.xxx) is added to the specification tree.

There must be no intersection between the axis and the profile.
Lp
Offset Surfaces
Extruded Surfaces
Swept Surfaces
Revolution Surfaces
Lofted Surfaces
Offset Surfaces

This task shows how to create a surface by offsetting an existing surface.

Open the Offset.CATPart document from the online/Samples/WireframeAndSurface directory.

1. Click the Offset icon.

The Offset Surface Definition dialog box appears.

2. Select the surface to be offset.

3. Specify the offset by entering a value or using the graphic manipulator.

The offset surface is displayed normal to the reference surface.

4. An arrow indicates the proposed direction for the offset.

You can invert the direction by clicking either the arrow or the Reverse Direction button.

5. Click OK to create the surface.

The surface (identified as Offset.xxx) is added to the specification tree.
Up
Offset Surfaces

Extruded Surfaces

Revolution Surfaces

Swept Surfaces

Lofted Surfaces
Swept Surfaces

You can create a swept surface by sweeping out a profile in planes normal to a spine curve while taking other user-defined parameters (such as guide curves and reference elements) into account.

You can sweep an explicit profile:
- along one or two guide curves (in this case the first guide curve is used as the spine)
- along one or two guide curves while respecting a spine.

The profile is swept out in planes normal to the spine.

In addition, you can control the positioning of the profile while it is being swept by means of a reference surface.

The profile position may be fixed with respect to the guide curve (positioned profile) or user-defined in the first sweep plane.

This task shows how to create a swept surface that uses an explicit profile.

Open the Sweep.CATPart document from the online/Samples/WireframeAndSurface directory.

1. Click the Sweep icon.

The Swept Surface Definition dialog box appears.

The profile type is Explicit by default.
2. Select a guide curve.

3. Select the planar profile to be swept out, that is the circle.

4. If needed, select a spine. If no spine is selected, the guide curve is implicitly used as the spine.

5. If needed, select a second guide curve.

6. If you want to control the position of the profile during the sweep, you can select a reference surface. You can impose a reference angle on this surface.

7. By default, a positioned profile is used. In CATIA P2 only, if you want to manually position the profile, click the Position profile >> button to access a set of positioning parameters.

These parameters and the graphic manipulators will allow you to position the profile in the first sweep plane.

- Specify a positioning point in the first sweep plane by either entering coordinates or selecting a point.
- Specify the x-axis of the positioning axis system by either selecting a line or specifying a rotation angle.
Select the X-axis inverted check box to invert the x-axis orientation (while keeping the y-axis unchanged).

Select the Y-axis inverted check box to invert the y-axis orientation (while keeping the y-axis unchanged).

Specify an anchor point on the profile by selecting a point. This anchor point is the origin of the axis system that is associated to the profile.

If you want to go back to the original profile, click the Sweep original profile << button to access the original positioning parameters.

8. Click OK to create the swept surface.

The surface (identified as Sweep.xxx) is added to the specification tree.
Lofted Surfaces

This task shows how to create a lofted surface.

You can generate a lofted surface by sweeping one or two planar section curves along a computed or user-defined spine. The surface can be made to respect one or more guide curves.

1. Click the Loft icon.

The Lofted Surface Definition dialog box appears.

2. Select one or two planar section curves.

These sections may be tangent to support surfaces. Closed section curves can have point continuity at each closing point.

3. If needed, select one or more guide curves.
4. In the Spine tab page, select the Spine check box to use an automatically computed spine or select a curve to impose that curve as the spine.

5. It is possible to edit the loft reference elements by first selecting a curve in the dialog box list then choosing a button to either:
   - Remove the selected curve
   - Replace the selected curve by another curve.
   - Add another curve.

More possibilities are available with the contextual menu depending on the element you selected.
6. Click OK to create the lofted surface.

The surface (identified as Loft.xxx) is added to the specification tree.
Performing Operations on Shape Geometry

CATIA - Wireframe and Surface allows you to modify your design using techniques such as trimming, translating and rotating.
Splitting Geometry

This task shows how to split a surface or wireframe element by means of a cutting element.

You can split:
- a wireframe element by a point, another wireframe element or a surface
- a surface by a wireframe element or another surface.

1. Click the Split icon

The Split Definition dialog box appears.

2. Select the element to be split.

You should make your selection by clicking on the portion that you want to keep after the split.

3. Select the cutting element.

A preview of the split appears. You can change the portion to be kept by selecting that portion.

You can also select the portion to be kept by clicking the Other side button.

4. Click OK to split the element.

The created element (identified as Split.xxx) is added to the specification tree.

When necessary, the cutting element will be extrapolated in order to split a surface correctly (as shown in following figure).
Trimming Geometry

This task shows how to trim two surfaces or two wireframe elements.

1. Click the Trim icon.

The Trim Definition dialog box appears.

2. Select the two surfaces or two wireframe elements to be trimmed.

A preview of the trimmed element appears. You can change the portion to be kept by selecting that portion.

You can also select the portions to be kept by clicking the Other side of element 1 and Other side of element 2 buttons.

You should make your selections by clicking on the portions that you want to keep after the trim.

When necessary, the cutting elements will be extrapolated in order to trim surfaces correctly.

3. Click OK to trim the surfaces or wireframe elements.

The trimmed element (identified as Trim.xxx) is added to the specification tree.
Up
Joining
Scaling
Splitting
Translating
Rotating
Nearest Sub-element
Trimming
Symmetry
Affinity
Joining Surfaces or Curves

This task shows how to join adjacent surfaces or adjacent curves. Please note that joining surfaces is a CATIA P2 functionality.

1. Click the Join icon. The Join Definition dialog box appears.

2. Select the surfaces or curves to be joined.

3. You can edit the list of elements in the definition list by means of the Remove and Replace buttons.

4. Click OK to create the joined surface or curve. The surface or curve (identified as Join.xxx) is added to the specification tree.
Translating Geometry

This task shows you how to translate a point, line or surface element.

Open the Translate.CATPart document from the online/Samples/WireframeAndSurface directory.

1. Click the Translate icon.

   The Translate Definition dialog box appears.

2. Select the element to be translated.

3. Select a line to take its orientation as the translation direction or a plane to take its normal as the translation direction.

   You can also specify the direction by means of X, Y, Z vector components by using the contextual menu on the Direction area.

4. Specify the translation distance by entering a value or using the Drag manipulator.
5. Click OK to create the translated element.

   The element (identified as Translat.xxx) is added to the specification tree.

   The original element is unchanged.
Performing a Symmetry on Geometry

This task shows you how to transform geometry by means of a symmetry operation.

Open the Transform.CATPart document from the online/Samples/WireframeAndSurface directory.

1. Click the Symmetry icon.

The Symmetry Definition dialog box appears.

2. Select the element to be transformed by symmetry.

3. Select a point, line or plane as reference element.

The figure below illustrates the resulting symmetry when the line is used as reference element.

The figure below illustrates the resulting symmetry when the point is used as reference element.

4. Click OK to create the symmetrical element.

The element (identified as Symmetry.xxx) is added to the specification tree.

The original element is unchanged.
<table>
<thead>
<tr>
<th>Operation</th>
<th>Diagram</th>
<th>Operation</th>
<th>Diagram</th>
<th>Operation</th>
<th>Diagram</th>
</tr>
</thead>
<tbody>
<tr>
<td>Up</td>
<td><img src="image" alt="Up" /></td>
<td>Joining</td>
<td><img src="image" alt="Joining" /></td>
<td>Scaling</td>
<td><img src="image" alt="Scaling" /></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Splitting</td>
<td><img src="image" alt="Splitting" /></td>
<td>Translating</td>
<td><img src="image" alt="Translating" /></td>
<td>Rotating</td>
<td><img src="image" alt="Rotating" /></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Trimming</td>
<td><img src="image" alt="Trimming" /></td>
<td>Symmetry</td>
<td><img src="image" alt="Symmetry" /></td>
<td>Affinity</td>
<td><img src="image" alt="Affinity" /></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Nearest Sub-element</td>
<td><img src="image" alt="Nearest Sub-element" /></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Transforming Geometry by Scaling

This task shows you how to transform geometry by means of a scaling operation.

Open the Transform.CATPart document from the online/Samples/WireframeAndSurface directory.

1. Click the Scaling icon

The Scaling Definition dialog box appears.

2. Select the element to be transformed by scaling.

3. Select the scaling reference point, plane or planar surface.

4. Specify the scaling ratio by entering a value or using the Drag manipulator.

The figure below illustrates the resulting scaled element when the plane is used as reference element (ratio = 2).

The figure below illustrates the resulting scaled element when the point is used as reference element (ratio = 2).

5. Click OK to create the scaled element.

The element (identified as Scaling.xxx) is added to the specification tree.

The original element is unchanged.
Rotating Geometry

This task shows you how to rotate geometry about an axis.

Open the Transform.CATPart document from the online/Samples/WireframeAndSurface directory.

1. Click the Rotate icon.

   The Rotate Definition dialog box appears.

2. Select the element to be rotated.

3. Select a line as the rotation axis.

4. Enter a value or use the Drag manipulator to specify the rotation angle.

5. Click OK to create the rotated element.

   The element (identified as Rotate.xxx) is added to the specification tree.

The original surface is unchanged.
Transforming Geometry by Affinity

This task shows you how to transform geometry by means of an affinity operation.

Open the Transform.CATPart document from the online/Samples/WireframeAndSurface directory.

1. Click the Affinity icon.

The Affinity Definition dialog box appears.

2. Select the element to be transformed by affinity.

3. Specify the characteristics of the axis system to be used for the affinity operation:
   - the origin
   - the xy plane
   - the x-axis.

4. Specify the affinity ratios by entering the desired X, Y, Z values.
The figure below illustrates the resulting affinity with ratios $X = 2$, $Y = 1$ and $Z = 1$.

The figure below illustrates the resulting affinity with ratios $X = 2$, $Y = 2$ and $Z = 1$.

The figure below illustrates the resulting affinity with ratios $X = 2$, $Y = 2$ and $Z = 1.5$. 
5. Click OK to create the affinity element.

The element (identified as Affinity.xxx) is added to the specification tree. The original element is unchanged.
Creating the Nearest Entity of a Multiple Element

This task shows you how to create the nearest entity of an element that is made up from several sub-elements.

1. Select the Insert > Operations > Near command.
The Near Definition dialog box appears.

2. Select the element that is made up from several sub-elements.

3. Select a reference element whose position is close to the sub-element that you want to create.

   This example shows a parallel curve comprising three sub-elements.

   This example shows the sub-element that is nearest to the reference point.

4. Click OK to create the element.

   This element (identified as Near.xxx) is added to the specification tree.
CATIA - Wireframe and Surfaces provides powerful tools to help you manage your surfaces and wireframe geometry.

- Updating Your Design
- Working with a Support
- Creating Datums
- Creating Constraints
- Editing Geometry
- Copying and Pasting
- Deleting Geometry
- Managing Open Bodies
- Managing Groups
- Performing Operations
- Using Tools
- Creating Wireframe Geometry
- Creating Surfaces
Updating Your Design

This task explains how and when you should update your design.

The point of updating your design is to make the application take your last operation into account. Indeed some changes to geometry or a constraint may require rebuilding the part. To warn you that an update is needed, CATIA displays the update symbol next to the part name and displays the corresponding geometry in bright red.

1. To update the part, click the Update icon.

However, keep in mind that some operations such as confirming the creation of features (clicking OK) do not require you to use the update command. By default, the application automatically updates the operation.

Controlling your update is possible: just select the Tools -> Options command and uncheck the automatic update option to make sure you will update your part only when you wish to do so.

2. To update the feature of your choice, just select that feature and use the Update contextual command.
Working with a Support

This task shows how to work on a support, which may be either a plane or a surface. This will allow you to easily reference a surface or plane whenever you need one. For example, you will not have to explicitly select the support element again when creating geometry.

1. Click the Work on Support icon. The Work on Support dialog box appears.

2. Select the plane or surface to be used as support element.
   If a plane is selected, a grid is displayed to facilitate visualization.

When you no longer need the support, just click on the icon again then click the Remove Support button.
Creating Datums

This task shows how to create geometry with the History mode disactivated. In this case, when you create an element, there are no links to the other entities that were used to create that element.

1. Click the Create Datum icon to disactivate the History mode.

   It will remain disactivated until you click on the icon again.

   The History mode (active or inactive) will remain fixed from one session to another: it is in fact a setting.
Creating Constraints

This task shows how to set geometric constraints on geometric elements. Such a constraint forces a limitation. For example, a geometric constraint might require that two lines be parallel.

To set a constraint between elements:

1. Multi-select the two or three elements to be constrained.
2. Click the Constraint with dialog box icon.

The Constraint Definition dialog box appears indicating the types of constraint you can set between the selected elements.

3. Select an available option to specify that the corresponding constraint is to be made.
4. Click OK.

The corresponding constraint symbol appears on the geometry.
To set a geometric constraint on a single element:

1. Select the element to be constrained.
2. Click the Constraint icon.

The corresponding constraint symbol appears on the geometry.
Editing Surface and Wireframe Definitions

This task shows how to edit the definition of an already created geometric element.

1. Activate the Definition dialog box of the element that you want to edit in one of the following ways:
   - Select the element then choose the xxx.object > Definition command from the contextual menu
   - Select the element then choose the Edit > xxx.object > Definition command
   - Double click on the element identifier in the specification tree.
2. Modify the definition of the element by selecting new reference elements or by entering new values.
3. Click OK to save the new definition.
Copying and Pasting

This task shows how to copy and paste open body entities in your part design.

1. Select the elements that you want to copy either directly in the part geometry or in the specification tree.
2. Select the Edit > Copy command.
3. Click the Open Body entity in the tree where you want to paste the selected elements.
4. Select the Edit > Paste command.

The elements are then copied into the target Open Body.

The identifiers of copied elements are incremented with respect to the original elements.

The original elements and copied elements can be edited independently.
Deleting Surfaces and Wireframe Geometry

This task shows how to delete geometry from your design.

1. Select the entity you want to delete.

2. Select the Delete command either from the Edit menu or the contextual menu.

   The Delete dialog box appears.

3. Set your desired options for managing the deletion of Parent and Child entities.

4. Click OK to confirm the deletion.
Managing Open Bodies in the Specification Tree

This task shows how to manage the specification tree. This involves:

- inserting open body entities
- removing open body entities
- changing body.

You will find other useful information in the Managing Groups section.

You can insert and manipulate open bodies in the specification tree in much the same way as you manage files in folders.

These management functions have no impact on the part geometry.

You should refer to the Copying and Pasting section for information about how open bodies can be used in a part edition context.

Inserting an Open Body

1. In the specification tree, select the branch where you want the new open body to be inserted.

   This branch is known as a father location which can be a part, a body or another open body entity.

2. Select the Insert > Open Body menu command.

   The Insert Open Body dialog box appears.

3. Select the entities that are to be included in the new open body.

4. Click OK to create the open body at the desired location.
Removing an Open Body
This is only possible when the father location of the open body is another open body.

1. Right-click the desired open body then select the Remove Open Body contextual command.

The open body is removed and its constituent entities are included in the father open body.

Moving an open body to a new body

1. Right-click the desired open body in the specification tree and select the Change Body command from the contextual menu.

The Change Body dialog box appears.

2. Select the new body where the open body is to be located.

3. Click OK to move the open body to the new body.
Managing Groups

This task shows how to manage groups of elements in an Open Body entity as follows:

- creating a group
- editing a group
- collapsing and expanding a group
- moving a group to a new body.

Creating a group

1. Right-click the desired Open Body entity in the specification tree.
2. Choose the Create Group command from the contextual menu.

The Group dialog box appears. The Support area indicates the name of the Open Body entity where the group is to be created.

3. If needed, modify the proposed default group name that appears in the Name area.
4. Select entities to be included in the group and remain visible in the tree.
5. Click OK to create the group.
In the Group dialog box you can:
- click the check box to specify whether the group is to be expanded or collapsed.
- click the Remove Group button to reset the group definition.

**Editing a group**

1. Right-click the desired group in the specification tree and select the Edit Group command from the contextual menu.
2. You can then:
   - rename the group
   - remove the group
   - add entities to the group.

**Collapsing and expanding a group**

1. To collapse a group, right-click the desired group in the specification tree and select the Collapse Group command from the contextual menu.

   The portion of the specification tree related to the group appears reduced.

2. To expand a collapsed group, right-click the desired group in the specification tree and select the Expand Group command from the contextual menu.

   All the entities belonging to the group are then visible in the specification tree.

**Moving a group to a new body**

1. Right-click the desired group in the specification tree and select the Change Body command from the contextual menu.

   A dialog box entitled Change Body appears.

2. Select the new body where the group is to be located.
3. Click OK to move the group to the new body.
Workbench Description

This section describes the menu and icon commands that are specific to the CATIA Version 5 Wireframe and Surface workbench, which is shown below.

You can click the hotspots on this image to see the related documentation.
CATIA - Wireframe and Surface Menu Bar

Here we will present the various menus and menu commands that are specific to CATIA - Wireframe and Surface Version 5.

Tasks corresponding to general menu commands are described in the CATIA Version 5 Infrastructure User's Guide.

Edit

Please note that most of the Edit commands available here are common facilities offered by the CATIA Version 5 Infrastructure.

The specific CATIA - Wireframe and Surface Edit commands depend on the type of object being edited: Open Body or other entity.

<table>
<thead>
<tr>
<th>Command...</th>
<th>Description...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Undo</td>
<td>Cancels the last action.</td>
</tr>
<tr>
<td>Redo</td>
<td>Recovers the last action that was undone.</td>
</tr>
<tr>
<td>Update</td>
<td>See Updating Your Design</td>
</tr>
<tr>
<td>Cut</td>
<td>Performs cut copy paste and special paste operations.</td>
</tr>
<tr>
<td>Copy</td>
<td></td>
</tr>
<tr>
<td>Paste</td>
<td></td>
</tr>
<tr>
<td>Paste Special...</td>
<td></td>
</tr>
<tr>
<td>Delete</td>
<td>Deletes selected geometry.</td>
</tr>
<tr>
<td>Search...</td>
<td>Allows searching and selecting objects.</td>
</tr>
<tr>
<td>Properties</td>
<td>Allows displaying and editing object properties.</td>
</tr>
<tr>
<td>Scan or Define in Work Object...</td>
<td>Allows scanning the part and working locally on an object.</td>
</tr>
<tr>
<td>XXX object &gt; Definition</td>
<td>Allows editing selected geometry.</td>
</tr>
<tr>
<td>Show /Hide</td>
<td>Allows showing a hidden object or hiding a visible object.</td>
</tr>
</tbody>
</table>
Insert

For... See...

Sketcher Refer to the *CATIA Version 5 Sketcher User's Guide.*

Open body See [Managing Open Bodies](#)

Wireframe Insert > Wireframe

Surfaces Insert > Surfaces

Operations Insert > Operations

Constraints Insert > Constraints

Insert > Wireframe

For... See...

Point Points

Line Lines

Plane Planes

Projection Creating Projections

Intersection Creating Intersections

Circle Circles

Spline Creating Splines

Corner Corners

Parallel Curve Creating Parallel Curves

Boundary Creating Boundary Curves

Insert > Surfaces
Insert > Operations

For... See...

Join Joining Geometric Elements
Trim Trimming Geometry
Split Splitting Geometry
Translate Translating Geometry
Rotate Rotating Geometry
Symmetry Performing Symmetry on Geometry
Scaling Transforming Geometry by Scaling
Affinity Transforming Geometry by Affinity
Near Creating Nearest Entity of a Multiple Element

Insert > Constraints

For... See...

Constraint Creating Constraints
Constraint Defined in Dialog Box

Tools

Please note that most of the Tools commands available here are common facilities offered by the CATIA Version 5 Infrastructure.

Specific CATIA - Wireframe and Surface Tools commands are described in the present document.

Command... Description...

Formula Allows editing parameters and formula.
Image Allows capturing images.
Macro Allows recording, running and editing macros.
Parent/Children Allows viewing the parents and children of a selected object.

Work on Support See Working with a Support
Customize: Allows customizing the workbench.
Options: Allows customizing settings.
Search Order: Allows specifying a search order list.

Up
- Surfaces Toolbar
- Operations Toolbar
- Constraints Toolbar

Menus
- Wireframe Toolbar

Tools
- Formula...
- Image
- Macro
- Parent/Children...
- Work on Support

Help
Wireframe Toolbar

This toolbar contains the following tools for creating wireframe geometry.

See Points
See Lines
See Planes
See Projections
See Intersections

See Circles
See Splines
See Corners
See Parallel Curves
See Boundary Curves

Surfaces Toolbar
Operations Toolbar
Constraints Toolbar
Surfaces Toolbar

This toolbar contains the following tools for creating surface geometry.

See [Extruded Surfaces](#)

See [Surfaces of Revolution](#)

See [Offset Surfaces](#)

See [Swept Surfaces](#)

See [Lofted Surfaces](#)
This toolbar contains the following tools for performing operations on surface and wireframe elements.

- See [Joining Geometry](#)
- See [Splitting Geometry](#)
- See [Trimming Geometry](#)
- See [Translating Geometry](#)
- See [Rotating Geometry](#)
- See [Performing a Symmetry on Geometry](#)
- See [Transforming Geometry by Scaling](#)
- See [Transforming Geometry by Affinity](#)
Tools Toolbar

This toolbar contains the following tools to help you model your part designs.

See [Updating Your Design](#)

See [Working with a Support](#)

See [Creating Datums](#)
Constraints Toolbar

This toolbar contains the following tools to help you manage constraints between geometric elements.

See Creating Constraints.
Glossary

A

affinity An operation in which an element is transformed by applying X, Y, Z affinity ratios with respect to a reference axis system.

C

child A status defining the hierarchical relation between a feature or element and another feature or element.

constraint A geometric or dimension relation between two elements.

E

extruded surface A surface that is obtained by extruding a profile along a specified direction.

F

feature A component of a part.

J

join An operation in which adjacent curves or adjacent curves can be joined.

L

lofted surface A surface that is obtained by sweeping one or more planar section curves along a spine, which may be automatically computed or user-defined. The surface can be made to follow one or more guide curves.

O

offset surface A surface that is obtained by offsetting an existing surface a specified distance.
parent A status defining the hierarchical relation between a feature or element and another feature or element.

part A 3D entity obtained by combining different features. It is the content of a CATPart document.

part body A component of a part made of one or several features.

profile An open or closed shape including arcs and lines.

revolution surface A surface that is obtained by revolving a profile around an axis.

rotate An operation in which an element is rotated by a specified angle about an given axis.

scaling An operation that resizes an element to a percentage of its initial size.

sketch A set of geometric elements created in the Sketcher workbench. For instance, a sketch may include a profile, construction lines and points.

split An operation in which one element is cut by another element.

swept surface A surface obtained by sweeping a profile in planes normal to a spine curve while taking other user-defined parameters (such as guide curves and reference elements) into account.

symmetry An operation in which an element is transformed by means of a mirror symmetry with respect to a reference plane, line or point.

translate An operation in which an element is displaced a specified distance along a given direction.

trim An operation in which two element cut each other mutually.
**wireframe element** Elements such as points, lines or curves that can be used to represent the outline of a 3D object.
Index

B

boundary curves
Boundary icon

C

circles
corners
constraints
Create Datum icon
creating
  boundary curves
  circles
  corners
  datums
  extruded surfaces
  intersections
  lines
  lofted surfaces
  offset surfaces
  parallel curves
  planes
  points
  projections
  revolution surfaces
  splines
  swept surfaces
D
 datums

E
 Extrude icon
extruded surfaces

G
 groups

I
 Intersection icon
intersections

J
 Join command
joined surfaces or curves

L
 Line icon
lines
Loft icon
lofted surfaces

O
 Offset icon
offset surfaces
operations
  affinity ➤
  join ➤
  rotate ➤
  scaling ➤
  split ➤
  symmetry ➤
  translate ➤
  trim ➤

P

parallel curves ➤
Parallel Curve icon ➤
part ➤
Plane icon ➤
planes ➤
Point icon ➤
points ➤
Projection icon ➤
projections ➤

R

revolution surfaces ➤
Revolve icon ➤

S

Spline icon ➤
splines ➤
Split icon ➤
support grid ➤
Sweep icon ➤
swept surfaces ➤
T

Trim icon

U

Update icon
updating your design

W

wireframe element
Work on Support icon
Working on support